Автор Тема: [SOLVED] Lenny->Squeeze ъпгрейд и Kernel Panic  (Прочетена 2927 пъти)

whoAH

  • Участници
  • ***
  • Публикации: 4
    • Профил
Здравейте!
Обнових Lenny -> Squeeze по нормалния начин - едит на sources.list(lenny -> squeeze) и след това:

Код:
sudo apt-get update
sudo apt-get install dpkg apt aptitude
sudo aptitude full-upgrade

Udev обаче не поиска да се инсталира заради старото ядро. Направих
Код:
touch /etc/udev/kernel-upgrade
и пуснах sudo apt-get full-upgrade наново.
Всичко уж тръгна като по вода. Трябваше да направя конфигурацията на няколко пакета, и както си ги инсталираше ("Unpacking... Setting up...") системният звънец издрънча два пъти и получих съобщение подобно на Kernel Panic в конзолата. SYSRQ нямаше резултат и затова направих твърд рестарт.

В GRUB имах Chainboot опцията за GRUB -> GRUB2. Тя веднага ми даде
Код:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
С новото ядро (2.6.32-5-686) стана същото. Старото ядро буутна, но даде десетки UDEV грешки и накрая при опит за логин върна segmentation fault. Забравих да кажа - файловата система е Reiserfs. Някакви идеи? На разположение имам единствено Knoppix LiveCD.

EDIT: Успях да го подкарам със старото ядро (2.6.26-2-686) и Single-User Mode. Сега какво? :D
« Последна редакция: Jun 13, 2010, 10:30 от whoAH »
Активен

jet

  • Напреднали
  • *****
  • Публикации: 2895
  • Distribution: debian
  • Window Manager: kde
    • Профил
Re: Lenny->Squeeze ъпгрейд и Kernel Panic
« Отговор #1 -: Jun 11, 2010, 17:35 »
apt-get   install   linux-image-2.6.32-trunk-686

Активен

..⢀⣴⠾⠻⢶⣦⠀
  ⣾⠁⢠⠒⠀⣿⡁
  ⢿⡄⠘⠷⠚⠋
  ⠈⠳⣄⠀⠀⠀⠀  Debian, the universal operating system.

ЗевсБг

  • Напреднали
  • *****
  • Публикации: 1178
  • Distribution: Kubuntu 14.04 Realtime 3.12.0-rt2 JACK Audio Connection Kit
  • Window Manager: KDE 4.13.3 !!! VLC-настр-Аудио-SRC-Sinc function(best quality)
    • Профил
Re: Lenny->Squeeze ъпгрейд и Kernel Panic
« Отговор #2 -: Jun 11, 2010, 22:44 »
 /etc/default/grub
 параметър за ядрото "nomodeset"
GRUB_CMDLINE_LINUX="nomodeset"
Активен

Кубунту  със Realtime Kernel дава звук, който няма нищо общо с другите дистрибуции...Линукс е за галеници на Боговете-не е за простосмъртни...при прекомпилиране-make menuconfig, Under ‘Processor type and features’, Scroll  down to ‘Timer Frequency’ and set this to 1,000Hz!!! за 3.12 иска lzop

bop_bop_mara

  • Напреднали
  • *****
  • Публикации: 2433
  • Distribution: Debian Testing
  • Window Manager: LXDE
  • Cute and cuddly
    • Профил
Re: Lenny->Squeeze ъпгрейд и Kernel Panic
« Отговор #3 -: Jun 11, 2010, 23:35 »
apt-get   install   linux-image-2.6.32-trunk-686
Каква ти е идеята?
Активен

jet

  • Напреднали
  • *****
  • Публикации: 2895
  • Distribution: debian
  • Window Manager: kde
    • Профил
Re: Lenny->Squeeze ъпгрейд и Kernel Panic
« Отговор #4 -: Jun 12, 2010, 00:14 »
идеята е че ползва древно ядро от Лени и от тогава много концепции по УДЕВ се смениха, ядрото което посочих си е последното в Скуиз.
Едно време имах същите проблеми като минавах от Едж към Лени - качих си текущото ядро и заспа.
Инсталацията на това ядро също ще си намести гръб конфига
Активен

..⢀⣴⠾⠻⢶⣦⠀
  ⣾⠁⢠⠒⠀⣿⡁
  ⢿⡄⠘⠷⠚⠋
  ⠈⠳⣄⠀⠀⠀⠀  Debian, the universal operating system.

whoAH

  • Участници
  • ***
  • Публикации: 4
    • Профил
Re: Lenny->Squeeze ъпгрейд и Kernel Panic
« Отговор #5 -: Jun 12, 2010, 01:47 »
/etc/default/grub
 параметър за ядрото "nomodeset"
GRUB_CMDLINE_LINUX="nomodeset"
Ами пробвах с GRUB (1) + nomodeset, същата работа.
Забелязах, че когато добавя initrd към GRUB, работата просто остава на "Loading, please wait..."

apt-get   install   linux-image-2.6.32-trunk-686
Аз уж съм с актуално ядро след ъпгрейда(2.6.32), ама... :S Иначе този пакет, който си го дал не съществува в Squeeze хранилището.

Между другото ето какво имам в menu.lst:

Код:
title Debian GNU/Linux, kernel 2.6.32-5-686
root (hd0,6)
kernel /boot/vmlinuz-2.6.32-5-686 root=/dev/hda7 ro quiet
initrd /boot/initrd.img-2.6.32-5-686
Активен

jet

  • Напреднали
  • *****
  • Публикации: 2895
  • Distribution: debian
  • Window Manager: kde
    • Профил
Re: Lenny->Squeeze ъпгрейд и Kernel Panic
« Отговор #6 -: Jun 12, 2010, 02:51 »
хакни един
aptitude dist-upgrade

защото този
aptitude full-upgrade
е мек ъпгрейд и много работи не са ти ъпгрейднати- напр. гледам че си с гръб1 а Скуиз е гръб2
Активен

..⢀⣴⠾⠻⢶⣦⠀
  ⣾⠁⢠⠒⠀⣿⡁
  ⢿⡄⠘⠷⠚⠋
  ⠈⠳⣄⠀⠀⠀⠀  Debian, the universal operating system.

whoAH

  • Участници
  • ***
  • Публикации: 4
    • Профил
Re: Lenny->Squeeze ъпгрейд и Kernel Panic
« Отговор #7 -: Jun 12, 2010, 10:00 »
хакни един
aptitude dist-upgrade

защото този
aptitude full-upgrade
е мек ъпгрейд и много работи не са ти ъпгрейднати- напр. гледам че си с гръб1 а Скуиз е гръб2
Ами аз взех, че направих един чист реинстал на Lenny (CDтата на Squeeze нямат поддръжка за ReiserFS), и го ъпгрейднах с aptitude dist-upgrade. Пак същата работа. То GRUB 2 и преди си го имах, но беше настроен да чейнлоудва от GRUB legacy. А като пробвах да го буутна даваше същия проблем.

Чудя се дали не са махнали поддръжката на ReiserFS от новото ядро в testing хранилищата? Дали да не го прекомпилирам, за да съм най-сигурен?
« Последна редакция: Jun 12, 2010, 10:01 от whoAH »
Активен

bop_bop_mara

  • Напреднали
  • *****
  • Публикации: 2433
  • Distribution: Debian Testing
  • Window Manager: LXDE
  • Cute and cuddly
    • Профил
Re: Lenny->Squeeze ъпгрейд и Kernel Panic
« Отговор #8 -: Jun 12, 2010, 12:42 »
Май уцели в десятката: http://us.generation-nt.com/where-now-reiserfs-debian-testing-netinstall-help-196570581.html
А щом не е проблем сам да си компилираш ядро предполагам, че ще се справиш  [_]3
Активен

whoAH

  • Участници
  • ***
  • Публикации: 4
    • Профил
SOLVED
« Отговор #9 -: Jun 13, 2010, 09:40 »
Ядрото се оказа, че има поддръжка за ReiserFS. Направих един update-from-grub-legacy и всичко заспа :o Интересно защо не успя да направи chainboot-а...
Активен

Warstomp

  • Напреднали
  • *****
  • Публикации: 344
  • Distribution: Debian, Ubuntu
    • Профил
Re: [SOLVED] Lenny->Squeeze ъпгрейд и Kernel Panic
« Отговор #10 -: Jun 15, 2010, 16:54 »
Имам подобен проблем. С debian squeeze съм и след update на пакетите ми смени 2.6.32-3-amd64 със 2.6.32-5-amd64.
Със новия кернел не може да зареди и дава куп странни съобщения. Това което успях да препиша е:

Код:
.......
BUG: unable to handle kernel paging request at 00000000001f104018
........
kernel panic - not syncing: Fatal exception in interupt.

Пуснах да се логват boot съобщенията във /var/log/boot, но там има редовете само след рестарта със старото ядро.
Някакви идеи?
« Последна редакция: Jun 16, 2010, 09:57 от Стефан Павлов »
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Kernel panic
Настройка на програми
Stepan 5 2071 Последна публикация Sep 24, 2006, 20:37
от DeViLBoy
Kernel panic :(
Хардуерни и софтуерни проблеми
savage 6 2208 Последна публикация Nov 29, 2006, 02:46
от savage
Kernel panic
Настройка на програми
exabyte 5 2009 Последна публикация Mar 12, 2007, 02:15
от bozho
Разлика, между Lenny, Squeeze & Wheezy – каква е тя?
Идеи и мнения
NikolayDONG 9 3038 Последна публикация Sep 05, 2013, 14:16
от NikolayDONG
ПРЕМЕСТЕНО: Разлика, между Lenny, Squeeze & Wheezy – каква е тя?
Системни настройки
neter 0 1095 Последна публикация Sep 03, 2013, 10:04
от neter