Автор Тема: настройка на рутер - не работи при ppp0  (Прочетена 7147 пъти)

vstoykov

  • Напреднали
  • *****
  • Публикации: 1286
  • Distribution: Ubuntu
  • Window Manager: Fluxbox
    • Профил
    • WWW
Имам два компютъра.
Първи компютър:
eth0 - адрес: 192.168.0.2 / маска: 255.255.255.0
eth1 - адрес: 10.1.x.x / маска: 255.255.0.0
Втори компютър:
eth0 - адес: 192.168.0.5 / маска:255.255.255.0

eth0 на първия компютър е свързан с eth0 на втория.
eth1 на първия компютър е към доставчика на Интернет.

На втория компютър съм задал за default gateway адреса на първия (eth0 - 192.168.0.2).  Настройките за DNS на двата компютъра са еднакви.

Правя следните настройки на първия компютър:
Примерен код

# echo "net.ipv4.ip_forward = 1" > /etc/sysctl.conf
# echo "net.ipv4.ip_local_port_range = 1024 32768"  >> /etc/sysctl.conf
# echo "net.ipv4.conf.all.arp_ignore = 1" >>  /etc/sysctl.conf
# sysctl -p

# modprobe ipt_TTL
# iptables -t mangle -A PREROUTING -i eth1 -j TTL --ttl-inc 1
# iptables -t mangle -A POSTROUTING -s 192.168.0.0/24 -o eth1 -j TTL --ttl-set 64
# iptables -t nat -I POSTROUTING -o eth1 -j MASQUERADE


До тук всичко работи. И на двата компютъра има връзка.

При пускане на ppp0 на първия компютър и изпълнение на горепосочените команди (като eth1 е заменено с ppp0) се наблюдава проблем - на втория компютър няма връзка.



Активен

divak

  • Напреднали
  • *****
  • Публикации: 829
    • Профил
настройка на рутер - не работи при ppp0
« Отговор #1 -: Jun 11, 2008, 22:45 »
Да не би ppp-то да ти променя DNS-а ?

/etc/ppp/pppoe.conf

Цитат

# DNS type: SERVER=obtain from server; SPECIFY=use DNS1 and DNS2;
# NOCHANGE=do not adjust.
DNSTYPE=SERVER

# Obtain DNS server addresses from the peer (recent versions of pppd only)
# In old config files, this used to be called USEPEERDNS. Changed to
# PEERDNS for better Red Hat compatibility
PEERDNS=no

DNS1=
DNS2=

# Make the PPPoE connection your default route. Set to
# DEFAULTROUTE=no if you don't want this.
DEFAULTROUTE=yes



Така ппп ти взима DNS от сървъра.



Активен

vstoykov

  • Напреднали
  • *****
  • Публикации: 1286
  • Distribution: Ubuntu
  • Window Manager: Fluxbox
    • Профил
    • WWW
настройка на рутер - не работи при ppp0
« Отговор #2 -: Jun 11, 2008, 22:56 »
Настройките в /etc/resolv.conf са еднакви във всеки един момент от време и на двата компютъра.
Активен

divak

  • Напреднали
  • *****
  • Публикации: 829
    • Профил
настройка на рутер - не работи при ppp0
« Отговор #3 -: Jun 11, 2008, 23:02 »
ми ...пусни пингове (от външната машина) на вън и на вътре - за да се знае дали тя има достъм до навсякъде, и от вътрешната машина за навън.
Може да се окаже че :
iptables -t mangle -A PREROUTING -i eth1 -j TTL --ttl-inc 1
не работи - тоест този модул не е зареден ...примерно
или ...ппп-то да не си взима настройките (по накаква причина)
-разните там .. SERVICENAME
А и рут таблицата дали е променена от ппп ?

Някой хитреци слагат TTL=0, и тогава :
iptables -t mangle -A PREROUTING -i eth1 -j TTL --ttl-inc 2



Активен

vstoykov

  • Напреднали
  • *****
  • Публикации: 1286
  • Distribution: Ubuntu
  • Window Manager: Fluxbox
    • Профил
    • WWW
настройка на рутер - не работи при ppp0
« Отговор #4 -: Jun 12, 2008, 12:44 »
Връзка с връзката между компютъра свързан с кабела на ISP-то и Интернет няма. Има връзка между двата компютъра (ползвам ssh за да подавам команди на втория компютър). Когато напиша "ping адерес_в_интернет" на втория компютър всичко изглежда наред. Даже успявам да се свържа чрез "lftp ftp.slackware.com", но не мога да тегля. Когато напиша wget dir.bg намира index.html и замръзва до там - не тегли нищо (същото е и с някой браузър - не се зарежда страницата).

Това с --ttl-inc 2  не дава резултат. Когато съм свързан без pptp всичко е наред и без да правя промени по TTL.
Активен

Gaara

  • Напреднали
  • *****
  • Публикации: 631
  • Distribution: Debian
  • Window Manager: E17
    • Профил
настройка на рутер - не работи при ppp0
« Отговор #5 -: Jun 12, 2008, 13:35 »
Пробвай да сложиш iptables -t nat -I POSTROUTING -o eth1 -j MASQUERADE преди заобикалянето на ттл-а. Интересното е, че аз съм така и нямам проблем. Ако е от значение, към спнет съм.
Активен

Last night, Darth Vader came down from planet Vulcan and told me that if you don't install Debian, he'd melt your brain.

vstoykov

  • Напреднали
  • *****
  • Публикации: 1286
  • Distribution: Ubuntu
  • Window Manager: Fluxbox
    • Профил
    • WWW
настройка на рутер - не работи при ppp0
« Отговор #6 -: Jun 12, 2008, 13:45 »
Пробвах горното, но не се получи.

За да опростя нещата направих следните прости настройки:

Примерен код


echo "net.ipv4.ip_forward = 1" > /etc/sysctl.conf
sysctl -p

# изчиствам настройките
iptables -F
iptables -X
iptables -F -t mangle
iptables -X -t mangle
iptables -F -t nat
iptables -X -t nat

# само един ред:
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE


Когато pppoe не работи всичко е ОК. Когато активиран pppoe, и променя горните настройки като заменя eth1 с ppp0, се получава това (това е на втория компютър):

Примерен код

root@darkstar:~# ping dir.bg
PING dir.bg (194.145.63.12) 56(84) bytes of data.
64 bytes from dir.bg (194.145.63.12): icmp_seq=1 ttl=58 time=12.1 ms
64 bytes from dir.bg (194.145.63.12): icmp_seq=2 ttl=58 time=12.4 ms
64 bytes from dir.bg (194.145.63.12): icmp_seq=3 ttl=58 time=11.8 ms

--- dir.bg ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2000ms
rtt min/avg/max/mdev = 11.821/12.119/12.421/0.244 ms
root@darkstar:~# wget dir.bg
--13:44:42--  http://dir.bg/
           => `index.html'
Преобразувам dir.bg... 194.145.63.12
Connecting to dir.bg|194.145.63.12|:80... успешно свързване.
HTTP изпратено искане, чакам отговор... 302 Found
Адрес: http://www.dir.bg/ [следва]
--13:44:42--  http://www.dir.bg/
           => `index.html'
Преобразувам http://www.dir.bg... 194.145.63.12
Connecting to http://www.dir.bg|194.145.63.12|:80... успешно свързване.
HTTP изпратено искане, чакам отговор...


и така чакам отговор до безкрайност...

При първия компютър има връзка с Интернет.

Доставчикът на интернет е Интербилд.



Активен

Gaara

  • Напреднали
  • *****
  • Публикации: 631
  • Distribution: Debian
  • Window Manager: E17
    • Профил
настройка на рутер - не работи при ppp0
« Отговор #7 -: Jun 12, 2008, 13:52 »
Я пробвай следният тестов скрипт, който работи при мен:
Примерен код

EXT=ppp0
INT=eth0
echo "net.ipv4.ip_forward = 1">> /etc/sysctl.conf
echo "net.ipv4.ip_local_port_range = 1024 32768 ">>/etc/sysctl.conf

iptables -F
iptables -t nat -F
iptables -t mangle -F
iptables -X
iptables -A INPUT -i lo -j ACCEPT
iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A INPUT -m state --state NEW -i ! $EXT -j ACCEPT
iptables -A FORWARD -i $EXT -o $INT -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i $INT -o $EXT -j ACCEPT
iptables -t nat -A POSTROUTING -o $EXT -j MASQUERADE
iptables -A FORWARD -i $EXT -o $INT -j REJECT
iptables -t mangle -A PREROUTING -i $EXT -j TTL --ttl-inc 1
iptables -t mangle -A POSTROUTING -s 192.168.0.0/24 -o $EXT -j TTL --ttl-set 64


Edit: DNS-те са ми еднакви и на двете машини, като втората няма и Х и само с wget боравя '<img'>



Активен

Last night, Darth Vader came down from planet Vulcan and told me that if you don't install Debian, he'd melt your brain.

vstoykov

  • Напреднали
  • *****
  • Публикации: 1286
  • Distribution: Ubuntu
  • Window Manager: Fluxbox
    • Профил
    • WWW
настройка на рутер - не работи при ppp0
« Отговор #8 -: Jun 12, 2008, 14:49 »
Благодаря на divak и Gaara за съдействието.

Пробвах горното. За съжаление не се получава при ppp0 (иначе с eth1 работи)...
Активен

Radev

  • Напреднали
  • *****
  • Публикации: 218
    • Профил
    • WWW
настройка на рутер - не работи при ppp0
« Отговор #9 -: Jun 12, 2008, 15:20 »
А от първия компютър wget-а работи ли през ppp0?
Активен

Човек и добре да живее... !

VladSun

  • Напреднали
  • *****
  • Публикации: 2166
    • Профил
настройка на рутер - не работи при ppp0
« Отговор #10 -: Jun 12, 2008, 15:23 »
Прилича ми на "рязане" по TTL за всички протоколи освен ICMP.
Активен

KISS Principle ( Keep-It-Short-and-Simple )
http://openfmi.net/projects/flattc/
Има 10 вида хора на този свят - разбиращи двоичния код и тези, които не го разбират :P

gat3way

  • Напреднали
  • *****
  • Публикации: 6050
  • Relentless troll
    • Профил
    • WWW
настройка на рутер - не работи при ppp0
« Отговор #11 -: Jun 12, 2008, 15:34 »
Мене ми прилича на PMTU проблем. На този втория компютър му смъкни интерфейса и го вдигни с ifconfig eth0 x.x.x.x netmask blabla mtu 1400 up, сложи му наново default gw-a (защото като смъкнеш интерфейса ще го отнема), после пробвай пак. Очевидно някъде поради някаква причина се филтрират ICMP fragmentation needed съобщенията.
Активен

"Knowledge is power" - France is Bacon

VladSun

  • Напреднали
  • *****
  • Публикации: 2166
    • Профил
настройка на рутер - не работи при ppp0
« Отговор #12 -: Jun 12, 2008, 15:53 »
Цитат (gat3way @ Юни 12 2008,15:34)
Мене ми прилича на PMTU проблем.

Да, определено пробвай - и този проблем съм го имал (макар и само с някои сайтове ...)
Активен

KISS Principle ( Keep-It-Short-and-Simple )
http://openfmi.net/projects/flattc/
Има 10 вида хора на този свят - разбиращи двоичния код и тези, които не го разбират :P

gat3way

  • Напреднали
  • *****
  • Публикации: 6050
  • Relentless troll
    • Профил
    • WWW
настройка на рутер - не работи при ppp0
« Отговор #13 -: Jun 12, 2008, 15:57 »
Ем то зависи къде е този пакостник дето се е разиграл с филтрирането '<img'>
Активен

"Knowledge is power" - France is Bacon

tolostoi

  • Напреднали
  • *****
  • Публикации: 1337
  • Distribution: Ubuntu
  • Window Manager: Unity
  • левел: авераж :)
    • Профил
настройка на рутер - не работи при ppp0
« Отговор #14 -: Jun 12, 2008, 18:42 »
Ооо направо претръпнах, преди година и половина 2 го мъчих тоя впн (то беше малко след като за първи път видях линукс '<img'> ) и ме би много жестоко, не мога да му го простя и още ме е яд  ':crazy:'  Бях го докарал горе-долу до това полужение и странното беше, че ICS на windows го прекарваше, а аз тогава не успях с Убунту (ама и от нищо не отбирах). Ще дам още малко инфо.
pptp с mppe 128 бит енкрипшън. Няма ограничение по ttl мисля, че не се режат и високите портове. Преди беше задължително да свалиш mtu-то за да работи нормално (1380 беше ОК) vstoykov да каже как е в момента при него.
То, май има и загуби на пакети при дълги пингове, сваляне и вдигане на ppp0 ги оправят (понякога) Според мен проблема си е във ВПН-а по добре да се пусне дебъг и да се види какво хвърля.

Дори ето го последният пиър който работеше при мен, може да го тествам довечера дали още работи.

Примерен код
remotename mytunnel
linkname mytunnel
ipparam mytunnel
# data stream for pppd to use
pty "pptp 195.138.138.17 --nolaunchpppd "
name *****
usepeerdns
require-mppe
mppe-stateful
persist
# do not require the server to authenticate to our client
noauth
# adopt defaults from the pptp-linux package
file /etc/ppp/options.pptp
#mtu 1450
#mtu 1450


vstoykov пробвай да махнеш всички статични маршрути, спри скриптовете които ги изпълняват и вдигни тунела ръчно сложи за deafult gw ppp0 и тогава маскирай ppp0, друг вариант е да пробваш да поставиш вместо ppp0 за deafult gw, адреса 195.138.138.2 не маскирай eth1



Активен


... в Столичен инспекторат една година след миграцията, продължават да работят под Linux. Което, май прави "експеримента" успешен
by entusiast

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Проблем с Рутирането на ppp0
Настройки на софтуер
chatlisi 1 1503 Последна публикация Mar 31, 2005, 08:52
от skotarov
Проблем с ppp0
Настройка на хардуер
techobg 15 2607 Последна публикация Jun 15, 2005, 22:53
от techobg
ppp0 не се вдига
Настройка на хардуер
KiselotoMliako 5 1728 Последна публикация Jan 16, 2006, 17:27
от romeo_ninov
Load balancing на ppp0 & eth1
Настройка на програми
senser 10 3356 Последна публикация Sep 18, 2008, 15:56
от senser
Как да направя мост между ppp0 eth2
Хардуерни и софтуерни проблеми
runtime 10 2509 Последна публикация Feb 07, 2016, 16:38
от BRADATA