Автор Тема: Gentoo проблем  (Прочетена 4411 пъти)

alabal

  • Напреднали
  • *****
  • Публикации: 2173
  • cat /earth/europe/bg/sofia | grep Nacamura
    • Профил
Gentoo проблем
« Отговор #15 -: Jan 12, 2005, 21:50 »
А как го направи?

emerge gcc
Или нещо друго?
Що не пробваш:
emerge upgrade system
Активен

It makes you awful glad that you were born a man.

ray

  • Напреднали
  • *****
  • Публикации: 1258
    • Профил
Gentoo проблем
« Отговор #16 -: Jan 12, 2005, 21:55 »
Здравей,
Поне на пръв поглед проблема май е в libtool. Каква е версията на GCC.
1.Първо пробвай със: fix_libtool_files.sh OLD_GCC (run:fix_libtool_files.sh за помощ). Вероятно за теб: OLD_GCC=3.3.3
2.Виж дали ти е инсталирана бибиотеката: libstdc++v3, ако си със GCC > 3.3.4. Недей, сега видях че си със 3.3.4
3.Най-универсалното решение е да провериш в Bugzilla (bugs.gentoo.org), там търсиш нещо за даден пакет и/или версия и четеш.
Вероятно си обновил GCC и отттам идва грешката. Само хипотеза
Имаш ли инсталиран - gcc-config и какво дава: gcc-config -l ?
Може да преинсталираш и libtool и т.н. и т.н., има доста варианти.
Още веднъж те съветвам да пробваш Bugzilla.
Успех
Румен
Активен

  • Гост
Gentoo проблем
« Отговор #17 -: Jan 17, 2005, 13:40 »
Пак имам проблем  '<img'> КДЕ 3.3.2 вървеше до тази сутрин без ни най-малък проблем. След като си компилирах krusader започна да "здава багажа". Като дам logout от менюто на КДЕ-то и част от екрана ми е бяла, а другата е на вертикални бели линии. Не можах да разбера защо стана така. Може ли някой да ми помогне моля '<img'> И имам още 1 питанка  '<img'> Когато изпълня /sbin/telinit 4 само показва, че превключва в init 4 режим и седи така. Какво трябва да направя за да имам графичен вход и да мога да избирам каква графична среда да използвам (ако има тази опция де '<img'> )
Активен

Galeon

  • Напреднали
  • *****
  • Публикации: 35
    • Профил
Gentoo проблем
« Отговор #18 -: Jan 17, 2005, 22:02 »
Цитат (Guest @ Ян. 17 2005,14:40)
Пак имам проблем  '<img'> КДЕ 3.3.2 вървеше до тази сутрин без ни най-малък проблем. След като си компилирах krusader започна да "здава багажа". Като дам logout от менюто на КДЕ-то и част от екрана ми е бяла, а другата е на вертикални бели линии. Не можах да разбера защо стана така. Може ли някой да ми помогне моля '<img'> И имам още 1 питанка  '<img'> Когато изпълня /sbin/telinit 4 само показва, че превключва в init 4 режим и седи така. Какво трябва да направя за да имам графичен вход и да мога да избирам каква графична среда да използвам (ако има тази опция де '<img'> )

Също така не мога да влизам в шарнати папки (самба). Има инсталиран самба пакет (emerge samba), но като напиша smb://<ip-to_na_server-a> ми излиза съобщение, че smb:// не е поддържан протокол. Това излиза при konueror и krusader. Какво да правя '<img'>
Активен

ray

  • Напреднали
  • *****
  • Публикации: 1258
    • Профил
Gentoo проблем
« Отговор #19 -: Jan 17, 2005, 22:48 »
Здравей,
При Gentoo няма нови версии, с излизане на новите пакети постоянно си обновяваш системата. Това обаче си има и цена, един пример, даден инсталиран пакет зависи от друг пакет/библиотека под него. Обаче излиза нова версия на библиотеката и тя се инсталира след това може пакета вече да не работи с новата версия или или пък да работи нестабилно.
Отделно при инсталация на нова версия на python и/или Perl има модули, които са компилирани за старата версия и трябва да се прекомпилират - за тази цел си има два инструмента: python-updater и libperl-rebuilder които се стартират след инсталиране на нова версия на интерпретаторите.
Отделно има и инструмент за libtool: fix_libtool_files.sh - обикновенно се ползва при проблеми с нови версии на GCC.
Най-сетне и нещо вероятно за твоя проблем: има още един '<img'> скрипт - revdep-rebuild, който проверява връзката на пакетите с динамичните библиотеки и ако има проблем докладва и евентуално прекомпилира.
Просто обяснение/аналогия може да се даде ако работиш с rpm или deb пакети и смесиш woody/sarge с sid пакети. Обикновенно се появява проблем и трябва и други пакети да се вземат от sarge/sid и т.н.
Така че моя съвет е: #revdep-rebuild -pv за да видиш дали и какви пакети ще трябва да се прекомпилират, после махаш '-p' за същинската компилиция.
По въпроса за telnit 4 - gentoo си има своя система за системата за стартиране, виж документите на сайта. Това не работи.
Съвсем накратко за графична среда: 'emerge xdm|kdm|gdm избери един от трите (може и без графичен логин-менажер - startx).
После 'rc-update add xdm|kdm|gdm default' и 'etc/init.d/xdm|kdm|gdm start.
На сайта (Gentoo) има страшно много ръководства, има и за самба виж ги, много са добри '<img'>
Успех
Румен
Активен