Автор Тема: Проблем със смяната на клавиатурните езици в Mandriva 2009 (KDE 3.5.10)  (Прочетена 2560 пъти)

LinuxFanUNIX

  • Напреднали
  • *****
  • Публикации: 408
  • Distribution: Slackware 12.2
  • Window Manager: KDE 3.5.10
    • Профил
Добър вечер.

Инсталирах си Mandriva 2009 и махнах KDE4 и си сложих 3-ката. Обаче се появи следният проблем:
Кликайки на знаменцата в трея, подредбата се сменя, но ако използвам Alt+Shift - не. Пробвах да го оправя от контролния панел (kcontrol), обаче пак не се получава. Прегледах в интернет - видях че не само аз имам този проблем, а и други хора, но техните решения с редактирането на xorg.conf не ми помогна... Пробвах kkbswitch, но и идея си нямам как да добавя втора подредба - има само опция за смяна на иконката на държавата - и съответно ми засича или само бг или само us.

Ето го и /etc/X11/xorg.conf:
Код
GeSHi (Bash):
  1. # nvidia-xconfig: X configuration file generated by nvidia-xconfig
  2. # nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Thu Feb  5 00:18:17 PST 2009
  3.  
  4. Section "ServerLayout"
  5.    Identifier     "Layout0"
  6.    Screen      0  "Screen0"
  7.    InputDevice    "Keyboard0" "CoreKeyboard"
  8.    InputDevice    "Mouse0" "CorePointer"
  9. EndSection
  10.  
  11. Section "Files"
  12.    FontPath        "/usr/share/fonts/default/Type1"
  13. EndSection
  14.  
  15. Section "Module"
  16.    Load           "dbe"
  17.    Load           "extmod"
  18.    Load           "type1"
  19.    Load           "freetype"
  20.    Load           "glx"
  21. EndSection
  22.  
  23. Section "InputDevice"
  24.    # generated from default
  25.    Identifier     "Mouse0"
  26.    Driver         "mouse"
  27.    Option         "Protocol" "auto"
  28.    Option         "Device" "/dev/psaux"
  29.    Option         "Emulate3Buttons" "no"
  30.    Option         "ZAxisMapping" "4 5"
  31. EndSection
  32.  
  33. Section "InputDevice"
  34.    # generated from default
  35.    Identifier     "Keyboard0"
  36.    Driver         "kbd"
  37.    Option         "XkbLayout" "us,bg"
  38.    Option         "XkbVariant" ",phonetic"
  39.    Option         "XkbOptions" "grp:alt_shift_toggle"
  40.  
  41. EndSection
  42.  
  43. Section "Monitor"
  44.    Identifier     "Monitor0"
  45.    VendorName     "Unknown"
  46.    ModelName      "Unknown"
  47.    HorizSync       28.0 - 33.0
  48.    VertRefresh     43.0 - 72.0
  49.    Option         "DPMS"
  50. EndSection
  51.  
  52. Section "Device"
  53.    Identifier     "Device0"
  54.    Driver         "nvidia"
  55.    VendorName     "NVIDIA Corporation"
  56. EndSection
  57.  
  58. Section "Screen"
  59.    Identifier     "Screen0"
  60.    Device         "Device0"
  61.    Monitor        "Monitor0"
  62.    DefaultDepth    24
  63.    SubSection     "Display"
  64.        Depth       24
  65.    EndSubSection
  66. EndSection
  67.  
  68.  

Ще се радвам ако някой може да ми помогне.

Благодаря предварително!
« Последна редакция: Mar 20, 2009, 13:54 от LinuxFanUNIX »
Активен

remotex

  • Напреднали
  • *****
  • Публикации: 344
    • Профил
Разкарай kkbswitch и редактирай ~/.kde/share/config/kdeglobals
 Switch to Next Keyboard Layout=Alt+Shift_L;Alt+Shift_R
- няма нужда да пипаш xorg.conf
Активен

Naka

  • Напреднали
  • *****
  • Публикации: 3063
    • Профил
Клавиатурата на КДЕ-то със знаменцата в трейя и  конфигурацията на xkb от xorg.conf си пречат взаимно.
можеш да ползваш или само едното или другото.

Например: Имаш правилно настроена калвиатура от xorg, всичко си работи нормално, но в момента когато пуснеш KDE  клавиатурата, престава да работи. Даже и да я спреш, след това пак не се вътаноява работата на xkb от xorg. проблема се решава чак след рестарт на X сървера. Защо е так нямам идея.

Съветвам те да не ползваш изобщо KDE- клавиатурата, все още е много бъгава ами да си настроиш правилно xorg.conf. Така ще имаш работеща подредба не само в кде но и във всички други графични менажери. За индикация вместо знаменцата може да се ползва ScrollLock лампичката на клавиатурата. grp_led:scroll
Код:
   Option      "XkbVariant" "phonetic"
   Option      "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll,altwin:meta_alt"
« Последна редакция: Mar 18, 2009, 11:32 от Naka »
Активен

Perl - the only language that looks the same before and after encryption.

LinuxFanUNIX

  • Напреднали
  • *****
  • Публикации: 408
  • Distribution: Slackware 12.2
  • Window Manager: KDE 3.5.10
    • Профил
Разкарай kkbswitch и редактирай ~/.kde/share/config/kdeglobals
 Switch to Next Keyboard Layout=Alt+Shift_L;Alt+Shift_R
- няма нужда да пипаш xorg.conf
Благодаря много! Стана по този начин!  [_]3

Naka оправих се по-горния начин, но благодаря за съвета, ще го имам предвид за друг път...

Сега се появи друг проблем - като се опитам да използвам командите Ctrl+C, Ctrl+V или каквато и да е клавишна комбинация за някакво действие, трябва да обърна на латиница (US) за да работи комбинацията, иначе на бг - не иска

Бихте ли ми помогнали?

Благодаря предварително!
Активен

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Сега се появи друг проблем - като се опитам да използвам командите Ctrl+C, Ctrl+V или каквато и да е клавишна комбинация за някакво действие, трябва да обърна на латиница (US) за да работи комбинацията, иначе на бг - не иска
Ползвай съответно Ctrl+Insert и Shift+Insert ;)
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

kolio_kolev

  • Напреднали
  • *****
  • Публикации: 356
  • Distribution: Mandriva 2011, Mandriva Cooker
  • Window Manager: KDE 4.6.x
    • Профил
    • WWW
Защо се мъчиш и не ползваш инструментите на Mandriva за локализация:
Задаване на подредби и превключване на клавиатурните подредби


Също така, ако е за домашна машина, сложи си Mandriva 2009.1 RC1 с новото КДЕ 4.2.1 - няма да съжаляваш.
Може да я изтеглиш от тук: http://wiki.mandriva.com/en/2009.1_RC_1
След един месец ще излезе и официалната версия.

« Последна редакция: Mar 18, 2009, 15:45 от kolio_kolev »
Активен

Кольо Колев
Mandriva BG: http://mandriva.biotronica.net
Bitronica.Net форуми: http://forum.biotronica.net

LinuxFanUNIX

  • Напреднали
  • *****
  • Публикации: 408
  • Distribution: Slackware 12.2
  • Window Manager: KDE 3.5.10
    • Профил
Защо се мъчиш и не ползваш инструментите на Mandriva за локализация:
Задаване на подредби и превключване на клавиатурните подредби


Също така, ако е за домашна машина, сложи си Mandriva 2009.1 RC1 с новото КДЕ 4.2.1 - няма да съжаляваш.
Може да я изтеглиш от тук: http://wiki.mandriva.com/en/2009.1_RC_1
След един месец ще излезе и официалната версия.
Дори направено по този начин който пише в линка който ми даде - пак не работят Ctrl+C, Ctrl+V когато съм на кирилица.

Не харесвам KDE 4.2. Много се зарадвах че все още има дистрибуция (след Debian) която може по нормален начин да и махнеш 4-ката и сложиш 3-ката.
Активен

Naka

  • Напреднали
  • *****
  • Публикации: 3063
    • Профил
Цитат
Дори направено по този начин който пише в линка който ми даде - пак не работят Ctrl+C, Ctrl+V когато съм на кирилица.
Въпрос: защо ти са Ctrl+C/V, след като само с осветявене и среден бутон на мишката (вместо Ctrl+V) става същото.
Досега само на Опен офисе му трябват Ctrl+C/V. и на mc майче?
« Последна редакция: Mar 18, 2009, 19:47 от Naka »
Активен

Perl - the only language that looks the same before and after encryption.

phantomlord

  • Напреднали
  • *****
  • Публикации: 1832
  • Distribution: Debian Sid
  • Window Manager: KDE 4
  • Fall to your knees and bow to the Phantom Lord
    • Профил
    • WWW
Не е необходмо да махаш kkbswitch, не пречи по никакъв начин. Можеш и спокойно да си ползваш Ctrl+C, Ctrl+V на кирилица.
При мен настройката на /etc/X11/xorg.conf е така:
Цитат
Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc104"
   Option "XkbLayout" "us,bg"
   Option "XkbVariant" ",phonetic"
   Option "XkbOptions" "grp:ctrl_shift_toggle,grp:lwin_switch,grp_led:scroll"
#за превключване ползвам ctrl+shift, за временно превключване - win бутона.
EndSection
Настройките в контрол-центъра на KDE за клавишните комбинации относно превключването на езиците обаче трябва да се изключват.
За предпочитане е използването на редакция на xorg.conf, защото действа за всяка графична среда.
« Последна редакция: Mar 19, 2009, 21:36 от phantomlord »
Активен

http://myfreesoft.net/phpBB2/index.php?c=7
Помогни си сам, за да ти помогне и Господ
Linux - connecting people...

LinuxFanUNIX

  • Напреднали
  • *****
  • Публикации: 408
  • Distribution: Slackware 12.2
  • Window Manager: KDE 3.5.10
    • Профил
Не стана по този горния начин.

Става въпрос че аз съм свикнал да използвам командите Ctrl+C, Ctrl+V, Ctrl+A, Ctrl+T... а и не искам да махам долу знаменцата, защото компютъра не се използва само от мен, а и е и неудобно да се превключва на US за да се натиснат тези комбинации...

Еех, как не помня в Debian как го оправих тоя проблем, и дали изобщо го имаше...
Активен

LinuxFanUNIX

  • Напреднали
  • *****
  • Публикации: 408
  • Distribution: Slackware 12.2
  • Window Manager: KDE 3.5.10
    • Профил
Благодаря много, чак сега схванах логиката...

Махам KDE Control Panel Layouts, оправям си xorg.conf, инсталирам kkbswitch и всичко лети...  :)

Благодаря Ви още веднъж...  [_]3 [_]3 [_]3 [_]3 [_]3
« Последна редакция: Apr 25, 2009, 13:04 от LinuxFanUNIX »
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
PPPoE в Mandriva 2009
Настройка на програми
MandrivaUser 3 3012 Последна публикация Mar 18, 2009, 12:44
от LinuxFanUNIX
Wireless-Atheros-Mandriva 2009
Настройка на хардуер
Dit_dh 4 2491 Последна публикация Jan 15, 2009, 12:19
от shoshon
Mandriva 2009 dvd +Xp
Настройка на програми
recepti 15 4023 Последна публикация Mar 03, 2009, 19:18
от kolio_kolev
Mandriva 2009
Настройка на програми
shalakov 0 989 Последна публикация Mar 17, 2009, 20:28
от shalakov
Mandriva 2009 pwp x64 не засича usb mouse
Настройка на програми
bazu 13 3283 Последна публикация Apr 22, 2009, 16:05
от kolio_kolev