Автор Тема: Проблеми с видео кодеците  (Прочетена 3184 пъти)

BOT_ev

  • Напреднали
  • *****
  • Публикации: 995
  • Distribution: Debian
  • Window Manager: KDE
    • Профил
Проблеми с видео кодеците
« Отговор #15 -: Apr 08, 2004, 21:48 »
Благодаря за линка но нямам data.bg, защото съм към evro.net!!
Активен

Get to da chopa !!!
----------------------------------------------------------------------

BOT_ev

  • Напреднали
  • *****
  • Публикации: 995
  • Distribution: Debian
  • Window Manager: KDE
    • Профил
Проблеми с видео кодеците
« Отговор #16 -: Apr 08, 2004, 22:28 »
Пробвах абсолютно всичко дори си преинсталирах системата от нулата - нищо не става!!! Нито rpm-и нито компилиране най-официално се отказвам. Ако има алтернатива (все пак не само тоя вече омразен за мен Mplayer) казвайте ако не .....!!!
Активен

Get to da chopa !!!
----------------------------------------------------------------------

  • Гост
Проблеми с видео кодеците
« Отговор #17 -: Apr 09, 2004, 00:00 »
otgovora e aviplayer
->google.com->search "aviplayer"
Активен

  • Гост
Проблеми с видео кодеците
« Отговор #18 -: Apr 09, 2004, 00:11 »
Eto ti i link:
http://avifile.sourceforge.net/
Активен

Al_Kapone

  • Напреднали
  • *****
  • Публикации: 30
    • Профил
Проблеми с видео кодеците
« Отговор #19 -: Apr 09, 2004, 12:02 »
Изтрих целиа Мплейър, изтеглих новия, последен, rpm za suse8.2, и ето какво ми дава Yast-a:

#### YaST2 conflicts list - generated 2004-04-09 11:54:35 ####

liblzo.so.1 not available
    Required by:
        MPlayer requires liblzo.so.1
    Conflict Resolution:
        ( ) Remove the Conflicting Package
            Do Not Install MPlayer
        ( ) Ignore Conflict and Risk System Inconsistencies
libmp3lame.so.0 not available
    Required by:
        MPlayer requires libmp3lame.so.0
    Conflict Resolution:
        ( ) Remove the Conflicting Package
            Do Not Install MPlayer
        ( ) Ignore Conflict and Risk System Inconsistencies
libtheora.so.0 not available
    Required by:
        MPlayer requires libtheora.so.0
    Conflict Resolution:
        ( ) Remove the Conflicting Package
            Do Not Install MPlayer
        ( ) Ignore Conflict and Risk System Inconsistencies
MPlayer 1.0pre3-pm.2 conflict
    Unresolved Requirements:
        MPlayer requires liblzo.so.1
        MPlayer requires libmp3lame.so.0
        MPlayer requires libtheora.so.0
    Conflict Resolution:
        ( ) Do Not Install MPlayer
        ( ) Ignore Conflict and Risk System Inconsistencies

#### YaST2 conflicts list END ###
Активен

fierce

  • Напреднали
  • *****
  • Публикации: 78
  • Distribution: SuSE от версия 8.2
  • Window Manager: KDE+Console
    • Профил
    • WWW
Проблеми с видео кодеците
« Отговор #20 -: Apr 09, 2004, 13:16 »
Първо инсталираш кодеците, после плеъра и най накрая скиновете. '<img'>
Активен

openSUSE 12.3 - Registered Linux user #376002

Home PC - AMD Phenom II X4 955 BE | ASRock K10N78D | 4GB RAM Kingston | GF 8800GT Zilent | WD 640GB AAKS | DVD-RW - LG GH22LS50 | Fortron 500W | LG 196WTQ |
Laptop - ASUS K51AE-SX063L

  • Гост
Проблеми с видео кодеците
« Отговор #21 -: May 05, 2004, 20:18 »
брей, уж всичко чета пък това съм го опуснал! Ето помощ бе човек, ти си се измъчил ! Стъпка по стъпка как го направих за 1.0pre3 '<img'>
Сваляш си СОРСА .tgz от страницата на Мплейр, разархивираш и влизаш в директорията където се екстрактна сорса.

1. ./configure --enable-gui --with-gtk-config=/opt/gnome/bin/gtk-config
--with-glib-config=/opt/gnome/bin/glib-config

Коментар: естествено че имаш GTK, просто пътя е друг '<img'>

2. make

3. Влез като root и make install
4. Свали си шрифтове пак от
http://www.mplayerhq.hu/homepage/dload.html

за OSD/Subtitles support, разархивирай ги и ги запиши в
/usr/local/share/mplayer/font/

5. Свали си скинове за GUI, разархивирай и сложи в
 /usr/local/share/mplayer/Skin/ (ако я няма тая дир СКИНС си я направи)
задължително трябва да сложиш една кожа (за да тръгне с някакъв дефаулт) във
/usr/local/share/mplayer/Skin/default/skin

6. оправи бъгчето за фонтовете

ln -s /usr/X11R6/lib/X11/fonts/truetype/luxisri.ttf ~/.mplayer/subfont.ttf

ако нямаш (което не вярвам) тоя фонт luxisri.ttf си избери друг. Това е бъгче което при стартиране на плеъра ти казва че нямало някакав си фонт - ето го вече оправено

7. полезно би било:

да линкнеш кодеците:
ln -s /usr/local/etc/mplayer/codecs.conf ~/.mplayer/codecs.conf

но това може и да те узори, при мене работи и без тая стъпка!

А сега се наслаждавай на плеъра, просто напиши gmplayer!
Активен

BOT_ev

  • Напреднали
  • *****
  • Публикации: 995
  • Distribution: Debian
  • Window Manager: KDE
    • Профил
Проблеми с видео кодеците
« Отговор #22 -: May 05, 2004, 23:00 »
Не знаеш в какво се забърка '<img'> Ето какъв е проблема сега:
Цитат
Checking for GUI ... yes
Checking for XShape extension ... yes
Checking for gtk version ... ./configure: line 1: /opt/gnome/bin/gtk-config: No such file or directory (using /opt/gnome/bin/gtk-config)
Checking for glib version ...
Error: The GUI requires GLib devel packages (which were not found)

И с тоя път не става '<img'> Имам glib2 между другото '<img'>
Активен

Get to da chopa !!!
----------------------------------------------------------------------

  • Гост
Проблеми с видео кодеците
« Отговор #23 -: May 06, 2004, 11:07 »
хмм, добре, явно трябва да му покажем мъжество! ако ползваш СуСЕ 9.0, и си инсталирал Гном трябва да го имаш!
в т.1. ако копираш целия ред от-до, там има пътя към glib, и gtk. провери ги за всеки случай, но не може при мене да са там. направи едно "cd /" после "find -name glib*.*" и така ще видиш кое каде е! Проблема е че тоя
Активен

dilyan

  • Напреднали
  • *****
  • Публикации: 186
  • Distribution: Debian, OpenBSD
  • Window Manager: Gnome, xfce
    • Профил
Проблеми с видео кодеците
« Отговор #24 -: May 06, 2004, 11:23 »
натиснах Enter без да искам '<img'> Значи проблема е че плеъра е компилиран за Слак, а в СуСЕ нещата са на други места. Иди сега в Yast Add /Remove Software намери glib-devel пакета и го инсталирай. после пак по точките от 1 до 6 '<img'>. Ако измранка за нещо друго че го няма, правиш "cd /" "find -name нещото*.*" най-добре като админ да го правиш! ако откриеш че го нямаш, търчиш в YaST и го добавяш, ако видиш че го имаш, просто му указваш пътя в configure --with-path-еди-кво-си=/еди/каде/си и си готов!
Активен

BOT_ev

  • Напреднали
  • *****
  • Публикации: 995
  • Distribution: Debian
  • Window Manager: KDE
    • Профил
Проблеми с видео кодеците
« Отговор #25 -: May 06, 2004, 11:57 »
Имам малко проблеми с машината, но веднага след като пробвам ще кажа дали има някакъв резултат '<img'>
Активен

Get to da chopa !!!
----------------------------------------------------------------------

  • Гост
Проблеми с видео кодеците
« Отговор #26 -: May 07, 2004, 01:56 »
Ето затова говорих и аз...Ще работим ли или ще си играем с тези компютри? Игри си има...
Активен