Автор Тема: звуков проблем  (Прочетена 1607 пъти)

stealth01

  • Гост
звуков проблем
« -: Jun 16, 2004, 11:02 »
Ползвам SuSE 9.1 с KDE 3.2.1, което вчера upgrade-нах до 3.2.3 с пакети от ftp.suse.com. рестартирах X и новото KDE тръгна заедно с един много неприятен шум... '<img'>
При просвирване на какъвто и да е звук, шумът намалява и почти не се чува... почти '<img'> След това отново започва да ми лази по нервите.
Реших проблема чрез преконфигуриране на звуковата карта от YaST, но тази сутрин при зареждането на KDE звукът отново се появи! ':angry:' Пак безуспешни опити...
Какво по дяволите пуска KDE-то, което не трябва да пуска? В контролния му център спрях Enable the sound system (това беше за arts, нали?), но нямаше полза...
Активен

kennedy

  • Напреднали
  • *****
  • Публикации: 2151
  • Николай Колев
    • Профил
звуков проблем
« Отговор #1 -: Jun 16, 2004, 12:14 »
пробвай като го пуснеш на раздела за хардуер да смениш OSS със ALSA
Активен

"за всичко иде час" Еклесиаст 3:1
всеки пост - отговор на въпрос
-----------------
24.12.2003 "MS Free"

stealth01

  • Гост
звуков проблем
« Отговор #2 -: Jun 16, 2004, 13:54 »
Мне, това не върши работа...
Странното е че просто като пусна от YaST найстройките за звук, без да променям нищо, още при зареждането на настройките проблема изчезва... Загледах се, точно при коя точка, се оправя и видях, че май е при "зареждане на настройките на картата(или нещо подобно, не го запомних точно)".
Примерен код
alsactl restore
и тръгна, тоест шума изчезва... Обаче не мога да разбера, какво прави KDE за да ми счупи настройките на аудиото? '<img'> И къде да пльосна горната команда, така че да се стартира веднага след като зареди KDE-то?
Активен

zazzko

  • Напреднали
  • *****
  • Публикации: 626
    • Профил
    • WWW
звуков проблем
« Отговор #3 -: Jun 16, 2004, 14:01 »
Прави това, че предефинира настройките на миксера. Отвори мискера на KDE и го настрой така, че да няма шум. След това от Контрол Панела на KDE влез в Мултимедия и запази текущите настройки.

stealth01

  • Гост
звуков проблем
« Отговор #4 -: Jun 16, 2004, 14:37 »
Мерси! '<img'>
А уж бърниках по миксера, но май не достатъчно...
Активен

Al_Kapone

  • Напреднали
  • *****
  • Публикации: 30
    • Профил
звуков проблем
« Отговор #5 -: Jun 16, 2004, 15:13 »
Аз имам друг проблем с звука на Сусето. С 8.2 съм, и не мога да разбера защо всички видове звуци, било то от филм, мп3, ай си кю, или каквото и да е, изчакват да свърши предния звук, все едно че се натрупват в някакъв буфер и после се изреждат един след друг'<img'>? Някой може ли да ми помогне?
Примерно отварям някаква страница която има флаш със звук, и съм си пуснал мп3-ка, докато не спра мп3-ката не мога да заредя страницата. След като спра мп3-ката и страницата си се зарежда и чувам звука от флаша. Или пък пуснал сам си пак да кажем мп3-ка, получавам съобщения на аи си кю, и като спра музиката и чувам сичките кукания на ай си кю-то подред едно след друго...със всички видове звуци ми е така. Не могат да вървят повече от 1 звук едновременно, а се изчакват...От къде мога да го оправя или настроя? Казаха ми да дигна АЛСА драйвери но и това не помогна...
Активен

stealth01

  • Гост
звуков проблем
« Отговор #6 -: Jun 16, 2004, 15:54 »
В Preferences / Audio IO Plug-ins на XMMS-а избираш за Output примерно aRts или нещо друго различно от OSS... за MPlayer-а по същия начин...
Активен

Al_Kapone

  • Напреднали
  • *****
  • Публикации: 30
    • Профил
звуков проблем
« Отговор #7 -: Jun 16, 2004, 16:11 »
ами не мисля че проблема е на дадена програма като xmms ili mplayer например, макар че направих това дето ми каза ама си е се така, слушам музика аи си кю получавам съобщения, спрях песента и аидееее, куку куку, дрън, всичките звуци се изредиха подред '<img'>
Активен

  • Гост
звуков проблем
« Отговор #8 -: Jun 16, 2004, 16:47 »
Bratko,
poiarvaj na sthealth, taka e kakto toj kazva.
V Control Panela si nastroj chudnia aRts demon - v sekcia Sound e - razgledaj go vnimatelno.
Активен

Al_Kapone

  • Напреднали
  • *****
  • Публикации: 30
    • Профил
звуков проблем
« Отговор #9 -: Jun 16, 2004, 17:16 »
Цитат (Guest @ Юни 16 2004,17:47)
Bratko,
poiarvaj na sthealth, taka e kakto toj kazva.
V Control Panela si nastroj chudnia aRts demon - v sekcia Sound e - razgledaj go vnimatelno.

Za koi kontrol panel mi govorish na Suse control center-a li?
ako e za nego puskam go, tam ima sound and multimedia, a vytre ima sound system, i vytre ima razdel "aRTs" i sound I/O, v nego vsi4ko mi e na auto:
sound I/O metod :autodetect
drugite vyzmojni sa: open sound system, advansed linux sound arhitekture.....si4kite gi izredih faida niama


soundcoality: auto

ne vijdam kakvo da nastroivam
Активен

  • Гост
звуков проблем
« Отговор #10 -: Jun 16, 2004, 22:28 »
Znachi,
dokolkoto si spomniam SuSE 8.2, purvata i predposledna Linux distribucia koiato opitah, v Control Centura na KDE ima pone dve stranichki za upravlenie na aRts - tam e problema, stoiah bez zvuk okolo mesec, dokato go razbera tochno ot kude. Tochno tam kudeto si gledal triabva da ima oshte edin buton za edni drugi neshta, koito ne si spomniam, no si spomniam, che biaha vajni. Smenih 18 cheshita alsa driver-i i posle se okaza, che e ot control panela.

Vuzmojno e da napravish slednoto:
1. pishesh v konzolata: man arts
i chetesh kak se spira i se puska toz pusti demon.
2. Spirash demona - pak ot konzolata.
3. Puskash demona i chetesh kakvo ti pishe.
4. Ako ne ti pishe nishto puskash xmms - ot shortcut i posle ot konzolata mplayer - ako ima konflikt nepremenno shte ti kaje kakuv e.
5. Ako ne se setish kakvo znachi tova koeto ti pishe - postvash otgovora tuk.

Tova e obshto vzeto, dano da pomogne.
I sori za latinicata.
Активен

Al_Kapone

  • Напреднали
  • *****
  • Публикации: 30
    • Профил
звуков проблем
« Отговор #11 -: Jun 17, 2004, 09:43 »
1.man arts
No manual entry for arts

2. V KDE control center->sound and multimedia-> imam 4 podmenu-ta:
-Audio CDs
-Sound System
-System Bell
-System Notification
samo v menuto Sound System ima za aRTs, eto i negovite podmenu-ta:
-aRTs
-Sound I/O
-Mixer
-MIDI

Zna4i v pyrvoto menu aRTs mi e otmetnato "start a aRTs soundserver on KDE startup"
V Sound I/O:
Sound I/O metod: autodetect (kato go dam na drugo i niamam izobshto sound)

Ne znam dali izobshto tam da tyrsia problema...

Sorry i za moiata latinica
Активен