Автор Тема: update на библиотеки  (Прочетена 2109 пъти)

worthless

  • Напреднали
  • *****
  • Публикации: 64
    • Профил
update на библиотеки
« -: Jan 23, 2005, 14:22 »
здравейте!
имам сусе 9.2 и се опитвам да ъпдейтна glib-библиотеката. изпълнявам
Примерен код
rpm -Uhv glib-2.3.5-1.i686.rpm
error: Failed dependencies:
        libglib-1.2.so.0 is needed by (installed) gtk-1.2.10-882
        libglib-1.2.so.0 is needed by (installed) pinentry-0.7.1-2
        libglib-1.2.so.0 is needed by (installed) WindowMaker-applets-1.0-649
        libglib-1.2.so.0 is needed by (installed) xdelta-1.1.3-3
        libglib-1.2.so.0 is needed by (installed) evms-gui-2.3.3-2
        libglib-1.2.so.0 is needed by (installed) ghostscript-library-7.07.1rc1-207
        libglib-1.2.so.0 is needed by (installed) fvwm2-2.5.10-2
        libglib-1.2.so.0 is needed by (installed) ghostscript-x11-7.07.1rc1-207
        libglib-1.2.so.0 is needed by (installed) freeciv-1.14.2-2
        libglib-1.2.so.0 is needed by (installed) libdv-0.103-2
        libglib-1.2.so.0 is needed by (installed) xmms-lib-1.2.10-56
        libglib-1.2.so.0 is needed by (installed) libquicktime-0.9.3-2
        libglib-1.2.so.0 is needed by (installed) xmms-1.2.10-56
        libglib-1.2.so.0 is needed by (installed) amarok-xmms-1.0.2.cvs20040907-12
        libglib-1.2.so.0 is needed by (installed) xmms-kde-3.1-50
        libglib-1.2.so.0 is needed by (installed) xmms-plugins-1.2.9-68
        libglib-1.2.so.0 is needed by (installed) imlib-1.9.14-188.2
        libglib-1.2.so.0 is needed by (installed) MPlayer-1.0pre5-pm.2
        libglib-1.2.so.0 is needed by (installed) kdeaddons3-kicker-3.3.2-3
        libgmodule-1.2.so.0 is needed by (installed) gtk-1.2.10-882
        libgmodule-1.2.so.0 is needed by (installed) pinentry-0.7.1-2
        libgmodule-1.2.so.0 is needed by (installed) WindowMaker-applets-1.0-649
        libgmodule-1.2.so.0 is needed by (installed) evms-gui-2.3.3-2
        libgmodule-1.2.so.0 is needed by (installed) ghostscript-library-7.07.1rc1-207
        libgmodule-1.2.so.0 is needed by (installed) fvwm2-2.5.10-2
        libgmodule-1.2.so.0 is needed by (installed) ghostscript-x11-7.07.1rc1-207
        libgmodule-1.2.so.0 is needed by (installed) freeciv-1.14.2-2
        libgmodule-1.2.so.0 is needed by (installed) libdv-0.103-2
        libgmodule-1.2.so.0 is needed by (installed) xmms-lib-1.2.10-56
        libgmodule-1.2.so.0 is needed by (installed) libquicktime-0.9.3-2
        libgmodule-1.2.so.0 is needed by (installed) xmms-1.2.10-56
        libgmodule-1.2.so.0 is needed by (installed) amarok-xmms-1.0.2.cvs20040907-12
        libgmodule-1.2.so.0 is needed by (installed) xmms-kde-3.1-50
        libgmodule-1.2.so.0 is needed by (installed) xmms-plugins-1.2.9-68
        libgmodule-1.2.so.0 is needed by (installed) imlib-1.9.14-188.2
        libgmodule-1.2.so.0 is needed by (installed) MPlayer-1.0pre5-pm.2
        libgmodule-1.2.so.0 is needed by (installed) kdeaddons3-kicker-3.3.2-3
        libgthread-1.2.so.0 is needed by (installed) evms-gui-2.3.3-2
        libgthread-1.2.so.0 is needed by (installed) xmms-lib-1.2.10-56
        libgthread-1.2.so.0 is needed by (installed) xmms-1.2.10-56
        libgthread-1.2.so.0 is needed by (installed) amarok-xmms-1.0.2.cvs20040907-12
        libgthread-1.2.so.0 is needed by (installed) xmms-plugins-1.2.9-68
        libgthread-1.2.so.0 is needed by (installed) kdeaddons3-kicker-3.3.2-3
        glib = 1.2.10 is needed by (installed) glib-devel-1.2.10-589
        glib2 is needed by (installed) shared-mime-info-0.14-10
        glib2 is needed by (installed) linc-1.0.3-180
        glib2-devel is needed by (installed) atk-devel-1.6.0-4
        glib2-devel is needed by (installed) pango-devel-1.4.1-3
        glib2-devel is needed by (installed) gtk2-devel-2.4.9-10
        glib2-devel is needed by (installed) arts-devel-1.3.1-3

виждам, че инсталираните библиотеки се ползват от разни програми и затова не могат се ъпдейтнат с -Uh. въпросът ми е безопасно ли е да инсталирам glib с "rpm -i glib.blabla.rpm" и ако не има ли някакъв начин да си ъпдейтна библиотеките без да прецакам нищо? ще съм благодарен на всеки, който даде няква идея. поздрави!

п.п. ако не съм преценил правилно мястото на тази тема във форума, се извинявам!
Активен

You can't spell "believe" without lie...

romeo_ninov

  • Напреднали
  • *****
  • Публикации: 2155
    • Профил
update на библиотеки
« Отговор #1 -: Jan 23, 2005, 14:50 »
По мое мнение ако ще ъпдейтваш го направи не с
Цитат

rpm -i glib.blabla.rpm

а с
Цитат

rpm -F glib.blabla.rpm
Активен

0x2B|~0x2B

worthless

  • Напреднали
  • *****
  • Публикации: 64
    • Профил
update на библиотеки
« Отговор #2 -: Jan 23, 2005, 16:04 »
ами няма резултат от тва...по-точно има, но е същия като този, който съм дал в предишния пост '<img'>...
Активен

You can't spell "believe" without lie...

saturn_vk

  • Напреднали
  • *****
  • Публикации: 215
    • Профил
update на библиотеки
« Отговор #3 -: Jan 23, 2005, 16:29 »
значи, личи се че рпм-а се опитва не само да затрие старият ти glib2, но и glib1. Затова ако има начин, му кажи да не затрива глиб1, или премахни глиб2 със --nodeps ако не се лъжа беше командата, и после инсталираи новият глиб2 като използваш същата команда
Активен

"That is not dead which can eternal lie,
And with strange aeons even death may die."

kennedy

  • Напреднали
  • *****
  • Публикации: 2151
  • Николай Колев
    • Профил
update на библиотеки
« Отговор #4 -: Jan 23, 2005, 17:44 »
я пробвай да го направиш това с
yast -i bla.rpm
Активен

"за всичко иде час" Еклесиаст 3:1
всеки пост - отговор на въпрос
-----------------
24.12.2003 "MS Free"

worthless

  • Напреднали
  • *****
  • Публикации: 64
    • Профил
update на библиотеки
« Отговор #5 -: Jan 23, 2005, 18:10 »
мда, точно това, което не исках да става... стана! значи пробвах с yast -i и то качи по-новата версия без да спазва dependencies. най-странното обаче е следното : когато пускам yast2 той ми дада broken dependencies za старата версия на glib, а като инсталирах отново стария пакет ми даде същото само че за новата версия. бозата е пълна! ако някой има идея, да казва '<img'> аз бях до тук  '<img'>
Активен

You can't spell "believe" without lie...

bsurgery

  • Напреднали
  • *****
  • Публикации: 24
  • Distribution: Linux Mint 19.2
  • Window Manager: cinnamon
    • Профил
update на библиотеки
« Отговор #6 -: Jan 24, 2005, 22:41 »
Преинсталирай братко, само това е оправията.
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
update на сайта?
Предложения за подобрения на сайта
lunarvalley 147 41518 Последна публикация Aug 29, 2018, 22:39
от bot
Проблем с repositori update
Настройка на програми
razorbladic 18 3673 Последна публикация Oct 25, 2014, 20:06
от cybercop
update php7
Настройка на програми
Vask0 8 2386 Последна публикация Feb 14, 2017, 23:15
от Vask0
Проблем с терминала след update.
Настройки на софтуер
deyan4 5 4889 Последна публикация Jul 14, 2017, 12:49
от go_fire
win 10 update и ... панделата !
Живота, вселената и някакви други глупости
spec1a 36 8491 Последна публикация Jun 07, 2018, 23:36
от rado84