Автор Тема: Kde + xkb  (Прочетена 1545 пъти)

Stratovarius

  • Напреднали
  • *****
  • Публикации: 179
    • Профил
Kde + xkb
« -: Dec 05, 2007, 04:34 »
дори в конфигурацията на Х го написах

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbModel" "cherryblueb"
    Option         "XkbLayout" "de,bg"
    Option         "grp:alt_space_toggle"
EndSection

въпреки това не работи. някакви идеи ?

FreeBSD 6.3
Активен

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Kde + xkb
« Отговор #1 -: Dec 05, 2007, 08:43 »
Цитат
Section "InputDevice"

Там добавяте/редактирате следните редове:

Option "XkbLayout"  "us,bg"
Option "XkbVariant" ",phonetic"

Това ще ви позволи да пишете на английски и български фонетичен. Ако предпочитате БДС, използвайте следния вариант:

Option "XkbLayout"  "us,bg"
Option "XkbVariant" ",bds"

За да използвате клавишни комбинации, добавяте следния ред:

Option "XkbOptions" "grp:ctrl_shift_toggle,grp:lwin_switch,grp_led:scroll"


edit: Забравих да ти напомня, че трябва да рестартираш графиката след промените '<img'>



Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

Stratovarius

  • Напреднали
  • *****
  • Публикации: 179
    • Профил
Kde + xkb
« Отговор #2 -: Dec 05, 2007, 12:04 »
Веднага след като написах:

wq!

рестартирах Х '<img'>
така че, не това е проблема
Активен

Hapkoc

  • Напреднали
  • *****
  • Публикации: 2117
    • Профил
Kde + xkb
« Отговор #3 -: Dec 05, 2007, 12:21 »
neter го е писал, но не знам дали си обърнал внимание:

  Option  "XkbOptions" "grp:alt_space_toggle"



Активен

Stratovarius

  • Напреднали
  • *****
  • Публикации: 179
    • Профил
Kde + xkb
« Отговор #4 -: Dec 05, 2007, 13:01 »
Това не работи
Примерен код

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbModel" "cherryblueb"
    Option         "XkbLayout" "de,bg"
    Option         "XkbVariant" ",phonetic"      Option         "XkbOptions" "grp:alt_space_toggle,grp:ctrl_shift_toggle"
EndSection


И директно

setxkbmap -option grp:alt_space_toggle

също не
Активен

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Kde + xkb
« Отговор #5 -: Dec 05, 2007, 13:10 »
Цитат
"XkbOptions" "grp:alt_space_toggle,grp:ctrl_shift_toggle"

Това е конфликт. Използвай един grp указател.
Примерен код
"XkbOptions" "grp:ctrl_shift_toggle"

Вглеждай се по-внимателно '<img'>
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

Hapkoc

  • Напреднали
  • *****
  • Публикации: 2117
    • Профил
Kde + xkb
« Отговор #6 -: Dec 05, 2007, 13:37 »
При мен в XKB настройките не намирам изобщо опция 'alt_space_toggle'. Сигурен ли си, че такава съществува?
Активен

Hapkoc

  • Напреднали
  • *****
  • Публикации: 2117
    • Профил
Kde + xkb
« Отговор #7 -: Dec 05, 2007, 13:40 »
http://sig11.blogspot.com/2006_10_01_archive.html

Доколкото чета тук, човека си я е добавил ръчно. Ти направил ли си го това?
Активен

Stratovarius

  • Напреднали
  • *****
  • Публикации: 179
    • Профил
Kde + xkb
« Отговор #8 -: Dec 05, 2007, 23:47 »
В университета имаме SuSe Linux. Там явно има предефинирана група алт_интервал, но тук наистина няма.
Искам алт_интервал понеже съм свикнал от ябълка ОС ябълка_интервал. но както и да е нека първо да направим контрол_шифт да работи.

в конфигурационния файл на Х
Option         "XkbOptions" "grp:ctrl_shift_toggle"


В лога на Х
(**) Option "XkbOptions" "grp:ctrl_shift_toggle"
(**) Keyboard0: XkbOptions: "grp:ctrl_shift_toggle"

В КДЕ никаква реакция
Активен

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Kde + xkb
« Отговор #9 -: Dec 06, 2007, 01:55 »
KDE използва друга настройка за клавишна комбинация от тази на Х. Намира се във файла /home/юзър/.kde/share/config/kdeglobals. Намираш реда "Switch to Next Keyboard Layout" и го задаваш равен на Ctrl+Shift_L или там каквато клавишна комбинация искаш '<img'>



Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

phantomlord

  • Напреднали
  • *****
  • Публикации: 1832
  • Distribution: Debian Sid
  • Window Manager: KDE 4
  • Fall to your knees and bow to the Phantom Lord
    • Профил
    • WWW
Kde + xkb
« Отговор #10 -: Dec 06, 2007, 02:04 »
Или направо изключи настройките за превключване на езиците в КДЕ контрол центъра.
Активен

http://myfreesoft.net/phpBB2/index.php?c=7
Помогни си сам, за да ти помогне и Господ
Linux - connecting people...

Stratovarius

  • Напреднали
  • *****
  • Публикации: 179
    • Профил
Kde + xkb
« Отговор #11 -: Dec 06, 2007, 15:38 »
Супер '<img'>

Много ви благодаря и на neter и на  phantomlord '<img'>

След като с ваша помощ решихме този проблем идва следващия '<img'>
Имам клавиатура Cherry CyMotion Expert (не линукс версията) настроих си бутоните за стартиране на програми като просто сложих от кде програмите да се стартират с тези бутони в КДЕ. обаче бутоните за контролиране на звука и на плеара и т.н. незнам как да ги направя. Копирах си от /usr/local/share/X11/xkb/symbols в /etc/X11/symbols
но незнам как се казват тези бутони за да ги настроя
Активен

phantomlord

  • Напреднали
  • *****
  • Публикации: 1832
  • Distribution: Debian Sid
  • Window Manager: KDE 4
  • Fall to your knees and bow to the Phantom Lord
    • Профил
    • WWW
Kde + xkb
« Отговор #12 -: Dec 06, 2007, 16:12 »
http://myfreesoft.net/phpBB2/viewtopic.php?t=131
Активен

http://myfreesoft.net/phpBB2/index.php?c=7
Помогни си сам, за да ти помогне и Господ
Linux - connecting people...