Автор Тема: Openoffice2  (Прочетена 1025 пъти)

Stratovarius

  • Напреднали
  • *****
  • Публикации: 179
    • Профил
Openoffice2
« -: Jan 17, 2008, 11:03 »
Здравейте,

имам следните проблеми:

OpenOffice не може да отваря файлове с интервали в името, има ли начин това да се промени ?

Koffice не показва правилно Екселски документи, но пък се справя с празните места ?

като сложа енкодинг utf-8:cp850 виждам специфичните немски букви но директориите с такива имена като се смени в тях се отварят рекузивно. Ако разкоментирам charset w /etc/nsmb.conf не виждам специалните букви както трябва но нямам проблеми да отварям файловете, но както казах по горе с OOo не мога да отварям файлове с интервали, което е изнервящо, зашото трябва да се преименуват много папки с интервали, което си е много работа.

Някакви предложения ?

//offtopic
Сега разбирам защо министара се е дърпал за OOo

OS e FreeBSD 6.3.
Активен

kennedy

  • Напреднали
  • *****
  • Публикации: 2151
  • Николай Колев
    • Профил
Openoffice2
« Отговор #1 -: Jan 17, 2008, 11:59 »
при мен си отваря с и без интервали

ОС SUSE 10.2/10.3

Нещо ти е бъгава ОС-а
Активен

"за всичко иде час" Еклесиаст 3:1
всеки пост - отговор на въпрос
-----------------
24.12.2003 "MS Free"

Stratovarius

  • Напреднали
  • *****
  • Публикации: 179
    • Профил
Openoffice2
« Отговор #2 -: Jan 17, 2008, 12:37 »
Много изчерпателен отговор!
Благодаря.

Както споменах по горе само ООо2 не може, това означава че ОС не ми е скапана '<img'>.

Или какво ще каже СуСе потребителя, къде да кликна за да го оправя?

Хайде ако има някой сериозен '<img'>, такива отговори като горния наистина не ми помагат
Активен

kennedy

  • Напреднали
  • *****
  • Публикации: 2151
  • Николай Колев
    • Профил
Openoffice2
« Отговор #3 -: Jan 17, 2008, 14:15 »
Не си задал правилно въпроса ми се струва. Затова така ти отговарям. Хайде сега да кажеш:

на локалния компютър ли отваряш или по мрежа?
какво ти изписва когато го стартираш от конзола?
защо намесваш /etc/nsmb.conf? да не би случайно да е сървър на който се закачат клиентите да си отварят файловете?
Активен

"за всичко иде час" Еклесиаст 3:1
всеки пост - отговор на въпрос
-----------------
24.12.2003 "MS Free"

Stratovarius

  • Напреднали
  • *****
  • Публикации: 179
    • Профил
Openoffice2
« Отговор #4 -: Jan 17, 2008, 21:04 »
Явно съм бил неточен.

Ситуацията е следната:
Малък офис с три работни станции, 2 от тях мигрирам на FreeBSD, единия е лаптоп, проблемите със съвместимостта се появиха при първата работна станция.
ООо не може да чете файлове които има в пътеката си празни места, независимо дали локално или споделени ресурси в мрежата. Пробвах с Версия 2.2.1 и 2.4 нямаше успех, с КОфис нямаше проблеми но не предтсавяше MS Excel формата както трябва, за това прекратихме за деня всичко и аз се прибрах да ходя на уни и да търся решение.

Така сега за nsmb.conf
Поради малкото на брой работни станции, не си заслужава да се копува сървър или да се дават много пари за NAS, за това ползваме евтино NAS решение, което може да ползва само SAMBA. След като моунтна дисковете на FBSD машината специалните немски букви в имената на факловете не се показват правилно, но въпреки това мога да ползвам файловете, като настроя nsmb.conf с горния енкодинг,  всичко се предтсавя както трябва, но като сменя в директорията тя се отваря рекузивно сама до без край, като се смения в нея.
Активен

plamen_f

  • Напреднали
  • *****
  • Публикации: 1246
    • Профил
Openoffice2
« Отговор #5 -: Jan 17, 2008, 23:43 »
Интересна ситуация...

Аз също имам проблем с ОО2 - при работа с монтирана през самба от windows директория отказва да пише в нея. Само ОО обаче, ако говорим за КОФИС, АБИ и други - няма проблем.

Някаква идея?
Активен

Stratovarius

  • Напреднали
  • *****
  • Публикации: 179
    • Профил
Openoffice2
« Отговор #6 -: Jan 23, 2008, 11:30 »
Сведох проблема до:

jdk15
cairo-java

след като
port fetch update
portupgrade cairo-java
след сваляне на jdk16 и другите файлове ръчно
portupgrade jdk15********
и след като компилирах ООо2.3.1_1 с няколко интересни опции
работи всичко перфектно '<img'>
Активен