Linux за българи: Форуми

Linux секция за начинаещи => Настройка на програми => Темата е започната от: elfenlied в Май 04, 2010, 08:15



Титла: PulseAudio
Публикувано от: elfenlied в Май 04, 2010, 08:15
Една вечер си включвам филм и гледам, че няма звук от колонките на лаптопа, проверявам нещо да не е намалено, но всичко си е точно. Пускам в жака слушалките и се чува звук. Нямам никаква идея от какво става така ???
На Sabayon 5.2 съм и Pulse Audio 0.9.21.1. Чакам с нетърпение идеите ви.


Титла: Re: PulseAudio
Публикувано от: tyuio в Май 04, 2010, 15:00
чакай сега слушалките в същия вход дето слагаш и колонките ли или друг?
В alamixer в конзолата всичко ли е вдигнато?


Титла: Re: PulseAudio
Публикувано от: elfenlied в Май 04, 2010, 15:57
чакай сега слушалките в същия вход дето слагаш и колонките ли или друг?
В alamixer в конзолата всичко ли е вдигнато?
Да всичко е точно. Слушалките са в жак, а колонките са вградени в лаптопа. От колонките няма звук, но като вкарам слушалките си има, е на тях само. Колонките ги тествах и работят от жив диск. Някъде има проблем с Pulseaudio-то.
Има и 2-ри проблем с миксера. При смяна на настройките звука ми се губи изцяло. След връщане на настройките звук пак няма да има (дори и да премахна .pulse папката). За второто проблемче знам от личен опит.
Мога и без pulseaudio, само да има нормален звук :)


Титла: Re: PulseAudio
Публикувано от: dejuren в Май 04, 2010, 18:27
Пробвай това решенийце:
Цитат
1. Backup and remove old configuration files:

$ mkdir ~/pulse-backup && cp -r ~/.pulse ~/.asound* /etc/asound.conf /etc/pulse -t ~/pulse-backup/
$ rm -r ~/.pulse* ~/.asound*
$ sudo rm /etc/asound.conf

2. Install necessary packages:

$ sudo apt-get install libasound2-plugins padevchooser libsdl1.2debian-pulseaudio

3. Remove “libflashsupport” (if present):

$ sudo apt-get remove --purge libflashsupport flashplugin-nonfree-extrasound

4. Run the mixer and set the defaults:

$ pulseaudio && pavucontrol

5. Reboot


Титла: Re: PulseAudio
Публикувано от: elfenlied в Май 04, 2010, 23:23
Интересно:
cp: cannot stat `/home/rpg/.asound*': No such file or directory
cp: cannot stat `/etc/asound.conf': No such file or directory
Все пак ще продължа напред :)
edit:

rpg@Peter ~/Desktop $ pulseaudio && pavucontrol
E: module-protocol-stub.c: Failed to create socket directory '/tmp/.esd/socket': Permission denied
E: module.c: Failed to load  module "module-esound-protocol-unix" (argument: ""): initialization failed.
E: main.c: Module load failed.
E: main.c: Failed to initialize daemon.
Само от слушалките има звук :(


Титла: Re: PulseAudio
Публикувано от: ivanatora в Май 05, 2010, 08:45
Същия проблем го имам и аз. В миксерите всичко е увеличено на максимум и unmute. Съществува следния workaround: alsamixergui. Не знам какво й е различното от нормалния alsamixer, но там ясно си показва че главния канал е mute и намален до минимум. Мискера с gui-я показва реалните стойности, а всички останали миксери... не.
Това е така на две десктоп и на лаптоп машини. На лаптопа махнах пакета pulseaudio и от тогава насам не съм имал проблеми. Всъщност и доста други проблеми със звука се оправиха с премахването на pulseaudio, примерно накъсването на звука в wine.


Титла: Re: PulseAudio
Публикувано от: elfenlied в Май 05, 2010, 10:41
Същия проблем го имам и аз. В миксерите всичко е увеличено на максимум и unmute. Съществува следния workaround: alsamixergui. Не знам какво й е различното от нормалния alsamixer, но там ясно си показва че главния канал е mute и намален до минимум. Мискера с gui-я показва реалните стойности, а всички останали миксери... не.
Това е така на две десктоп и на лаптоп машини. На лаптопа махнах пакета pulseaudio и от тогава насам не съм имал проблеми. Всъщност и доста други проблеми със звука се оправиха с премахването на pulseaudio, примерно накъсването на звука в wine.
Сега слагам alsamixergui. Ако почна премахване на pulseaudio се налага да махна много мапкети:
Едит:
Всичко се нареди :) Просто Mute и после unmute всичко под ред. Pulseaudio продължава да се прекацква при смяна :(