Автор Тема: Avance AC'97 Audio for VIA vuv Slack9  (Прочетена 1973 пъти)

DesertEagle

  • Участник
  • *****
  • Публикации: 1
    • Профил
Avance AC'97 Audio for VIA vuv Slack9
« -: May 24, 2003, 12:38 »
Ave hora kak da si podkaram prokletiq zvuk na Slack9 - az sum sus vgradena Ac'97 Audio for VIA. Sled instalaciq puskam X-a i mi kazva 4e imalo device error (/dev/dsp). Proverih v biosa vsi4ko dali e pusnato(pusnato e). Posle probvam /dev/dsp0 i /dev/dsp1 ama ne6te. Na automatic detection go slagam i pak ne6te. Promenqm plug-inite i puskam xmms i kato pusna nqkoq mp3-ka i tam kadeto se ot4ita zvuka se vijda aktivnost(basi i tnt) ama ni6to ne se 4uva. HELP
 '<img'>
Активен

  • Гост
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #1 -: May 27, 2003, 13:26 »
Здравей,
Пробвай с Алса.
Оттук си  намери модела на картата (предполагам via-82xx) http://alsa-project.org/alsa-doc/
Ако наистина е такава следвай инструкциите тук. http://alsa-project.org/alsa-do....via82xx
Ако не си намери твоя модел.
Свали си alsa-driver, alsa-lib и alsa-utils, компилираш, зареждаш както е описано и най-накрая пускаш alsamixer и увеличаваш звука, защото е изключен по подразбиране.
На XMMS-a му даваш да ползва Alsa като output plugin.
Надявам се да нямаш проблеми след това.
Активен

Michael

  • Участник
  • *****
  • Публикации: 39
    • Профил
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #2 -: May 27, 2003, 18:48 »
Аз имах същият проблем, само че моята платка беше Yamaha. Сега, трябва да прекомпилираш първо ядрото, защото то е компилирано по подразбиране с Creative, трябва да включиш съответния драйвер с ядрото, а не като модул и да изключиш Creative. Всичко това се намира в секцията sound на menuconfig или xconfig. След като компилираш ядрото трябва да компилираш и инсталираш модулите и ако всичко е наред то при рестаритирането на системата се създава /dev/dsp. След това можеш да качиш и Alsa. Но аз не го използвам.

Успех !

Michael
Активен

fire

  • Участник
  • *****
  • Публикации: 27
    • Профил
    • WWW
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #3 -: May 29, 2003, 17:29 »
Значи наскоро си купих лаптоп и той има същата карта.
Инсталирах си Мандрейк 9.1, който по подразбиране идва със ALSA и изобщо не съм имал проблеми със звука.

Единственият проблем е ако имаш и вграден модем Conexant, както е при мен - тогава забива много яко, та ми се наложи да забраня DMA-то на диска.
Активен

Посетете http://linux-book.hit.bg/ - Българската Книга за Линукс

ep98

  • Участник
  • *****
  • Публикации: 19
    • Профил
    • WWW
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #4 -: Jun 20, 2003, 16:35 »
Цитат (DesertEagle @ Май 24 2003,13:38)
Ave hora kak da si podkaram prokletiq zvuk na Slack9 - az sum sus vgradena Ac'97 Audio for VIA. Sled instalaciq puskam X-a i mi kazva 4e imalo device error (/dev/dsp). Proverih v biosa vsi4ko dali e pusnato(pusnato e). Posle probvam /dev/dsp0 i /dev/dsp1 ama ne6te. Na automatic detection go slagam i pak ne6te. Promenqm plug-inite i puskam xmms i kato pusna nqkoq mp3-ka i tam kadeto se ot4ita zvuka se vijda aktivnost(basi i tnt) ama ni6to ne se 4uva. HELP
 '<img'>

ALSA ne e obhodima w sluchaite kogato hardware e supported ot Kernel, za kakwo po diavolite triabwa da se instalirat wunshni moduli, kogato horata weche sa go napisali i sa go dobavili w kernel

za Slackware - GOTO /lib/modules/2.4.xx/kerle/drivers/sound
i pishesh
modprobe via82cxxx_audio
posle si go dobaviash w rc.modules i si gotov
a ako polzwash Debian, towa stawa awtomatichno s 'modconf'

tursete purwo reshenie na problema s nalichnia support ot kernel, i togawa s wunshni moduli
Активен

http://sf.net/projects/upms - Universal Pacakge Managment System
http://sf.net/projects/trinityos - Free GNU based OS, 99$ compatible with MS Windows

mironcho

  • Участник
  • *****
  • Публикации: 495
    • Профил
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #5 -: Jun 20, 2003, 20:29 »
В отношение настройка на хардуер, slackware 9 е доста "мързелива" дистрибуция '<img'>
От както има rc.hotplug , изобщо не му се налага на човек да мисли кои модули и как да ги вкарва (за sound, lan, usb, pcmcia, firewire и т.н.), или пък коя FS къде в /proc трябва да я монтира '<img'>

Така че:
# chmod +x /etc/rc.d/rc.hotplug
# /etc/rc.d/rc.hotplug start

и ако още нямаш звук, значи няма компилиран модул за твойта карта..
Като стана дума за модули, в slackware-current вече има ядро 2.4.21 , така че ако не стане със стандартното, изтегли новото и пробвай с него (то в current има и по нова версия на hotplug де, ама айде ;-) )

Българския mirror е:
http://mirrors.unixsol.org/slackware/
Активен

ep98

  • Участник
  • *****
  • Публикации: 19
    • Профил
    • WWW
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #6 -: Jun 20, 2003, 22:02 »
Цитат (DesertEagle @ Май 24 2003,13:38)
Ave hora kak da si podkaram prokletiq zvuk na Slack9 - az sum sus vgradena Ac'97 Audio for VIA. Sled instalaciq puskam X-a i mi kazva 4e imalo device error (/dev/dsp). Proverih v biosa vsi4ko dali e pusnato(pusnato e). Posle probvam /dev/dsp0 i /dev/dsp1 ama ne6te. Na automatic detection go slagam i pak ne6te. Promenqm plug-inite i puskam xmms i kato pusna nqkoq mp3-ka i tam kadeto se ot4ita zvuka se vijda aktivnost(basi i tnt) ama ni6to ne se 4uva. HELP
 '<img'>

proveri prednia POST za VIA KT400, tam si e napisano podrobno, kato ne chetete README, pone chete foruma
Активен

http://sf.net/projects/upms - Universal Pacakge Managment System
http://sf.net/projects/trinityos - Free GNU based OS, 99$ compatible with MS Windows

vde

  • Участник
  • *****
  • Публикации: 6
    • Профил
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #7 -: Jul 06, 2003, 18:01 »
Цитат
za Slackware - GOTO /lib/modules/2.4.xx/kerle/drivers/sound
i pishesh
modprobe via82cxxx_audio
posle si go dobaviash w rc.modules i si gotov


Здравеите имам същия проблем. Прочетох какво е писано тука (и в другата тема) ето какво направих и какво ми даде.

root@pluto:/lib/modules/2.4.20/kernel/drivers/sound# insmod ac97.o.gz
root@pluto:/lib/modules/2.4.20/kernel/drivers/sound# insmod ac97_codec.o.gz root@pluto:/lib/modules/2.4.20/kernel/drivers/sound# insmod via82cxxx_audio.o.gz
via82cxxx_audio.o.gz: init_module: No such device via82cxxx_audio.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg

ако не дам insmod ac97_codec.o.gz а направо дам modprobe via82cxxx_audio.о.gz ми казва, че не може да намери модул via82cxxx_audio.о.gz
Активен

Там където виждам моя баща
Там където виждам моята майка
мойте братя и сестри
Там където виждам моите предци
От там те ме викат
Те ме зоват да заема мястото си сред тях
В свещените зали на Валхала

ep98

  • Участник
  • *****
  • Публикации: 19
    • Профил
    • WWW
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #8 -: Jul 07, 2003, 22:40 »
Цитат (vde @ Юли 06 2003,19:01)
root@pluto:/lib/modules/2.4.20/kernel/drivers/sound# insmod ac97.o.gz
root@pluto:/lib/modules/2.4.20/kernel/drivers/sound# insmod ac97_codec.o.gz

a da se setish che sled [TAB] key, triabwa da se wurnesh s backspace da oburshesh .o.gz ?
Активен

http://sf.net/projects/upms - Universal Pacakge Managment System
http://sf.net/projects/trinityos - Free GNU based OS, 99$ compatible with MS Windows

vde

  • Участник
  • *****
  • Публикации: 6
    • Профил
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #9 -: Jul 08, 2003, 01:21 »
И с и без дава една и съща грешка  '<img'>
Активен

Там където виждам моя баща
Там където виждам моята майка
мойте братя и сестри
Там където виждам моите предци
От там те ме викат
Те ме зоват да заема мястото си сред тях
В свещените зали на Валхала

  • Гост
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #10 -: Jul 08, 2003, 16:15 »
Цитат (vde @ Юли 08 2003,02:21)
И с и без дава една и съща грешка  '<img'>

. . . za6to triabva da se ukazva putia do modula ?!?!?!?!
pri men
modprobe via82cxxx_audio
posle lsmod da vidi6 dali go e zaredilo i gotovo . . .
Активен

vde

  • Участник
  • *****
  • Публикации: 6
    • Профил
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #11 -: Jul 08, 2003, 21:35 »
Вие май не четете.
Цитат
via82cxxx_audio.o.gz: init_module: No such device via82cxxx_audio.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg


HEMA
тая грешка ми я рава не зависимо дали слагам о.gz или не.
А ако не отидам там където е просто ми дава, че не може да намери модула...логично...
Активен

Там където виждам моя баща
Там където виждам моята майка
мойте братя и сестри
Там където виждам моите предци
От там те ме викат
Те ме зоват да заема мястото си сред тях
В свещените зали на Валхала

mironcho

  • Участник
  • *****
  • Публикации: 495
    • Профил
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #12 -: Jul 09, 2003, 01:05 »
В крайна сметка, вместо да се мъчиш и да губиш толкова време, защо не си изтелиш alsa-drivers, да ги компилираш и инсталираш и после от същата директория (на разархивираното alsa-drivers) да изпълниш скрипта:

# ./utils/alsaconf

да кажеш ДА за картата която ще намери, да му разрешиш да да ти промени modules.conf и да забравиш за проблемите със звука до следващото инсталиране/преинсталиране ?
ALSA се е доказала че в повечето ситуации е много по удачно се използва вместо OSS.

Възможно е и да имаш хардуерен проблем - например да имаш едновременно вградена звукова карта и вградена лан карта - проблема ти е гарантиран '<img'>

А, да. И да не забравиш за ./snddevices също '<img'>



Активен

  • Гост
Avance AC'97 Audio for VIA vuv Slack9
« Отговор #13 -: Jul 12, 2003, 01:58 »
Цитат (vde @ Юли 08 2003,22:35)
Вие май не четете.
Цитат
via82cxxx_audio.o.gz: init_module: No such device via82cxxx_audio.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg


HEMA
тая грешка ми я рава не зависимо дали слагам о.gz или не.
А ако не отидам там където е просто ми дава, че не може да намери модула...логично...

. . . ako si recompile kernela moje i tva da ti dava (misleh 4e si sas jadroto ot install_CDto) za alsa ne znam . . .
moe li4no mnenie kogato ne6to se podurja ot kernela za kvo da make install na dublira6t soft
make bzImage otnovo s podrujka na sounda (ac97) i si gotov
ako iska6 i kato moduli si go napravi  . . . ako si ot sf i ne moje6 da go oprai6 svirkai silno '<img'>)) da se vidim niakade da go obsudim
HEMA HEMA 3BYK  . . .  '<img'>)))))))
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
slack9-gpm-X-IMPS2 bug?
Настройка на програми
sunhater 3 1101 Последна публикация Apr 01, 2003, 14:14
от sunhater
Mplayer & Slack9.0
Настройка на програми
tzarew 2 1027 Последна публикация May 23, 2003, 06:12
от Marto
Net prez Slack9
Настройка на програми
gamehack 2 1140 Последна публикация Jun 15, 2003, 00:44
от gamehack
4asovnik-a na slack9.1 ????
Настройка на програми
PAIN1 3 1022 Последна публикация Oct 07, 2003, 23:09
от saturn_vk
help как да си подкарам vpn connectiona под slack9
Настройка на хардуер
Wivern 3 1396 Последна публикация Apr 05, 2004, 20:42
от sunhater