Анкета

Въпрос: работи ли ви hibernate?

  • работи само "suspend to disk"
    - 7 (26.9%)
    работи само "suspend to ram"
    - 5 (19.2%)
    и двете работят добре
    - 7 (26.9%)
    че това в линукс има ли го?
    - 4 (15.4%)
    какво е това?
    - 3 (11.5%)

Общ брой гласове: 36

Автор Тема: работи ли ви hibernate?  (Прочетена 4643 пъти)

kennedy

  • Напреднали
  • *****
  • Публикации: 2151
  • Николай Колев
    • Профил
работи ли ви hibernate?
« -: Jan 21, 2007, 12:22 »
Тъй като имах проблем с настройването на тези функции ми се ще да зная какви са резултатите при различните дистрибуции. Затова ви моля да вмъкнете коментарче с тази информация.

При мен на сусе 10.2 работеше само суспенд то диск и то докъто не качих драйверите на Нвидията. После се наложи да дооправям на ръка хорг.конф за да тръгне. А при суспенд то рам нищо не прави, само гаси екрана за секунда и пак го пуска.



Активен

"за всичко иде час" Еклесиаст 3:1
всеки пост - отговор на въпрос
-----------------
24.12.2003 "MS Free"

ilian_BIOS

  • Напреднали
  • *****
  • Публикации: 602
  • Distribution: opensuse
  • Window Manager: kde
    • Профил
работи ли ви hibernate?
« Отговор #1 -: Jan 21, 2007, 12:31 »
Еми при мен в Дебиана изобщо няма такива екстри , само изключване , рестартиране и изход  от сесията  '<img'>
Активен

Radev

  • Напреднали
  • *****
  • Публикации: 218
    • Профил
    • WWW
работи ли ви hibernate?
« Отговор #2 -: Jan 21, 2007, 13:12 »
Debian testing (Etch), Gnome (инсталиран през netinst с tasksell, избрани са опциите за desktop и laptop) -> работи "дълбоко приспиване" (Suspend to Disk), а "приспиване" (Suspend to RAM) не работи от менюто - гаси екрана и веднага го пали със съобщение за грешка.

За сметка на това
Примерен код
echo mem > /sys/power/state
работи безотказно и безупречно, както и
Примерен код
echo disk > /sys/power/state
. 'B)'
В моята версия на документацията на gnome-power-manager пише нещо, че когато hal включи поддръжка на acpi ще се оправят нещата, но горните команди ползват точно hal (ако не се лъжа) така, че моя проблем вероятно е другаде. '<img'>
Активен

Човек и добре да живее... !

aaaaaa

  • Напреднали
  • *****
  • Публикации: 971
    • Профил
работи ли ви hibernate?
« Отговор #3 -: Jan 21, 2007, 16:33 »
echo mem > /sys/power/state работи перфектно.
echo disk > /sys/power/state работи, но като пусна отново лаптопа резолюцията е 1024x768, а по принцип трябва да е 1280x800. Явно прави някакви проблеми с 915resolution (понеже видеокартата ми е Intel GMA 950 се налага да използвам тази програма, за да мога да ползвам резолюцията 1280x800. При положение, че suspend to ram ми върши работа не съм се занимавал да накарам suspend to hard disk да работи както трябва. Дистрибуцията е нестабилен дебиан.



Активен

...to boldly go where no one has gone before...

TheNightmare

  • Гост
работи ли ви hibernate?
« Отговор #4 -: Jan 21, 2007, 19:10 »
При мене Suspend to Disk  само раоти и то частично щото след като реставрирам системата нямам нет. Системата е openSUSE 10.2



Активен

winboze

  • Напреднали
  • *****
  • Публикации: 242
    • Профил
    • WWW
работи ли ви hibernate?
« Отговор #5 -: Jan 21, 2007, 20:45 »
Аз пък под openSUSE 10.2 като направя Suspend to disk и след това влюча компа зарежда (според него) от диска image-a и след това черен екран... Ctrl-Alt-FN комбинациите не работят. Просто черен екран  ':crazy:'

edit: оправих го, трябва да се добави Option "NvAGP" "1" в секция Device веднага след Vendorname "Nvidia" в /etc/X11/xorg.conf.



Активен

.: МРАЗЯ ПАКЕТНИ ЗАВИСИМОСТИ :.

saejoh

  • Напреднали
  • *****
  • Публикации: 271
    • Профил
работи ли ви hibernate?
« Отговор #6 -: Jan 21, 2007, 22:07 »
Цитат (winboze @ Ян. 21 2007,20:45)
edit: оправих го, трябва да се добави Option "NvAGP" "1" в секция Device веднага след Vendorname "Nvidia" в /etc/X11/xorg.conf.

А махате ли intel_agp, ако сте с драйверите на Nvidia? На едно място четох, че трябвало да се процедира по следния начин:

Търсим кои agp modules са ни заредени:
Примерен код
# lsmod | grep agp

Типичните intel_agp, sis_agp, via_agp и т.н. ...
Маркираме agp module-а като "в черен списък" в /etc/modprobe.conf.local:
Примерен код
# blacklist agp module
   blacklist intel_agp

Рестартираме машината и се уверяваме, че не е стартиран agp module-а
Примерен код
# lsmod | grep agp

Не трябва да виждаме никакви vendor_agp module-и (intel_agp, sis_agp,...) , освен "agpgart".
Активен

SUSE Linux, Ath XP 1700+, Biostar M7NCG, More pictures at http://www.snimka.bg/album.php?album_id=20268

winboze

  • Напреднали
  • *****
  • Публикации: 242
    • Профил
    • WWW
работи ли ви hibernate?
« Отговор #7 -: Jan 21, 2007, 22:42 »
Доколкото разбрах, това е само за по-старите версии на suse, като 9.0. Аз не го махнах и работеше.
Активен

.: МРАЗЯ ПАКЕТНИ ЗАВИСИМОСТИ :.

saejoh

  • Напреднали
  • *****
  • Публикации: 271
    • Профил
работи ли ви hibernate?
« Отговор #8 -: Jan 21, 2007, 23:19 »
Цитат (winboze @ Ян. 21 2007,22:42)
Доколкото разбрах, това е само за по-старите версии на suse, като 9.0. Аз не го махнах и работеше.

Прав си, и аз нямаше практически какво да махам (оказа се, че имам само nvidia_agp, което обаче си е в пряка зависимост от nvidia). Единствено добавих въпросната Option "NvAGP" "1" в xorg.conf, рестартирах, дадох Suspend to disk, машината се изключи без грешки, натиснах си старт-бутона и в крайна сметка си влязох в сесията все едно че съм дал преди това "Заключване на сесията" ("Lock session").
По едно време се бях отчаял, че е невъзможно това да се случи под СуСЕ, но ето че стана работАта.
Не смея да пробвам Suspend to RAM все още...
А за другото - "В готовност" - пък да не говорим. ':p'
 ':ok:'
Активен

SUSE Linux, Ath XP 1700+, Biostar M7NCG, More pictures at http://www.snimka.bg/album.php?album_id=20268

saejoh

  • Напреднали
  • *****
  • Публикации: 271
    • Профил
работи ли ви hibernate?
« Отговор #9 -: Jan 21, 2007, 23:49 »
Suspend to RAM също май взе че проработи, но не разбрах точно какво става, освен че след това отново се появи "Заключена сесия" и трябваше да си пиша паролата, за да вляза.
"В-готовност" ("Standby") - усетих изключването на монитора и харддиска, захранването работеше, събуждане с мишката не стана, но при натискане на произволен клавиш от клавиатурата се получи желания ефект - влизане в сесията както при "Заключване ..." с парола.
Ако се добави в анкетата "В-готовност" ("Standby"), ще гласувам и за трите режима.
Между другото при каква "активна схема" в KPowersave (бързодействие, енергоспестяване, представяне или акустика) постигате резултатите? Аз - при "акустика". '<img'>
Активен

SUSE Linux, Ath XP 1700+, Biostar M7NCG, More pictures at http://www.snimka.bg/album.php?album_id=20268

kill_u

  • Напреднали
  • *****
  • Публикации: 1058
  • Distribution: Ubuntu 9.10
  • Window Manager: Gnome
  • Out of here....
    • Профил
    • WWW
работи ли ви hibernate?
« Отговор #10 -: Jan 22, 2007, 10:02 »
При мен откакто минах на Ubuntu 6.06 не работи. Не знам защо но на 5.10 работеше перфектно, а сега ако хибернирам се налага после така или иначе да рестартирам компютъра. Гнома твърдо отказва да запали след хибернация.
Активен

Всеки пост - отговор на въпрос!!!
Gnu/Linux user 411527

kmakaron

  • Напреднали
  • *****
  • Публикации: 50
    • Профил
работи ли ви hibernate?
« Отговор #11 -: Jan 22, 2007, 10:20 »
А с звука как сте? На моя лаптоп MSI M670X, след suspen to ram звука започва да цикли, като плъзгачите са до края. След превключване на конзола, виждам съобщение от алса драйверите което гласи(цитирам по памет).." ...._RESUME : Function not implemented.".
Активен

kennedy

  • Напреднали
  • *****
  • Публикации: 2151
  • Николай Колев
    • Профил
работи ли ви hibernate?
« Отговор #12 -: Jan 23, 2007, 08:09 »
звук, нет всичко си работи , само дето нямам режим "в готовност" или standbay като се води там ....
Активен

"за всичко иде час" Еклесиаст 3:1
всеки пост - отговор на въпрос
-----------------
24.12.2003 "MS Free"

Radev

  • Напреднали
  • *****
  • Публикации: 218
    • Профил
    • WWW
работи ли ви hibernate?
« Отговор #13 -: Jan 23, 2007, 09:29 »
Нали и аз това казвам - всичко е на шест, но suspend-а не работи през графичния мениджър а само с echo-то.
Ако ползваш ACPI можеш да опиташ така - най-вероятно ще стане.  'B)'
Активен

Човек и добре да живее... !

winboze

  • Напреднали
  • *****
  • Публикации: 242
    • Профил
    • WWW
работи ли ви hibernate?
« Отговор #14 -: Jan 23, 2007, 10:00 »
Странна работа. След като resume-вам системата, kicker ми вика Suspend  Failed... въпреки, че всичко си работи нормално.
Активен

.: МРАЗЯ ПАКЕТНИ ЗАВИСИМОСТИ :.