Автор Тема: Debian трудности!Направо полудявам!  (Прочетена 8480 пъти)

gamehack

  • Напреднали
  • *****
  • Публикации: 244
    • Профил
    • WWW
Debian трудности!Направо полудявам!
« Отговор #15 -: Jan 27, 2004, 21:29 »
reb00t dai si apt.conf i sources.list ako moje '<img'>
Активен

Simplicity all the way...

webmastera

  • Напреднали
  • *****
  • Публикации: 24
    • Профил
Debian трудности!Направо полудявам!
« Отговор #16 -: Jan 27, 2004, 22:06 »
V Slackware stava samo kato si izteglish paketite i pishesh:
installpkg '<img'> Super elementarno. Trygva si bez problem, raboti dobre i ne se nalaga da se zanimavam s obnoviavane na tova i na onova i da se vryshtam na distro ot predi niakolko godini(razbira woody) taka che Slack rulzzz '<img'> I sym na Kernel 2.6.1 pri tova. NO si ima i edno NO vinagi ima NO, imah strahotni problemi s LTSP naprimer koito ne razpoznavashe startovata sistema poradi koeto mi se nalozi da si izgubia edna nedelia dokato go naglasia i...tykmo trygna i se svyrzvah ot terminal klienta i startirah blackbox i reshih da pusna Mozilla i....zybi, posle go izkluchih ot kopcheto(klienta) i sega veche zybiva vednaga sled kato se startira KDM, no ne mi se zanimava da preinstaliram pak LTSP. Imam i drugi problemi de, naprimer s printera, no te ne sa samo na Slack, a po princip na Linux, i opitah skenercheto da si pusna no neshto zybiva na "scanimage -L" inache go otkriva, neshto mai imam problemi s niakoi ot modulite, mozebi triabva da upgrade-na sane poneze s novoto iadro ne sym go polzval. Ama ne znam de, az sega ako vlezna moze i da raboti veche. Osven tova ne moga da se opravia s bootsplash-a, t.e. az se opravih i si imam bootsplash no iskam da mu sloza progress bar, a za celta triabva da redaktiram init skriptovete, no poneze ne znam bash me e strah da pipam tam, kato go naucha moze da se opitam. A i s winex neshto ne mi trygva StarWars Racer, no tova pak ne e problem na Slack. Obshto vzeto v edin posting opisah vsichkite si problemi s Linux '<img'> E kyde po-dobre ot Windows - samo kato si pomislia che sym se zarazil pak s niakakyv virus i makar da imam Norton Corporate toi se e razpratil na vsichkite mi kontakti...Samoche v mplayer gledah che ima niakakvi iaki opcii za subtitri niama da e zle da gi vkluchat i v GUI-to shtoto az sluchaino gi vidiah i da go napraviat da raboti s ttf na kirlica. I kak se puska proxy v mplayer? Ne e zle da se napravi niakakyv analog na FlashGET za KDE, shtoto KGet e dosta daleche ot nego, a Downloader for X e za GTK, no pyk si ima wget koito e dosta po-moshten ot FlashGet...abe ot kyde trygnahme pyk dokade stignahme '<img'> takache pich slozi si Slack ili neshto za novaci - Mandrake naprimer, tova e moia syvet, taka ili inache si razkaral Debian.
Активен

gamehack

  • Напреднали
  • *****
  • Публикации: 244
    • Профил
    • WWW
Debian трудности!Направо полудявам!
« Отговор #17 -: Jan 27, 2004, 22:24 »
ne iskam drugi distros '<img'> minah ot redhat,mandrake,suse ... sled tova gentoo ne me izkefi momenta v na4aloto da si kompiliram cqlata system-a...ot slackware bqh dovolen bqh polovin godina na nego oba4e ne6to mi lipsva6e...apt-get mi lipsva6e znam 4e 6te kajete 4e ima swaret ili slapt-get no o6te ne sa na nivo ':p' i zatova sam na debian i mnogo me qd 4e si iztrih perfectniq desktop za da probvam kde 3.2 ... ko da praa darvena glava ':p' sega 6a sedq pod win dokata ne namerq nqkakvo re6enie ':p'
Активен

Simplicity all the way...

n_antonov

  • Напреднали
  • *****
  • Публикации: 1185
    • Профил
    • WWW
Debian трудности!Направо полудявам!
« Отговор #18 -: Jan 27, 2004, 22:37 »
Цитат
Trygva si bez problem, raboti dobre i ne se nalaga da se zanimavam s obnoviavane na tova i na onova i da se vryshtam na distro ot predi niakolko godini(razbira woody) taka che Slack rulzzz


Не разбрах проблема ти. Да проверим ли чий софтуер е по-нов - твоят или моят (Debian Woody/Sarge/Sid, с една дума смесена система);) В зависимост от критичността на софтуера пакетите се придържат към съответния release.

gamehack, има нещо, което не позволява на пакетите да се инсталират, вероятно е в apt.conf. Нещо да казва там да държи на stable или testing?

BTW, ако Debian беше само apt-get, изобщо нямаше да си струва човек да се занимава с него. Още повече, че и във Fedora този инструмент работи чудесно. Да де, ама не е само това'<img'>



Активен

-------------------------------------------------------------------------
./debian/rules

  • Гост
Debian трудности!Направо полудявам!
« Отговор #19 -: Jan 27, 2004, 22:47 »
Ami eto ti moq sources.list:
# Security updates for "stable"
deb ftp://debian.ludost.net/debian-security stable/updates main contrib non-free
deb http://security.debian.org stable/updates main contrib non-free
#Security updates for "testing"
deb ftp://debian.ludost.net/debian-security testing/updates main contrib non-free
deb http://security.debian.org testing/updates main contrib non-free
# Stable
deb ftp://debian.ludost.net/debian stable main contrib non-free
deb ftp://ftp.bg.debian.org/debian stable main contrib non-free
# Sources
deb-src ftp://debian.ludost.net/debian stable main contrib non-free
deb-src ftp://ftp.bg.debian.org/debian stable main contrib non-free
# Testing
deb ftp://debian.ludost.net/debian testing main contrib non-free
deb-src ftp://ftp.bg.debian.org/debian stable main contrib non-free
# Sources
deb-src ftp://debian.ludost.net/debian testing main contrib non-free
deb-src ftp://ftp.bg.debian.org/debian stable main contrib non-free
#Unstable
deb ftp://debian.ludost.net/debian unstable main contrib non-free
deb ftp://ftp.bg.debian.org/debian unstable main contrib non-free
# Sources
deb-src ftp://debian.ludost.net/debian unstable main contrib non-free
deb-src ftp://ftp.bg.debian.org/debian unstable main contrib non-free
# Others
deb http://kde.rb-hosting.de/~jens/kde/debian ./
deb-src http://kde.rb-hosting.de/~jens/kde/debian ./

apt.conf mi e standartniq, no moje i bez nego.

Az systo ti prepory4vam da si slojish Slack, zastoto  vsi4ko e prosto, pravish installpkg. i   nqma proverki i chekove i si mislish 4e vsi4ko e nared  i tova e ;-) Inache Webmaster-a ima dosta da pouchi dokato razbere zasto Debian stable e tolkova konservativen, i ima li debian testing, Debian unstalbe i Debian Experimental. Prosto oste ne e stignal do tam ;-)
Активен

gamehack

  • Напреднали
  • *****
  • Публикации: 244
    • Профил
    • WWW
Debian трудности!Направо полудявам!
« Отговор #20 -: Jan 27, 2004, 22:54 »
n_antonov, ето ми го apt.conf:
Примерен код

// $Id: apt.conf,v 1.2 2003/12/27 18:14:39 antonovn Exp $
/* This file is a sample configuration file with a few harmless sample
   options.  
*/

APT
{
  // Options for apt-get
  Get
  {
     Download-Only "false";
  };
  
};



// Always show packages to be upgraded (-u)
APT::Get::Show-Upgraded "true";

// Options for the downloading routines
Acquire
{
  Retries "0";
};

// Things that effect the APT dselect method
DSelect
{
  Clean "auto";   // always|auto|prompt|never
};

// DPkg
// {
//   Probably don't want to use force-downgrade..
//   Options {"--force-overwrite";}
// }

    APT::Default-Release "unstable";
    APT::Cache-Limit "25165824";

// All dpsyco packages should be updated after installation.
// DPkg::Post-Invoke {"/usr/sbin/update-dpsyco || true";};

това е....просто ми е много чудно защо имам тези проблеми със инсталирането на кде 3.2....
Активен

Simplicity all the way...

  • Гост
Debian трудности!Направо полудявам!
« Отговор #21 -: Jan 27, 2004, 23:09 »
mahni APT::Default-Release "unstable";
ot apt.conf stoto taka go karash da izbira ot unstable !
Активен

vampi

  • Напреднали
  • *****
  • Публикации: 106
  • Distribution: Debian
  • Window Manager: KDE
    • Профил
Debian трудности!Направо полудявам!
« Отговор #22 -: Jan 27, 2004, 23:30 »
KDE-то го има на официалните сървъри на Дебиан само дето 3.1.5 го има в "unstable" и "testing" ...
Аз имах проблеми когато бях добавил и "deb http://kde.rb-hosting.de/~jens/kde/debian ./" (или някъв подобен дето го бях изнамерил от kde.org), получиха се някви депенденси проблеми...
От тогава го карам на "unstable", като ползвам само:
"deb <a href="" target="_blank">ftp://ftp.bg.debian.org/debian</a> unstable main contrib non-free" във "sources.list"... това само на desktop машината, де...
Aко ти се минава на "unstable" -> слагаш го това по-горе-> apt-get update -> apt-get install kde

едит: опаа... тука се говорело за 3.2... SORRY!
Активен

Debian -
One Distro To Rule Them All...

  • Гост
Debian трудности!Направо полудявам!
« Отговор #23 -: Jan 28, 2004, 04:41 »
gamehack,
Къде живееш?
Ще взема да ти пратя кде-3.2 на CD, че да не се мъчиш повече.
През около седмица правя cvs update на кде-сорса и го build-вам на пакети. Е, не са изрядни, ама поне работят. Правя ги ей тъй за спорта - да уплътнявам свободното време на процесора ;-)
Имам предвид цялото КДЕ, заедно с kdeextragear-1 и -2 и още някоя друга програма за КДЕ. Общо около 320 пакета.
Като го почнах през ноември, changelog-овете нещо не бяха ъпдейтвани и незнам защо, но го подкарах на версия 3.1.99-1, 3.1.99-2 и т.н. Тъпо, ама като влезе след някой друг месец (предполагам) в unstable като 3.2 - няма да има проблем с ъпгрейда.

В момента КДЕ-то при мен е cvs20040120, че и тук-там по-ново
и:
gcc-3.3.2-1
libc6-2.3.2.ds1-10
libqt3c102-3.2.1-6
Xикса е версия 4.3.0-0pre1v4
и т.н.
С други думи - щом като си с unstable - трябва да тръгне при теб.
Моя unstable май по малко става testing ;-)
Напоследък не съм го ъпдейтвал. Преди да сложа КДЕ-3.2 бях с (3.1.1 .. 3.1.4) unstable

МЕжду другото, мога да ти кажа как го правя (build-a на пакетите де '<img'>, ама не съм сигурен, че ще имаш търпението да си оправиш debian директориите във всеки от сорсовете. Другия вариант е diff -файлове, ама това ще ме затрудни, защото е от cvs. Иначе не е голяма философия.

А колкото до тия работи: ./configure && make && make install - си е направо безумие. Толкова ли е трудно да се инсталира по някой по-модерен начин? .rpm, .deb '<img'>
make install -> tmp -> пакет -> install пакет !!!!!
После как проверяваме md5sums? Как деинсталираме и ъпгрейдваме?
Как ...?
Сигурно пазим стоте кила сорс на всичко в системата. Или ходим и трием ръчно. Или там, какво още беше...

И като слагате КДЕ хубаво гледайте дали е build-вано за  woody или за sarge или sid. И освен това, apt се настройва много по-лесно с ей тия работи, дето все ги пиша. Поне на мен са ми от полза.
apt-get install apt-howto debian-reference

И други има. Например:
apt-get install debian-history ;-)
Активен

  • Гост
Debian трудности!Направо полудявам!
« Отговор #24 -: Jan 28, 2004, 11:22 »
Цитат (Guest @ Ян. 28 2004,05:41)
А колкото до тия работи: ./configure && make && make install - си е направо безумие. Толкова ли е трудно да се инсталира по някой по-модерен начин? .rpm, .deb '<img'>

Е да, в един перфектен свят всичко щеше да е наред и за всяка дистрибуция би имало съответно .deb , .rpm , .tgz и т.н. НО това не е така -  единствено
Debian(евала .. за 3dwm) има прекомпилирани версии на почти всичко каквото се сетите,  при всички останали дистрибуции не е така .. и да .. когато видя rpm i tar.gz еми извинявайте, но ще си го компилирам по "безумния начин" пък който иска да си ползва rpm2tgz или alien, или каквото там ползва щом няма прекомпилиран пакет.
Активен

n_antonov

  • Напреднали
  • *****
  • Публикации: 1185
    • Профил
    • WWW
Debian трудности!Направо полудявам!
« Отговор #25 -: Jan 28, 2004, 11:35 »
Мдааа... Хора, не коментирайте Дебиан по този начин бе'<img'> .deb не означава прекомпилиран пакет (или по-точно "предварително компилиран"). Това е пакетен формат за компилирани файлове и за изходен код. Ако искаш да си компилираш цялата система от сорс, нямаш никакъв проблем, в Дебиан има много начини за това, просто защото до бинарните пакети стоят и пакетите с изходен код. Кеф ти да инсталираш едните, кеф ти другите, примерно с apt-build и със съответните оптимизации за процесор, компилатор и т. н., като и в двата начина всичко се свежда до една единствена команда.

Примерно, вместо:

apt-get install mozilla-browser

Пишеш:

apt-build install mozilla-browser

Пак ще се изтеглят всички зависимости, ще се компилират съответните библиотеки, необходими за компилацията на самия пакет и т.н. Съществуват и много опции, с които примерно можеш да кажеш на apt-build после да деинсталира пакетите, които са били необходими само за компилацията, за да не заемат място, чисти ти build-директорията и т.н.

Да продължавам ли...;)
Активен

-------------------------------------------------------------------------
./debian/rules

gamehack

  • Напреднали
  • *****
  • Публикации: 244
    • Профил
    • WWW
Debian трудности!Направо полудявам!
« Отговор #26 -: Jan 28, 2004, 12:14 »
dnes 6te mahna unstable v apt.conf i 6te probvam dali 6te stane '<img'>
Активен

Simplicity all the way...

  • Гост
Debian трудности!Направо полудявам!
« Отговор #27 -: Jan 28, 2004, 12:42 »
Melvin, vsichko tova koeto kazvash moje da se pravi na vseki UNIX ;-)
moje da se kompilira  pravilno ili nepravilno. Paketnata sistema na debian, koqto dal4e ne tretira samo binary packages e edno mnogo golqmo razshirenie na tova s koeto qvno oste ne si zapoznat. Samo nedej da u4ish debian kak se build-vat software (http://www.buildd.net/), stoto riskuvash da stanesh smeshen ;-)
GameHack, nedej da pravish slu4ajni raboti i da izpolzvash opcii koito ne sa ti qsni. Vreme e da se otyrvesh ot "kakvoto stane stane" metoda !
Активен

  • Гост
Debian трудности!Направо полудявам!
« Отговор #28 -: Jan 28, 2004, 13:22 »
reb00t не знам какъв ти е проблема, но бих те помолил ако имаш да казваш нещо по мой адрес направи го на private.
Не знам как стигна до _гениалния_ извод че имам нещо против пакетната система на дебиан или че съм тръгнал да ги уча да build-ват.

"Явно" искаш да се изкараш много разбиращ и оригинален в което няма нищо лошо .. просто не го прави за сметка на моите постове.

И към администраторите: Следващия път когато казвам подобно нещо ще бъде с PM , просто въпросния reb00t мина някои елементарни граници.

P.S. Аа и всъщност се пише Melwin.  ':angry:'
Активен

gamehack

  • Напреднали
  • *****
  • Публикации: 244
    • Профил
    • WWW
Debian трудности!Направо полудявам!
« Отговор #29 -: Jan 28, 2004, 16:47 »
И накрая на мъките:HAPPY END!Сега накратко ще опиша решението.
1.Махнах /etc/apt/apt.conf
2.apt-get remove kde*
3.В sources.list махнах # пред всички testing и unstable (без deb-src,защото не ми трябват)
4.Donwgrade на библиотеката libqt3c102-mt от 3.2.3 до 3.1.6+as+orth(защото kde-cvs-snapshot се нуждае точно от нея)
5.apt-get remove xfree86-common
6.apt-get install x-window-system -t experimental (защото kde-cvs-snapshot се нуждае от xlib > 4.3 )
6.apt-get install kdebase=4:3.2.0-0+cvs.... kdelibs=4:3.2.0-0+cvs..... arts=1.2.0+cvs....
7.startx

ей това е '<img'> цялата работа била,че КДЕ-то било билднато като се използвали либове от testing и някои от experimental.Иначе сега му се радвам на КДЕ-то,много фарчи,а пак е по-ергономично!Въобще,добре свършена работа!
thanks 2 all who helped me in my awful installation of KDE 3.2 ':p'
Активен

Simplicity all the way...

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
BG Debian
Предложения за български проект
asa 0 2632 Последна публикация Sep 25, 2002, 11:52
от asa
Debian i KDE
Настройка на програми
IvanST 9 8336 Последна публикация Jan 05, 2003, 21:54
от n_antonov
Грешка в MBR Debian не стартира!
Настройка на програми
IvanST 8 7643 Последна публикация Jan 07, 2003, 13:36
от IvanST
debian + kde 3.1
Настройка на програми
rat 0 1931 Последна публикация Jan 28, 2003, 17:28
от rat
Инсталиране на Debian върху подобна на Debian базирана дистрибуция
Настройка на програми
aspirina97 5 3366 Последна публикация Mar 25, 2009, 15:05
от zeridon