Автор Тема: Странен шум. m3n-ht deluxe  (Прочетена 1435 пъти)

sunhater

  • Напреднали
  • *****
  • Публикации: 329
    • Профил
Странен шум. m3n-ht deluxe
« -: Aug 31, 2008, 04:28 »
Здравейте,

Имам проблем със звука на новото ми дъно Asus M3N-HT Deluxe. Звук има, но има и едно много странно шумене, и след известно време playback, звука започва да прескача. Дистрибуцията е Gentoo. Ползвам модул snd_hda_intel.
Ето и малко подробности:

Примерен код
sunhater ~ # uname -a
Linux sunhater 2.6.25-gentoo-r7 #1 SMP Sat Aug 30 01:40:37 EEST 2008 x86_64 AMD Phenom(tm) 9950 Quad-Core Processor AuthenticAMD GNU/Linux
sunhater ~ # cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe020000 irq 21
sunhater ~ # lspci | grep Audio
00:07.0 Audio device: nVidia Corporation Device 0774 (rev a1)
sunhater ~ #


Интересното е че модулът snd_hda_intel има опции за различни видове кодеци:
Примерен код
Device Drivers  --->
    Sound  --->
        Advanced Linux Sound Architecture  --->
            PCI devices  --->
                <M> Intel HD Audio
                    [ ]   Build hwdep interface for HD-audio driver
                    [ ]   Build Realtek HD-audio codec support
                    [*]   Build Analog Device HD-audio codec support
                    [ ]   Build IDT/Sigmatel HD-audio codec support
                    [ ]   Build VIA HD-audio codec support
                    [ ]   Build ATI HDMI HD-audio codec support
                    [ ]   Build Conexant HD-audio codec support
                    [ ]   Build C-Media HD-audio codec support
                    [ ]   Build Silicon Labs 3054 HD-modem codec support
                    [*]   Enable generic HD-audio codec parser
                    [ ]   Aggressive power-saving on HD-audio

Но за моят случай - NVidia HD-audio codec няма. Единствените работещи са отбелязаните със звездичка (и поотделно и заедно работят), но с досадното шумене и прескачане. Знам че може би още няма поддръжка за моето дъно в ядрото, но няма ли някакъв начин да го накарам да тръгне звука, защото е тъпо да зареждам Windows за да гледам филм ;]
Активен

Naka

  • Напреднали
  • *****
  • Публикации: 2777
    • Профил
Странен шум. m3n-ht deluxe
« Отговор #1 -: Aug 31, 2008, 15:04 »
Някои миксери могът да изкарват цифрово аудио на нормалният аналогов изход. цифровото аудио се чува като постоянен шум.


Имах подобен проблем преди време. Виж си миксера и виж дали няма някъде включена опция за миксиране на цифрово аудио.



Активен

Perl - the only language that looks the same before and after encryption.

sunhater

  • Напреднали
  • *****
  • Публикации: 329
    • Профил
Странен шум. m3n-ht deluxe
« Отговор #2 -: Aug 31, 2008, 15:24 »
Звука не е цифров... Аналогов е... Чува се каквото трябва, но има и шум. И след известно време звукът започва да прескача. Проверих всички контроли на alsamixer-а но нищо не помогна.
Активен

Naka

  • Напреднали
  • *****
  • Публикации: 2777
    • Профил
Странен шум. m3n-ht deluxe
« Отговор #3 -: Aug 31, 2008, 17:14 »
Цитат (sunhater @ Авг. 31 2008,16:24)
Звука не е цифров... Аналогов е... Чува се каквото трябва, но има и шум. И след известно време звукът започва да прескача. Проверих всички контроли на alsamixer-а но нищо не помогна.

При мен се миксираха аналоговият нормален звук (и той се чуваше каквото трябва) с по-слаб фонов шум, който в последствие се оказа цифровото аудио. провери и разните други миксери. kmix, гноме миксера. това което си спомням е че тази опция я нямаше навсякъде във всички миксери. намерих я в kmix.

може нещо и съвсем друго да е.



Активен

Perl - the only language that looks the same before and after encryption.

sunhater

  • Напреднали
  • *****
  • Публикации: 329
    • Профил
Странен шум. m3n-ht deluxe
« Отговор #4 -: Aug 31, 2008, 18:40 »
Пробвах kmix, контролите са абсолютно същите, Gnome не ползвам и не ми се качва само за да пробвам, но си мисля че не в миксера е проблема.

Мултимедийните приложения хващат следните 2 audio devices:
hw:0,0 - HDA NVidia AD198x Analog
hw:0,1 - HDA NVidia AD198x Digital

Въпросния проблем е при hw:0,0. При hw:0,1 нищо не се чува.



Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
XANDROS 2 DeLuxe
Общ форум
Agent_SMITH 2 1129 Последна публикация Feb 23, 2004, 15:14
от gamehack
Zeta Deluxe
Идеи и мнения
gamehack 1 1121 Последна публикация Mar 01, 2004, 23:57
от asa
Проблем с компилиране на Antico Deluxe на Ubuntu 9.04
Настройка на програми
LinuxFanUNIX 0 957 Последна публикация Jun 04, 2009, 15:29
от LinuxFanUNIX