Автор Тема: Шрифтове на Firefox  (Прочетена 913 пъти)

Tuchkata

  • Напреднали
  • *****
  • Публикации: 89
  • Distribution: Ubuntu 10.04
  • Window Manager: Gnome
    • Профил
Шрифтове на Firefox
« -: Apr 28, 2010, 22:30 »
Здравейте. Тези дни ми направи впечатление нещо странно. На нетбуук си ползвам ХР, а на персоналния Убунту 9.10. Това, което ми направи впечатление, е, че има една странна разлика между шрифтовете на Уин-а и Линукс-а. Ще приложа и два скрийншота да видите за какво говоря точно. Шрифта например на заглавието на статията и на надписа "Барселона" в началото на статията е различен под двете операционни системи. Самите шрифтове в настройките на лисицата са абсолютно еднакви, но разликата се вижда. Това не е само в този сайт, а например и във форуми, когато в даден раздел има ново мнение и то е удебелено, на Линукс-а не го виждам. Благодаря предварително за помощта :)

П.П. ето и двата скрийншота
Активен

Bagatur

  • Напреднали
  • *****
  • Публикации: 267
  • Distribution: Debian Squeeze
  • Window Manager: KDE Development Platform: 4.4.5 , LXDE
    • Профил
Re: Шрифтове на Firefox
« Отговор #1 -: Apr 28, 2010, 23:20 »
Здравей , това което трябва да на правиш е да си инсталираш MS-шрифтове в линукса
Това става по следния начин:

1. Теглиш това (цъкни на линка) http://www.osresources.com/files/centos-windows-fonts/msfonts.tbz

2.Разархивираме ги 
#sudo tar xvjpf msfonts.tbz -C /usr/share/fonts/truetype/

3. Инсталираш msttcorefonts
#sudo apt-get install msttcorefonts

4.Теглиш другите шрифтове от (цъкаш на линка и свалянето трябва да започне) http://www.osresources.com/files/centos-windows-fonts/fontconfig.tbz

5.Разархивираш
#sudo tar xvjpf fontconfig.tbz -C /etc/fonts/

След която рестартираш X-a :)

Желая ти успех, ако има нещо неясно питай :p
« Последна редакция: Apr 28, 2010, 23:33 от SATANIC_SOUL »
Активен

Учим се докато сме живи....

vstoykov

  • Напреднали
  • *****
  • Публикации: 1286
  • Distribution: Ubuntu
  • Window Manager: Fluxbox
    • Профил
    • WWW
Re: Шрифтове на Firefox
« Отговор #2 -: Apr 28, 2010, 23:25 »
Инсталирането на шрифтовете на Microsoft става като се инсталира пакета msttcorefonts (намираш инструмента за инсталиране на пакети в менюто или пишеш в конзолата "sudo apt-get install msttcorefonts").

Може да пробваш да изключиш заглаждането на ниво пиксел:

Код
GeSHi (XML):
  1. <?xml version='1.0'?>
  2. <!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
  3. <fontconfig>
  4.  <match target="font" >
  5.   <edit mode="assign" name="rgba" >
  6.    <const>rgb</const>
  7.   </edit>
  8.  </match>
  9.  <match target="font" >
  10.   <edit mode="assign" name="hinting" >
  11.    <bool>true</bool>
  12.   </edit>
  13.  </match>
  14.  <match target="font" >
  15.   <edit mode="assign" name="hintstyle" >
  16.    <const>hintfull</const>
  17.   </edit>
  18.  </match>
  19.  <match target="font" >
  20.   <edit mode="assign" name="lcdfilter" >
  21.    <const>lcddefault</const>
  22.   </edit>
  23.  </match>
  24.  <match target="font" >
  25.   <edit mode="assign" name="antialias" >
  26.    <bool>false</bool>
  27.   </edit>
  28.  </match>
  29. </fontconfig>
  30.  

Това се записва като файл ~/.fonts.conf (/home/потребител/.fonts.conf). За да влязат настройките в сила трябва да рестартираш (logout/login) или да затвориш/стартираш браузъра (настройките важат само за новостартирани програми).

В тази тема пуснах мои снимки на екрана

Ръчках по настройките, обаче не успях да ги докарам като в Slackware. До сега по-хубаво изчертаване на шрифтовете от тези в Slackware 12.0 не успях да докарам. Това ми е конфигурационния файл в Slackware:

~/.fonts.conf
Код:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <dir>/opt/kde/share/fonts</dir>
 <dir>~/.fonts</dir>
 <dir>/usr/share/wine/fonts</dir>
 <dir>/usr/share/fonts/misc/</dir>
<!--
 <dir>/usr/X11R6/lib/X11/fonts/local/misc</dir>
 <dir>/usr/X11R6/lib/X11/fonts/local/bolkhov/misc</dir>
 <dir>/usr/X11R6/lib/X11/fonts/local/bolkhov/75dpi</dir>
 <dir>/usr/X11R6/lib/X11/fonts/local/cronyx/misc</dir>
 <dir>/usr/X11R6/lib/X11/fonts/local/cronyx/75dpi</dir>
 <dir>/usr/X11R6/lib/X11/fonts/local/cronyx/100dpi</dir>
--> <match target="font" >
  <edit mode="assign" name="hinting" >
   <bool>true</bool>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hintstyle" >
   <const>hintfull</const>
  </edit>
 </match>
 <alias>
  <family>sans-serif</family>
  <prefer>
   <family>DejaVu Sans Condensed</family>
  </prefer>
 </alias>
 <alias>
  <family>serif</family>
  <prefer>
   <family>DejaVu Serif Condensed</family>
  </prefer>
 </alias>
 <alias>
  <family>monospace</family>
  <prefer>
   <family>DejaVu Sans Mono</family>
  </prefer>
 </alias>
 <match target="font" >
  <edit mode="assign" name="rgba" >
   <const>rgb</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="antialias" >
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>

/etc/fonts/fonts.conf

Код:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/fonts.conf file to configure system font access -->
<fontconfig>

<!--
        DO NOT EDIT THIS FILE.
        IT WILL BE REPLACED WHEN FONTCONFIG IS UPDATED.
        LOCAL CHANGES BELONG IN 'local.conf'.

        The intent of this standard configuration file is to be adequate for
        most environments.  If you have a reasonably normal environment and
        have found problems with this configuration, they are probably
        things that others will also want fixed.  Please submit any
        problems to the fontconfig bugzilla system located at fontconfig.org

        Note that the normal 'make install' procedure for fontconfig is to
        replace any existing fonts.conf file with the new version.  Place
        any local customizations in local.conf which this file references.

        Keith Packard
-->

<!-- Font directory list -->

        <dir>/usr/share/fonts/OTF</dir>
        <dir>/usr/share/fonts/TTF</dir>
        <dir>/usr/share/fonts/Type1</dir>
        <dir>/usr/share/fonts/Speedo</dir>
        <dir>/usr/share/fonts/cyrillic</dir>
        <dir>/usr/share/fonts/misc</dir>
        <dir>~/.fonts</dir>

<!--    Commented out font directories:
        These are not indexed by default, as fontconfig then seems
        to prefer bitmapped fonts in some cases...
        <dir>/usr/share/fonts/100dpi</dir>
        <dir>/usr/share/fonts/75dpi</dir>
-->

<!-- Font cache directory list -->

        <cachedir>/var/cache/fontconfig</cachedir>
        <cachedir>~/.fontconfig</cachedir>

<!--
  Accept deprecated 'mono' alias, replacing it with 'monospace'
-->
        <match target="pattern">
                <test qual="any" name="family">
                        <string>mono</string>
                </test>
                <edit name="family" mode="assign">
                        <string>monospace</string>
                </edit>
        </match>

<!--
  Accept alternate 'sans serif' spelling, replacing it with 'sans-serif'
-->
        <match target="pattern">
                <test qual="any" name="family">
                        <string>sans serif</string>
                </test>
                <edit name="family" mode="assign">
                        <string>sans-serif</string>
                </edit>
        </match>

<!--
  Accept deprecated 'sans' alias, replacing it with 'sans-serif'
-->
        <match target="pattern">
                <test qual="any" name="family">
                        <string>sans</string>
                </test>
                <edit name="family" mode="assign">
                        <string>sans-serif</string>
                </edit>
        </match>

<!--
  Load local system customization file
-->
        <include ignore_missing="yes">conf.d</include>

        <config>
<!--
  These are the default Unicode chars that are expected to be blank
  in fonts.  All other blank chars are assumed to be broken and
  won't appear in the resulting charsets
 -->
                <blank>
                        <int>0x0020</int>       <!-- SPACE -->
                        <int>0x00A0</int>       <!-- NO-BREAK SPACE -->
                        <int>0x00AD</int>       <!-- SOFT HYPHEN -->
                        <int>0x034F</int>       <!-- COMBINING GRAPHEME JOINER -->
                        <int>0x0600</int>       <!-- ARABIC NUMBER SIGN -->
                        <int>0x0601</int>       <!-- ARABIC SIGN SANAH -->
                        <int>0x0602</int>       <!-- ARABIC FOOTNOTE MARKER -->
                        <int>0x0603</int>       <!-- ARABIC SIGN SAFHA -->
                        <int>0x06DD</int>       <!-- ARABIC END OF AYAH -->
                        <int>0x070F</int>       <!-- SYRIAC ABBREVIATION MARK -->
                        <int>0x115F</int>       <!-- HANGUL CHOSEONG FILLER -->
                        <int>0x1160</int>       <!-- HANGUL JUNGSEONG FILLER -->
                        <int>0x1680</int>       <!-- OGHAM SPACE MARK -->
                        <int>0x17B4</int>       <!-- KHMER VOWEL INHERENT AQ -->
                        <int>0x17B5</int>       <!-- KHMER VOWEL INHERENT AA -->
                        <int>0x180E</int>       <!-- MONGOLIAN VOWEL SEPARATOR -->
                        <int>0x2000</int>       <!-- EN QUAD -->
                        <int>0x2001</int>       <!-- EM QUAD -->
                        <int>0x2002</int>       <!-- EN SPACE -->
                        <int>0x2003</int>       <!-- EM SPACE -->
                        <int>0x2004</int>       <!-- THREE-PER-EM SPACE -->
                        <int>0x2005</int>       <!-- FOUR-PER-EM SPACE -->
                        <int>0x2006</int>       <!-- SIX-PER-EM SPACE -->
                        <int>0x2007</int>       <!-- FIGURE SPACE -->
                        <int>0x2008</int>       <!-- PUNCTUATION SPACE -->
                        <int>0x2009</int>       <!-- THIN SPACE -->
                        <int>0x200A</int>       <!-- HAIR SPACE -->
                        <int>0x200B</int>       <!-- ZERO WIDTH SPACE -->
                        <int>0x200C</int>       <!-- ZERO WIDTH NON-JOINER -->
                        <int>0x200D</int>       <!-- ZERO WIDTH JOINER -->
                        <int>0x200E</int>       <!-- LEFT-TO-RIGHT MARK -->
                        <int>0x200F</int>       <!-- RIGHT-TO-LEFT MARK -->
                        <int>0x2028</int>       <!-- LINE SEPARATOR -->
                        <int>0x2029</int>       <!-- PARAGRAPH SEPARATOR -->
                        <int>0x202A</int>       <!-- LEFT-TO-RIGHT EMBEDDING -->
                        <int>0x202B</int>       <!-- RIGHT-TO-LEFT EMBEDDING -->
                        <int>0x202C</int>       <!-- POP DIRECTIONAL FORMATTING -->
                        <int>0x202D</int>       <!-- LEFT-TO-RIGHT OVERRIDE -->
                        <int>0x202E</int>       <!-- RIGHT-TO-LEFT OVERRIDE -->
                        <int>0x202F</int>       <!-- NARROW NO-BREAK SPACE -->
                        <int>0x205F</int>       <!-- MEDIUM MATHEMATICAL SPACE -->
                        <int>0x2060</int>       <!-- WORD JOINER -->
                        <int>0x2061</int>       <!-- FUNCTION APPLICATION -->
                        <int>0x2062</int>       <!-- INVISIBLE TIMES -->
                        <int>0x2063</int>       <!-- INVISIBLE SEPARATOR -->
                        <int>0x206A</int>       <!-- INHIBIT SYMMETRIC SWAPPING -->
                        <int>0x206B</int>       <!-- ACTIVATE SYMMETRIC SWAPPING -->
                        <int>0x206C</int>       <!-- INHIBIT ARABIC FORM SHAPING -->
                        <int>0x206D</int>       <!-- ACTIVATE ARABIC FORM SHAPING -->
                        <int>0x206E</int>       <!-- NATIONAL DIGIT SHAPES -->
                        <int>0x206F</int>       <!-- NOMINAL DIGIT SHAPES -->
                        <int>0x3000</int>       <!-- IDEOGRAPHIC SPACE -->
                        <int>0x3164</int>       <!-- HANGUL FILLER -->
                        <int>0xFEFF</int>       <!-- ZERO WIDTH NO-BREAK SPACE -->
                        <int>0xFFA0</int>       <!-- HALFWIDTH HANGUL FILLER -->
                        <int>0xFFF9</int>       <!-- INTERLINEAR ANNOTATION ANCHOR -->
                        <int>0xFFFA</int>       <!-- INTERLINEAR ANNOTATION SEPARATOR -->
                        <int>0xFFFB</int>       <!-- INTERLINEAR ANNOTATION TERMINATOR -->
                </blank>
<!--
  Rescan configuration every 30 seconds when FcFontSetList is called
 -->
                <rescan>
                        <int>30</int>
                </rescan>
        </config>

</fontconfig>
« Последна редакция: Apr 28, 2010, 23:31 от vstoykov »
Активен

Tuchkata

  • Напреднали
  • *****
  • Публикации: 89
  • Distribution: Ubuntu 10.04
  • Window Manager: Gnome
    • Профил
Re: Шрифтове на Firefox
« Отговор #3 -: Apr 28, 2010, 23:56 »
Здравей , това което трябва да на правиш е да си инсталираш MS-шрифтове в линукса
Това става по следния начин:

1. Теглиш това (цъкни на линка) http://www.osresources.com/files/centos-windows-fonts/msfonts.tbz

2.Разархивираме ги 
#sudo tar xvjpf msfonts.tbz -C /usr/share/fonts/truetype/

3. Инсталираш msttcorefonts
#sudo apt-get install msttcorefonts

4.Теглиш другите шрифтове от (цъкаш на линка и свалянето трябва да започне) http://www.osresources.com/files/centos-windows-fonts/fontconfig.tbz

5.Разархивираш
#sudo tar xvjpf fontconfig.tbz -C /etc/fonts/

След която рестартираш X-a :)

Желая ти успех, ако има нещо неясно питай :p
Нещата станаха по този начин, благодаря :) А в случай, че искам да си върна старите на Линукс, просто махам msttcorefonts или ? Защото лисицата е ок в момента, но например Конки и терминала изглеждат значително по-грозни, за съжаление.
« Последна редакция: Apr 29, 2010, 00:00 от Tuchkata »
Активен

Bagatur

  • Напреднали
  • *****
  • Публикации: 267
  • Distribution: Debian Squeeze
  • Window Manager: KDE Development Platform: 4.4.5 , LXDE
    • Профил
Re: Шрифтове на Firefox
« Отговор #4 -: Apr 29, 2010, 00:06 »
Не е нужно да връщаш старите просто трябва да си настроиш шрифтовете в терминала и в Конки :) в терминала това става от Setting>Menage profiles>edit profiles , за конки не знам не го ползвам ще трябва друг да ти отговори
Активен

Учим се докато сме живи....

Tuchkata

  • Напреднали
  • *****
  • Публикации: 89
  • Distribution: Ubuntu 10.04
  • Window Manager: Gnome
    • Профил
Re: Шрифтове на Firefox
« Отговор #5 -: Apr 29, 2010, 00:10 »
Сега, омазах нещата тотално :D Сложих въпросните майкрософт шрифтове, после исках да си върна старите на Убунту и ънисталнах мстткорфонтс и нещата станаха страшно грозни :D Някакви идеи как да върна дифолт фонтовете на всичко ?
Активен

Bagatur

  • Напреднали
  • *****
  • Публикации: 267
  • Distribution: Debian Squeeze
  • Window Manager: KDE Development Platform: 4.4.5 , LXDE
    • Профил
Re: Шрифтове на Firefox
« Отговор #6 -: Apr 29, 2010, 00:15 »
Еми като бързаш така става . Пробваи да сложиш пак msttcorefonts и ако всичко е на ред си настрой терминала и там квото ти трябва още :)
Инъче ако трябва да връщаш по подрабиране е голяма играчка.(е не чак толкова но все пак)
« Последна редакция: Apr 29, 2010, 00:18 от SATANIC_SOUL »
Активен

Учим се докато сме живи....

Tuchkata

  • Напреднали
  • *****
  • Публикации: 89
  • Distribution: Ubuntu 10.04
  • Window Manager: Gnome
    • Профил
Re: Шрифтове на Firefox
« Отговор #7 -: Apr 29, 2010, 00:19 »
Ами като че ли ще искам да ги върна по подразбиране. Макар и с тази малка забележка при лисицата, със стандартните шрифтове на Линукс-а нещата бяха доста "по-красиви", ако може така да се каже. Ще се радвам ако напишеш как става връщането по подразбиране :)
Едит : успях да върна старите шрифтове и по-интересното е, че лисицата остана сякаш с тези на МС, а останалото си е на Линукс. Шрифтовете махнах като влезнах в /etc/fonts и написах
Код:
$sudo rm alias.conf msfonts-rules.conf local.conf misc.conf
« Последна редакция: Apr 29, 2010, 01:10 от Tuchkata »
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
firefox 0.9
Настройка на програми
kennedy 1 1937 Последна публикация Jun 25, 2004, 01:42
от Kasho
Проблем с Firefox
Настройка на програми
chubak 4 2914 Последна публикация Oct 01, 2004, 11:56
от empty
българска локализация за firefox
Настройка на програми
philip 5 3162 Последна публикация Jan 18, 2005, 19:11
от kennedy
Странен проблем с Firefox
Настройка на програми
Nuclear_man 12 4360 Последна публикация Feb 13, 2005, 16:24
от Goust
Firefox ная български
Настройка на програми
niko_lai 0 2027 Последна публикация Feb 22, 2005, 13:10
от niko_lai