Автор Тема: [РЕШЕН]при судо командата да не ми иска парола...  (Прочетена 1139 пъти)

bazu

  • Напреднали
  • *****
  • Публикации: 810
  • Distribution: Debian
  • superman
    • Профил
Та Дистрибуцията е ubuntu 10.04 x64 и в sudories слагам това
Код:
User_Alias FULLTIMERS = bazu
root    ALL=(ALL) ALL
FULLTIMERS ALL = NOPASSWD: ALL


И не става, а при slackware си работи това, a при sabayona работи като добавя и този ред преди това
Код:
Defaults:bazu timestamp_timeout=-1
А при убунтуто и по двата начина не работи.
« Последна редакция: May 05, 2010, 16:08 от bazu »
Активен

kill_u

  • Напреднали
  • *****
  • Публикации: 1058
  • Distribution: Ubuntu 9.10
  • Window Manager: Gnome
  • Out of here....
    • Профил
    • WWW
Пробва ли най-простия начин

Код:
sudo passwrd root
Активен

Всеки пост - отговор на въпрос!!!
Gnu/Linux user 411527

kill_u

  • Напреднали
  • *****
  • Публикации: 1058
  • Distribution: Ubuntu 9.10
  • Window Manager: Gnome
  • Out of here....
    • Профил
    • WWW
sudo passwd root

Извинявам се добавил съм един r в повече....
Всъщност сега виждам че искаш да не ти иска парола, до колкото се сещам то по принцип в 9.10 не искаше парола. Възможно ли е пак да са го въвели в 10.х
« Последна редакция: May 04, 2010, 14:12 от kill_u »
Активен

Всеки пост - отговор на въпрос!!!
Gnu/Linux user 411527

bazu

  • Напреднали
  • *****
  • Публикации: 810
  • Distribution: Debian
  • superman
    • Профил
Да, не искам да ме пита за парола на администратора като ползвам судо и силно ме дразни :) или ако не просто за определени команди като sudo bla bla да не ми иска парола, а за другите ако иска ще го приживея.
Активен

borovaka

  • Напреднали
  • *****
  • Публикации: 1331
  • Distribution: Каквото дойде
  • Window Manager: Gnome / KDE
    • Профил
Пропуснал си (ALL) би трябвало да изглежда така:
FULLTIMERS ALL=(ALL)  NOPASSWD: ALL
Активен

Та извода е прост: "Колкото по-големи ла*ната - толкова по-малка щетата! ... моралната де, не материалната"

bazu

  • Напреднали
  • *****
  • Публикации: 810
  • Distribution: Debian
  • superman
    • Профил
Е пак греша къде е проблема ето го целия код:
Код:
# /etc/sudoers
#
# This file MUST be edited with the 'visudo' command as root.
#
# See the man page for details on how to write a sudoers file.
#

Defaults env_reset
Defaults:bazu timestamp_timeout=-1
# Host alias specification

# User alias specification

# Cmnd alias specification

# User privilege specification
User_Alias FULLTIMERS = bazu
root ALL=(ALL) ALL
FULLTIMERS ALL=(ALL) NOPASSWD: ALL

# Allow members of group sudo to execute any command after they have
# provided their password
# (Note that later entries override this, so you might need to move
# it further down)
%sudo ALL=(ALL) ALL
#
#includedir /etc/sudoers.d

# Members of the admin group may gain root privileges
%admin ALL=(ALL) ALL
Активен

borovaka

  • Напреднали
  • *****
  • Публикации: 1331
  • Distribution: Каквото дойде
  • Window Manager: Gnome / KDE
    • Профил
Я махни този alias и пробвай да даваш права директно на потребителя ти.
Да стане директно "bazu ALL=(ALL) NOPASSWD: ALL" и махни User_Alias
Активен

Та извода е прост: "Колкото по-големи ла*ната - толкова по-малка щетата! ... моралната де, не материалната"

headless

  • Новаци
  • *
  • Публикации: 1
    • Профил
Два варианта:
<user> ALL=NOPASSWD: ALL
или
%<group> ALL=NOPASSWD: ALL

При първия няма да ти иска парола за коя да е команда изпълнена със судо на юзера, който ти посочиш.
При втория - за групата която ти посочиш.
Активен

c111100101

  • Гост
Ако наистина знаеш какво правиш е добре, иначе не случайно разработчиците са решили да е така. :)
Активен

bazu

  • Напреднали
  • *****
  • Публикации: 810
  • Distribution: Debian
  • superman
    • Профил
И с пуснат sshd няма как да се вържат към мен хем доставчика ми филтрира портовете хем имам и допълнителен рутер с firewall и сам седя на компа, а пък едва ли точно някой ще ходи мен да хаква да ми свали стоте снимки на Анна Курникова където имам. :) офф да е му се ненавиди направих го така
Код:
root    ALL=(ALL) ALL
bazu ALL=NOPASSWD: ALL
и пак не иска. Добре ако не може за всички команди поне за тази
Код:
sudo vbetool dpms off
искам без да ми иска парола за да мога да я сложа в key shortcut та да си гася дисплея.
« Последна редакция: May 05, 2010, 10:28 от bazu »
Активен

zeridon

  • Killmode enabled
  • Administrator
  • Напреднали
  • *****
  • Публикации: 1398
  • Distribution: Debian/Ubuntu
  • Window Manager: console/Gnome
  • BOfH
    • Профил
    • WWW
Трябва да отвориш нова сесия. Судото (поне ако за първи път го слагаш) иска нова сесия.  Разлогване и логване обикновенно помагат. Иначе наистина е:

Код
GeSHi (Bash):
  1. <user> ALL=NOPASSWD: ALL

Също така обърни внимание и на този фрагмент:
Код
GeSHi (Bash):
  1. # Members of the admin group may gain root privileges
  2. %admin ALL=(ALL) NOPASSWD: ALL

Поне лично за мен е по логично просто да си добавя юзера в група админ (примерно):
Код
GeSHi (Bash):
  1. usermod -a -G admin myuser
Активен

Внмимавай имам клещи за кабел
http://www.netsecad.com/
http://theregister.co.uk/odds/bofh/

bazu

  • Напреднали
  • *****
  • Публикации: 810
  • Distribution: Debian
  • superman
    • Профил
Аз рестартирам компа направо като пробвам по друго яче, а да не прави бела, защото нали убунтуто идва без админ парола и аз му добавих ръчно парола, но едва ли ще е от това.
Активен

bazu

  • Напреднали
  • *****
  • Публикации: 810
  • Distribution: Debian
  • superman
    • Профил
Добре къде бъркам
Код:
bazu@igoshin:~$ sudo -s
root@igoshin:~# usermod -a -G admin bazu
root@igoshin:~# exit
exit
bazu@igoshin:~$ apt-get update
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock the list directory
bazu@igoshin:~$
Активен

bazu

  • Напреднали
  • *****
  • Публикации: 810
  • Distribution: Debian
  • superman
    • Профил
@ROKO__ boko помогна за решението на казуса ми като ме препрати на един линк и там открих отговора
Код:
bazu    igoshin = NOPASSWD: ALL
където bazu е потребителя, а igoshin името(хоста) на машината.
Активен