Автор Тема: Проблем с Скайп под Убунту 10.4  (Прочетена 2308 пъти)

Deeds

  • Напреднали
  • *****
  • Публикации: 60
  • Distribution: KDE 14.04
    • Профил
Значи проблемът ми е следния:
Когато някой ми звънне по скайпа  и  отговоря работи само няколко секунди и целият скайп блокира. Мислех че е от моята камера, махнах я но пак същата работа. изключвам скайп-а отварям нов, при опит за логин ми изписва че е включено друго копие на скайп следователно трябва да рестартирам машината и преди рестарт-а ме пита дали да прекратя \usr\bin\Skype
Надявам се накой да помогне ще съм много благодарен

Благодаря предварително!!!
Активен

cybercop

  • Напреднали
  • *****
  • Публикации: 5579
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Проблем с Скайп под Убунту 10.4
« Отговор #1 -: Aug 30, 2010, 09:46 »
Откъде си инсталирал версията на Skype. съветвам те да инсталираш скайп само от хранилищата, просто като напишеш в конзолата sudo apt-get install skype. Провери дали ти е инсталирано pulseaudio. В Ubuntu/Kubuntu 10.04 има проблеми със звука на скайп ако не е инсталиран. Инсталирай си и alsamixergui с който прекрасно можеш да настройваш звука в системата.
« Последна редакция: Aug 30, 2010, 09:51 от cybercop »
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

Deeds

  • Напреднали
  • *****
  • Публикации: 60
  • Distribution: KDE 14.04
    • Профил
Re: Проблем с Скайп под Убунту 10.4
« Отговор #2 -: Aug 30, 2010, 09:51 »
Ми скайпа го истеглих от официалния сайт на скайп! но се га ще пробвам твоя начин!

пробвах но ми дава грешка при инсталацията на  alsamixergui "Това действие ще изисква инсталацията на пакет от непотвърдени източници."
« Последна редакция: Aug 30, 2010, 10:01 от Deeds »
Активен

cybercop

  • Напреднали
  • *****
  • Публикации: 5579
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Проблем с Скайп под Убунту 10.4
« Отговор #3 -: Aug 30, 2010, 10:42 »
Първо отвори synaptic и разреши всички хранилища без тези за предварително издадени и тези за неподдържани актуализации. След това ъпдейтвай. Премахни старият скайп със sudo apt-get remove skype и го инсталирай отново с команда. След това премахни и pulseaudio със sudo apt-get remove pulseaudio. След това инсталирай alsamixergui, регулирай регулирай контролерите и отново инсталирай pulseaudio. карам те да правиш това, защото като инсталираш pulseaudio, програмата поема контрола върху звука на системата и вече не можех да регулираш други канали освен главният. За всеки случай прослушай скайпа преди да инсталилираш pulseaudio, да не би да си от тези редки случай, при които скайпа си работи добре без него. Аз лично се съмнявам защото доста инсталации на познати на Убунту и Кубунту направих и никъде звука на скайпа не тръгна без него.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

trosho

  • Напреднали
  • *****
  • Публикации: 321
    • Профил
Re: Проблем с Скайп под Убунту 10.4
« Отговор #4 -: Sep 01, 2010, 01:08 »
Постът ми е малко встрани от първия въпрос, но все пак се отнася за Skype.
Имам инсталиран Skype 2.1.0.81 под Linux Mint, който си работи и с ALSA. Не знам дали е изключение, но може да видите обясненията тук - цък . Според написаното, PulseAudio не се изисква за работата на Skype.

Има и друг, по-лесен начин (според мен) за спиране на PulseAudio. Вместо да се деинсталира, може да се създаде файл ~/.pulse/client.conf, в който да се зададе "no" на "autospawn" опцията (показана е в онзи линк). За повече инфо: man pulse-client.conf. След това спираме PulseAudio-то. Ето и стъпките в терминала (като обикновен потребител):
nano ~/.pulse/client.conf
(въвеждаме: autospawn = no; записваме и излизаме от nano)
pulseaudio --kill
(с тази команда се "убива" pulseaudio сървърът)
Сега вече няма работещо PulseAudio. Доказателство за това е фактът, че звукът не може да се регулира през иконта в индикатор аплета, а само през alsamixer. Ако пуснем някое аудио приложение, трябва да го нaстроим да работи с ALSA.

Ако пък пуснем Skype и отидем в настройките, би трябвало да имаме директен достъп до звуковата карта:


По този начин бързо може да се провери дали ще има проблем със Skype и ALSA.
За да няма проблем с микрофона при работа с ALSA, трябва да е сигурно, преди да е изключен pulseaudio сървърът, че няма отметка на mute в "Sound Preferences" (настройките на PulseAudio).

За да се върнат нещата в предишното положение, правим "autospawn = yes" (за да върнем стандартната настройка) и отново стартираме pulseaudio сървъра с команда "pulseaudio --start".
« Последна редакция: Sep 01, 2010, 14:30 от trosho »
Активен