Автор Тема: Проблем при зареждане на Grub  (Прочетена 983 пъти)

elfenlied

  • Напреднали
  • *****
  • Публикации: 205
  • Distribution: Sabayon 5.3
  • Window Manager: Gnome 2.30.2
    • Профил
Здравейте! Днес заведох лаптопа си на ремонт, но вече нямаха части и ми смениха т.н шеси. Оставиха само харда, рамнта и процесора. Та сложих наново Sabayon 5.3, Цялата инсталация мина идеално, но след рестарта замръзва при зареждане на grub и до там. Стария дял с /home го запазих (имам важна информация на него ), а "/" го форматирах. Идеята ми е да заредя линукса без да загубя информацията или да запазя информацията(като я запиша на дискове), пък после да го форматирам. 
Активен

PC Cases: DELL 400W. Pentium IV, CPU speeds: 1700 MHz, MMX, SSE, SSE2,  FSB speeds: 400 MHz, x86. RAM MEMORY: RDRAM 2x256MB,  400Mhz. SVGA: NVidia TNT2 Memory: 32MB.
HDD: 40GB, 7400 RPM.
Motherboard Dell Dimension 8200

morbid_viper

  • Напреднали
  • *****
  • Публикации: 266
  • Distribution: (Open)SUSE since v5.3 (1999)
  • Window Manager: KDE ориентиран
    • Профил
Re: Проблем при зареждане на Grub
« Отговор #1 -: Sep 21, 2010, 23:19 »
можеш да си възстановиш груб да работи както трябва
може би проблемът е, че идентификаторът на диска ти е вече друг (обикновено може да се намери в /boot/grub/device.map)

най-чисто е да заредиш системата от друг зареждаш носител и да си пуснеш наново настройката на grub. не знам как е в sabayon, но в suse на инсталационния носител си има меню, от което може да се зареди вече инсталирана система… също така има и относително автоматизирана система за поправка на разни простотии – включително мениджърът на зареждането.

все пак за въпроса ти: най-добре си постъпил, като имаш отделен дял за home... така или иначе най-често там се трупат най-важните файлове. направи си един tar jvcf /media/flashka/backup_etc.tar.bz2 /etc, което да имаш за всеки случай и спокойно си изплющи нова инсталация. все пак ако си разхвърлял разни неща по другите директории (бази от данни, уеб сървъри и прочее) ще трябва да си ги запазиш – ти си знаеш най-добре.

този филм го играя всеки път като си преинсталирам компютъра с ново сусе… не че си няма отлична система за надграждане – просто с течение на времето съм наслагал толкова много пакети и тестови версии на какво ли не, че ми отнема много по-малко време просто да го инсталирам начисто.
Активен

-------------------------------------------------
Blessed are we to taste this life of sin!
-------------------------------------------------
Registered Linux user #251276

elfenlied

  • Напреднали
  • *****
  • Публикации: 205
  • Distribution: Sabayon 5.3
  • Window Manager: Gnome 2.30.2
    • Профил
Re: Проблем при зареждане на Grub
« Отговор #2 -: Sep 21, 2010, 23:27 »
И при Sabyaon я има тази опция, но за жалост нямаше подобрения след реконфигуриране ( автоматично от жиовото ЦД ). Сега направих един хубав сент (разбира се пак от живото ЦД ) през пим на друг компютър. Като се пратят ще се поръчкам без да ме е страх да скапя нещо, но груб си е замръзнал и си бия главата как да го разтопя.
Активен

PC Cases: DELL 400W. Pentium IV, CPU speeds: 1700 MHz, MMX, SSE, SSE2,  FSB speeds: 400 MHz, x86. RAM MEMORY: RDRAM 2x256MB,  400Mhz. SVGA: NVidia TNT2 Memory: 32MB.
HDD: 40GB, 7400 RPM.
Motherboard Dell Dimension 8200

c2h5oh

  • Напреднали
  • *****
  • Публикации: 675
  • Distribution: CentOS 7.4 Fedora 28
  • Window Manager: Plasma Desktop
    • Профил
Re: Проблем при зареждане на Grub
« Отговор #3 -: Sep 21, 2010, 23:41 »
"Стария дял с /home го запазих (имам важна информация на него ), а "/" го форматирах"  Какви са тези глупости? Ти бъзикаш ли се?
« Последна редакция: Sep 21, 2010, 23:51 от c2h5oh »
Активен

elfenlied

  • Напреднали
  • *****
  • Публикации: 205
  • Distribution: Sabayon 5.3
  • Window Manager: Gnome 2.30.2
    • Профил
Re: Проблем при зареждане на Grub
« Отговор #4 -: Sep 21, 2010, 23:47 »
"Стария дял с /home го запазих (имам важна информация на него ), а "/" го форматирах" Какви са тези глупости? Ти бъзикаш ли се?
Ами фактически форматирах sda1="/" ( където беше ос-то, безуспешно подкарано), а sda2 го оставих непокътнато и го моутнах на /home, както си беше и преди преинсталацията ( с надежда за груб). За жалост такива неща направих, но кажи къде греша? Правих каквото ми хрумне за бърза оправия.
Активен

PC Cases: DELL 400W. Pentium IV, CPU speeds: 1700 MHz, MMX, SSE, SSE2,  FSB speeds: 400 MHz, x86. RAM MEMORY: RDRAM 2x256MB,  400Mhz. SVGA: NVidia TNT2 Memory: 32MB.
HDD: 40GB, 7400 RPM.
Motherboard Dell Dimension 8200

c2h5oh

  • Напреднали
  • *****
  • Публикации: 675
  • Distribution: CentOS 7.4 Fedora 28
  • Window Manager: Plasma Desktop
    • Профил
Re: Проблем при зареждане на Grub
« Отговор #5 -: Sep 21, 2010, 23:53 »
Можеше например това да го напишеш още в началото.
Активен

elfenlied

  • Напреднали
  • *****
  • Публикации: 205
  • Distribution: Sabayon 5.3
  • Window Manager: Gnome 2.30.2
    • Профил
Re: Проблем при зареждане на Grub
« Отговор #6 -: Sep 22, 2010, 20:28 »
Успях да запазя всичко на друг компщютър, но интересен факт е. че после пробвах с Fedora, Mandriva, и още няколко диструбиции, а ситуацията беше същата. Замених grub с lilo и всичко си боотваше без да забива и да има проблеми :) Проблема с груб нямаше решение, но сега ще слагам лило на негово място. Благодаря на отзовалите се и все още приемам преложения за груб [_]3
Активен

PC Cases: DELL 400W. Pentium IV, CPU speeds: 1700 MHz, MMX, SSE, SSE2,  FSB speeds: 400 MHz, x86. RAM MEMORY: RDRAM 2x256MB,  400Mhz. SVGA: NVidia TNT2 Memory: 32MB.
HDD: 40GB, 7400 RPM.
Motherboard Dell Dimension 8200

kalinik

  • Напреднали
  • *****
  • Публикации: 539
  • Distribution: LMDE x64 2012/ LM 14 x64
  • Window Manager: Mate / KDE
  • ID user #521433
    • Профил
Re: Проблем при зареждане на Grub
« Отговор #7 -: Sep 22, 2010, 23:18 »
Успях да запазя всичко на друг компщютър, но интересен факт е. че после пробвах с Fedora, Mandriva, и още няколко диструбиции, а ситуацията беше същата. Замених grub с lilo и всичко си боотваше без да забива и да има проблеми :) Проблема с груб нямаше решение, но сега ще слагам лило на негово място. Благодаря на отзовалите се и все още приемам преложения за груб [_]3

Aми доколкото разбрах, проблема ти идва от UUID на дисковете, който grub ползва.Lilo НЕ го ползва и може би затова работи.
Виж /etc/default/grub има опция да НЕ се чете диска по UUID и махни коментара на реда GRUB_DISABLE_LINUX_UUID=true.
После update-grub и ако се наложи при boot-ването влез и му задай ръчно /dev/еди-кой-си-диск да търси (в твоят случай май е /dev/sda1)
Пробвай  ;)
Активен

elfenlied

  • Напреднали
  • *****
  • Публикации: 205
  • Distribution: Sabayon 5.3
  • Window Manager: Gnome 2.30.2
    • Профил
Re: Проблем при зареждане на Grub
« Отговор #8 -: Sep 23, 2010, 01:28 »
Kalinik. благодаря. Сега само да разбера как да стигна до едит ( все пак фреезва в никакъв етап ).
Активен

PC Cases: DELL 400W. Pentium IV, CPU speeds: 1700 MHz, MMX, SSE, SSE2,  FSB speeds: 400 MHz, x86. RAM MEMORY: RDRAM 2x256MB,  400Mhz. SVGA: NVidia TNT2 Memory: 32MB.
HDD: 40GB, 7400 RPM.
Motherboard Dell Dimension 8200

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Проблем с GRUB
Настройка на програми
angie_bg 11 2858 Последна публикация Feb 17, 2005, 11:54
от
Дребен проблем с GRUB.
Настройка на програми
niko_lai 0 1013 Последна публикация Feb 21, 2005, 14:19
от niko_lai
GRUB Проблем!!!
Настройка на програми
netvampire 4 1974 Последна публикация May 27, 2005, 22:08
от
Инсталиране на Grub
Настройка на програми
fogata 1 2249 Последна публикация Jun 08, 2005, 20:54
от colomager
GRUB
Настройка на програми
niko_lai 13 2460 Последна публикация Jun 30, 2005, 16:59
от Agent_SMITH