Автор Тема: Проблем с новото Убунту 11.10  (Прочетена 3966 пъти)

Egu

  • Напреднали
  • *****
  • Публикации: 28
    • Профил
Здравейте отново. С Убунту Гном класик съм и не мога да оправя за сега два проблема. Единият е да накарам текстовия редактоер gedit за запомни, че текстовете с кирилица са на CP 1251. Не мода да му отворя настройките както са описани http://profruit.blogspot.com/2010/07/ubuntu.html
Другото нещо е, че искам да сменя клавиатурният индикатор с флагове. До сега на другите версии го правех, но на тази нещо не става. Направил съм си папката с флаговете, само дето трябва да сложа отметка да се показват, но проблема е че не мога да отворя този прозорец. Преди се отваряше с клавишите Alt+F2, но сега не ще.

п.п. Въобще със всяка следваща версия все нови проблеми. Тъкмо да понаучи нещо човек и хоп нови неща, при които старото научено вече не действа.
Активен

malin

  • Гост
Re: Проблем с новото Убунту 11.10
« Отговор #1 -: Oct 23, 2011, 16:20 »
По послеписа : Хванал си се с Юбунту - знаеш/прочел си за какво става дума . И послеписа става излишен .
Активен

Egu

  • Напреднали
  • *****
  • Публикации: 28
    • Профил
Re: Проблем с новото Убунту 11.10
« Отговор #2 -: Oct 24, 2011, 21:15 »
Абсолютно нищо не разбрах от поста ти! Някой ако е разбрал, нека да ми обясни.
Активен

and1soma

  • Напреднали
  • *****
  • Публикации: 138
  • Distribution: Debian based
  • Window Manager: GTK+ / Qt
    • Профил
    • WWW
Re: Проблем с новото Убунту 11.10
« Отговор #3 -: Oct 25, 2011, 00:43 »
@malin има в предвид, че предварително е трябвало да се информираш за новостите в Ubuntu 11.10. ;D
Този версия идва с Unity и не очаквай нещата, които си правил преди, сега да работят. ;D
Това, което можеш да направиш, за да си върнеш нещата по старо му, е да си инсталираш Fall сесията на Gnome -
Код:
sudo apt-get install gnome-session-fallback
и след това от login менюто си избери "Gnome Classic", но и тука не е много розово.. (ако искаш да местиш или настройваш аплетите, се прави с Alt и десен клик), а другия вариант е да си изтеглиш УСУ, там по подразбиране имаш включени флагове, класически вид и т.н. + това новото УСУ, което ще се базира на Ubuntu 11.10, няма да използва Gnome-Shell или Unity, а максимално ще се доближава до стария вид и начин на работа. 8)
Активен

"Нищо не е по-далеч от истината."

Egu

  • Напреднали
  • *****
  • Публикации: 28
    • Профил
Re: Проблем с новото Убунту 11.10
« Отговор #4 -: Oct 25, 2011, 13:09 »
Благодаря. Може и да го направя това с УСУ или да се върна по-старата 10.10 версия. Аз забравих да кажа, че това с вече съм с Гном Класик, но въпреки това нещата на стават.
Активен

trosho

  • Напреднали
  • *****
  • Публикации: 321
    • Профил
Re: Проблем с новото Убунту 11.10
« Отговор #5 -: Oct 25, 2011, 14:37 »
Еди, пробвай директно от gedit. Версия 11.10 вече е с Gnome 3 (dconf), а показаното от Profruit е за Gnome 2 (gconf).

В gedit избери Open и през combobox "Character Encoding" добави и задай да се използва Windows-1251 кодировка.

ПП. Ако не стане по горния начин, можеш да използваш dconf-editor, за да направиш нещо подобно на предишното.
Инсталираш пакет dconf-tools: sudo apt-get install dconf-tools
Стартираш dconf-editor, отиваш на org.gnome.gedit.preferences.encodings и добавяш кодировка WINDOWS-1251 в ключове auto-detected и shown-in-menu:

Същото вероятно може да стане и с gsettings през терминала, но мисля, че така е по-лесно.
« Последна редакция: Oct 25, 2011, 15:25 от trosho »
Активен

Egu

  • Напреднали
  • *****
  • Публикации: 28
    • Профил
Re: Проблем с новото Убунту 11.10
« Отговор #6 -: Oct 29, 2011, 08:30 »
Здравейте! Успях да инсталирам пакета dconf-tools и отворих редактора от снимката, но не мога да запомня промяната. Добавям кодировката, както е показано на снимката, но не иска да я запомни.
Активен

trosho

  • Напреднали
  • *****
  • Публикации: 321
    • Профил
Re: Проблем с новото Убунту 11.10
« Отговор #7 -: Oct 29, 2011, 13:56 »
Не знам какво имаш предвид, като казваш, че не иска да я запомни. Просто цъкваш с мишката, за да влезеш в режим на редакция, добавяш кодировката и натискаш Enter.
След като затвориш dconf-editor, много лесно може да провериш дали е запомнена промяната с тази команда:
Код:
gsettings list-recursively org.gnome.gedit.preferences.encodings

Ако добавиш кодировката в края на спъска, както е показано на снимката по-горе, може да не сработи автоматичното разпознаване (при отваряне на нов, непознат файл). Затова е добре да сложиш новата кодировка в началото на спъсъка. Може би трябва също да излезеш от сесията и да влезеш отново, за да влязат в сила промените.
Активен

Egu

  • Напреднали
  • *****
  • Публикации: 28
    • Профил
Re: Проблем с новото Убунту 11.10
« Отговор #8 -: Oct 29, 2011, 20:15 »
Е сега се оправи. Благодаря за помоща. :)
Активен

Damp1r3

  • Напреднали
  • *****
  • Публикации: 76
    • Профил
Re: Проблем с новото Убунту 11.10
« Отговор #9 -: Dec 23, 2011, 13:15 »
И аз нещо си оплесках субтитрите нз как обаче ... до си гледах филми с СМПлеяр а днес не иска да ми чете субтитрите вобще не излизат нито маймунки нито нищо няма просто всичките ми настройки са като в скриина по-горе но субтитри няма на бутона subtitle ми ги показва но така и така си ги няма в филма като направя някаква промяна като ли че изкачат за секунда но немога да преценя просто мн бързо изчезват ако някой има идей сам целия в слух :0
Активен

"Загина столицата. Кули вековни
рухнaха след тежка борба,
рухнаха палати и светини чутовни,
борци връхлетя ги ужасна съдба!

В развалини смрадни Трапезица пуши
премина над Царевец огнен потоп,
край трупове грозни Янтра лъкатуши.
Превърна се Търново в гроб."

cybercop

  • Напреднали
  • *****
  • Публикации: 5580
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Проблем с новото Убунту 11.10
« Отговор #10 -: Dec 23, 2011, 15:22 »
Да не би да са махнали VLC от хранилищата ?
http://img683.imageshack.us/img683/9774/vlcxw.png
За знаменцата - първо  се добавят знаменца
http://dox.bg/files/dw?a=84cc0601df
http://dox.bg/files/dw?a=4e79c523d7
във файлова система>>usr>>share>>pixmaps и след това да се разрешат от gconf-editor>> Гном>>периферни устройства>>клавиатура>>индикатор.
« Последна редакция: Dec 23, 2011, 15:41 от cybercop »
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

and1soma

  • Напреднали
  • *****
  • Публикации: 138
  • Distribution: Debian based
  • Window Manager: GTK+ / Qt
    • Профил
    • WWW
Re: Проблем с новото Убунту 11.10
« Отговор #11 -: Dec 24, 2011, 20:12 »
Цитат
и след това да се разрешат от gconf-editor>> Гном>>периферни устройства>>клавиатура>>индикатор.
Това важи само за Gnome 2!
В Gnome 3 знаменцата пак се поставят в /usr/share/pixmaps, но настройката се прави от dconf-editor в org.gnome.libgnomekbd.indicator на true.
След като се приключи трябва да се рестартира сесията.
Ако пак нещо не сработи може да се пробва да се сменят имената - us-symbolic.png и bg-symbolic.png за българското.

П.П. По подразбиране Dconf-Editor не е инсталиран.
Инсталира се с командата -
Код:
sudo apt-get install dconf-tools

Но аз лично ти препоръчвам да се ориентираш към Kubuntu, който използва KDE за графична среда. Там нещата са къде, къде по-розови и изобщо като цяло KDE е много мощна среда. А и освен това по подразбиране имаш избор дали искаш текст или изображение да ти се показва като индикатор за клавиатурната подредба.
Ето това е едно интересно клипче за KDE.
Активен

"Нищо не е по-далеч от истината."