Автор Тема: Проблем с видео карта на лаптоп - Линукс Минт 12  (Прочетена 3569 пъти)

georgi950

  • Напреднали
  • *****
  • Публикации: 19
    • Профил
Здравейте,
Имам ето този лаптоп http://www.dell.com/support/troubleshooting/us/en/19/Index?c=us&l=en&s=&cs=19&t=system и проблема е, че когато инсталирам драйверите за видео картата се инсталират драйвери за вградената видео карта и се взима от рам паметта и процесора  се използва за 3Д графиките. Деинсталирах и инсталирах(по различни начини - първо от вграденото "Aditional drivers", после теглих драйверите от официалния сайт и ги инсталирвах) няколко пъти, но не успях да подкарам външната карта. Някой може ли да помогне?
Благодаря предварително!
« Последна редакция: Apr 01, 2012, 19:43 от georgi950 »
Активен

vyrgozunqk

  • Гост
Първо не си дал точен линк за лаптопа ти. Второ, при хибридните лаптопи, вградените видеокарти винаги работят и смучат рам : )
А щом си с хибрид, предполагам, че си поне с 4 ГБ рам, така, че какво толкова те бърка дали ползва или не.

Ако си с нвидия оптимус... кофти... трябва да ползваш bumblebee и с него специфично да задаваш кои приложения да ползват Nvidiata за допълнително ускорение, примерно, ако искаш да си пуснеш някоя игра, то нейният прозорец да е ускорен.
Активен

georgi950

  • Напреднали
  • *****
  • Публикации: 19
    • Профил
Линкът е точен просто трябва да цъкнеш "Components" сайта така е направен...имам 6гб рам и не ми пречи, че дърпа 256мб проблема е там, че външната въобще не работи, а вградената е доста по-слаба. Външната ми (amd mobility radeon HD 550v)има 1Гб собствена памет и е 128бита..вградената е 32 бита и е 256мб от рамта. Разликата е доста голяма. :)
« Последна редакция: Mar 30, 2012, 17:34 от georgi950 »
Активен

vyrgozunqk

  • Гост
Аз не виждам къде мога да цъкна 'components'. Сайта използва coockies и ти запомня нещата на твоят браузър, дай друг директен линк.  ;)

http://wstaw.org/m/2012/03/30/snapshot8.png

Щом  си с радеон в крайна сметка трябва да инсталираш каталист поне 12.1
И после в терминала да напишеш
sudo aticonfig --initial  ( това е при условие, че си с убунту )

А каталиста, който е в репотата на убунту е доста стар като версия, освен, ако не си с убунту 12.04 примерно...
« Последна редакция: Mar 30, 2012, 17:54 от vyrgozunqk »
Активен

georgi950

  • Напреднали
  • *****
  • Публикации: 19
    • Профил
Извинявам се за линка!

Характеристики:

Серия Inspiron M5010
Процесор AMD Phenom II Quad-Core N930 2.00 GHz, 2 MB L2, 3.6 GT/s
Памет, MB 6144 MB (1 x 4096 MB + 1 x 2048 MB) 1333 MHz DDR3 Dual Channel
Твърд диск, GB 640 GB Serial ATA 5.4 krpm
Оптично устройство 8X DVD+/-RW Drive including software
Дисплей, inch 15.6" (39.62 cm) High Definition (1366 x 768) WLED
Видео 1 GB ATI Mobility Radeon HD 550v
Звук 4-Watt (2 x 2W) HD Audio 2.0 Stereo Speakers Intel High Definition Audio 2.0

С линукс минт 12(гном, 64 бита!) съм и sudo aticonfig --initial не помага понеже минт изобщо не открива външната карта и използва само вградената. И въпроса е как да го накарам да използва външната? Мисля, че трябва да се прави нещо по xorg.conf (доколкото разбрах от гугъл), но съм с линукс от няколко дена и нямам идея какво точно да направя.
Активен

vyrgozunqk

  • Гост
Не открива външната ?! В биос разрешена ли е ?! - я дай един извод от sudo lspci
Интересно, бинарен драйвер от сайта на ати ли се опитваш да сложиш ?
Активен

georgi950

  • Напреднали
  • *****
  • Публикации: 19
    • Профил
Разрешена е в биоса.
ето изхода от sudo lspci:

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS880 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0)
00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
00:11.0 SATA controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] (rev 40)
00:12.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 42)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
00:16.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:16.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
02:00.0 VGA compatible controller: ATI Technologies Inc M96 [Mobility Radeon HD 4650]
02:00.1 Audio device: ATI Technologies Inc RV710/730
04:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)

Първо опитах да инсталирам драйвера, който минт намира!
След като не стана направих това и пак работеше само вградената.
$ sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx
$ sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
$ sudo apt-get install xserver-xorg-video-ati
$ sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
$ sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
$ sudo reboot
$ sudo sh ./ati-driver-installer-11-8-x86.x86_64.run
$ sudo aticonfig --initial -f
Активен

bvbfan

  • Напреднали
  • *****
  • Публикации: 1056
  • Distribution: KaOS
  • Window Manager: Plasma 5
    • Профил
Цитат
02:00.0 VGA compatible controller: ATI Technologies Inc M96 [Mobility Radeon HD 4650]
Като гледам видео картата ти е Mobility Radeon HD 4650 не е Mobility Radeon HD 550v, това е възможно, защото има модел и с едната и с другата. В Технополис има с въпросната карта модел. Освен това слагаш доста стар драйвер пробвай с този http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx Освен това няма нужда от mesa не изпълнявай нищо друго осен инсталирането на драйвера
« Последна редакция: Mar 31, 2012, 18:52 от bvbfan »
Активен

georgi950

  • Напреднали
  • *****
  • Публикации: 19
    • Профил
Вградената  ми видео карта е hd 4650. Външната е HD 550v и работи с 3д ускорител на HD 4850. Сигорен съм в това, понеже бях с windows и след инсталация на драйверите показва, че картата е hd 550v!
Активен

kalinik

  • Напреднали
  • *****
  • Публикации: 539
  • Distribution: LMDE x64 2012/ LM 14 x64
  • Window Manager: Mate / KDE
  • ID user #521433
    • Профил
Сваляш последния Catalyst 12.3 от сайта на Amd и го инсталираш , както вече си го направил с версия 11.8.Обаче първо трябва да го деинсталираш тотално и да рестартираш без fglrx.Изтрий и всякакви xorg.conf > /etc/X11 и в /home/юзър (ako Има)
Първо пробваш това:
sudo aticonfig --list-adapters
и виж как ти засича адаптерите.
След което пробвай с:
sudo aticonfig --adapter=0,1 --initial  *където 0 и 1 сменяш с твоите показатели.
После отваряш Catalyst-a и настройваш оттам коя карта да е активна по "default"

 [_]3
« Последна редакция: Mar 31, 2012, 21:23 от kalinik »
Активен

georgi950

  • Напреднали
  • *****
  • Публикации: 19
    • Профил
Направих това, което  ми каза, но пак картата не работи както трябва
sudo aticonfig --list-adapters връща това:
 $ sudo aticonfig --list-adapters
* 0. 02:00.0 ATI Mobility Radeon HD 4650

* - Default adapter

а параментрите на картата изобщо не са каквито казва минт:

sudo lshw -C video
  *-display               
       description: VGA compatible controller
       product: M96 [Mobility Radeon HD 4650]
       vendor: ATI Technologies Inc
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=fglrx_pci latency=0
       resources: irq:45 memory:c0000000-cfffffff ioport:e000(size=256) memory:fea20000-fea2ffff memory:fea00000-fea1ffff

а ето какво пише в контрол центъра:
http://wstaw.org/m/2012/04/01/Screenshot_at_2012-04-01_005814_png_750x750_q85.jpg

модела на картата е един и същ (грешката е моя, че казах, че ускорителя на 550v e hd4850....hd4650 e), но параметрите са различни.
Активен

bvbfan

  • Напреднали
  • *****
  • Публикации: 1056
  • Distribution: KaOS
  • Window Manager: Plasma 5
    • Профил
В крайна сметка, видео картата е една 4650 има и 1GB ram и как няма да са верни показанията. Не ги сравнявай с контролният център, там са работна честота и ширина на честотната лента, докато с 
Цитат
sudo lshw -C video
виждаш честота и ширината на шината и като гледам стойностите са реални. Виждам, че си сложил най-новият драйвер, някакви други проблеми има ли ?
Активен

georgi950

  • Напреднали
  • *****
  • Публикации: 19
    • Профил
Няма други проблеми. Просто sudo lshw -C video като показваше, че паметта е 256мб и мислех, че нещо не е наред.
 Благодаря за вниманието!
Активен