Автор Тема: проблем с Nvidia driver-а  (Прочетена 2784 пъти)

vitoorianoo

  • Участник
  • *****
  • Публикации: 12
    • Профил
проблем с Nvidia driver-а
« -: Jan 30, 2012, 18:02 »
Значи проблема е следния!!!...Със Убунту 11.10 съм картата ми е Nvidia Geforce`GT 520mx
Вчера свалих от Nvidia драйвера който мисля че е за мойта карта - NVIDIA-Linux-x86_64-290.10.run ,опитах  се да го инсталирам (незнам дали успях) и имам иконата на NVIDIA - като влезна обаче да си настроя сетингс в нея ми излиза надписа : you do not apear to be using nvidia X driver.Please EDIT YOUR x CONFIGURATION FAIL  (just run `nvidia-xconfig` as root),and restart the X server! Тва ми излиза като съобщение и всичко е празно нямам никакви настройки!!?Понеже съм малко бос бихте ли ми помогнали !!!От вчера чета ма немога да се ориентирам по този проблем
« Последна редакция: Jan 30, 2012, 18:05 от vitoorianoo »
Активен

stan_25

  • Участник
  • *****
  • Публикации: 66
    • Профил
Re: проблем с Nvidia driver-а
« Отговор #1 -: Jan 30, 2012, 19:45 »
you do not apear to be using nvidia X driver.Please EDIT YOUR x CONFIGURATION FAIL (just run `nvidia-xconfig` as root),and restart the X server!

Отваряш терминал и изпълняваш като супер потребител nvidia-xconfig. В убунту става така:

Код:
sudo nvidia-xconfig

И рестартираш компютъра

PS: И следващия път се опитай да прочетеш съобщението за грешка и да го осмислиш. Ще забележиш, че доста често и решението на проблема е написано там ;)
« Последна редакция: Jan 30, 2012, 20:22 от stan_25 »
Активен

vitoorianoo

  • Участник
  • *****
  • Публикации: 12
    • Профил
Re: проблем с Nvidia driver-а
« Отговор #2 -: Jan 30, 2012, 20:33 »
WARNING: Unable to locate/open X configuration file.

New X configuration file written to '/etc/X11/xorg.conf'
 
Тва ми написа след като го изпълних!?
Активен

stan_25

  • Участник
  • *****
  • Публикации: 66
    • Профил
Re: проблем с Nvidia driver-а
« Отговор #3 -: Jan 30, 2012, 20:52 »
WARNING: Unable to locate/open X configuration file.

New X configuration file written to '/etc/X11/xorg.conf'

Нормално е. Прости ти изписва, че не си имал файла /etc/X11/xorg.conf, след което е бил създаен такъв. Вече не би трябвало да имаш първоначалния проблем, естествено след рестарт на машината.

За в бъдеще просто информативно: Следи си внимателно ъпдейтите на системата. В момента в който ъпдейтеш ядрото на линукс ще се наложи да преинсталираш ръчно видео драйвера защото си го дръпнал от сайта на Нвидиа. Ако го беше инсталирал през Hardware Drivers това нямаше да се налага. Също надали щеше да имаш този проблем ;)
« Последна редакция: Jan 30, 2012, 20:54 от stan_25 »
Активен

stan_25

  • Участник
  • *****
  • Публикации: 66
    • Профил
Re: проблем с Nvidia driver-а
« Отговор #4 -: Jan 30, 2012, 22:30 »
За кирилицата - форума си има вградена ползвай нея - бутона "Клавиатура"



Ок. Дейнсталирал си драйвера свален от сайта на Nvida. Обаче не си изтрил файла /etc/X11/xorg.conf, където е указано да ползваш несъществуващ драйвер и от там проблема.

Логваш се в текстови режим и изтриваш файла за да се върнеш в изходно положение

Код:
sudo rm /etc/X11/xorg.conf

Това ще позволи на системата да зареди друг модул при кото да имаш някаква графична среда.

след което пробваш да стартираш графичната среда

Код:
sudo service lightdm

или ако ти е по лесно рестартираш целия компютър

Код:
sudo reboot

После пробвай отначало
Активен

vitoorianoo

  • Участник
  • *****
  • Публикации: 12
    • Профил
Re: проблем с Nvidia driver-а
« Отговор #5 -: Jun 13, 2012, 03:24 »
Значи разбрах проблема какъв е!!!!!Просто картата ми е от типа Optimus и фактически няма как да проработят при мене драйверите!!!
Активен

v_badev

  • Участник
  • *****
  • Публикации: 1355
    • Профил
Re: проблем с Nvidia driver-а
« Отговор #6 -: Jun 13, 2012, 09:32 »
Всъщност може да ползваш и драйвера на NVidia. За целта трябва да си инсталираш Bumblebee и да настроиш системата, както е описано тук.
Активен

gryzli

  • Участник
  • *****
  • Публикации: 2
    • Профил
Re: проблем с Nvidia driver-а
« Отговор #7 -: Jul 28, 2012, 14:51 »
Значи разбрах проблема какъв е!!!!!Просто картата ми е от типа Optimus и фактически няма как да проработят при мене драйверите!!!

Няма проблем да ползваш драйверите на Nvidia при положение, че картата ти е Optimus. Аз лично имах проблеми с подкарването на нещата използвайки Bumblebee, което е цитирал v_badev .

Това, което аз направих бе следното:
- От BIOS-а забраних ползването на Optimus-а, като указах ръчно да се ползва само Nvidii-ската карта : при мен опцията е: "Descrete graphics"
- Инсталирах драйвера на nvidia от сайта им (този който си посочил)  и всичко работеше окей

След инсталацията на драйвера е желателно да провериш дали ползваш ново инсталирания или този с който идва дистрото (nouveau). За целта може да пробваш следната команда:
lspci -vmk | grep -A 8 -B2 VGA 

Ако си с nvidii-ския драйвер, трябва да има нещо от сорта на: Driver: nvidia


Активен