Автор Тема: Проблем с драйвер за видеокатра ATI Radeon 9600 pro  (Прочетена 1428 пъти)

Boni_BG

  • Участник
  • *****
  • Публикации: 14
    • Профил
Здравейте,

имам сериозни проблеми с драйдера на горепосочената карта.Доста се занимавах и четох, накрая стигнах до този форум

http://forums.linuxmint.com/viewtopic.php?f=141&t=57678#p329948

 

където ме съветват това:

Try installing the glx libs:

- libgl1-mesa-dri
- libgl1-mesa-glx
- libglu1-mesa
- mesa-utils

 

проблема е , че не ми е ясно точно какво означава това.Това което също съветват е да не се качва този драйвер:

http://support.amd.com/us/gpudownload/linux/Legacy/Pages/radeon_linux.aspx

 

досега съм качил показаното на снимката:

http://alfa.kachi-snimka.info/viewer.php?id=bfi1358796392q.png

 

проблема ми е, че нямам никаква идея как да се справя.

п.п

Операционната система е Linux Mint Maya, Gnome 2

Накратко, има ли проверен работещ вариант на драйвер за тази карта.Ако нещо не е качено, посъветвайте ме какво?С така качения по подразбиране драйвер сега, се получават следните артефакти на случаен принцип при първоначално зареждане на системата.

http://alfa.kachi-snimka.info/viewer.php?id=cqs1358796531k.png
 

Благодаря
« Последна редакция: Jan 21, 2013, 21:33 от Boni_BG »
Активен

petar258

  • Участник
  • *****
  • Публикации: 339
  • Distribution: Ubuntu-mate 16.04, Windows 7
    • Профил
Възможно е линукса да разпознава грешно чипа или някои параметри на видеокартата. Имах подобен проблем преди години с карта на ати и ръчно задавах чипа в xorg.conf. Помня че сравнявах какво пише в данните за адаптера на видеото на уиндоуса и логовете на X-а в линукса. Не помня точно какъв беше конфигурационния ред, но ако се разровиш в документацията за конфига ще намериш нужното.
« Последна редакция: Jan 22, 2013, 13:55 от petar258 »
Активен

bop_bop_mara

  • Участник
  • *****
  • Публикации: 2433
  • Distribution: Debian Testing
  • Window Manager: LXDE
  • Cute and cuddly
    • Профил
Не разбрах, сложил си въпросните 4 пакета (libgl1-mesa-dri, libgl1-mesa-glx, libglu1-mesa, mesa-utils) и нещата не работят или искаш помощ как да ги сложиш?

Иначе, съветът да не инсталираш драйвъра от сайта на amd е много правилен. AMD поддържат драйвъри само за най-новите си модели, за по-старите се препоръчват отворените драйвъри, които ти се инсталират автоматично на системата.
Активен

Boni_BG

  • Участник
  • *****
  • Публикации: 14
    • Профил
Здравейте,
проблема ми е , че не смея и не знам как да ги сложа.Ще съм благодарна да помогнете!Но, по важният за мен въпрос си остава:С какво ще помогнат тези пакети, и въобще дали е нужно да се слагат?
Прощавайте, аз съм начинаеща сега се уча, но се сблъсках с този нерешим за мен проблем, който се получава и на случаен принцип?Интересно, че после като отворя браузер и след това го затворя, тези артефакти изчезват?

Благодаря предварително

п.п
Другия вариант е да си карам така
Активен

dejuren

  • Участник
  • *****
  • Публикации: 1025
  • Distribution: Ubuntu, RedHat
  • Window Manager: lxde KDE4
    • Профил
Варианта който препоръчвам е да смениш твоята карта с някой съгласен, който има Nvidia. Те също са зле с линух поддръжката, но поне не толкова. А инсталацията може да направиш през synaptic или от команден ред:
Код:
sudo apt-get install libgl1-mesa-dri libgl1-mesa-glx libglu1-mesa mesa-utils
Активен

http://webchat.freenode.net/?channels=ubuntu-bg
The quieter you become, the more you are able to hear.
Две седмици цъкане с мишката спестяват два часа четене на документацията.

NorthBridge

  • Участник
  • *****
  • Публикации: 177
  • Distribution: Slackware-current
  • Window Manager: Enlightenment E17
  • Mad Tinkerer
    • Профил
Варианта който препоръчвам е да смениш твоята карта с някой съгласен, който има Nvidia. Те също са зле с линух поддръжката, но поне не толкова. А инсталацията може да направиш през synaptic или от команден ред:
Код:
sudo apt-get install libgl1-mesa-dri libgl1-mesa-glx libglu1-mesa mesa-utils

Тука не съм съгласен. ATI напоследък взеха да мислят доста повече за драйверите си, и повечето от новите им карти се държат много по-добре в сравнение с еквивалентните на Nvidia. Колкото до старите карти, отворените драйвери имат кажи-речи пълна поддръжка до r200, и почти толкова пълна до r500.

Апропо:
От снимката виждам драйвер който е за ATI Rage 128, а не за Radeon 9800. Деинсталирай xserver-xorg-video-r128 и xserver-xorg-video-r128-dbg, те поне със сигурност не ти трябват и е възможно да правят конфликт с xserver-xorg-video-radeon, който е драйвер за всички видео карти. Ако не се разреши проблема, инсталирай xserver-xorg-video-r300 и тествай пак.

Освен това напиши в конзола това:
Код:
uname -r
...и копирай резултата тук, защото е възможно ако е старо ядро, да прави проблем с antialiasing-a и оттам да идват артефактите.
Активен

I did a 'zcat vmlinuz > /dev/audio' and I think I heard God...

dejuren

  • Участник
  • *****
  • Публикации: 1025
  • Distribution: Ubuntu, RedHat
  • Window Manager: lxde KDE4
    • Профил
/офф
Тука не съм съгласен. ATI напоследък взеха да мислят доста повече за драйверите си, и повечето от новите им карти се държат много по-добре в сравнение с еквивалентните на Nvidia. Колкото до старите карти, отворените драйвери имат кажи-речи пълна поддръжка до r200, и почти толкова пълна до r500.
Радвам се да го чуя! Повече нови драйвери, хубави и все по-хубави!
Активен

http://webchat.freenode.net/?channels=ubuntu-bg
The quieter you become, the more you are able to hear.
Две седмици цъкане с мишката спестяват два часа четене на документацията.

Boni_BG

  • Участник
  • *****
  • Публикации: 14
    • Профил
Здравейте,
след изпълнение на "uname -r", резултата е следния:3.2.0-23-generic
Активен

Boni_BG

  • Участник
  • *****
  • Публикации: 14
    • Профил
При деинсталирането на пакета xserver-xorg-video-r128
се деинсталират и
xserver-xorg-video-all
xserver-xorg-video-ati
и не посмях!Проблема ми е, че имам доста неяснотии околу тези пакети.

Пакета "xserver-xorg-video-r128-dbg" си е дифолтно не качен.

Такъв пакет xserver-xorg-video-r300
при мен не съществува?
Всичко останало съм го направилa, но резултат няма.Луда работа.Явно нещата ще останат така, до кога не знам!Както и да е.

Благодаря за помощта
« Последна редакция: Jan 24, 2013, 13:18 от Boni_BG »
Активен