Автор Тема: Подкарване на LFE под Ubuntu 13.04 64-бит  (Прочетена 1683 пъти)

WindRider

  • Участници
  • ***
  • Публикации: 4
    • Профил
Здравейте!

Имам X-Fi XtremeMusic - звука ми работи, но не и субууфъра. Пробвах всички възможни туториали и съвети в нета за пускане на 5.1 звук с PulseAudio, но няма и няма. Нищо не действа при мен. Някакъв съвет какво да опитам?

Като за начало ето ми /etc/pulse/daemon.conf:

Код:
; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

; high-priority = yes
; nice-level = -11

; realtime-scheduling = yes
; realtime-priority = 5

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

resample-method = speex-float-3
enable-remixing = yes
enable-lfe-remixing = yes

flat-volumes = no

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 1000000

; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
default-sample-channels = 6
default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe

default-fragments = 8
default-fragment-size-msec = 10

; enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 1
; deferred-volume-extra-delay-usec = 0
Активен

Odido

  • Напреднали
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Подкарване на LFE под Ubuntu 13.04 64-бит
« Отговор #1 -: Sep 09, 2013, 00:43 »
"default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe"  смени реда на "channel-map = front-left,front-right,rear-left,rear-right,lfe,front-center"  ,има вероятност да ти е разменен съраунда със субуфера...
Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"

kalinik

  • Напреднали
  • *****
  • Публикации: 539
  • Distribution: LMDE x64 2012/ LM 14 x64
  • Window Manager: Mate / KDE
  • ID user #521433
    • Профил
Re: Подкарване на LFE под Ubuntu 13.04 64-бит
« Отговор #2 -: Sep 09, 2013, 02:01 »
1. alsamixer в терминала
вдигни си нивата на всички канали на картата (избира се с F6, ако са 2 или повече аудио карти)
2. инсталирай си pavucontrol и оттам също разгледай и нагласи каналите.
3. restart на pulseaudio или на компютъра

Със стари ядра (< 2.9.0) преди години имах същия проблем с Audigy 2 ZX , но този проблем мисля го оправиха. За X-FI не вярвам да е нещо по-различно, но явно каналните подредби са проблемни, както спомена ApucTokpaT

Успех !
Активен

WindRider

  • Участници
  • ***
  • Публикации: 4
    • Профил
Re: Подкарване на LFE под Ubuntu 13.04 64-бит
« Отговор #3 -: Sep 09, 2013, 11:35 »
Пусках тестовете на каналите, но няма и център (размених временно кабелите за проба), по всяка вероятност и задни няма (нямам закачени колони). В alsamixer също всичко е включено на макс. Рестартирал съм сто пъти. Ето още малко информация...

Ред. Задни има, сега пробвах с размяна на кабелите!

Ubuntu 13.04 64-bit
X-Fi XtremeMusic (20K1 chip)

/etc/pulse/daemon.conf:
http://pastebin.com/JDJvC3hm

pacmd list-sinks
http://pastebin.com/DjnjM2EW

/etc/pulse/default.pa
http://pastebin.com/G6k1JVsg

alsamixer
http://i.imgur.com/Tm3dj6B.png

Само още не съм пробвал преинсталиране на pulseaudio, че ubuntu-desktop зависи от него. Да не се срине системата, че ми е работен компютър и ме е страх да експериментирам на воля. Също не съм пробвал с друг драйвер за Creative, но не съм запознат какъв и как и дали изобщо има.
« Последна редакция: Sep 09, 2013, 11:41 от WindRider »
Активен

kalinik

  • Напреднали
  • *****
  • Публикации: 539
  • Distribution: LMDE x64 2012/ LM 14 x64
  • Window Manager: Mate / KDE
  • ID user #521433
    • Профил
Re: Подкарване на LFE под Ubuntu 13.04 64-бит
« Отговор #4 -: Sep 09, 2013, 12:25 »
Странна работа  ???
Аз проблеми имам само при Windows, тъй като не може да се подкара заден център (6.1 канали) , но при linux всичко е ОК.
Освен да пробваш като конфигурация 7.1 и да напасваш каналите ... друго не знам какво да се пипне. А преинсталация на pulseaudio не е фатална, дори и да го махнеш  - няма проблем, но пък звука е кофти без него (специално за Creative)
Активен

WindRider

  • Участници
  • ***
  • Публикации: 4
    • Профил
Re: Подкарване на LFE под Ubuntu 13.04 64-бит
« Отговор #5 -: Sep 09, 2013, 14:21 »
Пробвах и pavucontrol, всичко си изглежда наред. Пробвах и 7.1 и други варианти, не става. Общо взето, всичко на високо ниво изглежда абсолютно точно и нищо съмнително не виждам, но звук няма. Та затова имам чувството, че нещо има омазано на ниво драйвер. Ползвам някакъв официален наречен "XFiDrv_Linux_Public_US_1.00". Тия Креатив толкова съм ги псувал, то няма такава противна фирма и враждебна към Линукс! Не съм много запознат ама май има различни разновидности на драйвера. Ти кой точно драйвер ползваш?

П.С.

Чудих се ей това http://manpages.ubuntu.com/manpages/oneiric/man7/oss_sbxfi.7.html
дали не е различно?
« Последна редакция: Sep 09, 2013, 14:23 от WindRider »
Активен

bvbfan

  • Напреднали
  • *****
  • Публикации: 1056
  • Distribution: KaOS
  • Window Manager: Plasma 5
    • Профил
Re: Подкарване на LFE под Ubuntu 13.04 64-бит
« Отговор #6 -: Sep 09, 2013, 17:27 »
Аз не съм тествал, нямам хардуера, но видях, че има по-нова верия бета се води XFiDrv_Linux_US-1.18-> ftp://ftp.sun.ac.za/pub/iso-images/sabayon/distfiles/media-sound/XFiDrv_Linux_US-1.18.tar.gz
Активен

WindRider

  • Участници
  • ***
  • Публикации: 4
    • Профил
Re: Подкарване на LFE под Ubuntu 13.04 64-бит
« Отговор #7 -: Sep 09, 2013, 21:10 »
Гледам тоя драйвер има много повече файлове и по-големи. Би трябвало да е верния избор. Пробвам да го инсталирм по инструкциите, обаче иска пълно конфигурирано за компилация ядро. Имам хедърите на ядрото обаче не намира някакви файлове version.h и autoconf.h. Пренасочвам ги с ln, обаче после друга грешка дава. Май ще го зарежа временно, че ми втръсна. Благодаря за помощта!
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
apt-get на Ubuntu?
Настройка на програми
Lamer 8 5137 Последна публикация May 29, 2009, 22:35
от go_fire
Раздавам Дискове на UBUNTU
Живота, вселената и някакви други глупости
IvanST 31 7503 Последна публикация Jan 25, 2005, 16:16
от Joro
Ubuntu live to ubuntu alternate?
Настройка на програми
Whisper 3 5178 Последна публикация Aug 30, 2007, 12:56
от bnight
Продавам Ubuntu Desktop 9.04:Kubuntu Desktop 9.04:Ubuntu Server 9.04 x64
Кошче
anakinchoo 34 14867 Последна публикация Jun 04, 2010, 16:32
от ROKO__
Ubuntu + Ubuntu Studio
Настройка на програми
H0lyGanGs7eR 5 5278 Последна публикация Feb 27, 2010, 13:20
от bazu