Автор Тема: Проблем с Ubuntu Mate  (Прочетена 4196 пъти)

Guliver

  • Участник
  • *****
  • Публикации: 8
    • Профил
Проблем с Ubuntu Mate
« -: Apr 29, 2015, 17:22 »
Здравейте на всички !!! Давам направо и цитирам по памет,защото компютъра не е пред мен в момента.Имам инсталиран Ubuntu Mate,но проблема е че при стартиране ми изписва следното: ACPI PACKAGE HAS ZERO ELEMENT и после в скоби някакви числа.В повечето случай стартирането продължава нормално,но понякога забива и се налага рестарт на системата.Според Гугъл това е някакъв бъг,но искам да се консултирам с Вас какво трябва да направя за да стартира нормално,без да ми се показва това съобщение.Предварително Ви благодаря за оказаното съдействие и Ви желая усмихнат ден на всички !!!
Активен

Odido

  • Участник
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #1 -: Apr 29, 2015, 17:50 »
hmm,може да е бъг ,може и да не е.Колегите от фоума на gentoo казват ,че това се получава при компилация на ядро или флага е:
Код
GeSHi (Bash):
  1. CONFIG_SATA_AHCI=m
вместо
Код
GeSHi (Bash):
  1. CONFIG_SATA_AHCI=y
,което предизвиква проблема...Ама пък не вярвам да си със собствено компилирано ядро...
П.П.Всъщност решението е тук https://forums.gentoo.org/viewtopic-t-933012-start-0.html ,но не виждам как начинаещ ще се оправи с него...
« Последна редакция: Apr 29, 2015, 17:54 от Odido »
Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"

4096bits

  • Участник
  • *****
  • Публикации: 3238
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #2 -: Apr 29, 2015, 18:30 »
А инсталиране на ново ядро няма ли да реши проблема? Например 3.16 или 3.18
Можеш ли да дадеш изхода от
uname -r
Активен

As they say in Mexico, "Dasvidaniya!" Down there, that's two vidaniyas.

Guliver

  • Участник
  • *****
  • Публикации: 8
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #3 -: Apr 30, 2015, 05:13 »
На компютъра имам инсталирани две операционни системи,съответно xpsp3 и Линукс mate 14.04.2 LTS Desktop amd 64 (swap).Като конфигурацията е следната :

Видео карта Nvidia GeForce 6150SE nForce 430 2.1.2 Nvidia 304.125

Рам 3гб

Процесор AMD Sempron le - 1250 2.22 Гхц

HDD 500 гб

Изхода от ~$ sudo uname -r : 3.16.0-36-generic

Въпроса ми е при инсталиране на ново ядро ще трябва ли преди това да направя backup,защото тъкмо си подредих къщичката и не ми се иска да почвам пак от начало.Това което остана като проблем е единствено това за което търся помощ,иначе всичко друго е наред и нямам забележки,доволен съм от това дистро на което се спрях след доста проби и смени.Като за начинаещ е добре.Питам Ви защото не се стърпях и направих следното:

$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb

$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb

$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-image-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb

$ sudo dpkg -i linux-headers-4.0.0*.deb linux-image-4.0.0*.deb

sudo reboot

Резултатът...  :D След първия рестарт проблема с ACPI го нямаше и много се зарадвах,но след още един рестарт Grub така и не се показа и ми изписа някаква грешка.Айде пак от начало за n-ти пореден път.Този път не искам да минавам през това и искам да се презастраховам доколкото е възможно  :) Новобранска ми работа,но какво да се прави все от някъде трябва да се започне.Постъпено изоставих XP и се пристрастих към Линукс.Удоволствието когато успея да направя нещо сам е несравнимо,което разбира се е свързано с много грешки и главоболия  :D Но Вие разбирате какво имам предвид !!!




Активен

Odido

  • Участник
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #4 -: Apr 30, 2015, 05:44 »
Код
GeSHi (Bash):
  1. sudo update-grub
Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"

Guliver

  • Участник
  • *****
  • Публикации: 8
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #5 -: Apr 30, 2015, 16:54 »
Код
GeSHi (Bash):
  1. sudo update-grub

Извинявам се, но не разбирам кога трябва да изпълня обновяването на Grub след като задам горните команди за ъпдейт на kernel, или самостоятелно и това ли е причината да не се зареди Grub,че не е обновен след обновяването до kernel 4.0 ?
Самостоятелното изпълнение на sudo update-grub по никакъв начин не променя нещата.Поздрави !!!
Активен

Odido

  • Участник
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #6 -: May 01, 2015, 05:36 »
Код
GeSHi (Bash):
  1. sudo update-grub

Извинявам се, но не разбирам кога трябва да изпълня обновяването на Grub след като задам горните команди за ъпдейт на kernel, или самостоятелно и това ли е причината да не се зареди Grub,че не е обновен след обновяването до kernel 4.0 ?
Самостоятелното изпълнение на sudo update-grub по никакъв начин не променя нещата.Поздрави !!!
дай изхода от командата да го видим.Или просто пусни някои от клиповете в тубата за рекавъри -например това: https://www.youtube.com/watch?v=gl8mfpZuDiM
« Последна редакция: May 01, 2015, 05:40 от Odido »
Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"

Guliver

  • Участник
  • *****
  • Публикации: 8
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #7 -: May 01, 2015, 10:51 »
Изхода от :~$ sudo update-grub :

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.16.0-36-generic
Found initrd image: /boot/initrd.img-3.16.0-36-generic
Found linux image: /boot/vmlinuz-3.16.0-34-generic
Found initrd image: /boot/initrd.img-3.16.0-34-generic
Found linux image: /boot/vmlinuz-3.16.0-33-generic
Found initrd image: /boot/initrd.img-3.16.0-33-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found Microsoft Windows XP Professional on /dev/sda1
done

А сега на къде ?!!  :)
Активен

Odido

  • Участник
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #8 -: May 01, 2015, 12:29 »
Сега рестартираш и си проверяваш дали всичко е наред.Ако имаш късмет ще имаш боза ,ако нямаш ,ще заскусваш само с баничка...
Пиши пак ,ако няма промяна.
Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"

Guliver

  • Участник
  • *****
  • Публикации: 8
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #9 -: May 01, 2015, 13:17 »
Няма промяна приятелю...гледам много клипове в тубата за ъпдейт на kernel,но не знам до колко са ефективни пък и не искам всичко да се омаже за пореден път,ако опита се окаже неуспешен.Защо опита ми за обновяване до kernel 4.0 се оказа неупешен след като изпълних всички стъпки ? Ядрото не е компилирано ли,къде греша ? :) Иначе при инсталиране на нова kernel версия съобщението за ACPI грешка изчезва и всичко е наред  :)
« Последна редакция: May 01, 2015, 13:20 от Guliver »
Активен

Odido

  • Участник
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #10 -: May 01, 2015, 14:54 »
Сега като се загледах няма и да има.Кернел 4.0 Дето си го сложил го няма в листата която си постнал след ъпдейт на grub.Не си направил както трябва нещо.Като се прибера ще погледна по обстойнотемата че пиша от телефон.
Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"

Guliver

  • Участник
  • *****
  • Публикации: 8
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #11 -: May 01, 2015, 15:18 »
Благодаря ти !!! :)
Активен

Odido

  • Участник
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #12 -: May 01, 2015, 16:44 »
Я да пробваме пак.Ще трябва изхода и от командата
Код
GeSHi (Bash):
  1. fdisk -l
За да разберем лоъдъра къде е инсталиран и защо не вижда кърнъла който ползваш. Целта на занятието е да се види ,кой е /boot партишъна (би трябвало уж да е само един) и постни резултата.Въз основа на това ,което върне ще конфигурираме grub.

Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"

Guliver

  • Участник
  • *****
  • Публикации: 8
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #13 -: May 01, 2015, 17:33 »
:~$ sudo fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x000b8403

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   292968812   146484375    7  HPFS/NTFS/exFAT
Partition 1 does not start on physical sector boundary.
/dev/sda2       292970494   976773081   341901294    5  Extended
Partition 2 does not start on physical sector boundary.
/dev/sda5       970616832   976773081     3078125   82  Linux swap / Solaris
/dev/sda6       292970496   970616831   338823168   83  Linux

Изхода от :~$ sudo update-grub :

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.16.0-36-generic
Found initrd image: /boot/initrd.img-3.16.0-36-generic
Found linux image: /boot/vmlinuz-3.16.0-34-generic
Found initrd image: /boot/initrd.img-3.16.0-34-generic
Found linux image: /boot/vmlinuz-3.16.0-33-generic
Found initrd image: /boot/initrd.img-3.16.0-33-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found Microsoft Windows XP Professional on /dev/sda1
done

« Последна редакция: May 01, 2015, 18:54 от Guliver »
Активен

Odido

  • Участник
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Проблем с Ubuntu Mate
« Отговор #14 -: May 01, 2015, 19:18 »
Код
GeSHi (Bash):
  1.  
  2. sudo grub-install --recheck /dev/sdа
  3. sudo update-grub
  4. reboot

Другия вариант е да се сложи линк в конфигурационния файл на grub към къстъм ядрото,която опция не съм пробвал никога... Надявам се, че вече ще проработи ,от 4 години не съм барал убунту.
« Последна редакция: May 01, 2015, 19:20 от Odido »
Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"