Автор Тема: Проблем с инсталирането на linux-headers  (Прочетена 1215 пъти)

MRadev751

  • Напреднали
  • *****
  • Публикации: 72
    • Профил
Това е проблема
root@kali:~# apt-get install linux-headers-$(uname -r) -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-headers-4.12.0-kali1-amd64
E: Couldn't find any package by glob 'linux-headers-4.12.0-kali1-amd64'
E: Couldn't find any package by regex 'linux-headers-4.12.0-kali1-amd64'

Само да добавя
изпълнени са командите apt update && apt-get -y dist-upgrade
всичко е обновено и надградено но проблема остава. Защо.
Активен

4096bits

  • Напреднали
  • *****
  • Публикации: 3447
    • Профил
Re: Проблем с инсталирането на linux-headers
« Отговор #1 -: Oct 29, 2017, 14:24 »
След като напишеш apt-get install linux-headers- натисни TAB и виж какво ще ти изкара. Така можеш да видиш, как точно са имената на пакетите.
Активен

As they say in Mexico, "Dasvidaniya!" Down there, that's two vidaniyas.

nslave

  • Напреднали
  • *****
  • Публикации: 101
  • Distribution: Fedora / Debian
  • Window Manager: Xfce
    • Профил
Re: Проблем с инсталирането на linux-headers
« Отговор #2 -: Oct 29, 2017, 16:35 »
Мисля, че ми се е случвало нещо такова, когато съм обновил kernel-а, но не съм рестартирал за да заработи системата с него :) Та... опитай да рестартираш :D
Активен

cybercop

  • Напреднали
  • *****
  • Публикации: 5571
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Проблем с инсталирането на linux-headers
« Отговор #3 -: Oct 29, 2017, 19:36 »
Много ли ще ти навреди на имиджа в хакерските среди, ако ползваш търсачката на Synaptic и инсталираш linux-headers-xxx и съответното ядро към него от там ?
В основното хранилище (main) на Buster има чудесно 3.13 ядро. Достатъчно е да инсталираш linux-headers-amd64 и linux-image-amd64 и ще имаш поддържано ядро от базовата дистрибуция.

Само да добавя
изпълнени са командите apt update && apt-get -y dist-upgrade
всичко е обновено и надградено но проблема остава. Защо.
Ако решиш да ползваш само вторичния инструмент APT, ще си спестиш още една думичка в командата.
su
apt update
apt full-upgrade

А, ако премахнеш предварителното одобрение на нещо, което не знаеш, какво съдържа ще постъпиш наистина хакерски.
Това -y е еквивалентно на подписване на празен лист. Първо погледни списъка с обновленията и тогава натисни "y". Дори ще спестиш едно тиренце.
« Последна редакция: Oct 29, 2017, 19:52 от cybercop »
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png