Автор Тема: Нещо не ми се получаава  (Прочетена 2343 пъти)

michael1960

  • Участник
  • *****
  • Публикации: 70
  • Distribution: Slackware 14.1
  • Window Manager: MATE Desktop Environment
    • Профил
    • WWW
Нещо не ми се получаава
« -: Авг 28, 2018, 10:37 »
Опитвам се да присадя mate 1.16 - 1.18, към Slackware 14.2, всичко описано по - долу правя вырху "чиста система".

Нещата се иснсталират нормално но при положение че сложа драйвер NVIDIA-linux-x86-340.104, изчезват двата панела и отгоре и отдолу, и съответно, няма никакъв начин да влезна в настройките, интересното е че ако не слагам посочения драйвер, а оставя стандартния nouveau, нещата са наред, с изключение на това че графичната среда работи като слон
Активен

Михаил Петров - град Смолян, България

Naka

  • Участник
  • *****
  • Публикации: 2641
    • Профил
Re: Нещо не ми се получаава
« Отговор #1 -: Авг 28, 2018, 11:03 »
Коя е точно nvidia-та?

Не знам какъв е проблема с твоето дистро...Но готовият бинарен драйвер 340.104, който имаш ако не става може спокойно да си го свалиш последният от nvidia и да го прекомилираш. Само един скрип е и много лесно.

Вчера слагах последният драйвер  390.77 от сайта на nvidia и всичко мина изключително успешно...Просто съм очарован. Изкомилира се правилно.....инсталира се.
За да го сложиш оттам ти трябват dev пакетите на кърнела и вероятно още някои неща...но то ще се оплаче. Изобщо няма много депенданси и са изключително ниски версии.

-----------------
PS: даже може да си направиш пакет без да го инсталираш, за да провериш дали ще мине правилно компилацията и да си по-спокоен да не развалиш нещо.

./NVIDIA-Linux-x86-390.77.run --add-this-kernel

това само ще го комилира, ако мине успешно ще разпакетира *.run пакета и ще го добави готовият драйвер вътре и пак ще го пакетира.

а след това само.
./NVIDIA-Linux-x86-390.77.run
« Последна редакция: Авг 28, 2018, 11:37 от Naka »
Активен

Perl - the only language that looks the same before and after encryption.

michael1960

  • Участник
  • *****
  • Публикации: 70
  • Distribution: Slackware 14.1
  • Window Manager: MATE Desktop Environment
    • Профил
    • WWW
Re: Нещо не ми се получаава
« Отговор #2 -: Авг 28, 2018, 11:10 »
Платката ми е NVIDIA GeForce 9500 GT, и драйвера ми се инсталира нормално и си работи, единственният проблем е че след като инсталирам MATE 1.16 или 1.18, при инсталиран драйвер не се показват панелите на MATE
Активен

Михаил Петров - град Смолян, България

Naka

  • Участник
  • *****
  • Публикации: 2641
    • Профил
Re: Нещо не ми се получаава
« Отговор #3 -: Авг 28, 2018, 11:19 »
Платката ми е NVIDIA GeForce 9500 GT, и драйвера ми се инсталира нормално и си работи, единственният проблем е че след като инсталирам MATE 1.16 или 1.18, при инсталиран драйвер не се показват панелите на MATE

Значи пак е драйверен проблем. Но за това 9500 GT би трябвало и този който имаш да е наред.

А при инсталиран драйвер, пробва ли с друг, нов юзер - при него как е?
« Последна редакция: Авг 28, 2018, 11:21 от Naka »
Активен

Perl - the only language that looks the same before and after encryption.

makeme

  • Участник
  • *****
  • Публикации: 682
  • Distribution: Many
  • Window Manager: Mate
    • Профил
Re: Нещо не ми се получаава
« Отговор #4 -: Авг 28, 2018, 11:20 »
Платката ми е NVIDIA GeForce 9500 GT, и драйвера ми се инсталира нормално и си работи, единственният проблем е че след като инсталирам MATE 1.16 или 1.18, при инсталиран драйвер не се показват панелите на MATE
За две неща се сещам в момента.
1. Когато се инсталират драйвери на видеото, понякога се променя dpi и картината се размества. Ако това е станало, пробвай да натиснеш "меню" клавиша, за да разбереш дали менюто не е в небитието.
2. Може и нещо да се е счупило и да се е получил някакъв дефаут на панела. Ако е така, пробвай да натиснеш ALT+F2  и напиши mate-tweak . От "интерфейс" превключи между различните панели и виж дали ще се появи.

пп: Ако нямаш шорткът ALT+F2, пробвай CTRL+ALT+T за терминал и там въведи mate-tweak.
« Последна редакция: Авг 28, 2018, 11:23 от makeme »
Активен

Distributions:  UbuntuMate 14.04; 15.10; 16.04, CentOS 6.x, 7.x, Kali 2.0 ...

remotexx

  • Участник
  • *****
  • Публикации: 788
    • Профил
Re: Нещо не ми се получаава
« Отговор #5 -: Авг 28, 2018, 15:26 »
А пробва ли първо да инсталираш драйвера и после Мате
Активен

michael1960

  • Участник
  • *****
  • Публикации: 70
  • Distribution: Slackware 14.1
  • Window Manager: MATE Desktop Environment
    • Профил
    • WWW
Re: Нещо не ми се получава
« Отговор #6 -: Авг 28, 2018, 16:34 »
Цитат
А пробва ли първо да инсталираш драйвера и после Мате

Пробвах, всякак, и все същата работа, в скоби казано,  с xfce и kde, всичко си е нормално
Активен

Михаил Петров - град Смолян, България

makeme

  • Участник
  • *****
  • Публикации: 682
  • Distribution: Many
  • Window Manager: Mate
    • Профил
Re: Нещо не ми се получава
« Отговор #7 -: Авг 28, 2018, 17:36 »
Цитат
А пробва ли първо да инсталираш драйвера и после Мате

Пробвах, всякак, и все същата работа, в скоби казано,  с xfce и kde, всичко си е нормално
А това, което написах ?

пп: Ако не ти работят никакви шорткъти: дясно копче на десктопа -> create launcher -> на редовете: name и command въведи mate-tweak
« Последна редакция: Авг 28, 2018, 18:01 от makeme »
Активен

Distributions:  UbuntuMate 14.04; 15.10; 16.04, CentOS 6.x, 7.x, Kali 2.0 ...

michael1960

  • Участник
  • *****
  • Публикации: 70
  • Distribution: Slackware 14.1
  • Window Manager: MATE Desktop Environment
    • Профил
    • WWW
Re: Нещо не ми се получаава
« Отговор #8 -: Авг 28, 2018, 19:11 »
Излъгах го, оказа се че секцията screen в xorg.conf, трябва да изглежда така:
Цитат
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP: 1280x1024 +0+0, CRT: 1280x1024 +1280+0"
    SubSection     "Display"
        Depth       24
    EndSubSection

Много съм благодарен на всички за помощта
Активен

Михаил Петров - град Смолян, България

Naka

  • Участник
  • *****
  • Публикации: 2641
    • Профил
Re: Нещо не ми се получаава
« Отговор #9 -: Авг 28, 2018, 19:30 »
А изобщо без xorg.conf как е?
Активен

Perl - the only language that looks the same before and after encryption.

michael1960

  • Участник
  • *****
  • Публикации: 70
  • Distribution: Slackware 14.1
  • Window Manager: MATE Desktop Environment
    • Профил
    • WWW
Re: Нещо не ми се получаава
« Отговор #10 -: Авг 28, 2018, 20:13 »
Цитат
А изобщо без xorg.conf как е?

цык, не мога при това положение да задам HorizDir и VertRefresh, и тогава разрешаващата способност става 800х600, а това не ме устройва

« Последна редакция: Авг 28, 2018, 20:39 от michael1960 »
Активен

Михаил Петров - град Смолян, България

michael1960

  • Участник
  • *****
  • Публикации: 70
  • Distribution: Slackware 14.1
  • Window Manager: MATE Desktop Environment
    • Профил
    • WWW
Re: Нещо не ми се получаава
« Отговор #11 -: Авг 29, 2018, 09:30 »
Цитат
2. Може и нещо да се е счупило и да се е получил някакъв дефаут на панела. Ако е така, пробвай да натиснеш ALT+F2  и напиши mate-tweak . От "интерфейс" превключи между различните панели и виж дали ще се появи.

Това не проработи, не знам защо, mate-tweak, такова нещо при мен няма

Всичко си тръгна като слънце, само трябва ше да добавя в секцията Screen следните редове:

Цитат

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP: 1280x1024 +0+0, CRT: 1280x1024 +1280+0"
    SubSection     "Display"
        Depth       24
        Modes "1280x1024" "1024x768"
        viewPort  0 0
        virtual  1280 1024
    EndSubSection
EndSection

Още веднъж благодаря на всички за помощта
« Последна редакция: Авг 29, 2018, 09:35 от michael1960 »
Активен

Михаил Петров - град Смолян, България