Автор Тема: Как мога да накарам Synaptic да игнорира broken пакет.  (Прочетена 1286 пъти)

Naka

  • Напреднали
  • *****
  • Публикации: 2745
    • Профил
Как мога да накарам Synaptic (дебиан9) да игнорира определени broken пакети и да си продължи да работи все едно нищо няма.

Като пусна Synaptic ми писка, че имам 9 развалени LibreOffice пакета. Проблема, че не са изобщо развалени- знам какво съм правил. Исталирал съм ръчно OpenOffice, и от там идва... Има приплетени док файлове (или линкове), което въобще не ме интерсува - нека си стоят така.   И двата и LibreOfice (системният) и OpenOffice си работят перфектно.


Та това състояние не искам да го закачам. Обаче същистинският проблем е, че заради това, като се опитам да инсталирам нещо например 'php' онова ми писка че требва да премахне LibreOfice. Какво общо има LibreOfice и 'php' . ??? ??? ??? ??
Активен

Perl - the only language that looks the same before and after encryption.

makeme

  • Напреднали
  • *****
  • Публикации: 766
  • Distribution: Many
  • Window Manager: Mate
    • Профил
Нямам Synaptic, но на тази снимка изглежда да има чекче за Broken
https://askubuntu.com/questions/236275/how-do-you-remove-individual-packages-from-the-list-in-synaptic-package-manager
Ако не стане, виж ги тия филтри. При APT има apt-mark.
Активен

Distributions:  UbuntuMate 14.04; 15.10; 16.04, CentOS 6.x, 7.x, Kali 2.0 ...

go_fire

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 5508
  • Distribution: Дебиан Сид
  • Window Manager: ROX-Desktop / е17
  • кашик с гранатомет в танково поделение
    • Профил
    • WWW
Не знам, защо при теб се получава така. Аз също съм си свалил deb-овете от SF и съм си ги инсталирал на ръка върху Аски (което отговаря напълно на 9). Даже и българската локализация съм си сложил. Единственият несъвместим пакет е този за интерграцията с Desktop. Но нея просто не съм я инсталирал. Много важно, че АОО го няма в стартовото меню и контекстните менюта.

В такива случаи съм правил едно от две неща. Първото е да вляза в базата и ръчно да променя състоянието на пакетите като неинсталирани. Така спират да пискат. Другия вариант (ползвам го за ФС на vdi за FUSE) е ръчно да разпакетирам пакетите по местата им. Така не се изпълняват postinstall scripts, ама ако толкова искам, мога и ръчно да ги пусна.
Активен

В $por4e2 e истината  ;)

***

Aко даваха стипендия за най-глупави, щях да съм човека с най-много Mини Kупъри

***

Reborn since 1998 || 15.09.2007 totally М$ free && conscience clear

Naka

  • Напреднали
  • *****
  • Публикации: 2745
    • Профил
Първото е да вляза в базата и ръчно да променя състоянието на пакетите като неинсталирани. Така спират да пискат.

Къде се бара? Търсих търсих по системата и Гого даже питах и нищо не намерих.
« Последна редакция: Jul 04, 2019, 16:32 от Naka »
Активен

Perl - the only language that looks the same before and after encryption.

jet

  • Напреднали
  • *****
  • Публикации: 1887
  • Distribution: debian sid
  • Window Manager: kde
    • Профил
Активен

Linux: From WTF to OMG

Naka

  • Напреднали
  • *****
  • Публикации: 2745
    • Профил
Мерси. Преди рових търсих променях....но не можах да се справя. Може и този файл да съм ровил /var/lib/dpkg/status  ??? Оправих се по дърварският начин като махнах LibreOffice.
Следващият път ще го знам.

При редхат-ските обаче съм мазал, инсталирал....с всякави конфликти и графичният Yumex никога не се оплаквал, ако това което инсталира в момента не го засяга пряко. Оплаквал се е ако има конфликт със самите пакети които инсталира. Тогава ги оправям на ръка с rpm --force или rpm --nodeps..... и след това пак с Yumex.


Ама дебиана е друга бира. Ебати и запека >:( Понеже има проблем някъде на майната си в пакет А.......Не мога да ти инсталирам пакет ЯЯ, (който обаче няма нищо общо с А, нито конфликт с А).

Считам че това е сериозен недостатък на Synaptic. От друга страна пък е много лесно за 'обикновенния' потребител. Никога не му се дава шанс да обърка нещо.



« Последна редакция: Oct 23, 2019, 14:34 от Naka »
Активен

Perl - the only language that looks the same before and after encryption.

go_fire

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 5508
  • Distribution: Дебиан Сид
  • Window Manager: ROX-Desktop / е17
  • кашик с гранатомет в танково поделение
    • Профил
    • WWW
Я, че това хакване много пъти съм го споменавал. Направо е чудно, че си го пропуснал. Многократно съм заменял „install ok installed“ с „deinstall ok config-files“. Но човек наистина трябва да знае. Последно ми се случи при прехода към Джеси. Там имаше един пакет за fuse, който чете vdi (т'ва може и с обикновен инструментариум, ама е голяма врътня). Сочеше, че е в конфликт. Е да, ама не. Изобщо не е. Проверих, какво, къде слага и с нищо не беше в конфликт. А и си работеше после месеци при мен, без никаква грешка.

Но тия неща наистина са опасни. Човек наистина трябва да знае, какво прави. Ще го потретя, ако трябва. Понякога стават грешки на разработчиците, като в моя случай, но не са чак толкова чести.

Аз от преди се чудя, какви са тия проблеми между ЛО и АОО. При мен в конфликт е само пакета за интеграция с менютата. Но може би, защото при мен ЛО не е с българските пакети. Доскоро и правописна проверка нямаше. Сложих я само, защото някакви хора твърдят, че hunspell е по-добре от aspell в Емакс. Ама техните примери са на английски. Нещо не можах да извадя при мен релевантни български примери. Ама все пак го направих. А после май го махнах. Ама пакетите си останаха.

Поне си обяснявам, че само в тези пакети може да има проблем.

Между другото в Шиндош са ми правили по-големи проблеми. На работа бяхме с XP, имахме инсталиран АОО, а аз си бях сложил и портативен ЛО за експерименти. Двете не можеха да работят заедно. А, ако си пускал едното, не може после да пуснеш другото. Причината беше, че се пуска някакво демонче soffice, което седи в паметта. Ако искаш да пуснеш другата програма, трябва да убиеш това демонче. Тогава става възможно дори да са едновременно пуснати. Това в Девуан (преди това и Дебиан) никога не ми се е случвало. Тези демончета ги има и тук, но не си пречат едно на друго. И не съм сигурен дали изобщо са пуснати постоянно. Трябва да проверя в ps auxf|grep.

Малко преди да ме съкратят, ЛО извади шеста версия, която не поддържа XP, в резултат  на което реших да го разкарам. И без това е тежък и муден, а подобренията не са кой знае, какви. Липсваха ми буквално една, две формули.

И съвсем накрая, вчера от АОО отново се похвалиха с някакви стотици хиляди сваляния.
Активен

В $por4e2 e истината  ;)

***

Aко даваха стипендия за най-глупави, щях да съм човека с най-много Mини Kупъри

***

Reborn since 1998 || 15.09.2007 totally М$ free && conscience clear

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
broken pipe?
Настройка на хардуер
worthless 4 1474 Последна публикация Jul 14, 2004, 19:06
от worthless
E:Sorry, broken packages
Настройка на програми
Monty 5 1709 Последна публикация Dec 28, 2004, 09:17
от Monty
Kdebase-dev debian broken!
Настройка на програми
lawlessbg 2 1361 Последна публикация May 14, 2008, 17:50
от lawlessbg
Apt broken package remove
Хардуерни и софтуерни проблеми
Marto 3 1723 Последна публикация Jul 19, 2008, 12:45
от Marto
Безопастно ли е изтриването на broken links?
Настройка на програми
angie_bg 6 1678 Последна публикация Jun 13, 2012, 11:03
от angie_bg