Автор Тема: MAKEDEV<->mknod  (Прочетена 1188 пъти)

nina

  • Напреднали
  • *****
  • Публикации: 17
    • Профил
MAKEDEV<->mknod
« -: Dec 05, 2004, 09:02 »
Здравейте отново!
Налага ми се да ползвам ipnat, но когато се опитам да извикам програмата получавам следния отговор:
Примерен код
Mangau# ipnat -l
/dev/ipnat: open: No such file or directory

Усетих че ми липсва съответното устройство в /dev и като се поинтересувах как мога да си го съдам стигнах до mknod, заместителя на MAKEDEV. Видях зор със стойностите на major i minor бях принудена да намеря конкретен пример на командата mknod за създаване на ipnat устройство. Водейки се от тук се опитах и аз да си направя необходимите устройства и направих следното:
Примерен код
mknod ipl c 59 0
mknod ipfstat c 59 1
mknod ipnat c 59 2

след това ги монтирах с mount_devfs в /dev, но там не се появи нищо и продължих да получавам съобщение че няма такъв файл. Забелязах че не ми позволява да ги създам направо в /dev, за това ги направих първо в /tmp/dev и след това монтирах. В /tmp/dev ги има, но не и в /dev след mount_devfs...явно някъде греша, вижда ли някой къде ?
Активен

  • Гост
MAKEDEV<->mknod
« Отговор #1 -: Dec 07, 2004, 12:51 »
Step 1 - Turn on ipnat at startup :


And add the following to /etc/rc.conf (Some of these already set in /etc/defaults/rc.conf):

gateway_enable="YES"
ipnat_enable="YES"
ipnat_program="/sbin/ipnat"
ipnat_rules="/etc/ipnat.rules"
ipnat_flags=""
ipmon_enable="YES"
ipmon_program="/sbin/ipmon"
ipmon_flags="-Ds"

не трябва да имаш никакъв проблем!!!
това при положение че ползваш ДЖЕНЕРИК кърнъл
иначе ако си прекомпилирала може оттам да идват проблемите
ама не може бе човек
Активен