Автор Тема: Apache, не стартира при boot бърка ли го с cron ?  (Прочетена 814 пъти)

theshit

  • Гост
Значи пичове имам следния проблем:
рестартирам сървърчето, но пък при boot не пуска апаче по една или друга причина ... тъпия ми въпрос е дали мога да наглася cronjob на root да го проверява на 5 мин дали е пуснат, щото като спре тока и не сам в нас ... сайтовете няколко дена са доло .. ии да не съм със Linux, но мисля, че работите вървят по същия начин ... специално за апаче и крон дето ги има от 89-та година, та така или иначе никой няма да ме накара да повярвам в противното ...
това което питах е ... има ли проблеми да сетна апачето в крона на роот-а ?
благодаря предварително :)
Активен

Acho

  • Напреднали
  • *****
  • Публикации: 3660
  • Distribution: Slackware, MikroTik - сървърно
  • Window Manager: console only
    • Профил
    • WWW
Нещо по логовете не пише ли колега ?
Активен

CPU - Intel Quad-Core Q8400, 2.66 GHz; Fan - Intel Box; MB - Intel G41M-T2; RAM - DDR2-800, Kingston HyperX, 2X2048 MB; VC - onboard, Intel G41 Express Chipset; HDD - SeaGate, 160 GB, SATAII; SB - Realtek HD Audio; DVD-RW - TSSTcorp DVD-RW; LAN - Realtek PCI-E GBE Controller; PSU - Fortron 350 Watt.

theshit

  • Гост
Starting cron.
[running /etc/rc.d/apache]
Starting apache.
(49)Can't assign requested address: make_sock: could not bind to address 85.217.210.147:80
no listening sockets available, shutting down
Unable to open logs
/etc/rc.d/apache exited with code 1
[failures]
The following components reported failures:
    /etc/rc.d/ntpdate /etc/rc.d/socks5 /etc/rc.d/apache
See /var/run/rc.log for more information.
[/etc/rc finished at Mon Mar  4 20:49:45 EET 2013]
[/etc/rc exiting with status 0]
« Последна редакция: Mar 04, 2013, 20:52 от theshit »
Активен

Acho

  • Напреднали
  • *****
  • Публикации: 3660
  • Distribution: Slackware, MikroTik - сървърно
  • Window Manager: console only
    • Профил
    • WWW
Идеята ми беше колега, ако си указал web-сървъра да се запуска автоматично при боот на системата, а после се крашва нещо и процеса спира, би трябвало да запише някаква причина за краша в логовете. Или логовете на Apache, или в системните логове.

Можеби това ще ти подскаже какво не му харесва. Да си го изправиш, и web-сървъра да си работи нон стоп.
Активен

CPU - Intel Quad-Core Q8400, 2.66 GHz; Fan - Intel Box; MB - Intel G41M-T2; RAM - DDR2-800, Kingston HyperX, 2X2048 MB; VC - onboard, Intel G41 Express Chipset; HDD - SeaGate, 160 GB, SATAII; SB - Realtek HD Audio; DVD-RW - TSSTcorp DVD-RW; LAN - Realtek PCI-E GBE Controller; PSU - Fortron 350 Watt.

theshit

  • Гост
мисля, че трябва да махна прокси то и тия сокс 5
Активен

theshit

  • Гост
nptd...изтрито... fxp0 ... a apacheto ...изтрито... - lan ...изтрито... !

Добре! Не мога да разбера защо SSH-то ми а вързва на порта а Apache-то - НЕ!  ... на SSH то кви са му настройките по деф ? 0.0.0.0:22  ?

Редактирано, съгласно т. 3 от Правилата на форума.
bop_bop_mara
« Последна редакция: Mar 05, 2013, 00:54 от bop_bop_mara »
Активен

Йордан

  • Напреднали
  • *****
  • Публикации: 1451
  • Distribution: Ubuntu / Gentoo
  • Window Manager: Gnome
  • не е важно колко ти е голяма пишката, а какво можеш с нея
    • Профил
    • WWW
Нещо ти държи 80'ти порт. Направи netstat -ntap|grep -i list|grep ":80" след ребоот преди да е запалило апачето
Активен

Всеки пост - отговор на въпрос !!!

Йордан Георгиев
http://ygeorgiev.net/

n00b

  • Напреднали
  • *****
  • Публикации: 1248
  • Distribution: OSX
  • Window Manager: 10.6, 10.8, 10.9
  • Live to hack, hack to live.
    • Профил
Защо си набил на Apache IP? 85.217.210.147:80

Кажи му да се вързва към всичко живо - 0.0.0.0:80
Активен

mobilio - професионални мобилни приложения

theshit

  • Гост
Защо си набил на Apache IP? 85.217.210.147:80

Кажи му да се вързва към всичко живо - 0.0.0.0:80

Дам, това оправи проблема, набих му да връзва на всичко живо и вече си рън-ва при буут. Просто исках всичко да е стриктно, но явно не съм преценил добре, понеже имам и вътрешна мрежа, отсега нататък ще знам.
Благодаря!
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
cron
Настройка на програми
sunhater 2 1674 Последна публикация Nov 02, 2003, 21:27
от sunhater
Проблем с cron - не стартира нищо
Настройка на програми
senser 5 2198 Последна публикация Oct 07, 2005, 11:52
от sunhater
Малко пощош относно cron
Настройка на програми
abadon 3 1522 Последна публикация Jan 18, 2007, 14:21
от abadon
Cron работи ли?
Настройки на софтуер
anakinn 2 1853 Последна публикация Jun 26, 2007, 17:25
от anakinn
Зареждане на сайт със cron
Настройка на програми
pwizard 5 1185 Последна публикация Jan 30, 2010, 11:34
от zeridon