Автор Тема: Проблем с kde  (Прочетена 1766 пъти)

Bagatur

  • Напреднали
  • *****
  • Публикации: 267
  • Distribution: Debian Squeeze
  • Window Manager: KDE Development Platform: 4.4.5 , LXDE
    • Профил
Проблем с kde
« -: May 04, 2008, 19:43 »
Здравите.Отдавна не бях се обръщал към потребителите на форума за съвет но ето че се наложи.
Та , инсталирах си Кубунту 8.04 и се оказа 4е не мога да си наглася резолюцията  и честотата която искам.До скоро бях с Kubuntu 7.10 и вървеше иделно и намах такива елементарни проблеми но с по новата версия имам.
Разрових се малко из /etc/X11/xorg.conf и успях да докарам резолюцията но 4естотата остана една никаква на 62 Hz надявам се някои да ми помогне ако ви трябва повече инфо кажете точно какво ви трябва
Е то какво имам аз в xorg.conf:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us,bg"
   Option      "XkbVariant"   ",phonetic"
   Option      "XkbOptions"   "grp:alt_shift_toggle,grp_led:scroll"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
   Boardname   "NVIDIA GeForce FX (generic)"
   Busid      "PCI:1:0:0"
   Driver      "nvidia"
   Screen   0
   Vendorname   "NVIDIA"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
   Vendorname   "Plug 'n' Play"
   Modelname   "Plug 'n' Play"
  modeline  "1920x1440@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
   Gamma   1.0
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
   Defaultdepth   24
   SubSection "Display"
      Depth   24
      Virtual   1920   1440
      Modes      "1920x1440@60"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen 0 "Default Screen" 0 0
EndSection
Section "Module"
   Load      "glx"
   Load      "GLcore"
   Load      "v4l"
EndSection
Section "device" #
   Identifier   "device1"
   Boardname   "NVIDIA GeForce FX (generic)"
   Busid      "PCI:1:0:0"
   Driver      "nv"
   Screen   1
   Vendorname   "NVIDIA"
EndSection
Section "screen" #
   Identifier   "screen1"
   Device      "device1"
   Defaultdepth   24
   Monitor      "monitor1"
EndSection
Section "monitor" #
   Identifier   "monitor1"
   Gamma   1.0
EndSection
Section "ServerFlags"
EndSection
Активен

Учим се докато сме живи....

bulg

  • Напреднали
  • *****
  • Публикации: 916
  • Distribution: *bsd/linux
  • Животът е тръпка... иначе живот ли е това...
    • Профил
    • WWW
Проблем с kde
« Отговор #1 -: May 04, 2008, 23:06 »
Що не пуснеш едно:
nvidia-settings
Активен

http://www.youtube.com/watch?v=9rX8Fn-YJpI
---------------------------------------------------------------------
http://cleargreen.com

zeridon

  • Killmode enabled
  • Administrator
  • Напреднали
  • *****
  • Публикации: 1398
  • Distribution: Debian/Ubuntu
  • Window Manager: console/Gnome
  • BOfH
    • Профил
    • WWW
Проблем с kde
« Отговор #2 -: May 05, 2008, 01:34 »
Също така кажи какъв ти е монитора (и максимални честоти/резолюции ако знаеш) и какво е видеото ... иначе няма проблем ... мога да ти дам modeline но може и да ти изпържа нещо без да искам (бъзик)
Активен

Внмимавай имам клещи за кабел
http://www.netsecad.com/
http://theregister.co.uk/odds/bofh/

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Проблем с kde
« Отговор #3 -: May 05, 2008, 04:20 »
Цитат (bulg @ Май 04 2008,23:06)
Що не пуснеш едно:
nvidia-settings

Нека по-добре бъде
Примерен код
dpkg-reconfigure xserver-xorg
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

Bagatur

  • Напреднали
  • *****
  • Публикации: 267
  • Distribution: Debian Squeeze
  • Window Manager: KDE Development Platform: 4.4.5 , LXDE
    • Профил
Проблем с kde
« Отговор #4 -: May 05, 2008, 08:31 »
Цитат (neter @ Май 05 2008,05:20)
Цитат на: bulg,Май 04 2008,23:06
Що не пуснеш едно:
nvidia-settings

Нека по-добре бъде
Примерен код
dpkg-reconfigure xserver-xorg
Изпълних това което ми каза обаче сега x-a въобще не пожела да зацепи.
Видеокартата ми е Gforse FX 5200-128Mb
Moнитора е Samsung SyncMaster 757mb
Обикновенно използвам резолюция 1024-768@85hz
Резолюцията я бях докарал само честотата се ебаваше



Активен

Учим се докато сме живи....

bulg

  • Напреднали
  • *****
  • Публикации: 916
  • Distribution: *bsd/linux
  • Животът е тръпка... иначе живот ли е това...
    • Профил
    • WWW
Проблем с kde
« Отговор #5 -: May 05, 2008, 12:52 »
Тия #(коментари), дето ти са в края на описанието (Section "device" #, Section "screen" #, Section "monitor" #) в xorg.conf, едва ли са коректно поставени. Kaкто и да е, ako още не ти пали Х-а:
ctrl+alt+f1
# За всеки случай:
sudo /etc/init.d/kdm stop
sudo rm /tmp/*X*
# После:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.back.tekushtata_data
sudo rm /etc/X11/xorg.conf
sudo apt-get install build-essential pkg-config
sudo apt-get install linux-headers-tuk_pishesh_versiqta_na_qdroto(която ще видиш с командата):
uname -r
# напр.: sudo apt-get install linux-headers-2.6.24-1
sudo apt-get install lynx
lynx nvidia.com
# Свали от http://nvidia.com, необходимия ти драйвър.
sudo nvidia-installer --uninstall
sudo sh /kydeto_e_svalen_driver-a/nvidia_drivera.run
# NO&NO
sudo nvidia-installer --update
sudo dpkg-reconfigure xserver-xorg
# Избери(със Space) резолюция 1024x768 u 800x600
startx
sudo nvidia-settings
# Настройваш честота и тн., след което - "Save to X configuration file"(ще  допълни xorg.conf)
CTRL+ALT+BACKSPACE
Влизаш отново и си got off '<img'>



Активен

http://www.youtube.com/watch?v=9rX8Fn-YJpI
---------------------------------------------------------------------
http://cleargreen.com

Bagatur

  • Напреднали
  • *****
  • Публикации: 267
  • Distribution: Debian Squeeze
  • Window Manager: KDE Development Platform: 4.4.5 , LXDE
    • Профил
Проблем с kde
« Отговор #6 -: May 05, 2008, 21:52 »
blug не става така.
1. Не ми испулнява никоя от посочените команди
2.Казва ми че директориите които ме кара6 да премахна не съществуват
Та как да е X-a го подпалих инсталирах на ново драивер за видеото но сега в xorg.conf липсват някои редове и не знам какви точно да добоавя , но съм почти сигурен че проблема е именно там.
Ето как изглейда сега xorg.conf:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us,bg"
   Option      "XkbVariant"   ",phonetic"
   Option      "XkbOptions"   "grp:alt_shift_toggle,grp_led:scroll"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
EndSection



Активен

Учим се докато сме живи....

bulg

  • Напреднали
  • *****
  • Публикации: 916
  • Distribution: *bsd/linux
  • Животът е тръпка... иначе живот ли е това...
    • Профил
    • WWW
Проблем с kde
« Отговор #7 -: May 05, 2008, 22:14 »
Това направи ли го в графична среда:
Цитат
sudo nvidia-settings
# Настройваш честота и тн., след което - "Save to X configuration file"(ще  допълни xorg.conf)
CTRL+ALT+BACKSPACE




Активен

http://www.youtube.com/watch?v=9rX8Fn-YJpI
---------------------------------------------------------------------
http://cleargreen.com

Bagatur

  • Напреднали
  • *****
  • Публикации: 267
  • Distribution: Debian Squeeze
  • Window Manager: KDE Development Platform: 4.4.5 , LXDE
    • Профил
Проблем с kde
« Отговор #8 -: May 05, 2008, 22:20 »
направих го, но и него не пожела да изпълни
кара ме да гледам хелповете
е гледах ги опитвах разли4ни вариации и чрез тях дано успея, но уви с Kubuntu 7.10 нямаше такива проблеми и се чудя сега на какво се дължи това  '<img'>  '<img'>



Активен

Учим се докато сме живи....

bulg

  • Напреднали
  • *****
  • Публикации: 916
  • Distribution: *bsd/linux
  • Животът е тръпка... иначе живот ли е това...
    • Профил
    • WWW
Проблем с kde
« Отговор #9 -: May 05, 2008, 22:23 »
Свали драйвъра за твойта карта, инсталирай го; бек-ни xorg.conf и дай:
nvidia-xconfig
startx

пп. Що не вземеш, преди това, да влезеш в root, посредством:
su
 '<img'>



Активен

http://www.youtube.com/watch?v=9rX8Fn-YJpI
---------------------------------------------------------------------
http://cleargreen.com

Bagatur

  • Напреднали
  • *****
  • Публикации: 267
  • Distribution: Debian Squeeze
  • Window Manager: KDE Development Platform: 4.4.5 , LXDE
    • Профил
Проблем с kde
« Отговор #10 -: May 05, 2008, 22:44 »
хехе е не съм чак толкова зле '<img'> всички неща ги правя под root дори минах само под  текстови режим защото драивера на Nvidia
kойто изтеглих трябва да се инсталира именно така поне така пише в RADME



Активен

Учим се докато сме живи....

bulg

  • Напреднали
  • *****
  • Публикации: 916
  • Distribution: *bsd/linux
  • Животът е тръпка... иначе живот ли е това...
    • Профил
    • WWW
Проблем с kde
« Отговор #11 -: May 05, 2008, 22:54 »
Покажи грешката, която ти дава:
Примерен код
# /usr/bin/nvidia-settings

в гр. режим.



Активен

http://www.youtube.com/watch?v=9rX8Fn-YJpI
---------------------------------------------------------------------
http://cleargreen.com

Bagatur

  • Напреднали
  • *****
  • Публикации: 267
  • Distribution: Debian Squeeze
  • Window Manager: KDE Development Platform: 4.4.5 , LXDE
    • Профил
Проблем с kde
« Отговор #12 -: May 07, 2008, 17:56 »
няма смисъл оправих нещата като си инсталирах пак 7.10 върви перфектно явно КДЕ 3.5.9 е доста бъгава всичко е от версията май като подобрят 4-ката ще пробваме с нея как е ама за сега и от нея не съм доволен  '<img'>
Благодаря за помоща на всички се пак



Активен

Учим се докато сме живи....