Автор Тема: Segmentation Fault, Help  (Прочетена 1366 пъти)

KeuH

  • Напреднали
  • *****
  • Публикации: 68
    • Профил
Segmentation Fault, Help
« -: Jun 17, 2005, 12:25 »
Вчера пуснах една тема за инсталация на Slackware 10.1.  Имах input/output грешки при Glibc, които като че ли не зависеха от носителя и четящото устройство.  kdepetkov ме посъветва да проверя хард дисковете, но аз отговорих, че при първоначалната инсталация съм направил format with bad blocks checking.  Опитах с друга версия на Slackware - unofficial no X от unixsol, и пак даде същата грешка, но по-натам и segmentation fault.  Ето какво пише:

Цитат

(един ред 32-битови шестнадестични числа като 2fffffff ...)
Call Trace: ([<пак същатата работа>]) ... няколко реда

Code: тука са някакви 8-битови числа като 8b 52 34 ...
Segmentation Fault
hda: read_intr: Status=0x59 {DriveReady SeekComplete DataRequest Error}
hda: read_intr: error=0x40 {UncorrectableError}, LBASect=1117576, sector=1117512
end_request: I/O error, dev 03:01 (hda), sector 1117512
hda: irq timeout, status = 0xD0 {Busy}

и т.н.

 


Мисля, че очевидно се касае за грешка в primary master твърдия диск.  Но защо format with bad blocks checking не оправи нещата в началото?
Активен

alabal

  • Напреднали
  • *****
  • Публикации: 2173
  • cat /earth/europe/bg/sofia | grep Nacamura
    • Профил
Segmentation Fault, Help
« Отговор #1 -: Jun 18, 2005, 00:08 »
Братко, аз имах подобен проблем (извади съшите грешки) но в kernel, т.е. независимо от дистрибуцията, а не при glibc. Все пак да кажа на какво се дължаха. Дъното ми е AN8E на ASUS и съответния модул amd74xx за ide зависи от още три модула - ide-disk, ide-generic и ide-cd. Странно, но когато и четирите са включени статично в ядрото не разпознава хард диск на ide или по-точно го разпознава, но вади един чаршаф грешки и не разпознава правилно дяловете на диска. Когато са модули - работи като пушка.
Имам sata диск и когато добавих другия хард ми се изправиха косите да не е заминал, че е вече старичък, а и защото повечето мнения в нета са, че когато се появи:
 
Цитат
{DriveReady SeekComplete DataRequest Error}

диска е заминал или си заминава.
Не знам доколко ти помага това, но е поне някаква информация.
Активен

It makes you awful glad that you were born a man.

the_real_maniac

  • Напреднали
  • *****
  • Публикации: 1258
  • Kernel panic, me - no panic ;-) :-)
    • Профил
Segmentation Fault, Help
« Отговор #2 -: Jun 18, 2005, 11:19 »
НЕ Е (!!!!!'<img'> задължително хдд-то да си занимава.
Може да е хардуерната връзка.

IDE ATA Кабела или дори захранващия кабел.

Реален пример - от близо година един хдд 40ГБ макстор ми даваше подобан грешка без тези шестнайсетични числа, може да си вкарал опция за debug в ядрото :? ; и един път като трябваше да правя малко backup от него го качих на друга машина от тази , на която е и реших да му направя badblock scan - нищо не излезе!  Товага вече и съмненията ми се потвърдиха '<img'> Също така не даваше и да се пипа DMA на хард диска , когато кабела беше скапан , което малко ме очуди, но няма значение.

Смених кабелчето на машианта , на кято по принцип е и воаля '<img'>

Успех '<img'> !
Активен

Powered by Debian GNU / LINUX /// Intel inside ...

„Насилието е последното убежище на некомпетентността“ - Айзък Азимов (1920 — 1992)