Автор Тема: Инсталиране адаптер с chipset Atheros Ar9271  (Прочетена 6740 пъти)

Lena1

  • Напреднали
  • *****
  • Публикации: 38
  • Distribution: Debian Lenny
  • Window Manager: LXDE
    • Профил
Re: Инсталиране адаптер с chipset Atheros Ar9271
« Отговор #15 -: Jan 23, 2011, 16:08 »
Хм, нещо не се получи от първия път  ???
Ето какво направих:

Firmware: изтеглих прикачения файл от другата ти тема, екстрактнах/разархивирах го направо в директория lib/firmware, като трябваше да го направя като root.

Компилация:
Разархивирах compat-wireless-... на произволно място. Влязох в него през конзолата и ./scripts/driver-select ath9k_htc
make
make install
Това го направи ОК, не даде грешки.

Рестартирах, iwconfig - няма никой  :(

Къде ли греша?
Активен

tolostoi

  • Напреднали
  • *****
  • Публикации: 1337
  • Distribution: Ubuntu
  • Window Manager: Unity
  • левел: авераж :)
    • Профил
Re: Инсталиране адаптер с chipset Atheros Ar9271
« Отговор #16 -: Jan 23, 2011, 17:45 »
Като за начало, опитай както те посъветвах да не изключваш НИЩО от сорса на пакета, написах го по рано :(.
Сега влез в папката където си компилирал сегашния и изпълни
Код:
make uninstall
Рестартирай, и вземи пак сорса, направо го разархиварай (или изтегли пак) и отначало
Код:
make
make install

П.П. Ако искаш дай да видим какво се случва с това което си инсталирал, покажи какво отговарят комадите
Код:
dmesg | grep ath
dmesg | grep irmw
Активен


... в Столичен инспекторат една година след миграцията, продължават да работят под Linux. Което, май прави "експеримента" успешен
by entusiast

Lena1

  • Напреднали
  • *****
  • Публикации: 38
  • Distribution: Debian Lenny
  • Window Manager: LXDE
    • Профил
Re: Инсталиране адаптер с chipset Atheros Ar9271
« Отговор #17 -: Jan 24, 2011, 10:45 »
debian:/home/lena# dmesg | grep ath
[   39.636803] usb 1-1.3: ath9k_htc: Firmware - ar9271.fw not found
[   39.660248] ath9k_hif_usb: probe of 1-1.3:1.0 failed with error -22
[   39.660355] usbcore: registered new interface driver ath9k_hif_usb
debian:/home/lena# dmesg | grep irmw
[   39.636803] usb 1-1.3: ath9k_htc: Firmware - ar9271.fw not found
debian:/home/lena# lsusb
Bus 001 Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 003: ID 07a6:8515 ADMtek, Inc. AN8515 Ethernet
Bus 001 Device 002: ID 0e8f:0016 GreenAsia Inc. 4 port HUB
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Адаптера е свързан, но не свети никакъв индикаторен диод. Ти имаш ли същия адаптер? При теб има ли индикаторна светлина като го включиш?
Активен

tolostoi

  • Напреднали
  • *****
  • Публикации: 1337
  • Distribution: Ubuntu
  • Window Manager: Unity
  • левел: авераж :)
    • Профил
Re: Инсталиране адаптер с chipset Atheros Ar9271
« Отговор #18 -: Jan 24, 2011, 12:05 »
Свети, да (всъщност не съм сигурен моя е един тп линк) От изхода се вижда, че ти го няма фърмуера където го търси, покажи какво имаш в папката с команда
Код:
ls -l /lib/firmware/
Вероятно не е копиран там.
EDIT:
Прикрепеният файл от другата, тема, след като го изтеглиш и разархивираш, трябва файловете от него да се копират в /lib/firmware но не с цялата папка, просто самите файлове, ако си ги копирал с папката, ще се получи че са в /lib/firmware/firmware/ а то ще ги търси в /lib/firmware. И пак ти казвам, че е по-добре да компилираш и инсталираш целият compat-wireless понеже не съм сигурен дали няма модула който ти трябва да зависи от някой друг модул в пакета, който ти нямаш или ще е различна версия, по тази причина и в папката с firmware съм качил няколко различни firmwar-a а не само въпросният ar9271.fw
« Последна редакция: Jan 24, 2011, 12:28 от tolostoi »
Активен


... в Столичен инспекторат една година след миграцията, продължават да работят под Linux. Което, май прави "експеримента" успешен
by entusiast

Lena1

  • Напреднали
  • *****
  • Публикации: 38
  • Distribution: Debian Lenny
  • Window Manager: LXDE
    • Профил
Re: Инсталиране адаптер с chipset Atheros Ar9271
« Отговор #19 -: Jan 24, 2011, 16:14 »
трябва файловете от него да се копират в /lib/firmware но не с цялата папка, просто самите файлове, ако си ги копирал с папката, ще се получи че са в /lib/firmware/firmware/ а то ще ги търси в /lib/firmware.

Tова е бил проблема, че бяха в папка и като ги извадих ТРЪГНА!
 ;D Мооого благодаря!
Активен