Автор Тема: нов debian  (Прочетена 783 пъти)

Nortalion

  • Напреднали
  • *****
  • Публикации: 27
    • Профил
нов debian
« -: Jul 09, 2006, 18:53 »
с риск да полазя по нечи нерви...
начи /etc/apt/source.list ми е:
Цитат

#deb file:///cdrom/ sarge main

deb cdrom:[Debian GNU/Linux testing _Sarge_ - Official Snapshot i386 Binary-1 (20050312)]/ unstable contrib main

# deb http://security.debian.org/ testing/updates main contrib

deb <a href="" target="_blank">ftp://ftp.bg.debian.org/debian/</a> stable main contrib non-free
deb <a href="" target="_blank">ftp://ftp.bg.debian.org/debian/</a> testing main contrib non-free
deb <a href="" target="_blank">ftp://ftp.bg.debian.org/debian/</a> unstable main contrib non-free

deb http://security.debian.org/ stable/updates main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free

deb http://wine.sourceforge.net/apt/ binary/
deb http://wine.sourceforge.net/apt/ testing/
deb http://wine.sourceforge.net/apt/ unstable/



ако се опитам да инсталирам нещо с aptitude ми писва че половината ми пакети не са ми нужни вече, защото никой не ги използва и сака да ги трие, а аз не знам дали трябва :/ ако искам да си инсталирам нещо с apt-get install нещо, ми обяснява как:

Цитат
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gaim: Depends: libcairo2 (>= 1.0.2-2) but it is not going to be installed
        Depends: libgtk2.0-0 (>= 2.8.0) but it is not going to be installed
        Depends: libgtkspell0 (>= 2.0.2) but it is not going to be installed
        Depends: libpango1.0-0 (>= 1.12.3) but it is not going to be installed
        Depends: libxfixes3 but it is not going to be installed
        Depends: libxinerama1 but it is not going to be installed
        Depends: libxss1 but it is not going to be installed
E: Broken packages



това спира да е така, след като добавя APT::Force-LoopBreak "true"; във /etc/apt/apt.conf, но преди малко го добавих, инсталирах няколко пакета, рестартирах и повече не видях X....
а реда го добавих, защото като искам някой от тия дето depends, ми казваше че го иска... а сега ми казва:
Цитат

...
The following packages will be REMOVED:
  base-config
...

и тва само защото apt-get install libcairo2...

какво да правя, не смея да пипам, за да не остана без ОС отново  '<img'>
Активен

redcure

  • Напреднали
  • *****
  • Публикации: 914
    • Профил
нов debian
« Отговор #1 -: Jul 09, 2006, 19:04 »
Цитат

......сака да ги трие .......

 ':huh:'

Предполагам, че нямаш много опит с Debian и unstable не е за теб, т.е. в sources.list остави само testing. След това пишеш
Примерен код

$su
#apt-get update
#apt-get dist-upgrade



П.П. За пускане на графична среда след като си направил upgrade даваш
Примерен код

#apt-get install x-window-system kdm kdebase xserver-xorg


Успех, баце  ':p'
Активен

Debian testing 2.6.18, Enlightenment DR17

http://www.debian.org/doc/manuals/apt-howto/index.en.html

Nortalion

  • Напреднали
  • *****
  • Публикации: 27
    • Профил
нов debian
« Отговор #2 -: Jul 09, 2006, 19:11 »
само testing демек да махна и stable ?? щото и върху това доста се почудих...
и дали има някакъв шанс да мога да направя всичко което си казал от в кде ?? ':zzz:'
и голямо благодаря  '<img'>
Активен

redcure

  • Напреднали
  • *****
  • Публикации: 914
    • Профил
нов debian
« Отговор #3 -: Jul 09, 2006, 19:18 »
Можеш през synaptic-а, но след upgrade си сложи и малко по-ново ядро '<img'>
Разгледай опциите на synaptica ..... аз не го ползвам, но е изключително полезен и приятен.
Активен

Debian testing 2.6.18, Enlightenment DR17

http://www.debian.org/doc/manuals/apt-howto/index.en.html

Nortalion

  • Напреднали
  • *****
  • Публикации: 27
    • Профил
нов debian
« Отговор #4 -: Jul 10, 2006, 01:42 »
отидох у една приятелка да гледаме финала, прибирам се... и:
Цитат


....
E: This installation run will require temporarily removing the essential package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option.
E: Internal Error, Could not early remove e2fsprogs

now what  '<img'>
инак си е изтеглило пакетите де - Fetched 459MB in 32m40s (234kB/s)



Активен

  • Гост
нов debian
« Отговор #5 -: Jul 10, 2006, 07:51 »
Сега ТУК теглиш Книгата за Дебиан на български и четеш.

Това заглавие в стил 24часа "Нов ***, нови проблеми" си го задръж. Описвай проблеми, не емоции моля.
Активен

Nortalion

  • Напреднали
  • *****
  • Публикации: 27
    • Профил
нов debian
« Отговор #6 -: Jul 10, 2006, 10:39 »
еми аз си го чета от тук(наистина е малко по-стара версия), но единственото което ме вдъхнови беше :
Цитат

опитайте тази команда:

# dpkg --configure --pending

за да конфигурирате пакетите, които все пак са разпакетирани, но не и конфигурирани. След това опитайте

# apt-get install -f
# apt-get upgrade -f
# apt-get dist-upgrade -f

И след това първата команда (без -f) отново. Продължавайте, колкото е необходимо. Обикновено голяма част от конфликите могат да се решат по този начин. Ако се споменават проблемни пакети, можете да пробвате и да ги премахнете.

само дето не мога да продължавам особено дълго, понеже гршката, която бях посочил по-горе ми се появява отново и отново.. ако позволя  APT::Force-LoopBreak ще мога да продължа, но това което питам(макар и да не го изразявам особено ясно досега) е, безопасно ли е да позволя тази опция ?
Активен

  • Гост
нов debian
« Отговор #7 -: Jul 10, 2006, 12:06 »
Цитат (Nortalion @ Юли 09 2006,20:11)
само testing демек да махна и stable ?? щото и върху това доста се почудих...
и дали има някакъв шанс да мога да направя всичко което си казал от в кде ?? ':zzz:'
и голямо благодаря  '<img'>

Stable няма да махаш.. оставаш testing и stable. '<img'>
Активен

Nortalion

  • Напреднали
  • *****
  • Публикации: 27
    • Профил
нов debian
« Отговор #8 -: Jul 10, 2006, 13:22 »
еми аз и testing махнах след поредния преинстал( но ставам все по-добър ...). Във всички случай мисля, че трябва да понауча още туй онуй за линукс, пък и за моя си компютър, преди да се фащам с квото и да било по-напреднало, или може да си изтегля инсталационно cd за sid по-натам... ще видя. засега благодаря на всички, които предложиха помощ, и ако пак оквацам нещо ще си кажа  '<img'>
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
BG Debian
Предложения за български проект
asa 0 3118 Последна публикация Sep 25, 2002, 11:52
от asa
Debian i KDE
Настройка на програми
IvanST 9 9207 Последна публикация Jan 05, 2003, 21:54
от n_antonov
Грешка в MBR Debian не стартира!
Настройка на програми
IvanST 8 8532 Последна публикация Jan 07, 2003, 13:36
от IvanST
debian + kde 3.1
Настройка на програми
rat 0 2290 Последна публикация Jan 28, 2003, 17:28
от rat
кои CD-та на Debian ми трябва ?
Настройка на програми
brady 5 6212 Последна публикация Jul 10, 2003, 16:33
от FuckBTK