Автор Тема: Doom3demo-липсва звук  (Прочетена 1806 пъти)

arlekin

  • Напреднали
  • *****
  • Публикации: 28
    • Профил
Doom3demo-липсва звук
« -: Apr 05, 2006, 15:57 »
здравейте!с мандрива 2006 съм и инсталирах дуум3 демоверсията,но нямам никакъв звук!?иначе играта се държи чудесно.може ли някой да ми помогне-търсих къде ли не!
между другото това е първата по-"сериозна" игра за линукс,която инсталирам.иначе през уайн съм играл и не съм имал проблеми със звука
Активен

Lord Bad

  • Напреднали
  • *****
  • Публикации: 1667
  • Distribution: Fedora 13
  • Window Manager: GNOME
  • Jedi Knight
    • Профил
Doom3demo-липсва звук
« Отговор #1 -: Apr 05, 2006, 16:32 »
Най-вероятно имаш вградена звукова карта, която не поддържа хардуерно миксиране на звука. Трябва да си инсталираш звуков сървър като dmix или някоя по-нова версия на алса, защото доколкото знам там вече има поддръжка на софтуерно миксиране по подразбиране именно чрез интеграция на dmix, ако не греша...
Активен

Fuelled by Fedora 13 "Goddard"
====================================
Rock it!

arlekin

  • Напреднали
  • *****
  • Публикации: 28
    • Профил
Doom3demo-липсва звук
« Отговор #2 -: Apr 05, 2006, 18:56 »
не е май там проблема-попрочетох във форума за алса.пускам два плеъра и си работят независимо един от друг;е,кашата от звуци е като на плажа лятото верно'<img'>
благодаря все пак,пък може и да не съм схванал нещо...
други идеи?
вижте какво ми изписа като стартирах дума в терминал:
during DOOM 3 initialization...
WARNING: mmap 57344 bytes on device /dev/dsp failed: Input/output error

WARNING: sound subsystem disabled
Активен

Lord Bad

  • Напреднали
  • *****
  • Публикации: 1667
  • Distribution: Fedora 13
  • Window Manager: GNOME
  • Jedi Knight
    • Профил
Doom3demo-липсва звук
« Отговор #3 -: Apr 05, 2006, 20:39 »
Я пусни играта от терминала като суперпотребител. Може да има проблеми с правата, макар че като гледам грешката от предното ти мнение се съмнявам че това е проблема.
Активен

Fuelled by Fedora 13 "Goddard"
====================================
Rock it!

arlekin

  • Напреднали
  • *****
  • Публикации: 28
    • Профил
Doom3demo-липсва звук
« Отговор #4 -: Apr 06, 2006, 09:54 »
нищо не се променя като съм като  root...обаче забелязах още нещо,незнам дали има връзка:
------------- Warnings ---------------
during game/demo_mars_city1...
WARNING: Couldn't load sound 'guisounds.wav' using default
WARNING: file def/weapon_bfg.def, line 102: Unknown entityDef 'damage_bfgSplash'                                            inherited by 'damage_bfgsplash_cinematic'
WARNING: file def/weapon_bfg.def, line 92: Unknown entityDef 'damage_bfg' inheri                                           ted by 'damage_bfg_cinematic'
WARNING: file def/weapon_bfg.def, line 97: Unknown entityDef 'damage_bfgFreq' in                                           herited by 'damage_bfgfreq_cinematic'
WARNING: Unknown classname 'weapon_plasmagun' on 'weapon_plasmagun_1'
благодаря ти за съдействието,независимо дали ще разрешим проблема сега '<img'>
пеждувременно се зачетох във файла doomconfig.cfg и намерих нещо като че ли интригуващо:
seta s_numberOfSpeakers "6"
seta s_doorDistanceAdd "150"
seta s_globalFraction "0.8"
seta s_subFraction "0.75"
seta s_playDefaultSound "1"
seta s_volume_dB "0"
seta s_meterTopTime "2000"
seta s_reverse "1"
seta s_spatializationDecay "2"
seta s_maxSoundsPerShader "1"
seta sys_lang "english"
seta s_dsp "/dev/dsp"
seta s_driver "oss"
seta sys_videoRam "0"



Активен

Lord Bad

  • Напреднали
  • *****
  • Публикации: 1667
  • Distribution: Fedora 13
  • Window Manager: GNOME
  • Jedi Knight
    • Профил
Doom3demo-липсва звук
« Отговор #5 -: Apr 06, 2006, 12:45 »
Направи един ls -l /dev/dsp и постни тук резултата от командата.
Активен

Fuelled by Fedora 13 "Goddard"
====================================
Rock it!

arlekin

  • Напреднали
  • *****
  • Публикации: 28
    • Профил
Doom3demo-липсва звук
« Отговор #6 -: Apr 06, 2006, 12:58 »
просто написах това,което ми каза в конзолата,но нищо не се случи,изписа ми това:
[ljubo@cable-84-43-144-233 ~]$  ls -l /dev/dsp
crw-rw----  1 ljubo audio 14, 3 апр  6 12:07 /dev/dsp
може би не разбрах правилно задачата-хич ме няма с конзолата!
/dev/dsp беше изписано с жълт цвят ако това има някакво значение



Активен

arlekin

  • Напреднали
  • *****
  • Публикации: 28
    • Профил
Doom3demo-липсва звук
« Отговор #7 -: Apr 07, 2006, 11:27 »
явно е от играта проблема-инсталирах друга и всичко тръгна по вода '<img'> а как се деинсталира игра,която не е от рпм пакет?
Активен

  • Гост
Doom3demo-липсва звук
« Отговор #8 -: Apr 08, 2006, 21:47 »
seta s_driver "oss"
Пробвай да го промениш на
seta s_driver "alsa"
Активен

arlekin

  • Напреднали
  • *****
  • Публикации: 28
    • Профил
Doom3demo-липсва звук
« Отговор #9 -: Apr 13, 2006, 16:24 »
пробвах какво ли не-не става и тва си е...сложих го и на друг компютър с убунту-същата работа.нямаше да повдигам темата пак,обаче с QUAKE 3 се получи същото нещо-не ми върви с продуктите на id май!все някаква причина трябва да има-никой ли не е имал подобен проблем'<img'>? '<img'>
Активен

plamen_t

  • Напреднали
  • *****
  • Публикации: 170
    • Профил
Doom3demo-липсва звук
« Отговор #10 -: May 31, 2006, 00:23 »
Аз съм със Slackware и имам същия проблем със звука. Даже дава същата грешка. Както прочетох в http://www.linuxquestions.org
Doom 3 искал карта с OSS и май не работи с ALSA. Аз успях да подкарам донякъде звука с помощта на artsdsp:
Примерен код
artsdsp --mmap /пътя/до/играта

Обаче звукът накъсва бая и не може да се играе на резолюция по-голяма от 800х600 (не знам защо, ама се отрязява на резолюцията).
Имам и Quake3 и той също е без звук, но поне с artsdsp си работи идеално.
Активен