Автор Тема: Проблем с modul tulup  (Прочетена 1827 пъти)

Chiro

  • Напреднали
  • *****
  • Публикации: 70
    • Профил
Проблем с modul tulup
« -: May 31, 2007, 21:54 »
Здравейте,
имам следният проблем с 1 машина.
dmesg се препълва със съобщение
Примерен код

01:08.0: tulip_stop_rxtx() failed

до колкото успях да разгледам това е една от мрежовите карта която ми служи за достъп до машината. Проблема е че през 2-3 дни губя връзка и се налага рестарт. Пробвах да сетвам твърдо на 10FD/HF 100FD/HD но няма ефек (съобщенията продължават). Ще съм благодарен ако някой ми даде идея къде да търся проблема и как бих могъл да го отстраня. Не съм сигурен дали проблем е kernel modul-а или е hardware-ен със самата карта,
lspci
Примерен код
01:08.0 Ethernet controller: Davicom Semiconductor, Inc. 21x4x DEC-Tulip compatible 10/100 Ethernet (rev 31)


lsmod
Примерен код

tulip                  40896   1
crc32                   2880   0  [tulip]

uname
Примерен код
2.4.31
Активен

mironcho

  • Напреднали
  • *****
  • Публикации: 495
    • Профил
Проблем с modul tulup
« Отговор #1 -: Jun 01, 2007, 08:07 »
Щом като е с чип Davicom, по-добре пробвай с dmfe модула.
Активен

metal

  • Напреднали
  • *****
  • Публикации: 414
    • Профил
Проблем с modul tulup
« Отговор #2 -: Jun 01, 2007, 09:03 »
dmfe ползваш ли? Имах преди време проблем с една давиком-ка и го реших чрез прекомпилиране на кърнъла - премахване на tulip и dmfe директно в ядрото. Ако искаш да проследиш обссъждането на проблема ми, можеш да видиш тук (първите 3-4 поста са за друг проблем)
Активен

Gentoo 2007.0 - 2.6.23-r3
Debian testing - 2.6.22-3

petkouzunski

  • Напреднали
  • *****
  • Публикации: 208
    • Профил
Проблем с modul tulup
« Отговор #3 -: Jun 16, 2007, 21:26 »
Същия проблем с друга мрежова:


Примерен код
00:0b.0 Ethernet controller: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)



Примерен код
Linux Tulip driver version 1.1.13 (May 11, 2002)
ACPI: PCI Interrupt 0000:00:0b.0[A] -> GSI 19 (level, low) -> IRQ 21
tulip0:  MII transceiver #1 config 1000 status 786d advertising 05e1.
eth2: ADMtek Comet rev 17 at 0001d000, 00:08:A1:41:5B:88, IRQ 21.
0000:00:0b.0: tulip_stop_rxtx() failed
eth2: Setting full-duplex based on MII#1 link partner capability of 4de1.


Оскубах си косата и не знам какво да правя.

Модула, който използвам е "tulip". Картата спря да работи в един момент (не е за първи път).
Активен

neter

  • Global Moderator
  • Напреднали
  • *****
  • Публикации: 3408
  • Distribution: Debian, SailfishOS, CentOS
  • Window Manager: LXDE, Lipstick
    • Профил
    • WWW
Проблем с modul tulup
« Отговор #4 -: Jun 17, 2007, 04:13 »
А който (поради някаква причина) не иска да прекомпилира, може да сложи tulip в черната листа на /etc/discover.conf и да добави dmfe в /etc/modules  '<img'>
Активен

"Да си добре приспособен към болно общество не е признак за добро здраве" - Джиду Кришнамурти

metal

  • Напреднали
  • *****
  • Публикации: 414
    • Профил
Проблем с modul tulup
« Отговор #5 -: Jun 17, 2007, 09:11 »
Цитат (neter @ Юни 17 2007,05:13)
А който (поради някаква причина) не иска да прекомпилира, може да сложи tulip в черната листа на /etc/discover.conf и да добави dmfe в /etc/modules  '<img'>

Може и да не помогне (не го твърдя - само предполагам), защото когато имах tulip и dmfe като модули, rmmod-на ли tulip-а ми пада eth-то. При твоя вариант нещата са по-други - ти не даваш на tulip-а да се зарежда, което най-вероятно ще позволи на dmfe-то да поеме контрола над картата. Незнам...
Активен

Gentoo 2007.0 - 2.6.23-r3
Debian testing - 2.6.22-3

petkouzunski

  • Напреднали
  • *****
  • Публикации: 208
    • Профил
Проблем с modul tulup
« Отговор #6 -: Jun 17, 2007, 12:22 »
С модул dmfe картата не се разпознава. Или поне не се показва като устройство.
Активен

metal

  • Напреднали
  • *****
  • Публикации: 414
    • Профил
Проблем с modul tulup
« Отговор #7 -: Jun 17, 2007, 14:54 »
dmfe e за Davikom (не знам за други, но това не значи че няма (нито пък, че има)). Кой обаче е за твоята нямам идея.
Активен

Gentoo 2007.0 - 2.6.23-r3
Debian testing - 2.6.22-3

KPETEH

  • Напреднали
  • *****
  • Публикации: 584
    • Профил
Проблем с modul tulup
« Отговор #8 -: Jun 17, 2007, 15:02 »
Значи относно ето тази карта

Примерен код
00:0b.0 Ethernet controller: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)


В предишната ми работа компютъра който ползвах беше със
същата мрежова карта.На него компютър имах поредно инсталирани слак 10.2 след няколко месеца и 11 значи принципно модула за картата беше rtl8139too.
И при двете дистрибуции беше така.
Активен

Най-добрата страна на алчността е способността и да стопява коефициента на интелигентност дори на най-умния човек.

petkouzunski

  • Напреднали
  • *****
  • Публикации: 208
    • Профил
Проблем с modul tulup
« Отговор #9 -: Jun 17, 2007, 23:29 »
Цитат (KPETEH @ Юни 17 2007,16:02)
Значи относно ето тази карта

Примерен код
00:0b.0 Ethernet controller: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)


В предишната ми работа компютъра който ползвах беше със
същата мрежова карта.На него компютър имах поредно инсталирани слак 10.2 след няколко месеца и 11 значи принципно модула за картата беше rtl8139too.
И при двете дистрибуции беше така.

Благодаря за отговора. Ще пробвам с този модул.
Активен

gat3way

  • Напреднали
  • *****
  • Публикации: 6050
  • Relentless troll
    • Профил
    • WWW
Проблем с modul tulup
« Отговор #10 -: Jun 18, 2007, 00:03 »
Хм, редхат-подобните системи много обичат да зареждат първо модула tulip. Не знам защо. Освен това разглезват потребителите някак си. Както и да е, това са ми лични наблюдения, оффтопик '<img'>
Активен

"Knowledge is power" - France is Bacon

KPETEH

  • Напреднали
  • *****
  • Публикации: 584
    • Профил
Проблем с modul tulup
« Отговор #11 -: Jun 18, 2007, 09:01 »
Олеле чак сега видях каква глупост съм написал модула е 8139too за модела rtl8139 не знам защо ADMtek в слака го разпознава така.
Активен

Най-добрата страна на алчността е способността и да стопява коефициента на интелигентност дори на най-умния човек.

petkouzunski

  • Напреднали
  • *****
  • Публикации: 208
    • Профил
Проблем с modul tulup
« Отговор #12 -: Jun 24, 2007, 18:10 »
Цитат (KPETEH @ Юни 18 2007,10:01)
Олеле чак сега видях каква глупост съм написал модула е 8139too за модела rtl8139 не знам защо ADMtek в слака го разпознава така.

При мен зарежда модула, но не показва мрежовата. Предполагам е заради това, че имам друга карта с чипсет на realtek.
Активен

KPETEH

  • Напреднали
  • *****
  • Публикации: 584
    • Профил
Проблем с modul tulup
« Отговор #13 -: Jun 25, 2007, 09:54 »
Цитат (petkouzunski @ Юни 24 2007,18:10)
Цитат (KPETEH @ Юни 18 2007,10:01)
Олеле чак сега видях каква глупост съм написал модула е 8139too за модела rtl8139 не знам защо ADMtek в слака го разпознава така.

При мен зарежда модула, но не показва мрежовата. Предполагам е заради това, че имам друга карта с чипсет на realtek.

Значи за ядро 2.4.x добавяш в /etc/modules.conf:
Примерен код
alias eth0 8139too

а за ядро 2.6.x добавяш същото но в :
Примерен код
/etc/modprobe.conf

като eth0 е само примерно,ти си го поправи за правилната мрежова карта
Активен

Най-добрата страна на алчността е способността и да стопява коефициента на интелигентност дори на най-умния човек.

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
NTFS modul
Хардуерни и софтуерни проблеми
hellmaker 3 1002 Последна публикация Jun 24, 2004, 08:38
от IvanST
Problem s edin modul
Настройка на хардуер
defiler 1 805 Последна публикация Jul 11, 2004, 16:00
от Uvigii
insmod: error inserting 'modul.o': -1 File exists
Настройка на програми
lachezar2001 1 849 Последна публикация Jul 30, 2004, 13:17
от melwin