Автор Тема: apt-get upgrade1 upgraded, 0 newly installed, 0 to  (Прочетена 1605 пъти)

costas

  • Участник
  • *****
  • Публикации: 16
    • Профил
Kogato izpalnih
#apt-get upgrade

Poluchh slednoto saobshtenie za greshka

Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  libxft-dev: Depends: libxft2 (= 2.1.2-5) but 2.1.2-6 is installed
E: Unmet dependencies. Try using -f.

Sled tova ;
apt-get -f install mi dava:

1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0B/60.2kB of archives.
...
dpkg-divert: rename involves overwriting `/usr/X11R6/include/X11/Xft/Xft.h' with  different file `/usr/X11R6/include/X11/Xft/Xft1.h', not allowed
dpkg: error processing /var/cache/apt/archives/libxft-dev_2.1.2-6_i386.deb (--unpack):
 subprocess pre-installation script returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/libxft-dev_2.1.2-6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Kakvo ne e nared i kak molq vi se mi kajete da go opravq.
Активен

sebastianz55

  • Участник
  • *****
  • Публикации: 1136
    • Профил
    • WWW
apt-get upgrade1 upgraded, 0 newly installed, 0 to
« Отговор #1 -: Mar 31, 2004, 00:18 »
knoppix?
виж в apt.conf дали не ти е закована дистрибуцията на stable например
след това пробваш коят команда се изпълнява нормално като добавиш и force опциите например можеш да опиташ apt-get:
build-dep libxft-dev или libxft2
install --force-yes libxft-dev
remove /--purge/ libxft2/*/ - по късно пак го слагаш.
dist-upgrade
dpkg --unpack --force-all libxft-dev_2.1.2-6_i386.deb
-f install
-f upgrade
пробвай да преименуваш за момент и Xft.h
и така нататък като продължаваш с експериментите и докато някое не тръгне да се поправя и другите не го последват.
Въпреки това вероятността да омажеш нещо така е много голяма.
Аз бях с Кнопикс на hdd и по подобни вариации инсталираш kde 3.2.
Активен

С уважения:
Sebastianz55
------------------
http://www.fsa-bg.org
                              
Open Fest Initiative  http://openfest.org
                                              
Моля ви, уважавайте процесорното време на другите - пишете на кирилица и използвайте търсачката на форума!

vesok

  • Участник
  • *****
  • Публикации: 39
    • Профил
apt-get upgrade1 upgraded, 0 newly installed, 0 to
« Отговор #2 -: Mar 31, 2004, 02:34 »
По някаква причина имаш файл /usr/X11R6/include/X11/Xft/Xft.h и dpkg отказва да запише друг файл с това име.

Ако файла ти е инсталиран от .deb пакет (`dpkg -S Xft.h` ще ти каже кой пакет го е инсталирал) то деинсталирай въпросния друг пакет първо.

По-вероятно е да си инсталирал въпросния файл без да ползваш dpkg/apt-get - например от сорс .tar.gz файл. В такъв случай е хубаво да разбереш как точно този файл се е появил там и да го деинсталираш - както него, така и останалите файлове инсталирани заедно с него. Тогава `apt-get -f install ` трябва да свърши работа.

Ползване на --force-yes е игра с огъня и те съветвам да не го правиш. Системата ти и без това не изглежда добре, като "насилиш" apt-get съвсем ще я замажеш. Може да го позваш като последно средство преди форматиране на HDD!
Активен

  • Гост
apt-get upgrade1 upgraded, 0 newly installed, 0 to
« Отговор #3 -: Apr 01, 2004, 05:24 »
Ако файлът не принадлежи на някой пакет, тогава dpkg ще го презапише - незнаен файл *няма* място при системните файлове. Мястото на незнайните е в /usr/local, /opt и .т.н.
apt-get отказва да инсталира файл, ако въпросния файл принадлежи на друг пакет.

Това за форматирането звучи много зловещо ;-)
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
You need to have the libstdc++ headers installed
Хардуерни и софтуерни проблеми
kicker 0 656 Последна публикация Mar 09, 2004, 16:57
от kicker
u must have libstdc++ headers installed
Настройка на програми
kicker 7 1416 Последна публикация Mar 28, 2004, 21:29
от biglamer
Software engineers (r & d department) for a newly
Търсене
bulwork 9 4994 Последна публикация May 12, 2008, 16:40
от sdr
decoder plugin which is not installed.
Настройка на програми
JoannaM 16 1874 Последна публикация Aug 20, 2009, 00:25
от JoannaM