Автор Тема: Конфигурация на клавиатурна подредба в LXDE  (Прочетена 8132 пъти)

alkor

  • Напреднали
  • *****
  • Публикации: 135
    • Профил
Как мога да конфигурирам клавиатурната подредба, така че да мога да е сменям US-BG, BG-US когато ми е необходимо. В Lubuntu намерих индикатор знаменце) който показва на какъв език пишеш, но не мога да му добавя друг? Как да му задам с кой клавиш да се сменя клавиатурната подредба ?
Активен

Ipolit

  • Напреднали
  • *****
  • Публикации: 417
    • Профил
    • WWW
setxkbmap -option grp:ctrl_shift_toggle,grp_led:scroll us,bg   #това за смяна с контрол и шифт us,bg(bds)
setxkbmap -option grp:ctrl_shift_toggle,grp_led:scroll us,bg -varian ,phonetic #това за us,bg(phonetic)

Като влезеш в сесията, трябва да го изпълниш. Най-добре е да го пъхнеш в .config/autostart
« Последна редакция: Apr 21, 2010, 17:57 от Ipolit »
Активен

Face Your FreeBSD at http://ipolit.hit.bg

Recku

  • Напреднали
  • *****
  • Публикации: 206
  • Distribution: Debian Stable
  • Window Manager: KDE
    • Профил
Добре, но защо трябва да "тъпчим" rc.local файла, като има по-добър вариант.
Отваряте файла /etc/X11/xorg.conf и настройвате! А за повече информация как да бъде конфигуриран man xorg (или питайте нас ;))
Успех! ;)
« Последна редакция: Apr 21, 2010, 19:52 от Recku »
Активен

This aptitude does not have Super Cow Powers.

Ipolit

  • Напреднали
  • *****
  • Публикации: 417
    • Профил
    • WWW
Това не се слага в rc.local а след като се стартира lxde session. Принципно най-добре е в xorg.conf, обаче новите версии на убунту тотално игнорират всичко написано там. И общо взето нищо не пише в този файл - configured monitor,configured adapter....
Най-интересното е, че мойто ubuntu-netbook-remix даже няма xorg.conf
тъй че setxkbmap е перфектно решение за lxde. За гном, кде, хface няма проблем, защото те си имат разни инструментчета (които между другото правят точно setxkbmap)

Код:
ls /etc/X11/
app-defaults             fonts    xinit       Xsession          XvMCConfig
cursors                  rgb.txt  xkb         Xsession.d        Xwrapper.config
default-display-manager  X        Xresources  Xsession.options
root@HatoriHANZO:~#
Активен

Face Your FreeBSD at http://ipolit.hit.bg

Recku

  • Напреднали
  • *****
  • Публикации: 206
  • Distribution: Debian Stable
  • Window Manager: KDE
    • Профил
Оу, да от бързане пиша глупости... :D :D :D
Цитат на: Ipolit
Това не се слага в rc.local а след като се стартира lxde session.
Точно така...
Активен

This aptitude does not have Super Cow Powers.

alkor

  • Напреднали
  • *****
  • Публикации: 135
    • Профил
Recku в Lubuntu липсва xorg.conf. bIpolit този файл също не съществува .config/autostart
Активен

Ipolit

  • Напреднали
  • *****
  • Публикации: 417
    • Профил
    • WWW
значи имам предвид /home/alkor/.config/autostart
но не изключвам и да не съществува.
Принципът е че трябва да си направиш едно изпълнимо файлче, примерно keyboard и в него да сложиш тези редове. После да си направиш десктоп файл, който да стартира това файлче. Десктоп файловете са нещо от вида на keyboard.desktop за име и съдържание
Код:
[Desktop Entry]
Encoding=UTF-8
Name=keyboard
Comment=Change keyboard layout
Exec=lxterminal --command "/home/alkor/keyboard" #това е пътя до файлчето
Terminal=true

и този файл keyboard.desktop го слагаш в /home/alkor/.config/autostart
Но може твойто наистина да няма .config/autostart
Иначе просто като влезеш изпълнявай този файл keyboard в терминала.
Естествено трябва да го направиш изпълним
cmod 777 keyboard

./keyboard
Активен

Face Your FreeBSD at http://ipolit.hit.bg

alkor

  • Напреднали
  • *****
  • Публикации: 135
    • Профил
Ето още едно решение на проблема. Влиза се в терминал като root и ис изпълнява следната команда 
dpkg-reconfigure console-setup
след което правиш настройките през терминал. Тук само не успях да сложа българския флаг при смяна на клавиатурната подредба. Ще пробвам и твоя вариант, за да видя кой е по-удачен.
Активен

Ipolit

  • Напреднали
  • *****
  • Публикации: 417
    • Профил
    • WWW
за флага си сложи fbxkb.
пак с такъв аутостарт. то не прави нищо освен да показва флага
Активен

Face Your FreeBSD at http://ipolit.hit.bg

dvd

  • Участници
  • ***
  • Публикации: 11
  • Distribution: Debian testing/unstable
  • Window Manager: E17
    • Профил
за флага си сложи fbxkb.
пак с такъв аутостарт. то не прави нищо освен да показва флага
Може и xxkb ако искаш всеки прозорец да е с отделен layout.
Активен

biggie

  • Напреднали
  • *****
  • Публикации: 142
  • Distribution: Crunchbang Linux
  • Window Manager: openbox
    • Профил
има си applet в lxpanel за целта - keyboard layout switcher :)
Активен

mind_exploit

  • Напреднали
  • *****
  • Публикации: 60
    • Профил
setxkbmap -option grp:ctrl_shift_toggle,grp_led:scroll us,bg   #това за смяна с контрол и шифт us,bg(bds)
setxkbmap -option grp:ctrl_shift_toggle,grp_led:scroll us,bg -varian ,phonetic #това за us,bg(phonetic)

Като влезеш в сесията, трябва да го изпълниш. Най-добре е да го пъхнеш в .config/autostart

Еее, направо ми спасихте живота :) ... вече и аз не знам от колко време се мъча да го оправя това :)
Мерси много :) ...
Активен

Neven Boyanov

  • Новаци
  • *
  • Публикации: 1
    • Профил
Тази статия наистина ми помогна да си реша проблема с LXDE и клавиатурната подредба.

Ето какво направих аз за да се стартира всеки път ...
 - във файла autostart добавих командата описана по-горе, при мен това е:
Код:
setxkbmap -option grp:alt_shift_toggle,grp_led:scroll us,bg -variant ,bas_phonetic
- файлът се намира в ~/.config/lxsession/LXDE, но може и да го няма все още, така че да се наложи да бъде създаден.
- това трябва да се направи за всеки потребител който иска да ползва различни клавиатурни подредби.

Друг вариант би бил да се сложи в /etc/xdg/lxsession/LXDE/autostart, но това не съм го пробвал. В този случай би трябвало да тръгва за всеки потребител. Всъщност правил съм го, но за друга програма - conky - работи безпроблемно.

За индикация ползвам панела който се предоставя с LXDE.

Активен