Автор Тема: лап топ toshiba L30-115 ati vga и убунту  (Прочетена 4308 пъти)

aliver

  • Напреднали
  • *****
  • Публикации: 12
  • поръчал съм два тира интернет
    • Профил
С toshiba L30-115 и при логване не ми зарежда - смисъл тъмен екран но има мишка (не винаги). Това при преся от 8.10 нагоре иначе . 7.10 няма проблем ,.
Четох че можеби прави проблем самата видео карта с драйвера , но не зная как да процедирам . другото което е и при всички дистрибуции нямам звук с realtek ALC861 съм .

Въпроса е как под рецовъри мод да направя следното :
Цитат
Some ATI cards don't need their proprietary drivers to work with Compiz as the open-sourced driver (radeon) also has support for 3D acceleration. However, the open-sourced driver isn't as fast as the closed-sourced (fglrx) one, so if you need the proprietary one you'll have to tinker around in the terminal a little.

1. After you've installed the driver, either through the proprietary manager or directly from ATI's site, you'll have to setup the Xorg configuration file to work with your new driver. Always remember to back up the original file before altering, in case something goes wrong. Open up a terminal and enter:

  sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

  sudo aticonfig --initial --input=/etc/X11/xorg.conf

This will disable the default radeon driver and replace it with ATI's own.


2. Now, let's tell Compiz not to care about drivers that are blacklisted:

  echo SKIP_CHECKS="yes" >> $HOME/.config/compiz/compiz-manager

Alternatively, you could whitelist the driver, which is a much prettier solution. Run this command to edit the Compiz startup-script:

 gksudo gedit /usr/bin/compiz

Search for Driver whitelist and add fglrx to the end of the line, like this:

 # Driver whitelist
 WHITELIST="nvidia intel ati radeon i810 fglrx"


3. Reboot your computer, login and enable Compiz as mentioned above et voilà! Behold Compiz and ATI hugging.

за начинаещ като мен е малко трудно да го направя в терминал

ето как става и звука :

Цитат

Adding SND_PCI_QUIRK(0x1179, 0xff31, "Toshiba", ALC861_TOSHIBA) to the realtek_patch.c worked for me.

Sound is working perfect now.

For those who dont know how to patch this, its quite simple.

Open alsa-driver-1.0.XX/alsa-kernel/pci/hda/patch_realtek.c in a text editor

search for 'snd_pci_quirk alc861vd_cfg_tbl[] = {' without quotes
add 'SND_PCI_QUIRK(0x1179, 0xff31, "Toshiba", ALC861_TOSHIBA),' without quotes below.

Compile the source and install as usual.

« Последна редакция: Oct 29, 2010, 19:14 от aliver »
Активен

cybercop

  • Напреднали
  • *****
  • Публикации: 5589
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: лап топ toshiba L30-115 ati vga и убунту
« Отговор #1 -: Oct 29, 2010, 19:51 »
Какво Убунту 8.10 бе пич. То е история. Приеми, че не съществува. Или 8.04 или 10.04. Ако 10.04 ти е тежко за хардуера инсталираш xubuntu. Липсата на звук е твърде вероятно да се дължи не на липсващи драйвъри, а на намалени докрай контролери PCM и Front на звуковият миксер.
« Последна редакция: Oct 29, 2010, 19:53 от cybercop »
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

aliver

  • Напреднали
  • *****
  • Публикации: 12
  • поръчал съм два тира интернет
    • Профил
Re: лап топ toshiba L30-115 ati vga и убунту
« Отговор #2 -: Oct 29, 2010, 19:56 »
Гледай за да падна на тази дистрибуция значи има проблем с най-новите .
Първо сложих 10.10 не тръгна , после 10.4 и така надоло докато не тръгна 7.10 така въпроса е труден защо после при ъпгрейт пак става така . сега пак ще мъча едни неща
Активен

cybercop

  • Напреднали
  • *****
  • Публикации: 5589
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: лап топ toshiba L30-115 ati vga и убунту
« Отговор #3 -: Oct 29, 2010, 20:53 »
Ако Убунту 8.04 или xubuntu 10.04 не върви, значи трябва да смениш дистрибуцията. Има Mandriva xfce, Fedora xfce, Sabayon xfce. Все лесни за настройка дистрибуции. Ако и xfce графичната среда ти е тежка, пробвай lxde. прочетох характеристиките на лаптопа. Стандартно е с 256 MB RAM, а процесорът е приличен. Просто сложи още малко RAM и мисля, че няма да имаш проблеми. При 256 RAM на Убунту 10.04 няма да стартира графичната среда, а xubuntu ще работи много бавно.
« Последна редакция: Oct 29, 2010, 21:03 от cybercop »
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

ROKO__

  • Напреднали
  • *****
  • Публикации: 1531
  • Distribution: Calculate Linux Workstation amd64
  • Window Manager: GNOME 2.30
  • AMD Athlon64 4000+ Dual Core 2100 MHz 2MB L2 cache
    • Профил
Активен

Не е важно да си добър, важно е да си най добрия!!!

http://www.calculate-linux.ru/
http://www.agilialinux.ru/

b2l

  • Напреднали
  • *****
  • Публикации: 4786
  • Distribution: MCC Interim
  • Window Manager: - // - // -
  • ...sometimes I feel like screaming... || RTFM!
    • Профил
    • WWW
Re: лап топ toshiba L30-115 ati vga и убунту
« Отговор #5 -: Oct 29, 2010, 21:00 »
Да обърнем внимание на 10 градуса разлика между двете снимки :D :D :D.
Активен

"Човекът е въже, опънато между звяра и свръхчовека, въже над пропаст. Човекът е нещо, което трябва да бъде превъзмогнато." - Фр. Ницше

cybercop

  • Напреднали
  • *****
  • Публикации: 5589
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: лап топ toshiba L30-115 ati vga и убунту
« Отговор #6 -: Oct 29, 2010, 21:06 »
Не знам за градусите, но това, което виждам на снимките ми харесва. Предполагам, че ще върви на 256 MB RAM, така, че може и това да е решението.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

aliver

  • Напреднали
  • *****
  • Публикации: 12
  • поръчал съм два тира интернет
    • Профил
Re: лап топ toshiba L30-115 ati vga и убунту
« Отговор #7 -: Oct 29, 2010, 21:29 »
Да правилно че е по принцип с 256 :) но съм сложил една допълнителна плочка  1г :) , това което разбрах че "Л" серията имат доста проблеми със звука  а това че не стартира е това че не видеото е 2Д  а повечето версии на убунту има нужда от 3д  и трябва да се сложи самия драйвер и от там се настройва

Код:
Notes

The ATI Radeon Xpress 200M included in the L30 can work with either the open source radeon module or ATI's proprietary fglrx module. However the 200M has minimal 3D support so there isn't much point in installing the fglrx module.

The sound system in the L30 does not work without patching the ALSA code so it will require some compiling work for it to being functioning. More information on this issue can be found on here.
Summary

The sound issue in Linux that the Toshiba Satellite L30 currently has makes this a poorly supported laptop for Linux.

ха ми аз така го разбрах ;)
Активен

cybercop

  • Напреднали
  • *****
  • Публикации: 5589
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: лап топ toshiba L30-115 ati vga и убунту
« Отговор #8 -: Oct 29, 2010, 21:37 »
Напиши xserver в Synaptic и виж какви драйвъри ще ти излязат. Това, че някой драйвър го няма на диска, не означава, че липсва и в хранилищата.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

aliver

  • Напреднали
  • *****
  • Публикации: 12
  • поръчал съм два тира интернет
    • Профил
Re: лап топ toshiba L30-115 ati vga и убунту
« Отговор #9 -: Oct 30, 2010, 00:08 »
Цитат
Напиши xserver в Synaptic и виж какви драйвъри ще ти излязат.
Така сложих си пак версията 7.10 (защото другите не могат  ) така на синпатика всички са маркитани (инсталирани без един които може и да не се слага )
само restricted drivers нямам отметка на ATI accelerated graphics driver , a там ми е и wifi  atheros hardware access layer (hal)

ето и изхода на командата :

Цитат
lspci -v

Код:
00:00.0 Host bridge: ATI Technologies Inc Unknown device 5a31 (rev 01)
Subsystem: Toshiba America Info Systems Unknown device ff31
Flags: bus master, 66MHz, medium devsel, latency 64

00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge (prog-if 00 [Normal decode])
Flags: bus master, 66MHz, medium devsel, latency 64
Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
I/O behind bridge: 00009000-00009fff
Memory behind bridge: d0100000-d01fffff
Prefetchable memory behind bridge: d4000000-d7ffffff
Capabilities: [b0] Subsystem: ATI Technologies Inc RS480 PCI Bridge

00:12.0 IDE interface: ATI Technologies Inc 4379 Serial ATA Controller (rev 80) (prog-if 8f [Master SecP SecO PriP PriO])
Subsystem: Toshiba America Info Systems Unknown device ff31
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16
I/O ports at 8440 [size=8]
I/O ports at 8430 [size=4]
I/O ports at 8420 [size=8]
I/O ports at 8410 [size=4]
I/O ports at 8400 [size=16]
Memory at d0004000 (32-bit, non-prefetchable) [size=512]
[virtual] Expansion ROM at 10000000 [disabled] [size=512K]
Capabilities: [60] Power Management version 2
Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-

00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80) (prog-if 10 [OHCI])
Subsystem: Toshiba America Info Systems Unknown device ff31
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 17
Memory at d0005000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-

00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80) (prog-if 10 [OHCI])
Subsystem: Toshiba America Info Systems Unknown device ff31
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 17
Memory at d0006000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-

00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80) (prog-if 20 [EHCI])
Subsystem: Toshiba America Info Systems Unknown device ff31
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 17
Memory at d0007000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [dc] Power Management version 2
Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-

00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 81)
Subsystem: Toshiba America Info Systems Unknown device ff31
Flags: 66MHz, medium devsel
I/O ports at 8040 [size=16]
Memory at d0004400 (32-bit, non-prefetchable) [size=1K]

00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller (rev 80) (prog-if 88 [Master SecP])
Subsystem: Toshiba America Info Systems Unknown device ff31
Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 18
I/O ports at 01f0 [size=8]
I/O ports at 03f4 [size=1]
I/O ports at 0170 [size=8]
I/O ports at 0374 [size=1]
I/O ports at 8460 [size=16]
Capabilities: [70] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-

00:14.2 Audio device: ATI Technologies Inc SB450 HDA Audio (rev 01)
Subsystem: Toshiba America Info Systems Unknown device ff31
Flags: bus master, slow devsel, latency 64, IRQ 18
Memory at d0000000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-

00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
Subsystem: Toshiba America Info Systems Unknown device ff31
Flags: bus master, 66MHz, medium devsel, latency 0

00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80) (prog-if 01 [Subtractive decode])
Flags: bus master, 66MHz, medium devsel, latency 64
Bus: primary=00, secondary=09, subordinate=0e, sec-latency=64
I/O behind bridge: 0000a000-0000afff
Memory behind bridge: d0200000-d02fffff

01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M] (prog-if 00 [VGA])
Subsystem: Toshiba America Info Systems Unknown device ff31
Flags: bus master, 66MHz, medium devsel, latency 66, IRQ 11
Memory at d4000000 (32-bit, prefetchable) [size=64M]
I/O ports at 9000 [size=256]
Memory at d0100000 (32-bit, non-prefetchable) [size=64K]
[virtual] Expansion ROM at d0120000 [disabled] [size=128K]
Capabilities: [50] Power Management version 2
Capabilities: [80] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-

09:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Subsystem: Toshiba America Info Systems Unknown device ff31
Flags: bus master, medium devsel, latency 64, IRQ 19
I/O ports at a000 [size=256]
Memory at d0210000 (32-bit, non-prefetchable) [size=256]
Capabilities: [50] Power Management version 2

09:04.0 Ethernet controller: Atheros Communications, Inc. AR2413 802.11bg NIC (rev 01)
Subsystem: Askey Computer Corp. Unknown device 7094
Flags: bus master, fast Back2Back, medium devsel, latency 168, IRQ 16
Memory at d0200000 (32-bit, non-prefetchable) [size=64K]
Capabilities: [44] Power Management version 2


Редактирано от bop_bop_mara - оправих малко форматирането :)
« Последна редакция: Oct 30, 2010, 00:23 от bop_bop_mara »
Активен

ROKO__

  • Напреднали
  • *****
  • Публикации: 1531
  • Distribution: Calculate Linux Workstation amd64
  • Window Manager: GNOME 2.30
  • AMD Athlon64 4000+ Dual Core 2100 MHz 2MB L2 cache
    • Профил
Re: лап топ toshiba L30-115 ati vga и убунту
« Отговор #10 -: Oct 30, 2010, 09:09 »
Не знам за градусите, но това, което виждам на снимките ми харесва. Предполагам, че ще върви на 256 MB RAM, така, че може и това да е решението.

При 64МБ си върви безгрижно
Активен

Не е важно да си добър, важно е да си най добрия!!!

http://www.calculate-linux.ru/
http://www.agilialinux.ru/

aliver

  • Напреднали
  • *****
  • Публикации: 12
  • поръчал съм два тира интернет
    • Профил
Re: лап топ toshiba L30-115 ati vga и убунту
« Отговор #11 -: Nov 28, 2010, 14:36 »
Проблема е решен на половина !!! Ще обясня първия случай след инсталация на Убунту 10.04 (успях да сложа тази версия с 1г рам -старата 1г беше нещо бъгава но я смениха сега всичко е ок) имах звук само със слушалки , но не и на говорителите . Сега имам на говорителите но не и на слушалки - не ми трябва там за сега !!!

Ето процедурате е много лесна но трябва да знаеш какво да напишеш :

В терминал пишете :

Цитат
sudo nano /etc/modprobe.d/alsa-base.conf

за версия 10.04 (по старите мисля че е sound не знам)

и добавяте ред :

Цитат
options snd-hda-intel model=uniwill-m31 position_fix=1

Запазвате и рестарт!

Мен този ред ми пусна звука !!!
Има още няколко вариянта и те са :
model=toshiba
model=6stack-digout
тези последните не съм си играл с тях поне за сега

Можете да сложите SLOVE  на темата   Ако трябва да напиша нова тема не е проблем !
Активен