Автор Тема: 3 ethernet cards проблем  (Прочетена 1644 пъти)

chonny

  • Участник
  • *****
  • Публикации: 16
    • Профил
3 ethernet cards проблем
« -: Jul 06, 2004, 11:14 »
Имам рутер с 3 лан карти. Доставчикът ми е с кабелни модеми и тъй като имам два модема се опитвам да дублирам скороста. Когато пусна двата интерфейса към доставчикът ми се губят връзките. Имате ли идея защо?Като дам единият down другият си върви и обратно. Адресирте са ех. 100.200.200.141 и 100.200.200.147. На третият интерфейс ми е локалата мрежа. RedHat 9.1

ps Дали има нещо общо с това че ползват една мрежа и линукса се бърка по кой интерфейс да праща пакетите.
Активен

ntenev

  • Участник
  • *****
  • Публикации: 125
    • Профил
3 ethernet cards проблем
« Отговор #1 -: Jul 06, 2004, 13:28 »
Тъй като не успях да разбера точно проблема това по-скоро се явява като няколко допълнителни въпроса за да видя дали изобщо мога да ти помогне ( поне желание имам а ? '<img'> )

След като това е рутер провери ipforward дали е активно (във файла /proc/sys/net/ipv4/ip_forward трябва да имаш стойност 1). Докато изрично не го забраниш машината ти ще отговаря за всяко IP което има през всеки един интерфейс. В смисъл:

ако:

eth0 - 100.200.200.141
eth1 - 100.200.200.147
eth2 - 192.168.0.1

и на eth2 дойде заявка за 100.200.200.141 рутера ще я приеме и т.н.

Това може да е причина когато единия модем е down нещата да вървят, а когато са 2 не ... макар че пак би трябвало.

От друга страна причина може да е това че заявките ти излизат през единия, но се връщат през другия и машината ти да се сърди. Това може да го провериш като пуснеш ping до машината след теб и с tcpdump провериш какво се чува по интерфейсите.

Третото което не разбрах е какво разбираш под дублиране на връзка ? Единия модем да стои като backup на другия или паралелно да ползваш и двата ?

Предполагам че ако дадеш малко инфо от ifconfig и route -n също би било полезно както и начина (редовете) с които вдигаш интерфейсите и сетваш route таблицата.

Сетих се и за още нещо ... щом си с модеми, може би адресите ти идват по DHCP и тогава, когато втория модем си вземе IP-то, той взема и нов default gateway който подменя този от първия модем ... предполагам че маскираш адресите от вътрешната ти мрежа и в такъв случай може би е по-удачно да се използва -j MASQUERADE вместо SNAT ... а и ако проблема с gateway е този, трябва да се потърси начин да прави така че единия да не подменя другия а да се добавя (сещам се за един-два варианта) ... но пък я има проблематиката че DHCP обновява стойностите през някакъв интервал от време и трябва и това да се предвиди.

Това мога да ти кажа засега. Ако дадеш още малко инфо сигурно може да се намери добро решение '<img'>

Поздрави
Н. Тенев
Активен

  • Гост
3 ethernet cards проблем
« Отговор #2 -: Jul 06, 2004, 16:00 »
Цитат (chonny @ Юли 06 2004,12:14)
Имам рутер с 3 лан карти. Доставчикът ми е с кабелни модеми и тъй като имам два модема се опитвам да дублирам скороста. Когато пусна двата интерфейса към доставчикът ми се губят връзките. Имате ли идея защо?Като дам единият down другият си върви и обратно. Адресирте са ех. 100.200.200.141 и 100.200.200.147. На третият интерфейс ми е локалата мрежа. RedHat 9.1

ps Дали има нещо общо с това че ползват една мрежа и линукса се бърка по кой интерфейс да праща пакетите.

dual routing tables & WCCP & load balansing
Активен

chonny

  • Участник
  • *****
  • Публикации: 16
    • Профил
3 ethernet cards проблем
« Отговор #3 -: Jul 06, 2004, 16:48 »
Ок.
Значи да ти отговоря на въпроситте :
Със статични реални IP адреси съм.
IP_forward е включен. другото което предполагаш че зачвките излизат от единят и идват от другия също не е така защото те въобще не излизат. Като пусна двата външни интерфейса просто нищо не се пингва.
Под дублиране на връзката имам предвид да я удвоя. Ако сега те е 15 КВ да стане 30КВ
Активен

ntenev

  • Участник
  • *****
  • Публикации: 125
    • Профил
3 ethernet cards проблем
« Отговор #4 -: Jul 06, 2004, 17:04 »
опитай, когато си пуснал ping, да обходиш интерфейсите със:
tcpdump -n -i eth?

и виж .. все от някой трябва да излизат icmp echo request и въпроса е дали се получават icmp echo replay, а ако се получават - къде точно ?

Няма логика нещо да умира когато пуснеш втория модем, по-скоро се получава някакво рамазване по route таблицата. Дай резултатите от ifconfig и route -n със и без втория модем. Може да добавиш и резултатите от tcpdump. Да подкараме мрежата а после ще правим дублирането, че то е малко по-особенна материя '<img'>

Успех и поздрави
Н. Тенев
Активен

  • Гост
3 ethernet cards проблем
« Отговор #5 -: Jul 06, 2004, 19:21 »
http://www.lartc.org
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
hwdata и /usr/X11R6/lib/X11/Cards
Хардуерни и софтуерни проблеми
vstoykov 3 1057 Последна публикация Feb 26, 2005, 19:30
от rpetrov
2 LAN cards
Настройка на хардуер
nb 3 1074 Последна публикация May 10, 2005, 09:59
от toxigen
Lan Cards install
Настройка на хардуер
Hel1Fire 20 2565 Последна публикация Sep 05, 2005, 20:52
от Agent_SMITH
Debian sound cards
Настройка на хардуер
BayDragoy 3 1180 Последна публикация Oct 01, 2005, 02:52
от divak
Информация за Network cards
Настройка на хардуер
clovenhoof 13 1683 Последна публикация Jan 07, 2012, 14:22
от clovenhoof