Автор Тема: няма българско лейоут и в яст2 а иначе в гном си го има  (Прочетена 771 пъти)

liubo1

  • Участник
  • *****
  • Публикации: 83
    • Профил
здравейте тъкмо спря да ми се рестартира лаптопа ( http://www.linux-bg.org/forum/index.php?topic=44943.0 ) (само да кажа че си инсталирах графична среда ЛХДЕ и от тогава не се рестартира доста странно) но пък сега няма българско лейоут и в яст2 а иначе в гном си го има.. намерих следната команда setxkbmap bg phonetic обаче тя ми замества английската с бг и си остава само бг без анг.. Как да го оправя да си ги имам и 2те. В яст просто няма бг за добавяне това ми е проблема
Активен

cybercop

  • Участник
  • *****
  • Публикации: 5561
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
В Open SUSE и LXDE, клавиатурните подредби се настройват, като се редактира xorg.conf. Не съм сигурен и дали клавиатурната подредба не беше в друг файл, също в etc.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

liubo1

  • Участник
  • *****
  • Публикации: 83
    • Профил
xorg.conf.d i posle 90-keytable.conf :
Section "InputClass"
   Identifier "LocalKeyboard"
   MatchIsKeyboard "on"
   Option   "XkbLayout"   "us"
EndSection

...изтрито... :D :-[

Редактирано, съгласно т. 3 от Правилата на форума. Може да използваш вградения конвертор на форума (бутончето „Клавиатура“). Ако има проблем с него, пиши.
bop_bop_mara
« Последна редакция: Юни 10, 2013, 19:32 от bop_bop_mara »
Активен

dejuren

  • Участник
  • *****
  • Публикации: 1025
  • Distribution: Ubuntu, RedHat
  • Window Manager: lxde KDE4
    • Профил
Код:
drago@tt:~$  cat /etc/default/keyboard
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="us,bg" #клавиатурни подретби
XKBVARIANT=",phonetic" #варианти
XKBOPTIONS="grp:toggle" #бутон за превключване (десен Alt)

http://wiki.lxde.org/en/Change_keyboard_layouts
https://wiki.archlinux.org/index.php/LXDE#Keyboard_layout
Активен

http://webchat.freenode.net/?channels=ubuntu-bg
The quieter you become, the more you are able to hear.
Две седмици цъкане с мишката спестяват два часа четене на документацията.

liubo1

  • Участник
  • *****
  • Публикации: 83
    • Профил
оплесках нещата значи ето какво стана редактирах файла xorg.conf.d i posle 90-keytable.conf :
Section "InputClass"
   Identifier "LocalKeyboard"
   MatchIsKeyboard "on"
   Option   "XkbLayout"   "us"
EndSection

като добавих "бг" след "ус" и сега неиска да ми стартира Х. пише че има грешка в тоя файл и неиска. Много моля някой да ми каже как да го редактирам тоя файл чрез терминала за да махна "бг" gksu/gksudu gedit нестава.

П.П - ОПРАВИХ ТОВА ВЕчЕ СЪМ СПОКОЕН :д
« Последна редакция: Юни 10, 2013, 23:07 от liubo1 »
Активен

liubo1

  • Участник
  • *****
  • Публикации: 83
    • Профил
Option "XkbLayout" "us" в файла 90-keytable.conf ако добавя бг след "us" за да стане (-> "us,bg") дали ще прави пак проблеми или вече ще имам и бг?
на мойто пц:
Section "InputClass"
   Identifier "LocalKeyboard"
   MatchIsKeyboard "on"
   Option   "XkbLayout"   "us"
EndSection

и на сайта от който гледам (http://www.xfree86.org/current/XKB-Config2.html) тоя сайт е препратка от първия линк на dejuren.:
Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"

    Option "XkbModel" "logicordless"
    Option "XkbLayout" "us,cz,de"
    Option "XKbOptions" "grp:alt_shift_toggle"
EndSection
« Последна редакция: Юни 10, 2013, 23:06 от liubo1 »
Активен