Автор Тема: Firestarter на Debian 8 „Jessie“ ?  (Прочетена 3933 пъти)

maxich

  • Напреднали
  • *****
  • Публикации: 119
    • Профил
Firestarter на Debian 8 „Jessie“ ?
« -: Jul 05, 2015, 16:05 »
Здравейте,

Опитах да мигрирам към новия Debian и открих че вече не поддържат Firestarter. За моята работа това е ключов инструмент, без който просто не мога да си позволя миграцията. Намерих и дръпнах firestarter_1.0.3-11_i386.deb, инсталирах. Но когато опитвам да стартирам, не става. От една страна, излиза диалогов прозорец със съобщение:
Цитат
„A proper configuration for Firestarter was not found. If you are running Firestarter from the directory you built it in, run 'make install-data-local' to install a configuration, or simply 'make install' to install the whole program.
Firestarter will now close.“

От друга, през Терминала:
Цитат
„Gtk-Message: Failed to load module "canberra-gtk-module"

(firestarter:21065): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.“

„Canberra“ е за звукови съобщения и явно не е проблем, но „firestarter:21065“ се повтаря поне седем пъти при всеки опит за старт

Ако знаете, моля, предложете нещо

_________________________________
PS. Може би темата трябваше да е в раздела за „Настройка на програми“. Не забелязах че я отварям в „Системна Сигурност“
« Последна редакция: Jul 05, 2015, 16:12 от maxich »
Активен

Odido

  • Напреднали
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #1 -: Jul 05, 2015, 23:37 »
Компилирай си го от сорс:
Код
GeSHi (Bash):
  1. wget http://kaz.dl.sourceforge.net/project/firestarter/firestarter/1.0.3/firestarter-1.0.3.tar.gz
  2. tar -xvf firestarter-1.0.3.tar.gz
  3. cd firestarter-1.0.3
  4. ./configure --sysconfdir=/etc
  5. make
  6. make install
Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"

maxich

  • Напреднали
  • *****
  • Публикации: 119
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #2 -: Jul 06, 2015, 15:53 »
Благодаря, но не може да се генерира make-файл. „kaz.dl.sourceforge.net“, който предлагате, не работи. Аз дръпнах веднъж от „kent.dl.sourceforge.net“ и втори път от „cznic.dl.sourceforge.net“. И в двата случая, след tar -xvf firestarter-1.0.3.tar.gz , положението е такова:
Цитат
firestarter-1.0.3/
firestarter-1.0.3/src/
firestarter-1.0.3/src/eggtrayicon.h
firestarter-1.0.3/src/dhcp-server.c
firestarter-1.0.3/src/xpm/
firestarter-1.0.3/src/xpm/firestarter-pixbufs.h
firestarter-1.0.3/src/xpm/icon_locked.png
firestarter-1.0.3/src/xpm/icon_stop_normal.png
firestarter-1.0.3/src/xpm/Makefile.in
firestarter-1.0.3/src/xpm/icon_clear.png
firestarter-1.0.3/src/xpm/pengo.png
firestarter-1.0.3/src/xpm/icon_start_toolbar.png
firestarter-1.0.3/src/xpm/tray_hit4.png
firestarter-1.0.3/src/xpm/icon_wizard.png
firestarter-1.0.3/src/xpm/tray_hit1.png
firestarter-1.0.3/src/xpm/icon_stop_toolbar.png
firestarter-1.0.3/src/xpm/icon_unlocked.png
firestarter-1.0.3/src/xpm/icon_start_normal.png
firestarter-1.0.3/src/xpm/icon_start_large.png
firestarter-1.0.3/src/xpm/icon_locked_large.png
firestarter-1.0.3/src/xpm/tray_hit2.png
firestarter-1.0.3/src/xpm/icon_stop_large.png
firestarter-1.0.3/src/xpm/Makefile.am
firestarter-1.0.3/src/xpm/tray_hit5.png
firestarter-1.0.3/src/xpm/icon_edit.png
firestarter-1.0.3/src/xpm/logo.png
firestarter-1.0.3/src/xpm/tray_hit3.png
firestarter-1.0.3/src/Makefile.in
firestarter-1.0.3/src/savelog.c
firestarter-1.0.3/src/logread.h
firestarter-1.0.3/src/firestarter.h
firestarter-1.0.3/src/netfilter-script.c
firestarter-1.0.3/src/logread.c
firestarter-1.0.3/src/util.c
firestarter-1.0.3/src/gui.h
firestarter-1.0.3/src/savelog.h
firestarter-1.0.3/src/wizard.h
firestarter-1.0.3/src/statusview.h
firestarter-1.0.3/src/service.c
firestarter-1.0.3/src/wizard.c
firestarter-1.0.3/src/scriptwriter.h
firestarter-1.0.3/src/tray.h
firestarter-1.0.3/src/statusview.c
firestarter-1.0.3/src/hitview.h
firestarter-1.0.3/src/firestarter.c
firestarter-1.0.3/src/menus.c
firestarter-1.0.3/src/service.h
firestarter-1.0.3/src/policyview.c
firestarter-1.0.3/src/menus.h
firestarter-1.0.3/src/wizard-choices.c
firestarter-1.0.3/src/tray.c
firestarter-1.0.3/src/scriptwriter.c
firestarter-1.0.3/src/preferences.c
firestarter-1.0.3/src/gui.c
firestarter-1.0.3/src/eggtrayicon.c
firestarter-1.0.3/src/preferences.glade
firestarter-1.0.3/src/policyview.h
firestarter-1.0.3/src/netfilter-script.h
firestarter-1.0.3/src/dhcp-server.h
firestarter-1.0.3/src/hitview.c
firestarter-1.0.3/src/wizard-choices.h
firestarter-1.0.3/src/preferences.h
firestarter-1.0.3/src/Makefile.am
firestarter-1.0.3/src/util.h
firestarter-1.0.3/src/globals.h
firestarter-1.0.3/firestarter.console
firestarter-1.0.3/firestarter.desktop
firestarter-1.0.3/po/
firestarter-1.0.3/po/ro.gmo
firestarter-1.0.3/po/ml.po
firestarter-1.0.3/po/ca.gmo
firestarter-1.0.3/po/ca.po
firestarter-1.0.3/po/pa.gmo
firestarter-1.0.3/po/el.gmo
firestarter-1.0.3/po/de.gmo
firestarter-1.0.3/po/nb.gmo
firestarter-1.0.3/po/ja.po
firestarter-1.0.3/po/hu.gmo
firestarter-1.0.3/po/pl.gmo
firestarter-1.0.3/po/en_CA.gmo
firestarter-1.0.3/po/de.po
firestarter-1.0.3/po/sr@Latn.gmo
firestarter-1.0.3/po/uk.po
firestarter-1.0.3/po/ru.gmo
firestarter-1.0.3/po/sq.gmo
firestarter-1.0.3/po/POTFILES.in
firestarter-1.0.3/po/Makefile.in.in
firestarter-1.0.3/po/da.gmo
firestarter-1.0.3/po/sv.po
firestarter-1.0.3/po/ro.po
firestarter-1.0.3/po/cs.gmo
firestarter-1.0.3/po/az.gmo
firestarter-1.0.3/po/ja.gmo
firestarter-1.0.3/po/pl.po
firestarter-1.0.3/po/it.po
firestarter-1.0.3/po/en_CA.po
firestarter-1.0.3/po/sv.gmo
firestarter-1.0.3/po/es.gmo
firestarter-1.0.3/po/pt.po
firestarter-1.0.3/po/es.po
firestarter-1.0.3/po/az.po
firestarter-1.0.3/po/ga.gmo
firestarter-1.0.3/po/lv.po
firestarter-1.0.3/po/zh_TW.po
firestarter-1.0.3/po/en_GB.po
firestarter-1.0.3/po/fr.po
firestarter-1.0.3/po/hr.gmo
firestarter-1.0.3/po/hr.po
firestarter-1.0.3/po/fi.gmo
firestarter-1.0.3/po/lv.gmo
firestarter-1.0.3/po/da.po
firestarter-1.0.3/po/ml.gmo
firestarter-1.0.3/po/ChangeLog
firestarter-1.0.3/po/nb.po
firestarter-1.0.3/po/tr.gmo
firestarter-1.0.3/po/no.po
firestarter-1.0.3/po/nl.gmo
firestarter-1.0.3/po/zh_CN.po
firestarter-1.0.3/po/ko.po
firestarter-1.0.3/po/hu.po
firestarter-1.0.3/po/zh_TW.gmo
firestarter-1.0.3/po/firestarter.pot
firestarter-1.0.3/po/pt.gmo
firestarter-1.0.3/po/pt_BR.po
firestarter-1.0.3/po/it.gmo
firestarter-1.0.3/po/sq.po
firestarter-1.0.3/po/sr.po
firestarter-1.0.3/po/sr@Latn.po
firestarter-1.0.3/po/ga.po
firestarter-1.0.3/po/ru.po
firestarter-1.0.3/po/pt_BR.gmo
firestarter-1.0.3/po/zh_CN.gmo
firestarter-1.0.3/po/fr.gmo
firestarter-1.0.3/po/en_GB.gmo
firestarter-1.0.3/po/sr.gmo
firestarter-1.0.3/po/ko.gmo
firestarter-1.0.3/po/vi.po
firestarter-1.0.3/po/el.po
firestarter-1.0.3/po/sk.gmo
firestarter-1.0.3/po/fi.po
firestarter-1.0.3/po/nl.po
firestarter-1.0.3/po/vi.gmo
firestarter-1.0.3/po/no.gmo
firestarter-1.0.3/po/sk.po
firestarter-1.0.3/po/cs.po
firestarter-1.0.3/po/pa.po
firestarter-1.0.3/po/uk.gmo
firestarter-1.0.3/po/tr.po
firestarter-1.0.3/INSTALL
firestarter-1.0.3/NEWS
firestarter-1.0.3/aclocal.m4
firestarter-1.0.3/scripts/
firestarter-1.0.3/scripts/Makefile.in
firestarter-1.0.3/scripts/Makefile.am
firestarter-1.0.3/scripts/non-routables
firestarter-1.0.3/config.h.in
firestarter-1.0.3/missing
firestarter-1.0.3/Makefile.in
firestarter-1.0.3/CREDITS
firestarter-1.0.3/intltool-update.in
firestarter-1.0.3/firestarter.pam
firestarter-1.0.3/firestarter.spec
firestarter-1.0.3/firestarter.spec.in
firestarter-1.0.3/intltool-merge.in
firestarter-1.0.3/TODO
firestarter-1.0.3/intltool-extract.in
firestarter-1.0.3/COPYING
firestarter-1.0.3/firestarter.schemas.in
firestarter-1.0.3/config.sub
firestarter-1.0.3/AUTHORS
firestarter-1.0.3/mkinstalldirs
firestarter-1.0.3/configure.in
firestarter-1.0.3/ChangeLog
firestarter-1.0.3/fedora.init
firestarter-1.0.3/install-sh
firestarter-1.0.3/configure
firestarter-1.0.3/firestarter.desktop.in
firestarter-1.0.3/config.guess
firestarter-1.0.3/ltmain.sh
firestarter-1.0.3/README
firestarter-1.0.3/autogen.sh
firestarter-1.0.3/stamp-h.in
firestarter-1.0.3/pixmaps/
firestarter-1.0.3/pixmaps/Makefile.in
firestarter-1.0.3/pixmaps/firestarter.png
firestarter-1.0.3/pixmaps/Makefile.am
firestarter-1.0.3/Makefile.am

После, от ./configure --sysconfdir=/etc следва (:), но от къде да дръпна „automake-1.4“ и дали ще функционира, защото в Debian 8 се предлага най-много automake-1.14 и въпреки че съм го инсталирал, явно не бачка. Също, това „aclocal-1.4“ го няма за сваляне, в т.ч. като съм пъхнал инсталационния диск
Цитат
checking for intltool >= 0.30... 0.31.2 found
checking for perl... /usr/bin/perl
checking for XML::Parser... ok
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets $(MAKE)... yes
checking for working aclocal-1.4... missing
checking for working autoconf... found
checking for working automake-1.4... missing
checking for working autoheader... found
checking for working makeinfo... found
checking whether to enable maintainer-specific portions of Makefiles... no
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for library containing strerror... none required
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ANSI C... (cached) none needed
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether make sets $(MAKE)... (cached) yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a sed that does not truncate output... /bin/sed
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking how to run the C++ preprocessor... g++ -E
checking for g77... no
checking for f77... no
checking for xlf... no
checking for frt... no
checking for pgf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for f90... no
checking for xlf90... no
checking for pgf90... no
checking for epcf90... no
checking for f95... no
checking for fort... no
checking for xlf95... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for gfortran... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether  accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc static flag  works... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC
checking if g++ PIC flag -fPIC works... yes
checking if g++ supports -c -o file.o... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
appending configuration tag "F77" to libtool
checking what warning flags to pass to the C compiler... -Wall -Wmissing-prototypes
checking what language compliance flags to pass to the C compiler...
Using config source xml:merged:/etc/gconf/gconf.xml.defaults for schema installation
Using $(sysconfdir)/gconf/schemas as install directory for schema files
checking for gconftool-2... /usr/bin/gconftool-2
checking for pkg-config... no
*** The pkg-config script could not be found. Make sure it is
*** in your path, or set the PKG_CONFIG environment variable
*** to the full path to pkg-config.
*** Or see http://www.freedesktop.org/software/pkgconfig to get pkg-config.
configure: error: Library requirements (libgnome-2.0 >= 2.0.0
                  libgnomeui-2.0 >= 2.0.0
                  gtk+-2.0 >= 2.4.0
                  gnome-vfs-2.0 >= 2.6.0
        libglade-2.0 >= 2.3.6) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

libgnome-2-0, версия 2.32.1-5, също е инсталиран. Има само libgnomeui-0, версия 2.24.5-3 -- инсталиран. gtk+-2.0 и gnome-vfs-2.0 изобщо не намирам. libglade2-0 е инсталиран, версия 1:2.6.4-2

И в крайна сметка, make дава:
Цитат
make: *** No targets specified and no makefile found.  Stop.
« Последна редакция: Jul 06, 2015, 17:00 от maxich »
Активен

Odido

  • Напреднали
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #3 -: Jul 07, 2015, 22:22 »
Една от причините поради ,които зарязах дебиан....Помня ,че правих врътки за да надграждам пакетите ,като добавях тестинг хранилище и после замразявах версиите им да не се даунгрейднат.Така инсталирах програми ,които искаха по-новите библиотеки ,особени ядове имаше  c версията на libc,от която зависи сумати софтуер...
Сега даже ме е яд ,че не вдигнах някакъв блог ,за да си описвам експериментите,щяха да са от помощ на някой.
« Последна редакция: Jul 07, 2015, 22:25 от Odido »
Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"

cybercop

  • Напреднали
  • *****
  • Публикации: 5578
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #4 -: Jul 07, 2015, 22:49 »
Намерих и дръпнах firestarter_1.0.3-11_i386.deb, инсталирах.
Как го инсталирахте ?  Свалих .deb пакета. В Ubuntu 14.04 всички зависимости са налични, но са 20 броя.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

Odido

  • Напреднали
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #5 -: Jul 08, 2015, 00:40 »
Намерих и дръпнах firestarter_1.0.3-11_i386.deb, инсталирах.
Как го инсталирахте ?  Свалих .deb пакета. В Ubuntu 14.04 всички зависимости са налични, но са 20 броя.
Ubuntu ползва по-нови версии на задължителните за пакета библиотеки.Стабилния дебиан го закотвят с последните версии от момента на замразяването му и не ги барат почти през целия рилийз.Затова и предполагам са махнали от хранилището firestarter-a.
Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"

maxich

  • Напреднали
  • *****
  • Публикации: 119
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #6 -: Jul 09, 2015, 08:39 »
Намерих и дръпнах firestarter_1.0.3-11_i386.deb, инсталирах.
Как го инсталирахте ?  Свалих .deb пакета. В Ubuntu 14.04 всички зависимости са налични, но са 20 броя.

*.deb файлове се инсталират елементарно с инсталатора на пакети. Не съм имал видими проблеми със зависимости, после в „Synaptic“ приложението си е обозначено като инсталирано и, всъщност, аз мигрирах от Ubuntu към Debian 7 именно защото в непрекъснато обновяваното Ubuntu вече Firestarter не можеше да работи. Firestarter действително е старичко приложение, явно не го обновяват от доста време, но е незаменимо в редица аспекти от гледна точка на всичко друго, което би могло да се ползва за такива цели. И мисля, че ако тук намерим начин да го подкараме също на Debian 8, ще да бъдем полезни, най-малкото за хората в България, съпричастни с тази дистрибуция

По-късно през деня, когато имам време да превключа операционната, ще отбележа и как стои въпроса за инсталираните зависимости
« Последна редакция: Jul 09, 2015, 08:45 от maxich »
Активен

cybercop

  • Напреднали
  • *****
  • Публикации: 5578
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #7 -: Jul 09, 2015, 09:19 »
...всъщност, аз мигрирах от Ubuntu към Debian 7 именно защото в непрекъснато обновяваното Ubuntu вече Firestarter не можеше да работи. ..
Не работи или изобщо не стартира ?
Мога да те уверя, че обновявам Ubuntu непрекъснато и, досега не ми се е случало приложение, обезпечено със зависимости да не работи, освен, ако самият издател не е прекратил предоставяна от него услуга. Напоследък, в Debian съвсем са го ударили през просото. Неотстранените критични бъгове непрекъснато се трупат. От кръпката с която отстраниха бъга със загуба на данни в RAID, десет дни след другите дистрибуции, не са пипнали нищо. Ubuntu, отстраниха оттогава няколко критични бъга в същото ядро.
За приложението :
http://s19.postimg.org/546h3ru29/firest1.png
http://s19.postimg.org/k2ovy794j/firestarter.png
Взех пакета от хранилищата на Ubuntu 12.04 и го инсталирах на актуализирано до вчерашна дата Ubuntu 14.04.
« Последна редакция: Jul 09, 2015, 09:27 от cybercop »
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

maxich

  • Напреднали
  • *****
  • Публикации: 119
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #8 -: Jul 09, 2015, 09:43 »
Не, нямаше как вече да се подкара тогава в новото Ubuntu, проблемът се натрупваше с предходните обновления, където преставаха да функционират отделни функции на Firestarter, писна ми да се занимавам с конкретни бъгове -- bugs.launchpad.net/ubuntu/+source/firestarter/+bug/705704 -- и просто, моля, да не изместваме темата. Ако искате да коментирате сравнения между Debian и Ubuntu в тази връзка, отворете нова

Току що проверих зависимостите едно по едно в Debian 8 и, точно както в Debian 7, всички са налице -- инсталирани и в необходимите изисквания за версия
« Последна редакция: Jul 09, 2015, 09:56 от maxich »
Активен

Odido

  • Напреднали
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #9 -: Jul 09, 2015, 11:01 »
Ами показаното от терминала казва друго....Не е проблем да се инсталира,просто трябват малко гимнастики с риск да се омаже нещо
Както казах вероятно пакетите в системата са с по-ниска версия от задължителните за инсталация на програмата.
системата ти подсказва за проблема
Код
GeSHi (Bash):
  1. gnome-vfs-2.0 >= 2.6.0
  2. gtk+-2.0 >= 2.4.0

                  извади ми настоящите версии на библиотеките  ,които ползваш в момента с :
Код
GeSHi (Bash):
  1. apt-cache show  gnome-vfs
  2. apt-cache show gtk+
« Последна редакция: Jul 09, 2015, 11:05 от Odido »
Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"

cybercop

  • Напреднали
  • *****
  • Публикации: 5578
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #10 -: Jul 09, 2015, 11:28 »
Не, нямаше как вече да се подкара тогава в новото Ubuntu, проблемът се натрупваше с предходните обновления, където преставаха да функционират отделни функции на Firestarter, писна ми да се занимавам с конкретни бъгове
Доколкото прочетох, разработката на приложението е спряна в началото на 2005г. Пишете, че е невъзможно да мигрирате към друга защитна стена, но ви препоръчвам да потърсите актуална алтернатива.
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

maxich

  • Напреднали
  • *****
  • Публикации: 119
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #11 -: Jul 09, 2015, 11:59 »
...
                  извади ми настоящите версии на библиотеките  ,които ползваш в момента с :
Код
GeSHi (Bash):
  1. apt-cache show  gnome-vfs
  2. apt-cache show gtk+
Както отбелязах, всички зависимости са налице и отговорят на изискванията за версия. Конкретно за пакетите, които питате, Firestarter зависи от libgnomevfs2-0 (>=1:2.17.90) и libgtk2.0-0 (>=2.8.0). В Debian 8 са инсталирани съответно:

libgnomevfs2-0 , версия: 1:2.24.4-6+b1
libgtk2.0-0 , версия 2.24.25-3
Активен

KPETEH

  • Напреднали
  • *****
  • Публикации: 584
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #12 -: Jul 09, 2015, 12:11 »
Прочитайки много внимателно всеки пост от темата въпреки че дебиан не съм пипал от много време изникват няколко въпроса към автора.

1. Защо единствено Firestarter има ли някаква сериозна причина ?
2. Пробвано ли е да се ползва ufw като заместител ?
Активен

Най-добрата страна на алчността е способността и да стопява коефициента на интелигентност дори на най-умния човек.

maxich

  • Напреднали
  • *****
  • Публикации: 119
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #13 -: Jul 09, 2015, 12:59 »
Проблемът е как да подкараме Firestarter на Debian 8. Ако имаше друго толкова гениално с тази функционалност, като Firestarter, отдавна щях да го открия. Всъщност, ползвам и ufw, както и приложения за наблюдение на свързаността и трафика, но нито едно от тях, не ми предоставя всичко онова, което прави Firestarter
« Последна редакция: Jul 09, 2015, 13:20 от maxich »
Активен

Odido

  • Напреднали
  • *****
  • Публикации: 627
  • Distribution: Arch Linux
  • Window Manager: Gnome
    • Профил
Re: Firestarter на Debian 8 „Jessie“ ?
« Отговор #14 -: Jul 09, 2015, 14:04 »
не съм го пипал от 2 години някъде , та ще сложа виртуалка на дебиан да видя за какво точно става въпрос и ще постна ако има развитие по темата.Не вярвам да не може да се инсталира.
Активен

"Congratulations, you broke the Internet
Look at what you did! Are you happy now?"