Автор Тема: Chrome 57 няма да обновява Flash (проблеми с Debian, Windows)  (Прочетена 3307 пъти)

remotexx

  • Напреднали
  • *****
  • Публикации: 810
    • Профил
Откак ми се обнови Хрома до версия 57 (признавам си без бой под Уиндоус, ама предполагам навсякъде е така) и ми изчезнаха плъгининте т.е. chrome://plugins  и нъцки, но не ми е това основния проблем
Има някакви остатъци/наченки за разрешаване/забраняване само (в настройките) и то само Джава и Флаш, но проблемът е че не го обновява... това си е проблем, направо дупка, в сигурността

те първо го преместиха (няколко версии назад) от Хрома
C:\Program Files (x86)\Google\Chrome\Application\48.0.2564.97\PepperFlash
в глобален (за ОС)
C:\Users\UserName\AppData\Local\Google\Chrome\User Data\PepperFlash\
ама там си ми седи стария - 24.0.0.221 и не го обновява и като ида през Хром на
http://www.adobe.com/software/flash/about/
и там си седи стария 24.0.0.221 вместо новия 25.0.0.127

Както и да е въпросът ми сега е за Дебиян (и деривати т.е. Убунту като по-напред) при положение че ползват/ме
/usr/sbin/update-flashplugin-nonfree
/usr/sbin/update-pepperflashplugin-nonfree
където втория специално ми сваляше целия Хром само за да извлече от него флаша
т.е. сега ще има ли промяна - т.е. каква е генералната линия
1) ще ги обновят утилките да го свалят от друго място
2) да си инсталираме ние и поддържаме/обновяваме сами глобален пепър флаш
3) или нещо съвсем друго
щото ако си остане необновен и смятай че ...все нещо ще налази

П.П. Може ли някой да провери т.е. който има Хром 57 под линукс да иде на линка по-горе и да каже коя версия му е флаша т.е. дали е 25.ххх или е остнала на 24.хх

Корекция: Сега се сетих че имам една Федора във виртуалка и тествах там - обнови се до Хром 57 ама явно федората има друг метод на дистрибуция и не ползва тези утилки или може и направо да си го пакетират пак със новия/последния флаш Хрома [You have version 25,0,0,127 installed] (не съм запознат там с лицензи и пр. права), та... проблема се очертава май само за Дебиян (и подобни)
« Последна редакция: Mar 17, 2017, 20:56 от remotexx »
Активен

PaperNick

  • Напреднали
  • *****
  • Публикации: 286
  • Window Manager: Xfce
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #1 -: Mar 17, 2017, 17:37 »
Аз имам инсталиран само adobe-flashplugin на Chrome Version 57.0.2987.110 (64-bit) и ми изкарва
Цитат
You have version 25,0,0,127 installed

Преди година четох в някакво wiki на ubuntu, че pepperflash не трябва да се използва защото няма да го обновяват (или нещо такова), и да се използва adobe-flashplugin вместо него.
Активен

За да вървиш напред, понякога се налага да започнеш отначало.

remotexx

  • Напреднали
  • *****
  • Публикации: 810
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #2 -: Mar 17, 2017, 17:53 »
Благодаря много
значи минаваме на вариант 2)
и аз така си помислих ама не знаех името на пакета, довечера ще разкарам стария pepperflashplugin-nonfree и ще инсталирам новия adobe-flashplugin

Допълнителен въпрос - тоя новия само пипера или и солта  ;) така де той всички флашове ли замества или само пепър флаша с голбални, щото ако всички ще трябва и другия пакет да разкарам flashplugin-nonfree

и още - това за Дебиян ли е или за Убубту или нещо различно, защото се зачудих как така досега пък dist-upgrade не ми го фана тоя новия и да разкара ония двата... може би ще го направи но по-натам (както знаем Дебиян не е най-напред с новите технологии, да видим колко време ще я има тая 'дупка')
Активен

deant01

  • Напреднали
  • *****
  • Публикации: 221
  • Distribution: Debian/sid
  • Window Manager: Gnome 3
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #3 -: Mar 17, 2017, 19:29 »
Според мен имаш нещо омазано по системите, защото при мени на Вин и на Дебиан всичко е с последна версия. За Pepper  знам, че той е интегриран в Хрома и няма отношение към пакетите на адобе в Дебиан. Самите адобе няколко години не бутаха нищо по флаш за линукс и трябваше от Гугъл да вършат тяхната работа линукс. Адобе се усетиха сега, когато видяха, че флаша им отива в канала вече и никой не иска да го ползва. Лично в момента пробвах и двете версии за Вин/Лин и всичко изглежда ок.
Активен

Ripples of paradox spread out across the sea of causality.

remotexx

  • Напреднали
  • *****
  • Публикации: 810
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #4 -: Mar 17, 2017, 19:39 »
Забравих да уточня
1) с Debian testing съм
2) да не би да има пакет от дистрибуцията със Хром щото аз ползвам от Гугъл пакета т.е. репото
3) не съм се прибрал още да видя каква е хавата с Дебияна, но го забелязах първо тук на работа - Уин10 Anniversary даже със
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.98 Safari/537.36
а то под Уин няма пакет  (във ОС/Уин)- всичко е от официалния сайт
т.е. до предишната версия 56.хх си го обновяваше
да не би под Уиндоус да разчитат на Уиндоус ама на вчера ми се обнови до последно - нали patch Thursday
та не знам вече какво да си мисля...
Активен

PaperNick

  • Напреднали
  • *****
  • Публикации: 286
  • Window Manager: Xfce
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #5 -: Mar 17, 2017, 19:45 »
Принципно си е глобален пакет и няма нужда от другите флашове, може да ги разкараш.
Иначе сега като разцъках на Firefox и Chromium се оказа, че версията на флаша от adobe-flashplugin е 24,0,0,221. Предния коментар го писах от Google Chrome и изглежда, че идва с някакъв негов си флаш и май игнорира глобално инсталирания.

Тези неща ти ги пиша от Ubuntu 16.04, но мен тази дупка не ме засяга особено защото си използвам предимно Firefox без флаш и Google Chrome само за работа.

п. п. Ето го и линка от wiki-то:
https://wiki.ubuntu.com/Chromium/Getting-Flash

Изглежда че pepperflashplugin-nonfree е depricated, за другите не знам.

п. п. п. Сега видях че преди два дни са сложили актуалната версия и седи на proposed. Явно скоро ще го одобрят и ще влезе.
https://launchpad.net/ubuntu/+source/adobe-flashplugin
« Последна редакция: Mar 17, 2017, 19:59 от PaperNick »
Активен

За да вървиш напред, понякога се налага да започнеш отначало.

deant01

  • Напреднали
  • *****
  • Публикации: 221
  • Distribution: Debian/sid
  • Window Manager: Gnome 3
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #6 -: Mar 17, 2017, 20:07 »
Забравих да уточня
1) с Debian testing съм
2) да не би да има пакет от дистрибуцията със Хром щото аз ползвам от Гугъл пакета т.е. репото
3) не съм се прибрал още да видя каква е хавата с Дебияна, но го забелязах първо тук на работа - Уин10 Anniversary даже със
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.98 Safari/537.36
а то под Уин няма пакет  (във ОС/Уин)- всичко е от официалния сайт
т.е. до предишната версия 56.хх си го обновяваше
да не би под Уиндоус да разчитат на Уиндоус ама на вчера ми се обнови до последно - нали patch Thursday
та не знам вече какво да си мисля...
пиша от Сид, и нямам подобе проблем с флаш. също нямам подобен проблем на работния на работа на Вин10. Специялно се логнах от тука за да пробвам.Пепър е флаш дистрибутиран от Гугъл специялно за Хром под Линукс. Той е вътре и е неразделна част от Хрома (може да бъде спрян но е включен вътре). Т.е. не е нужно да инсталираш НИЩО друго освен Хром, под Дебиан, за да имаш Флаш на Хром. Огнената лисица е друга бира, за която не говорим тук.
Активен

Ripples of paradox spread out across the sea of causality.

PaperNick

  • Напреднали
  • *****
  • Публикации: 286
  • Window Manager: Xfce
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #7 -: Mar 17, 2017, 20:27 »
пиша от Сид, и нямам подобе проблем с флаш. също нямам подобен проблем на работния на работа на Вин10. Специялно се логнах от тука за да пробвам.Пепър е флаш дистрибутиран от Гугъл специялно за Хром под Линукс. Той е вътре и е неразделна част от Хрома (може да бъде спрян но е включен вътре). Т.е. не е нужно да инсталираш НИЩО друго освен Хром, под Дебиан, за да имаш Флаш на Хром. Огнената лисица е друга бира, за която не говорим тук.

Аха, значи Chrome си има собствен, пък за другите които нямат си важи глобално инсталирания.
Активен

За да вървиш напред, понякога се налага да започнеш отначало.

remotexx

  • Напреднали
  • *****
  • Публикации: 810
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #8 -: Mar 17, 2017, 20:33 »
@deant01 ти явно имаш инсталиран глобално пепър флаш (под Уиндоус говоря) и той оттам си се обновява, но аз нямам т.е. досега съм разчитал на пакетирания с Хрома, него от известно време го преместиха т.е. вместо в Хром папките го инсталираха в глобалната локация (обявено бе официално) и там пак си го обновяваха, но от 57.хх вече официално обявиха че няма да го пакетират и поддържат - и за хора като мене дето тов аим бе единстгвения флаш - остава дупката, за тези като тебе дето някогаш са си инсталирали от адобе явно исталира техен си спайуер такак де сервиз дето да го обновява, ама на моя си остана на старата версия
Официално от Хром 57 - от натройки може само да се разрешава/забранява флаш и джава т.е. вече се водят external plugins

явно не съм само аз
http://www.ghacks.net/2017/01/29/google-removes-plugin-controls-from-chrome/
и явно проблемът е от по-отдавна (Хром 54) но намазването но по-нов Хром го е поддържало но "командно дишане", но явно и това вече не работи
https://bugs.launchpad.net/ubuntu/+source/pepperflashplugin-nonfree/+bug/1632870

Благодаря на всички - сега вече мис е изясни картинката - ще пробвам с новия пакет под линукс, а под уиндоуса ще карам без (да не зарбавя да изтрия остатъците)
Активен

petar258

  • Напреднали
  • *****
  • Публикации: 340
  • Distribution: Ubuntu-mate 16.04, Windows 7
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #9 -: Mar 17, 2017, 20:39 »
Проблема не е в потребителя или настройки, а в Гугле. Те са решили да махнат chrome:plugins . Има го доста коментирано из нета но няма решение. Явно Гугле не иска да виждате с какво ви следи.
За подробно инфо https://www.google.bg/?gws_rd=ssl#q=chrome+57+plugins+not+accessible&*
П.С. При мен флаша в хрома е обновен сам до 25,0,0,127. Дистрибуцията е убунту-мате 16.04
« Последна редакция: Mar 17, 2017, 20:41 от petar258 »
Активен

remotexx

  • Напреднали
  • *****
  • Публикации: 810
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #10 -: Mar 17, 2017, 20:40 »
Значи да уточня
1) Хром си идваше със собствен
2) до версия 54.хх си се инсталираше в Хром директориите
3) в. 54.х до 56.ххх се инсталираше в глобалното (и за Адобе място , но само ако е по-нов)
4) от 57.хх вече нито се инталира нито е в пакета нито се поддържа (т.е. не се поддържа обновяването му, но ако имате инсталиран глобален то може само да го разрешите или забраните)

- ако имате/сте имали глобален (от адобе) той ще се самоподдържа - предполагам исталира сервиз (и пр. спайуер) но ако сте били като мен - тъй и тъй пепър флаш се ползваше само от Хрома и разчитах само на него, си оставате с последната версия т.е. внимание - ако сте го пускали наскоро ще останете (понеже се самообновява ама требе някой да го пуска от време на време) та ще останете с последната версия активна към датата на последното пускане или макс. 24.х - няма да се обнови до 25.х, 26.х и т.н. (а тук  някой разпраяше убедително че след 21.х или 22.х вече щели само цифричките след 22. да се менят)
« Последна редакция: Mar 17, 2017, 21:07 от remotexx »
Активен

remotexx

  • Напреднали
  • *****
  • Публикации: 810
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #11 -: Mar 17, 2017, 20:44 »
Съгласен съм с Петър
проблема е че ми оставиха старата си версия - като ще го махат да я деинсталират и така да принудят хората да се сетят да инсталират от Адобе, а не да ми оставят нещо което с времето ще става като швейцарското сирене - с повече и повече дупки и повечето потребители даже няма и да разберат че не им се обновява щото флаша си върви
ама мен това ми е най-малкия дерт, проблема ми беше че линукс утилките доколкото знам го извличаха от тези пакети затова запитах и вече ми отговориха че има по - най- нов пакет с друго име , защото там вече се бях притеснил а и dist-upgrade не го хваща (Дебиян тестинг)
Активен

remotexx

  • Напреднали
  • *****
  • Публикации: 810
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #12 -: Mar 17, 2017, 20:52 »
За съжаление тоя пакет май го няма в Дебиян
adobe-flashplugin

https://www.debian.org/distrib/packages

търсих във всички - стабилни, тестови, експериментални
кой ги знае пак какво ще измислят дебианци

а хич, ама ХИЧ, не ми се разчита на адобе
Активен

petar258

  • Напреднали
  • *****
  • Публикации: 340
  • Distribution: Ubuntu-mate 16.04, Windows 7
    • Профил
Re: Chrome 57 - дупка в сигурността (Debian)
« Отговор #13 -: Mar 17, 2017, 20:54 »
провери за flashplugin-installer възможно е да е набутано някъде из non-free
Активен

deant01

  • Напреднали
  • *****
  • Публикации: 221
  • Distribution: Debian/sid
  • Window Manager: Gnome 3
    • Профил
откакто ми спряха любимата флаш игрица, се радвам, че нямам допир с флаш абсолютно никъде. Иначе сега и аз забелязвам, че се е заформила страшна каша, най-вече от страна Гугъл.
Активен

Ripples of paradox spread out across the sea of causality.