Начало Вход/Регистрация Помощ Tazi stranica s latinski bukwi
Области
 Новини
 Актуална тема
 Linux портали
 Какво е Линукс?
 Въпроси-отговори
 Форуми
   •Трудова борса
   •Конкурс
 Статии
 Дистрибуции
   •Поръчка на CD
 Made In BG
 Файлове
 Връзки
 Галерия
 Конференции
Настройки
 Външен вид
 Предложения
 Направи си сам
И още ...
 За нас
 Линукс за българи ЕООД
 Линк към нас
 Предложения

Подкрепяно от:
TelePoint - Място за хора със свободни идеи

SiteGround

initLab

Adsys Group

SAP Bulgaria

Въпроси отговори
Въпрос: Малко помощ с тоя GLIBC 2.3
[Търси: ]

ВНИМАНИЕ: Използвайте форумите на сайта за дa зададете вашите въпроси.

Към началото |Добави въпрос |Отговори
 
Въпрос
От: SinFull (sinfull4 __@__ mail< dot >bg) Дата: 05/27/2004
 Пуснал съм два сървара на Counter-Strike под Linux-Slackware
Linux 8.1
 понеже има инсталирани и AMX Mod и WarCraft3 Mod исках да
обновя малко AMX Mod-а
 при което след инсталиране и стартиране на сървара ми показа
следното съобщение
 [META] ERROR: dll: Failed query plugin '';
 Couldn't open file
 '/games/hlds_l/cstrike/addons/amx/dlls/amx_mm_i686.so':
 /lib/libc.so.6: version `GLIBC_2.3' not found (required by
/games/hlds_l/cstrike/addons/amx/dlls/amx_mm_i686.so)
 Разбирам че трябва да се инсталне тва чудо но някой може ли
на по простичък език да ми обясни какво е
 и за какво служи и защо на предната версия на AMX Mod-a не
се изискваше такова нещо
Благодаря предварително.......



Отговор #1
От: Н. Антонов (nikola (a) linux-bg[ точка ]org) Дата: 05/27/2004
 Най-логичното предположение: това, което искаш да
 инсталираш (каквото и да е там), е компилирано с версия 2.3
но glibc. Твоята е по-ниска и затова няма да тръгне.

 Съвет: не си пипай glibc-то, защото от него зависи целият
 софтуер, инсталиран на системата ти. Ако сложиш насляпо
 по-висока версия, може изведнъж да получиш един напълно
 неработещ Линукс или поне да ти изгърмят купчина неща.
 Просто си инсталирай начисто актуална версия на Slack и
после си сложи геймърските джаджи.


Отговор #2
От: Georgi Alexandrov (g[ точка ]alexandrov __@__ bgservice[ точка ]net) Дата: 05/27/2004
Безумие!

 и другия месец като излезе "по нова" версия пак ли ще
преинсталираш Никола ?

към SinFull:
 можеш да го направиш ръчно с upgradepkg, или по елегантния
 вариант с swaret(.org) например да си ъпдейтнещ машината до
current.


Отговор #3
От: Н. Антонов (nikola (a) linux-bg[ точка ]org) Дата: 05/27/2004
 Не, няма да преинсталирам, защото всъщност изобщо не ползвам
 тази дистрибуция:) Просто посъветвах човека така, както
 намерих за добре, като взех предвид и други неща, които на
теб примерно ти убгягват.


Отговор #4
От: Georgi Alexandrov (g__dot__alexandrov __@__ bgservice__dot__net) Дата: 05/27/2004
заядлив както винаги.
не ми се спори с теб, владей светове ;-)


Отговор #5
От: Иполит Дата: 05/28/2004
теглиш пакетите и инсталираш, ако нещо се развали ги махаш.
 ама си дръпни пакети за слак. нищо сложно. аз на моя сякакви
боклуци слагам. 
 като сложиш библиотеките пусни swaret --dep - ако липсва
 нещо свързано с тия библиотеки ще ти каже и може да го
оправи.
слак 8.1 си се поддържа.


<< Suse 9.1 + Kernel 2.6.6 (4 ) | Onboard video - KM-400 M2 and X? (0 ) >>

 
© 2011-... Асоциация "Линукс за българи"
© 2007-2010 Линукс за българи ЕООД
© 1999-2006 Slavej Karadjov
Ако искате да препечатате или цитирате информация от този сайт прочетете първо това
Външния вид е направен от MOMCHE
Code Version: 1.0.8 H (Revision: 23-09-2011)
 
Изпълнението отне: 0 wallclock secs ( 0.07 usr + 0.01 sys = 0.08 CPU)