Автор Тема: Звук и debian testing  (Прочетена 2272 пъти)

madmax_haskovo

  • Напреднали
  • *****
  • Публикации: 24
    • Профил
    • WWW
Звук и debian testing
« -: Mar 04, 2008, 10:54 »
Здравейте. Вчера си инсталирах Debian 4.0 stable, който надстроих до testing. Всичко беше ок, но когато се опитах да стартирам плеъра amarok, се оказа, че няма звук. Самия плеър показва някаква активност ( има инсталиран Xine енджина, както и плъгина за MP3 ), но звук не се чува. По същия начин се държи и Audaicious. Само плеъра на Gnome върви, както и звуковите събития в Gnome. Изглежда ALSA-та нещо се дъни някъде, но не мога да разбера къде. Някой имал ли е подобен случай и как го е решил евентуално? Благодаря предварително.
Активен

Каквото и да си мислиш, може и да не е вярно.

tolostoi

  • Напреднали
  • *****
  • Публикации: 1337
  • Distribution: Ubuntu
  • Window Manager: Unity
  • левел: авераж :)
    • Профил
Звук и debian testing
« Отговор #1 -: Mar 04, 2008, 14:19 »
"Само плеъра на Gnome върви, както и звуковите събития в Gnome" това ме навежда на мисълта, че си ги включил, щото по-подразбиране ги няма, а преди време като пробвах май бачкаха само с esd и трябваше да се инсталира един пакет който заместваше друг (от алса-та) та вероятно това си направил. Но ти обясни какво си правил точно.

А може и да провериш в гнома менюто за звук, какво ползва, пробвай да го зададеш на АЛСА или ако не става си оправи плеърите да не ползват алса ами ... там каквото си включил еsound предполагам.
Активен


... в Столичен инспекторат една година след миграцията, продължават да работят под Linux. Което, май прави "експеримента" успешен
by entusiast

madmax_haskovo

  • Напреднали
  • *****
  • Публикации: 24
    • Профил
    • WWW
Звук и debian testing
« Отговор #2 -: Mar 04, 2008, 14:27 »
Цитат (tolostoi @ Март 04 2008,14:19)
"Само плеъра на Gnome върви, както и звуковите събития в Gnome" това ме навежда на мисълта, че си ги включил, щото по-подразбиране ги няма, а преди време като пробвах май бачкаха само с esd и трябваше да се инсталира един пакет който заместваше друг (от алса-та) та вероятно това си направил. Но ти обясни какво си правил точно.

А може и да провериш в гнома менюто за звук, какво ползва, пробвай да го зададеш на АЛСА или ако не става си оправи плеърите да не ползват алса ами ... там каквото си включил еsound предполагам.

Не съм пипал нищо по настройките на звука, просто инсталирах пакета със звуците на Gnome и ги пуснах. Когато инсталирах Amarok ( който предпочитам пред всички останали, независимо, че работя с Gnome ), след инсталацията на Amarok  и принадлежащите му зависимости, пускам Amarok, той "симулира " възпроизвеждане, но звук не се чува. Audaicious направи същото, но той даже не започна да се опита да свири. Не съм пипал нищо повече.
Активен

Каквото и да си мислиш, може и да не е вярно.

tolostoi

  • Напреднали
  • *****
  • Публикации: 1337
  • Distribution: Ubuntu
  • Window Manager: Unity
  • левел: авераж :)
    • Профил
Звук и debian testing
« Отговор #3 -: Mar 04, 2008, 14:34 »
Това как ти е
Влез в настройките на плеърите и им кажи (там трябва да има опции) кое да ползват. За аудишъс, мисля трябва да му инсталираш плъгините за там различните файлови формати и тогава ще свири, виж ги в синаптик.
Активен


... в Столичен инспекторат една година след миграцията, продължават да работят под Linux. Което, май прави "експеримента" успешен
by entusiast

madmax_haskovo

  • Напреднали
  • *****
  • Публикации: 24
    • Профил
    • WWW
Звук и debian testing
« Отговор #4 -: Mar 04, 2008, 15:13 »
Цитат (tolostoi @ Март 04 2008,14:34)
Това как ти е
Влез в настройките на плеърите и им кажи (там трябва да има опции) кое да ползват. За аудишъс, мисля трябва да му инсталираш плъгините за там различните файлови формати и тогава ще свири, виж ги в синаптик.

Сега съм на работа, но като се прибера, ще погледна...
Активен

Каквото и да си мислиш, може и да не е вярно.

madmax_haskovo

  • Напреднали
  • *****
  • Публикации: 24
    • Профил
    • WWW
Звук и debian testing
« Отговор #5 -: Mar 07, 2008, 09:22 »
Оправих го. Оказа се, че трябва да изключа вграденото смесване на ESD от Gnome и сега всичко работи както трябва. Звука минава през ALSA, като и смесването на ALSA работи.
Активен

Каквото и да си мислиш, може и да не е вярно.