Покажи Публикации - Nik123
* Виж публикациите на потр. | Виж темите на потр. | Виж прикачените файлове на потр
Страници: [1] 2 3 ... 38
1  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 28, 2020, 19:16

При мен след като вече имах добра конфигурация на ядрото за моята машина, при излизане на ново ядро само ползвах старата конфигурация (плюс някои нови опции за новите ядра, почти винаги има такива, понякога са доста на брой, но рядко са необходими).
Следва компилация, инсталация и работа (ако всичко е наред).


Аз до тая стъпка не мога да стигна. Прекомпилирал съм преди 5-6 години поне и бяха по-прости нещата (може би). "Правил" съм ядра за предишния си лаптоп,  за стара пентиумска машина на 333 мхз, но беше отдавна. Тогава, след като вече имам едно "мое" ядро, което бачка- зареждам стария конфиг, добавям това-онова, от новите опции и готово. Но беше преди, сега не успявам да стигна до работещо прекомпилирано от мен ядро. С това ядро доста си играх, да изключа поддръжка за това, което не ми трябва и няма да ползвам - изгубих доста време и аз да чета кое какво е и когато не знаех, а в конфига има опция "If unsure, say N", или "If you do not know what is this- say N"- така постъпвах. Не са ми познанията на високо ниво. Целия конфиг (make xconfig) ми отне 2-3 дена, основно четене в нета, кое какво значи, и накрая пак не станаха нещата и просто изгубих интерес. Идеята ми да съм с ново ядро беше, защото в старото, последното на магея 6, телефона ми през USB прави проблеми (mtp protocol died unexpectedely) и не ми разпознава един принтер/копир/скенер (3в1), на който на всичкото отгоре съм и сложил драйвъра (има поддръжка за линукс). А на жена ми на лаптопа, който е по-стар и от моя, с последната магея- 7, и принтера, и телефона си работят ок. И някои други неща, които при мен не бачкат. Затова реших, че с по-ново ядро, в по-старата ми дистрибуция има шанс да пробачкат нещата. Но наистина не ми се занимава, а по ред причини не искам и да преинсталирам, и оставям така нещата.  [_]3
2  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 28, 2020, 16:18
Прекомпилирах сорса наново, 5.4.10. Make, make modules_install, make install, всичко ок, без грешки. Рестарт, в новото ядро, всичко уж тръгва и като ми извади логин скрийна на LXDE, на дисплей мениджъра му по-точно, всичко замръзна- няма мишка, няма бутони. Само часовника върти. Няма ctrl-alt-del, ctrl-alt-backspace, нищо. Нито тъчпада работи, нито мишката през USB. Не съм си играл с нвидията, за графиката си ползвам интела. След твърд рестарт с копчето- recovery mode- init 3- мишката бачка, мести се по текста в черния екран, върху буквите. Инит 5- cannot open display.. съвсем ми писна, рестарт в последното налично ядро на магеята, make clean на това, което аз компилирах и толкова. Оставам си на магейското ярдо. Благодаря на отзовалите се в тази тема!

Едит: @jet - благодаря и на теб, просто нямам повече нерви да се занимавам с ядра и прекомпилации.
3  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 19, 2020, 17:22
Аз чисто от спортна злоба, ще се пробвам пак с прекомпилиране на ядро от сорса на кернел.орг. Щом преди години някак съм успявал, и е работило, и сега ще стане, с малко зор. Но си взех бележките- никакви нвидии и никакви дкмс - като писах в началото на темата, след прекомпилирането и рестарта в новото ядро, на стъпките с дкмс умря всичко (и не беше само нвидията, а и broadcom-wl на магеята, който ми трябва за уайърлеса). Сорса ще го компилирам на машината си в офиса, че е с по-мощен процесор (интел и5) от тоя на лаптопа- интел 2030м, двуядрен. Ще трябва да разкарам и dkms-broadcom-wl от лаптопа, което значи, че няма да имам уайърлес в ядрата на магея, но предполагам, че тоя модул може да се инсталира и без дкмс, ще потърся инфо из нета. Като се получи (или осере качествено), ще постна тук  ;D ;D
4  Linux секция за начинаещи / Настройка на хардуер / Re: Свързване с WI FI -: Jan 18, 2020, 23:57
Някаква грешка дава ли ти при опита за свързване? Не съм специалист, но ако дадеш малко подробности,  колегите може да  помогнат. Коя версия на Убунту, какво се случва, след като въведеш паролата за уайърлеса..
5  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 18, 2020, 23:27
Мейкми, вече схванах и аз за какво иде реч с тоя оптимус на нвидията, благодарение на тая тема и включилите се в нея. Стартира интел, а ако ще ти трябва 3д графика, за да тръгне нвидията (и то не автоматично), а с такава гимнастика- "За да се превключва от Intel към Nvidia без рестарт, се използва bumblebee" под линукс. При него обаче винаги използваш Intel и ръчно пускаш Nvidiа за съответното приложение (с optirun)"- най-малко си правиш някакъв шел скрипт от сорта на /bin/bash
./optirun нещо си
T.e. използваш допълнителна програма - бамбълби в случая, както разбирам, че и ръчно. Щом няма работещ оптимус за линукс, в моя случай си оставам на интела. Игрите и без това са под уина. Но ми е интересно, защо няма работещ оптимус под линукс- производителя на хардуера не го е*е за потребителите на нещо извън уиндоус?
6  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 18, 2020, 15:38
Ами доколкото разбирам от инфото в поста ти, и конкретно това :

URL         : https://github.com/NVIDIA/libglvnd 

и факта, че имаш инсталиран драйвър на нвидия, при теб това libglvnd пак си е на нвидия. то и при мен сочеше към libgl.so.1 на нвидия, но като махнах нвидията, и му дадох ldconfig-a, явно сега при мен ползва на mesa-та, с интелската карта. Нвидията при мен изобщо няма да се опитвам да я подкарвам, стига ми толкова главоболие.

Едит: Моя грешка, сега видях тоя линк за libglvnd, да, в твоята дистрибуция май е някаква междинна стъпка към OpenGL - дали на нвидия, дали на месата, каквото имаш инсталирано. Аз поне така го разбирам- libglvnd is a vendor-neutral dispatch layer for arbitrating OpenGL API calls between multiple vendors. It allows multiple drivers from different vendors to coexist on the same filesystem, and determines which vendor to dispatch each API call to at runtime.

Both GLX and EGL are supported, in any combination with OpenGL and OpenGL ES.

libglvnd was originally described in Andy Ritger's OpenGL ABI proposal [1]. При мен явно са се омазали нещата, защото и нвидията има opengl и mesa а ги имам и двете и е нормално с карта нвидия и инсталиран драйвър, да ползва на нвидията. Да, ама нвидията не бачка, картата не тръгва, обаче и интелската карта като настройвах, то си търсеше на нвидия opengl-a и ставаше мазало. Сега, като изчистих нвидията, остана само месата и нещата на лаптопа са ок с интелската карта.


Едит 2 : libglvnd contains code from the Mesa project. Source code from the Mesa project is available from:

http://cgit.freedesktop.org/mesa/mesa
 И това го пише в https://github.com/NVIDIA/libglvnd Явно във всяка дистрибуция си решават нещата с opengl различно
7  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 18, 2020, 15:24
[root@localhost ~]# rpm -qif  /lib64/libGL.so.1
Name        : lib64mesagl1
Version     : 17.3.9
Release     : 1.mga6
Architecture: x86_64
Install Date: Tue 11 Dec 2018 02:16:47 PM EET
Group       : System/Libraries
Size        : 905488
License     : MIT
Signature   : RSA/SHA256, Thu 19 Apr 2018 10:29:03 AM EEST, Key ID b742fa8b80420f66
Source RPM  : mesa-17.3.9-1.mga6.src.rpm
Build Date  : Thu 19 Apr 2018 10:16:51 AM EEST
Build Host  : localhost
Relocations : (not relocatable)
Packager    : tmb <tmb>
Vendor      : Mageia.Org
URL         : http://www.mesa3d.org
Summary     : Files for Mesa (GL and GLX libs)
Description :
Mesa is an OpenGL 4.5 compatible 3D graphics library.
GL and GLX parts.
8  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 18, 2020, 15:12
Като руут, предполагам. Ето :

[root@localhost ~]# ldd /usr/bin/glxinfo
   linux-vdso.so.1 (0x00007ffe3a5ac000)
   libGL.so.1 => /lib64/libGL.so.1 (0x00007f6a68c4c000)
   libX11.so.6 => /lib64/libX11.so.6 (0x00007f6a6890f000)
   libc.so.6 => /lib64/libc.so.6 (0x00007f6a6855c000)
   libz.so.1 => /lib64/libz.so.1 (0x00007f6a68340000)
   libexpat.so.1 => /lib64/libexpat.so.1 (0x00007f6a68116000)
   libxcb-dri3.so.0 => /lib64/libxcb-dri3.so.0 (0x00007f6a67f13000)
   libxcb-present.so.0 => /lib64/libxcb-present.so.0 (0x00007f6a67d10000)
   libxcb-sync.so.1 => /lib64/libxcb-sync.so.1 (0x00007f6a67b09000)
   libxshmfence.so.1 => /lib64/libxshmfence.so.1 (0x00007f6a67906000)
   libglapi.so.0 => /lib64/libglapi.so.0 (0x00007f6a676d5000)
   libXext.so.6 => /lib64/libXext.so.6 (0x00007f6a674c3000)
   libXdamage.so.1 => /lib64/libXdamage.so.1 (0x00007f6a672c0000)
   libXfixes.so.3 => /lib64/libXfixes.so.3 (0x00007f6a670ba000)
   libX11-xcb.so.1 => /lib64/libX11-xcb.so.1 (0x00007f6a66eb8000)
   libxcb.so.1 => /lib64/libxcb.so.1 (0x00007f6a66c92000)
   libxcb-glx.so.0 => /lib64/libxcb-glx.so.0 (0x00007f6a66a79000)
   libxcb-dri2.so.0 => /lib64/libxcb-dri2.so.0 (0x00007f6a66874000)
   libXxf86vm.so.1 => /lib64/libXxf86vm.so.1 (0x00007f6a6666e000)
   libdrm.so.2 => /lib64/libdrm.so.2 (0x00007f6a6645d000)
   libm.so.6 => /lib64/libm.so.6 (0x00007f6a6615d000)
   libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f6a65f40000)
   libdl.so.2 => /lib64/libdl.so.2 (0x00007f6a65d3c000)
   /lib64/ld-linux-x86-64.so.2 (0x00007f6a68eb7000)
   libXau.so.6 => /lib64/libXau.so.6 (0x00007f6a65b38000)
   libXdmcp.so.6 => /lib64/libXdmcp.so.6 (0x00007f6a65932000)
   libbsd.so.0 => /lib64/libbsd.so.0 (0x00007f6a6571d000)
   librt.so.1 => /lib64/librt.so.1 (0x00007f6a65515000)
9  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 18, 2020, 14:08


https://bbs.archlinux.org/viewtopic.php?id=209230

Това помогна! Изчетох много внимателно. Въпреки, че не ползвам в момента нвидията, драйвъра й си стои (от техния сайт, уж точно за моята GF705M и не работеше де).

Доколкото разбрах, при мен се опитва да търси тоя glx тука - /usr/lib/nvidia/libGL.so.1 и т.н., вместо където е на месата- /usr/lib/xorg/modules/extensions/libglx.so

Вместо да редактирам ръчно /etc/ld.so.conf с голяма степен на вероятност да осера нещо, избрах по-лесния вариант:
su -l root, init 3
#cd /където е нвидията от сайта им
#sh /NVIDIA-нещо си-.run --uninstall ... uninstal completed
#/sbin/ldconfig
init 5
Не съм пипал mesa-та, защото за нейния ънинстал ми поиска да махне поне стотина зависимости, между които и целия Х, а не исках да рискувам с rpm -e --force --nodeps и такива.
И алелуя. Плазмата тръгна, няма вече никакви Unable to load OpenGL и такива, вайбъра не вади грешки. Благодаря на всички отзовали се. Оставам обаче с LXDE, не го бях позлвал отдавна, но лекотата му ме впечатли. И без нвидия. На магеята не играя, така че не ми трябва тук.  [_]3

Сега всичко работи с интелската карта

[nik@localhost ~]$ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
304 frames in 5.0 seconds = 60.608 FPS
301 frames in 5.0 seconds = 60.020 FPS
301 frames in 5.0 seconds = 60.023 FPS
301 frames in 5.0 seconds = 60.021 FPS
[nik@localhost ~]$ glxinfo | grep "direct"
direct rendering: Yes
    GL_ARB_depth_clamp, GL_ARB_derivative_control, GL_ARB_direct_state_access,
    GL_ARB_draw_elements_base_vertex, GL_ARB_draw_indirect,
    GL_ARB_half_float_vertex, GL_ARB_indirect_parameters,
    GL_ARB_multi_draw_indirect, GL_ARB_occlusion_query2,
[nik@localhost ~]$


ЕДИТ: И повече никакви експерименти няма да си правя с ядра от кернел.орг

Още веднъж благодаря!
10  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 18, 2020, 12:47
Всичко, що съдържа в себе си mesa, libmesa, libmesagl +всякакви -devel, е инсталирано (от репосите). Изчетох темата за двете видеокарти. Сега проверих и биоса, в секцията Display > Graphics Device > две опции, Switchable graphics и Integrated graphics. При мен е Switchable. Другата опция там е OS Detection for switchable graphics > Enabled/Disabled- при мен е Enabled.
Предполагам, че ако го сложа Integrated и махна ОС детекшъна, ще работи само интела, но това за уина не ме устройва. Досега си е било на Switchable и OS- enabled. Явно с моите експерименти с прекомпилацията на ядро от сорс се е омазало здраво нещо по тоя OpenGL и оттам плазмата се срина, защото допреди това работеше, нещо, което ми е извън познанията да хвана. Ще почета още малко, но май нещата отиват да си оставам с LXDE. Не искам да преинсталирам в по-новата магея, или да преинсталирам тази, защото е един малък ад пак да местя GRUB на друго място, след като го плясне в МБР и да оправям пак буутлоудъра на Truecrypt.
11  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 18, 2020, 12:22
Ще почета още малко инфо. А за супата, аз я духам цяла седмица и все гореща стои  ;D  Имам лек напредък, по-скоро случаен. Инсталирах от репосите на ROSA 2016.1 (магеята няма пакет на вайбър, а този от официалния сайт не тръгва) viber-10.3.0.37-2-rosa2016.1.x86_64 пакета и вайбъра взе, че тръгна, въпреки това, което вади в терминала :
[nik@localhost ~]$ viber
QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
WebEngineContext used before QtWebEngine::initialize() or OpenGL context creation failed.
QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
failed to acquire GL context to resolve capabilities, using defaults..
qrc:/QML/Feed/FeedView.qml:98:5: QML ListViewEx: Binding loop detected for property "bottomMargin"

Ама работи!

По тоя проблем - QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled - досега четох в нета и инсталирах какви ли не либс, но проблема остава. Аз нямам и толкова големи познания, за да разбера същността на проблема. Вайбъра работи иначе. Но плазмата не тръгва. Склонен съм да я прежаля и да си остана в LXDE. А колкото до /etc/x11/xorg.conf, то в момента секцията му за видеокартата изглежда така:

Section "Device"
    Identifier "device1"
    VendorName "Intel Corporation"
    BoardName "Intel 810 and later"
    Driver "intel"
    Option "DPMS"
EndSection

изходът от glxinfo е този:

[nik@localhost ~]$ glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".


12  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 18, 2020, 11:02
Изглежда е с това Optimus, което до вчера изобщо не бях чувал.
В  сайта за тая карта- GeForce 705 M -  https://www.geforce.com/hardware/notebook-gpus/geforce-705m пише Supported technologies- Cuda, Optimus, DirectX12. Явно до пробема с прекомпилацията си е работил само с интела. Но нямаше грешки с opengl нито с плазмата, нито с вайбъра. Ще видя и тази тема, благодаря
13  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 18, 2020, 10:12

В xorg.conf за драйвер може да имаш 3 варянта: nv, nouveau и nvidia.
nv и nouveau са свободните. nv беше първият свободеден драйвер (разбира се reverse engineered). след това казаха ами ще правим по нов и съвършен и направиха nouveau. Само че дето nouveau не винаги работи както трябва, аз много често връщам на nv.

А nvidia е за затвореният официален драйвер. Като слагаш nonfree free пакет променяш ли в xorg.conf



Не съм променял ръчно xorg.conf от времето на мандрива 2006. Магеята сама си прави промените, досега (до версия 6 вкл., преди да се връщам към забравени занимания с ядро от сорс) след XFdrake - избирам- тест- работи. А този драйвър nv изглежда са го разкарали от магеята, защото го няма в хранилищата. Има само dkms-nouveau, но и с него не работи. Почнах да си мисля, че изобщо никога не е ползвана картата на нвидия при мен под линукс, защото се сещам, че при инстала на магеята преди 2 г. и нещо пак имах някакви проблеми с настройките й и забих просто intel810 and later - както и в момента. Но вайбъра си работеше.
14  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 17, 2020, 23:18
И в крайна сметка :

To satisfy dependencies, the following packages are going to be installed:
=> ok(auto)


retrieving rpm files from medium "Nonfree Updates (distrib13)"...
    $MIRRORLIST: media/nonfree/updates/nvidia304-doc-html-304.137-2.mga6.nonfree.x86_64.rpm
    $MIRRORLIST: media/nonfree/updates/x11-driver-video-nvidia304-304.137-2.mga6.nonfree.x86_64.rpm
    $MIRRORLIST: media/nonfree/updates/dkms-nvidia304-304.137-2.mga6.nonfree.x86_64.rpm
retrieved $MIRRORLIST media/nonfree/updates nvidia304-doc-html-304.137-2.mga6.nonfree.x86_64.rpm x11-driver-video-nvidia304-304.137-2.mga6.nonfree.x86_64.rpm dkms-nvidia304-304.137-2.mga6.nonfree.x86_64.rpm
...retrieving done
installing nvidia304-doc-html-304.137-2.mga6.nonfree.x86_64.rpm dkms-nvidia304-304.137-2.mga6.nonfree.x86_64.rpm x11-driver-video-nvidia304-304.137-2.mga6.nonfree.x86_64.rpm from /var/cache/urpmi/rpms
starting installing packages
created transaction for installing on / (remove=0, install=0, upgrade=3)

Creating symlink /var/lib/dkms/nvidia304/304.137-2.mga6.nonfree/source ->
                 /usr/src/nvidia304-304.137-2.mga6.nonfree

DKMS: add Completed.

Preparing kernel 4.14.145-desktop-2.mga6 for module build:
(This is not compiling a kernel, just preparing kernel symbols)
Storing current .config to be restored when complete
Running Generic preparation routine
make mrproper.....
using /proc/config.gz
make oldconfig.....
make prepare....

Building module:
cleaning build area....
'make' -j2 SYSSRC=/lib/modules/4.14.145-desktop-2.mga6/build module............
cleaning build area....
cleaning kernel tree (make mrproper).....

DKMS: build Completed.

nvidia304.ko.xz:
 - Installation
   - Installing to /lib/modules/4.14.145-desktop-2.mga6/dkms/drivers/char/drm/

depmod......

DKMS: install Completed.
removing installed rpms (nvidia304-doc-html-304.137-2.mga6.nonfree.x86_64.rpm dkms-nvidia304-304.137-2.mga6.nonfree.x86_64.rpm x11-driver-video-nvidia304-304.137-2.mga6.nonfree.x86_64.rpm) from /var/cache/urpmi/rpms
----------------------------------------------------------------------
More information on package x11-driver-video-nvidia304-304.137-2.mga6.nonfree.x86_64
This driver is for GeForce 6xxx and GeForce 7xxx cards.

Use XFdrake to configure X to use the correct NVIDIA driver. Any needed
packages will be automatically installed if not already present.
1. Run XFdrake as root.
2. Go to the Graphics Card list.
3. Select your card (it is usually already autoselected).
4. Answer any questions asked and then quit.

If you do not want to use XFdrake, see README.manual-setup.

----------------------------------------------------------------------
unlocking urpmi database
unlocking rpm database

Изглежда ОК. И след TEST
An error occurred:
(EE)
Fatal server error:

Try to change some parameters
Това го вади в прозорец, бях пуснал lxde-control-center като руут през терминала. Не ще и това е.
15  Linux секция за начинаещи / Настройка на програми / Re: компилиране на ядро -: Jan 17, 2020, 23:05
С още малко зор.. резултата е този :

[root@localhost ~]# urpmq -y mesa
lib64mesaegl1
lib64mesaegl1-devel
lib64mesagl1
lib64mesagl1-devel
lib64mesaglesv1_1
lib64mesaglesv1_1-devel
lib64mesaglesv2_2
lib64mesaglesv2_2-devel
lib64mesaglu1
lib64mesaglu1-devel
lib64osmesa-devel
lib64osmesa8
mesa
mesa-common-devel
mesa-demos
[root@localhost ~]# urpmi mesa
Package mesa-17.3.9-1.mga6.x86_64 is already installed
[root@localhost ~]# urpmi libmesagl1 libmesagl1-devel
No package named libmesagl1
No package named libmesagl1-devel
[root@localhost ~]# urpmq -y mesa
lib64mesaegl1
lib64mesaegl1-devel
lib64mesagl1
lib64mesagl1-devel
lib64mesaglesv1_1
lib64mesaglesv1_1-devel
lib64mesaglesv2_2
lib64mesaglesv2_2-devel
lib64mesaglu1
lib64mesaglu1-devel
lib64osmesa-devel
lib64osmesa8
mesa
mesa-common-devel
mesa-demos
[root@localhost ~]# urpmi mesa
Package mesa-17.3.9-1.mga6.x86_64 is already installed
[root@localhost ~]# urpmi lib64mesagl1 lib64mesagl1-devel
Packages lib64mesagl1-devel-17.3.9-1.mga6.x86_64, lib64mesagl1-17.3.9-1.mga6.x86_64 are already installed
Marking lib64mesagl1-devel as manually installed, it won't be auto-orphaned
writing /var/lib/rpm/installed-through-deps.list
[root@localhost ~]# glxinfo
name of display: :0.0
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  38
  Current serial number in output stream:  39
[root@localhost ~]# urpmq -y glx
glxinfo
lib64qt5glxsupport-static-devel
lib64xcb-glx0
nexuiz-glx
[root@localhost ~]# urpmi glxinfo
Package glxinfo-8.3.0-1.mga6.x86_64 is already installed
Marking glxinfo as manually installed, it won't be auto-orphaned
writing /var/lib/rpm/installed-through-deps.list
[root@localhost ~]# urpmi lib64xcb-glx0
Package lib64xcb-glx0-1.12-2.mga6.x86_64 is already installed

А след опит през графиката (контрол центъра на LXDE) да настроя видеото с драйвъра nouveau (Xorg-video-driver-nouveau)- вади това -
An error occurred:
(EE)
Fatal server error:

Try to change some parameters

И никакви чейнджове на параметри не изчейнджват тоя резултат.
[nik@localhost ~]$ glxinfo | grep "OpenGL version"
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  38
  Current serial number in output stream:  39
[nik@localhost ~]$ glxinfo | grep "OpenGL version"
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  38
  Current serial number in output stream:  39
[nik@localhost ~]$ glxinfo
name of display: :0.0
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  38
  Current serial number in output stream:  39
[nik@localhost ~]$

Edit: Без да искам, съм копирал два пъти едно и също нещо по-горе. Ще пробвам за последно с дкмс-нвидия304, която работеше, преди да оцапам всичко с опита за прекомпилиране на ярдото от кернел.орг и ако не стане, мисля за преинсталация.
Страници: [1] 2 3 ... 38