Автор Тема: Размяна на video0 и video1 при старт  (Прочетена 921 пъти)

plamikcho

  • Напреднали
  • *****
  • Публикации: 48
    • Профил
Ае хора, от скоро съм с Убунту 6.06, за 2-3 дни успях да го приведа в нормален вид. Остана само един досаден проблем - при стартиране си подрежда устройствата както му е угодно, а това прави проблеми. Основния е, че разменя тв тунера с уеб камерата и в момента съм си направил 2 стартера със съответните команди: tvtime -d /dev/video0, tvtime -d /dev/video1. При камерата е по-деликатно, трябва направо да преконфигурирам съответния клиент, което е още по-досадно. Ако изключа камерата, пък се появява 3-та мрежова карта eth2 - това е eth1, защо я преименува, не мога да разбера. Съответно, трябва и интернета да оправям. Дайте, ако обичате, някоя свежа идея, как да задам опциите в modules.
Активен

Ubuntu 9.04/ DELL Inspiron 1525 laptop

d1saster

  • Напреднали
  • *****
  • Публикации: 182
    • Профил
Размяна на video0 и video1 при старт
« Отговор #1 -: Jun 09, 2006, 17:21 »
Виждам, че няма идеи по твоя въпрос. Аз съм от съседната тема с размяна на имената на мрежовите интерфейси  '<img'>  Ето една идея, която може би ще помогне:

Можеш да сложиш имената на модулите в /etc/hotplug/blacklist По този начин те няма да се зареждат в ред удобен на hotplug скрипта. След това ги слагаш да се заредят ръчно в /etc/rc.d/rc.modules в последователността, в която ти искаш.

Успех!
Активен

plamikcho

  • Напреднали
  • *****
  • Публикации: 48
    • Профил
Размяна на video0 и video1 при старт
« Отговор #2 -: Jun 09, 2006, 17:32 »
d1saster - Благодаря, че си писал. Справих се сам. В Dapper няма hotplug - само udev. Ето какво направих, може да свърши работа на някого:
#/etc/modules
-------------
alias video0 spca5xx
alias video1 bttv
-------------
Работи за всякакви устройства, примерно аз го видях направено за мрежови карти и реших да пробвам.
Активен

Ubuntu 9.04/ DELL Inspiron 1525 laptop

plamikcho

  • Напреднали
  • *****
  • Публикации: 48
    • Профил
Размяна на video0 и video1 при старт
« Отговор #3 -: Jun 09, 2006, 18:13 »
Добавка - по-горното, което написах, не е вярно. Гадината ме заблуди - 3 пъти рестартирах и нямаше размяна. Обаче на 4-тия - изненада  ':angry:' . Понеже ми писна да се занимавам с глупости, реших проблема по един балъшки начин и вече работи 100 %  '<img'> Написах един скрипт, поставих го в /etc/init.d, дадох му някаква номерация в rcS.d, която да не пречи на нещо друго  и така устройствата са винаги в един и същ ред. Ето и "скрипта"
modprobe -vr bt878
modprobe -vr spca5xx
modprobe -v spca5xx
modprobe -v bttv
Просто премахвам модулите и зареждам първо драйвера на камерата, който пък зарежда videodev, който прави камерата /dev/video0 - това, което искам.
Активен

Ubuntu 9.04/ DELL Inspiron 1525 laptop

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
open /dev/video0: No such device
Настройка на хардуер
PAIN1 2 948 Последна публикация Jul 20, 2003, 16:25
от PAIN1
open /dev/video0: No such device
Хардуерни и софтуерни проблеми
PAIN1 2 1016 Последна публикация Jul 20, 2003, 16:39
от PAIN1