Автор Тема: Quake 3  (Прочетена 4389 пъти)

pr0fessor

  • Напреднали
  • *****
  • Публикации: 70
  • Distribution: Slackware
  • Window Manager: KDE
    • Профил
Quake 3
« Отговор #15 -: Oct 28, 2007, 09:51 »
така... значи появиха се новите драйвери на ати ati-driver-installer-8.42.3-x86.x86_64.run дето вече има opengl за 1х серията... аз съм с x1300 имам си opengl:
Примерен код
fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1300 / X1550 Series
OpenGL version string: 2.0.6958 Release

glxgears работи:
Примерен код
glxgears
14129 frames in 5.0 seconds = 2825.465 FPS
14348 frames in 5.0 seconds = 2869.548 FPS

както и fgl_glxgears:
Примерен код
fgl_glxgears
Using GLX_SGIX_pbuffer
2891 frames in 5.0 seconds = 578.200 FPS

но като пусна quake3 вади тва:
Примерен код
...loading libGL.so.1: QGL_Init: Can't load libGL.so.1 from /etc/ld.so.conf or current dir: /usr/local/games/quake3/libGL.so.1: cannot open shared object file: No such file or directory
failed

като му копирам библиотеката на оказаното място казва:
Примерен код
...loading libGL.so.1: QGL_Init: Can't load libGL.so.1 from /etc/ld.so.conf or current dir: /usr/local/games/quake3/libGL.so.1: cannot handle TLS data
failed

вади го със всичките библиотеки:
/usr/lib/libGL.so
/usr/lib/libGL.so.1
/usr/X11R6/lib/libGL.so.1.2
/usr/X11R6/lib/libGL.so
/usr/X11R6/lib/FGL.renamed.libGL.so.1.2
/usr/X11R6/lib/libGL.so.1
които копирам във въпросната папка под името ibGL.so.1 и странното е че пътищата с библиотеката:
/usr/local/lib/
/usr/X11R6/lib/
ги има във /etc/ld.so.conf
същото е и с ioquake...
на друг комп с gforce2 mx200/mx400 и същия слак 11 си вървят и LD_PRELOAD=/usr/lib/libGL.so.1 /usr/local/games/quake3/quake3 двете игри
p.s. в новия amdcccle (каталист контрол център) има настройки за AA до 2х и AF до 16х '<img'>

и за последно след ровене и з нета:
LD_PRELOAD=/usr/lib/libGL.so.1 /usr/local/games/quake3/quake3 тръгва
 '<img'>



Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Quake 3 - без звук
Настройка на програми
Devil_D 0 825 Последна публикация Mar 23, 2005, 09:08
от Devil_D
Quake 3 проблем
Общ форум
erjo82 10 3733 Последна публикация Sep 06, 2006, 14:42
от Йордан
Quake 3 сървър под дебиан
Общ форум
skuller 3 3051 Последна публикация Jun 17, 2008, 22:30
от Agent_SMITH
HTML5 && Quake II
Живота, вселената и някакви други глупости
b2l 29 4777 Последна публикация May 23, 2010, 03:27
от chen_dzen
Quake live
Общ форум
zxz 11 3482 Последна публикация Apr 09, 2013, 03:26
от n00b