Автор Тема: Problem s LAN pod SuSe 9.0  (Прочетена 2021 пъти)

pixar

  • Напреднали
  • *****
  • Публикации: 15
    • Профил
Problem s LAN pod SuSe 9.0
« -: Feb 08, 2004, 20:42 »
Проблемат е следния, немога да пусна мрежата под линукса, но под Windows всичко си работи перфектно.

Ето и малко повече инфо:
pixar:/home/pixar # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:C0:26:25:85:1D
          inet addr:195.69.109.165  Bcast:195.69.109.193  Mask:255.255.255.224
          inet6 addr: fe80::2c0:26ff:fe25:851d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8198 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:540622 (527.9 Kb)  TX bytes:1704 (1.6 Kb)
          Interrupt:11 Base address:0x8000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:118 errors:0 dropped:0 overruns:0 frame:0
          TX packets:118 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:7652 (7.4 Kb)  TX bytes:7652 (7.4 Kb)

pixar:/home/pixar # route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
195.69.109.160  *               255.255.255.224 U     0      0        0 eth0


pixar:/home/pixar # ping 195.69.110.1
connect: Network is unreachable

pixar:/home/pixar # route add default gw 195.69.110.1
connect: Network is unreachable

pixar:/home/pixar #


Значи имам си
IP 195.69.109.165
Netmask: 255.255.255.224
GW: 195.69.110.1
DNS: 195.69.108.2


Да не би нещо в рутиращата таблица да не е наред, какво значи това Destination в нея....?!?!?!
Активен

  • Гост
Problem s LAN pod SuSe 9.0
« Отговор #1 -: Feb 08, 2004, 22:01 »
Защо не използваш YasT като си със Сусе?
Активен

  • Гост
Problem s LAN pod SuSe 9.0
« Отговор #2 -: Feb 09, 2004, 02:24 »
kakva ti e lan kartata???
Активен

pixar

  • Напреднали
  • *****
  • Публикации: 15
    • Профил
Problem s LAN pod SuSe 9.0
« Отговор #3 -: Feb 09, 2004, 07:28 »
Не искам да използвам Yast, защото искам да се запознаиа по добре с Линукса...а какво по-добре от това да си усвойш командите.... '<img'>

Пробвах и с Yast-a , ама същите резултати.
Лан картата ми е:
Realtek RTL8139 Family PCI Fast Ethernet NIC
Активен

n_antonov

  • Напреднали
  • *****
  • Публикации: 1185
    • Профил
    • WWW
Problem s LAN pod SuSe 9.0
« Отговор #4 -: Feb 09, 2004, 07:31 »
Нещо си объркал настройките. Виж си gw и собственото IP. От различни мрежи са, в което няма никаква логика.
Активен

-------------------------------------------------------------------------
./debian/rules

pixar

  • Напреднали
  • *****
  • Публикации: 15
    • Профил
Problem s LAN pod SuSe 9.0
« Отговор #5 -: Feb 09, 2004, 09:11 »
Не съм ги объркал...и на мен ми направи това впечатление...
Но са си така IP и GW....
?!?!  '<img'>
Активен

melwin

  • Напреднали
  • *****
  • Публикации: 222
    • Профил
Problem s LAN pod SuSe 9.0
« Отговор #6 -: Feb 09, 2004, 10:52 »
Объркал си нещо рутинг-а
За да работят нещата рутинг таблицата трябва да изглежда така:
localnet        *               255.255.255.224   U     0      0        0 eth0
loopback        *               255.0.0.0       U     0      0        0 lo
default        195.69.110.1 0.0.0.0         UG    1      0        0 eth0
това се постига със следните команди:
1. ifconfig eth0 195.69.109.165 netmask 255.255.255.224(kernel-a avtomati4no shte dobavi route)
2. route add default gw 195.69.110.1 (друг вариант route add default dev eth0)

където localnet=195.69.109.0

Забележи че сегашния  ifconfig ти дава че си със .165-то ип ,a в route имаш запис за .160-то .. еми няма да работи да '<img'>

Надявам се че съм помогнал
Активен

The second is the basic unit of time. It is the length of time taken for 9192631770 periods of vibration of the caesium-133 atom to occur.

pixar

  • Напреднали
  • *****
  • Публикации: 15
    • Профил
Problem s LAN pod SuSe 9.0
« Отговор #7 -: Feb 09, 2004, 11:22 »
Цитат (melwin @ Фев. 09 2004,11:52)
Объркал си нещо рутинг-а
За да работят нещата рутинг таблицата трябва да изглежда така:
localnet        *               255.255.255.224   U     0      0        0 eth0
loopback        *               255.0.0.0       U     0      0        0 lo
default        195.69.110.1 0.0.0.0         UG    1      0        0 eth0
това се постига със следните команди:
1. ifconfig eth0 195.69.109.165 netmask 255.255.255.224(kernel-a avtomati4no shte dobavi route)
2. route add default gw 195.69.110.1 (друг вариант route add default dev eth0)

където localnet=195.69.109.0

Забележи че сегашния  ifconfig ти дава че си със .65-то ип ,a в route имаш запис за .160-то .. еми няма да работи да '<img'>

Надявам се че съм помогнал

Zna4i v momenta nemoga da go probvam tova, no dove4era shte probvam.
Problemat e, 4e si pravia
ifconfig eth0 195.69.109.165 netmask 255.255.255.224
route add default gw 195.69.110.1
no sled wtoria red mi dava greshlka... Network not reachable?!? Triabva li da si dam eth0 down ili ne???
Struva mi se 4e ima neshto neredno...?'<img'>

Zashto taka neznam, shte probvam s "add default dev eth0'


A kak da mahna route table... za da moga da po4na na 4isto ?
Активен

the_real_maniac

  • Напреднали
  • *****
  • Публикации: 1258
  • Kernel panic, me - no panic ;-) :-)
    • Профил
Problem s LAN pod SuSe 9.0
« Отговор #8 -: Feb 09, 2004, 18:36 »
AKO имаш проверка по мак и си с друга карта '<img'>
Активен

Powered by Debian GNU / LINUX /// Intel inside ...

„Насилието е последното убежище на некомпетентността“ - Айзък Азимов (1920 — 1992)

pixar

  • Напреднали
  • *****
  • Публикации: 15
    • Профил
Problem s LAN pod SuSe 9.0
« Отговор #9 -: Feb 09, 2004, 23:53 »
Nai setne, uspiah da podkaram LAN cartata...ve4e imam internet...
zna4i problemat be6e v route table....prosto ne e iskalo da iztrire sushtestvuvashtata tablica s nova...pri konfiguriraneto s:
route add default gw IP eth0

Purvo si slojih gw moito IP za da vidia dali kartata ba4ka.... i ia ping-nah...vsi4ko be6e ok!
Posle si slojih gw...deistvitelnia i go prie !?!?
Ta taka...

No niakoi moje li da mi obiasni zashto otna4alo neiskashe da  prieme deistvitelnia gw....
i imali niakakva komanda s koiato da iztrivam sushtestvuvashtata route table....


PP: Balgodaria na vsi4ki koito se opitaha da mi pomognat!
Активен

melwin

  • Напреднали
  • *****
  • Публикации: 222
    • Профил
Problem s LAN pod SuSe 9.0
« Отговор #10 -: Feb 10, 2004, 09:12 »
1. Със ifconfig ethX down изтриваш съответното "entry" за интерфейса от рутинг таблицата
2. route del '<img'>
Активен

The second is the basic unit of time. It is the length of time taken for 9192631770 periods of vibration of the caesium-133 atom to occur.

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Problem sys SuSE 9.1 & SerialATA disk
Настройка на хардуер
sirmarioo 2 986 Последна публикация Oct 09, 2004, 19:42
от LinuxVMANIACHEN
Problem pri vlizaneto v SuSE-HELP
Настройка на програми
iosco 3 986 Последна публикация Jul 05, 2005, 14:20
от angie_bg
Suse 9.3 - problem s routing
Настройка на програми
mazda_626 1 943 Последна публикация Feb 13, 2007, 21:30
от Kalin
Problem sys zvuka pri suse 10.1 final
Кошче
CosmicD 4 1775 Последна публикация Oct 16, 2007, 09:22
от mhydra
Problem sus skype na suse 10.3
Настройка на програми
linuxnewbie 6 2431 Последна публикация Mar 03, 2008, 10:33
от linuxnewbie