Автор Тема: libpam-runtime error  (Прочетена 1121 пъти)

Agent_SMITH

  • Administrator
  • Напреднали
  • *****
  • Публикации: 3082
  • matrix kernel module
    • Профил
libpam-runtime error
« -: Apr 14, 2004, 10:24 »
Привет братя!

Сблъсках се със странен проблем - инсталирам кнопикс на харда, взимам моите настройки на apt-get (надлежно запазени след одит на Ник Антонов '<img'> ), и пускам ъпгрейд...

Хубаво, ама нейде по средата libpam-runtime почва да се зъби, и не ебава да се подменя...

Reading Package Lists...
Building Dependency Tree...
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  libpam0g-dev: Depends: libpam0g (= 0.76-18) but 0.76-15 is installed

Логично, опитвам форс инстал, и:

Reading Package Lists...
Building Dependency Tree...
Correcting dependencies... Done
The following extra packages will be installed:
  libpam0g
Suggested packages:
  libpam-doc
The following packages will be upgraded:
  libpam0g
1 upgraded, 0 newly installed, 0 to remove and 634 not upgraded.
3 not fully installed or removed.
Need to get 0B/73.8kB of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue? [Y/n] Setting up libpam-runtime (0.76-18) ...

И отново грешка... Всите грешки все около libpam-runtime се мотаят... Погледнах - този пакет бил за управление на РАМ библиотеки (каквото и да значи това) - мислех да го изкъртя (purge remove), ама като писна тая ми ти конзола "ТИ ЛУД ЛИ СИ? Тея пакети са essential бре човек..." '<img'> Съответно - не съм и помислял да ги "резна".

Понеже (както винаги) по тъмна доба на морна глава правя тея работи, сигурно пропускам нещо... Ако вижда някой какво...

Смит
Активен

-= СПАЗВАЙТЕ ПРАВИЛАТА НА ФОРУМА =-

  • Гост
libpam-runtime error
« Отговор #1 -: Apr 14, 2004, 15:17 »
Ами ти правиш ъпдейт , ъпгрейд до последните налични версии ? Може още пакета да не е качен , макар че поне щеше да го има в списъка и щеше да ти кажа , че няма такъв пакет дефакто ... Ами все пак си сложи default-release в apt.conf, ако не си '<img'> Друго направи отново apt-get update и виж '<img'> Друго не ми идва на ум '<img'> Просто зависимиост '<img'>
Активен

  • Гост
libpam-runtime error
« Отговор #2 -: Apr 14, 2004, 16:32 »
Опитах и следното - свалих последните версии на libpam-runtime, libpam0g & libpam0g-dev, с идеята да ги инастлаирам - нито с форс, нито с друго става! Мистерия ви казвам!

По едно време (не помня кой етап) почна да се вайка, че libpam-runtime не било конфигурирано ?  Някакъв пост-инсталационен скрипт... Добре, ама аз като не разбирам и грам от скриптове... Дори като го отворих тоя скрипт - нищо нередно не виждам (ако изобщо приемем че виждам, а не просто гледам)...

Не знам кво става. Направо съм шашнат. Досега съм инсталирал на мои и приятелски машини сигурно 30 кнопикса - такова нещо НЕ ГО Е БИЛО!

Смит
Активен