Автор Тема: Въпрос след ъпдейт на ядрото (LMDE)  (Прочетена 2545 пъти)

NikolaiTalev

  • Напреднали
  • *****
  • Публикации: 307
  • Distribution: Debian Wheezy
  • Window Manager: KDE
    • Профил
    • WWW
Здравейте възможно ли е след ъпдейт на ядрото системата да стане незначително по бавна от колкото с по старото ядро
Ядрата са 2.6.32-5-686 и новото 2.6.38-2-686 и забелязвам че с новото ядро харчи 15 MB повече RAM
Активен

Веднъж Linux, цял живот Linux.

http://blog.nk-support.eu/

radoshow

  • Напреднали
  • *****
  • Публикации: 1312
  • Distribution: Arch Linux
  • Window Manager: Cinnamon
    • Профил
Re: Въпрос след ъпдейт на ядрото (LMDE)
« Отговор #1 -: May 04, 2011, 00:26 »
Не мисля,че има място за притеснение за тези 15МБ РАМ.Като го сметнеш в проценти колко ти се вдигна разхода?Като си движиш мишката харчи повече РАМ. [_]3
Активен

NikolaiTalev

  • Напреднали
  • *****
  • Публикации: 307
  • Distribution: Debian Wheezy
  • Window Manager: KDE
    • Профил
    • WWW
Re: Въпрос след ъпдейт на ядрото (LMDE)
« Отговор #2 -: May 04, 2011, 00:39 »
Май съм се филмирал  ;D (вече няколко часа сравнявам)
Супер си е
Активен

Веднъж Linux, цял живот Linux.

http://blog.nk-support.eu/

kalinik

  • Напреднали
  • *****
  • Публикации: 539
  • Distribution: LMDE x64 2012/ LM 14 x64
  • Window Manager: Mate / KDE
  • ID user #521433
    • Профил
Re: Въпрос след ъпдейт на ядрото (LMDE)
« Отговор #3 -: May 04, 2011, 12:04 »
Недей се впряга толкоз :)

След като си сложил 2.6.38 - от другата тема  за видеокартата не ти трябват тия гимнастики. Драйвърите са доста променени и не би трябвало да имаш проблеми.
Единствено можеш да пипнеш/добавиш в /etc/X11/xorg.conf aко липсва това в секцията Device :

Код:
Option "AccelMethod" "XAA"  # или "EXA"
Option "EnablePageFlip" "true" #върви комплект с горния ред
Option "TripleBuffer"  #това ти тряба за [b]compiz[/b]


Aко всичко е ОК - може да добавиш и това (стига картата да го поддържа)
Код:
Option "ColorTiling" "true" #за по-плавно и вярно трансформиране на цветовете при движение( да не се бърка със скорост на движение  )



ОЩЕ ИНФО:
http://www.thinkwiki.org/wiki/Additional_options_for_the_radeon_driver

Активен

AMD

  • Напреднали
  • *****
  • Публикации: 873
  • Distribution: Calculate Linux Scratch 64 / Alt Linux Centaurus 6.0 64
  • Window Manager: Gnome 2.32/3.2 XFCE 4.8/4.10-git
  • AMD Athlon64/Sempron64 4000+Dual Core/3400+
    • Профил
Re: Въпрос след ъпдейт на ядрото (LMDE)
« Отговор #4 -: May 04, 2011, 12:45 »
Отначало мислех да инсталирам дебиан на брачеда но като го инсталирах този новия. От най - малките неща се препълваше паметта и суап дяла.

Установих че проблема е в фабричното ядро. След като изтеглих изходния му код от сървър на Дебиан и го компилирах ръчно, проблемите с харчене на памет изчезнаха.

/офтопик но както и да е той го изтри вече ;D
Активен

Господи моля те пази ме от ламерите, от хакерите и сам мога да се пазя.

NikolaiTalev

  • Напреднали
  • *****
  • Публикации: 307
  • Distribution: Debian Wheezy
  • Window Manager: KDE
    • Профил
    • WWW
Re: Въпрос след ъпдейт на ядрото (LMDE)
« Отговор #5 -: May 04, 2011, 23:25 »
Недей се впряга толкоз :)

След като си сложил 2.6.38 - от другата тема  за видеокартата не ти трябват тия гимнастики. Драйвърите са доста променени и не би трябвало да имаш проблеми.
Единствено можеш да пипнеш/добавиш в /etc/X11/xorg.conf aко липсва това в секцията Device :

Код:
Option "AccelMethod" "XAA"  # или "EXA"
Option "EnablePageFlip" "true" #върви комплект с горния ред
Option "TripleBuffer"  #това ти тряба за [b]compiz[/b]


Aко всичко е ОК - може да добавиш и това (стига картата да го поддържа)
Код:
Option "ColorTiling" "true" #за по-плавно и вярно трансформиране на цветовете при движение( да не се бърка със скорост на движение  )



ОЩЕ ИНФО:
http://www.thinkwiki.org/wiki/Additional_options_for_the_radeon_driver

Проблема е че не намирам xorg.conf ето какво имам в X11


Активен

Веднъж Linux, цял живот Linux.

http://blog.nk-support.eu/

kalinik

  • Напреднали
  • *****
  • Публикации: 539
  • Distribution: LMDE x64 2012/ LM 14 x64
  • Window Manager: Mate / KDE
  • ID user #521433
    • Профил
Re: Въпрос след ъпдейт на ядрото (LMDE)
« Отговор #6 -: May 05, 2011, 00:04 »
След като няма xorg.conf
CTRL+ALT+F1 и почваш :)
Код:
sudo /etc/init.d/gdm3 stop
Код:
Xorg -configure
мисля, че ще създаде файла /home/потребителя/xorg.conf.new

Пускаш тестово да го зареди (една тънкост за новия Xserver )
Код:
X -config /home/nikolai/xorg.conf.new -retro
*nikolai го видях от горната картинка, ако е друг - сменяш името !

Трябва да ти стартира един сив екран с настройка на мишката  ;)

Ако всичко е ОК - копираш /home/nikolai/xorg.conf.new в /etc/X11/xorg.conf

Може и да пробваш дали стандартния пакет няма да ти създаде готов файл:
Код:
sudo aptitude install xserver-xorg-video-ati
  или
Код:
sudo aptitude install xserver-xorg-video-radeon

Тъй като си с доста ново ядро - може да пробваш въе файла /etc/modprobe.d/radeon-kms.conf да напишеш
Цитат
options radeon modeset=1

И друго се сещам - ако си пробвал да инсталираш Catalyst - задължително :
Код:
sudo apt-get purge fglrx amdccle

Успех :)
Активен

NikolaiTalev

  • Напреднали
  • *****
  • Публикации: 307
  • Distribution: Debian Wheezy
  • Window Manager: KDE
    • Профил
    • WWW
Re: Въпрос след ъпдейт на ядрото (LMDE)
« Отговор #7 -: May 05, 2011, 00:11 »
Цитат
Тъй като си с доста ново ядро - може да пробваш въе файла /etc/modprobe.d/radeon-kms.conf да напишеш
Цитат
options radeon modeset=1

Това си е така  :)
Активен

Веднъж Linux, цял живот Linux.

http://blog.nk-support.eu/

kalinik

  • Напреднали
  • *****
  • Публикации: 539
  • Distribution: LMDE x64 2012/ LM 14 x64
  • Window Manager: Mate / KDE
  • ID user #521433
    • Профил
Re: Въпрос след ъпдейт на ядрото (LMDE)
« Отговор #8 -: May 05, 2011, 00:48 »
Цитат
Тъй като си с доста ново ядро - може да пробваш въе файла /etc/modprobe.d/radeon-kms.conf да напишеш
Цитат
options radeon modeset=1

Това си е така  :)

Нормално е тогава. Последните ядра са с доста "тунинговани" опции и драйвъри.
Аз сега се мъча с 2.6.39 да подкарам Catalyst 11.4 , обаче пак не ще да се инсталира  ??? ... та и аз ще почвам гимнастиките от отворения драйвър... та да стигна до fglrx   :D
Приемам идеи всякакви  [_]3
... с Минт10 Gnome 2.32 и gnome-shell  + LMDE x64 съм
Активен

NikolaiTalev

  • Напреднали
  • *****
  • Публикации: 307
  • Distribution: Debian Wheezy
  • Window Manager: KDE
    • Профил
    • WWW
Проблем с conky след ъпдейт на ядрото (LMDE)
« Отговор #9 -: May 08, 2011, 23:28 »
Много странна работа защо с новото ядро не ми показва температурата conky-то
${offset 240}${color slate grey}CPU:${color } $cpu% ${acpitemp}C

acpitemp не работи  ???

а решението е

${offset 240}${color slate grey}CPU:${color } $cpu% ${hwmon temp 1}C
Активен

Веднъж Linux, цял живот Linux.

http://blog.nk-support.eu/